Установка программы

Комплект поставки программы SLS-Дисконт включает в себя:

  • Установочный диск
  • Электронный ключ
  • Лицензионное соглашение
  • Инструкция по установке программы

Для установки программы необходимо:

  • Вставить диск в дисковод. Через Стартовое меню вызвать программу "Проводник", открыть содержимое диска, найти и запустить файл setup.exe. Для запуска файла можно в Стартовом меню выбрать пункт "Выполнить" и указать файл A:\setup.exe.

  • Подтвердить установку программы.

  • Далее Пользователю будет предложено ознакомиться с Лицензионным соглашением

  • Выбрать папку для установки программы. Для выбора папки нужно нажать кнопку "Обзор". Если указать несуществующую папку, программа установки создаст ее автоматически.

  • Выбрать программную группу для создания группы пиктограмм в Стартовом меню. По умолчанию программ установки предложит выбрать группу SoftLand Systems. Для выбора другой группы нужно нажать кнопку "Обзор".

  • После подтверждения начнется инсталляция программы.

ВНИМАНИЕ!

Для успешного запуска программы необходимо вставить в LPT-порт (разъем для подключения принтера) электронный ключ, поставляемый с программой Дисконт. Для этого выключите компьютер и вставьте ключ. После этого компьютер можно включить. Без вставленного ключа программа работать не будет.

Если на Вашем компьютере установлен Windows 95/98, то после изменения параметров BIOS может потребоваться переустановка драйверов. Windows автоматически определяет необходимость в переустановке драйверов. Для успешной переустановки драйверов Вам потребуется установочный диск с Windows 95/98.

Чтобы избежать переустановки драйверов, требуется сначала успешно выполнить установку программы с диска и только после этого вставить электронный ключ.


Основные возможности программы Дисконт-Офис

Дисконт-Офис

Программа SLS-ДисконтОф предназначена для создания, ведения БД покупателей, а также истории правил предоставления скидок розничным покупателям, имеющим дисконтные карты магазинов сети. Дополнительно программа отвечает за подготовку файлов с новой информацией для магазинов и чтение новой информации, подготовленной магазинами сети.

Дополнительно см. Описание процесса сбора, хранения информации о покупателях, расчета скидок, обмена информацией между центральным офисом и магазинами сети


Основные возможности программы Дисконт-Магазин

Дисконт-Магазин

Программа SLS-ДисконтМаг предназначена для хранения необходимой информации о покупателях сети в БД каждого магазина, расчета скидки покупателя по запросу программы Касса, предоставления программе Касса информации о скидках по покупателям, накопления информации о покупках, совершенным каждым покупателем в магазине, а также для хранения и предоставления работникам магазина информации о том, с кем из покупателей и каким образом нужно связаться в связи с проведением маркетинговых акций. Дополнительно программа отвечает за подготовку файлов с новой информацией для центрального офиса и чтение информации, подготовленной центральным офисом.

Дополнительно см. Описание процесса сбора, хранения информации о покупателях, расчета скидок, обмена информацией между центральным офисом и магазинами сети


Требования к оборудованию и программному обеспечению

Для работы программы SLS-Дисконт для Windows требуется:

Программные средства:

  • Операционная система Windows 95/98 или Windows NT 4.0
  • Для сетевого варианта наличие локальной вычислительной сети, поддерживающей протокол IPX или NETBIOS (например, сети NOVELL или WINDOWS).

Аппаратные средства:

  • Оперативная память min - 16 Mb. Рекомендуется - 32Mb.
  • Процессор, тактовая частота min - 100 MHz. Рекомендуется - 200 MHz.
  • Рекомендуемое разрешение экрана - 800х600.
  • Наличие LPT-порта для подключения электронного ключа для однопользовательской версии.


Описание процесса

Описание процесса сбора, хранения информации о покупателях, расчета скидок, обмена информацией между центральным офисом и магазинами сети

  • В магазинах сети покупатели заполняют анкету и получают карточку с персональным штрих-кодом. Новые анкеты, заполненные покупателями, с присвоенными покупателям штрих-кодами ежедневно записываются администратором в базу данных (БД) магазина. В магазине, выдавшем карточку, покупка покупателя, получившего карточку, автоматически заносится в БД дисконтной системы магазина. При этом в БД формируется карточка нового клиента, в которой заполнен штрих-код и занесена сделанная покупка. В центральном офисе оператор может оформить новую карточку покупателя, выданную в офисе, при необходимости указав начальную сумму покупок.
  • В БД центрального офиса подготавливается и вводится в действие таблица скидок, предоставляемых покупателям сети в зависимости от суммы покупок (в рублях), совершенных покупателем в магазинах сети.
  • Ежедневно после сбора и обработки информации от всех магазинов центральный офис готовит файл обновлений для каждого магазина. В файл обновлений попадает информация о новых покупателях, изменения в информации уже имеющихся покупателей, таблица скидок. Таким образом, новая информация по покупателям (новая карточка, новая общая сумма покупок и пр.) подготавливается для магазинов сети в течение одного дня после свершения самого события (выдачи карточки с штрих-кодом, совершения новой покупки и пр.). И покупатель может воспользоваться полученной карточкой со штрих-кодом или новой скидкой не раньше, чем через 1 день после совершения покупки.
  • Считается, что для каждого магазина сети есть список покупателей, за которых магазин «отвечает». Это означает, что при проведении маркетинговых акций этим магазином, сотрудники магазина должны связаться с покупателями, находящимися в его зоне ответственности, и проинформировать покупателей о проводящихся маркетинговых акциях. По покупателям, за которых магазин «отвечает», в магазин передается не только штрих-код и сумма покупок, но еще контактная информация.
  • Первоначально магазины из центрального офиса (в порядке обновления информации) получают список покупателей, имеющих карточку покупателя, и таблицу скидок. На основании этой информации формируется первоначальная БД в каждом магазине. Список покупателей во всех магазинах и информация об общей сумме покупок каждого покупателя, а также таблица скидок во всех магазинах сети в идеальном случае должны быть одинаковыми. Различаться они могут только в случае неуспешного завершения процесса передачи информации из центрального офиса в какие-либо магазины сети, либо из-за существенного различия во времени окончания работы магазинов сети и офиса, обусловленного их географическим положением.
  • Дисконтная система в магазине готовит для касс файл, определяющий текущую скидку для каждого покупателя. Когда покупатель совершает покупку в магазине сети и предъявляет на кассе свою карточку покупателя, программа SLS-Касса отыскивает в файле по штрих-коду покупателя и соответствующую ему скидку. Если покупатель не найден, скидка не предоставляется, однако информация о покупке по карточке заносится в БД дисконтной системы магазина. В дальнейшем эта информация передается в центральный офис, где оператор должен принять решение, будет ли эта карточка признана недействительной, и по ней покупатели обслуживаться не будут, либо необходимо карточку с неправильно читающимся кодом заменить на новую, либо что-либо еще. Соответствующие отметки делаются в БД дисконтной системы.
  • При совершении покупки программа SLS-Касса формирует чек покупателю с учетом полученного значения скидки. Если чек успешно пробит (покупатель совершил покупку), то полная информация по чеку покупателя записывается в файл.
  • Периодически дисконтная система магазина считывает новую информацию о покупках из файлов, созданных кассами, и записывает эту информацию в БД дисконтной системы.
  • В конце рабочего дня (по времени магазина) дисконтная система магазина готовит файл со всеми покупателями, имеющими штрих-код, совершившими покупки с момента последней успешной отсылки информации в центральный офис. По каждому покупателю передается вся информация по чекам, пробитым для этого покупателя за рассматриваемый период, а также анкетная информация для новых покупателей. Подготовленный файл записывается по адресу файла экспорта, описанному в настройках системы. Если для записи такого файла необходимо активировать канал связи с удаленным ресурсом, то дисконтная система инициирует процесс подключения к этому ресурсу.
  • В конце рабочего дня (по времени центрального офиса) дисконтная система центрального офиса опрашивает все файлы импорта от магазинов (описанные в настройках системы) и считывает в БД дисконтной системы центрального офиса всю полученную новую информацию из магазинов о покупках, совершенных покупателями сети.
  • После успешного завершения импорта информации дисконтная система центрального офиса пересчитывает общие суммы покупок, совершенных покупателями, и рассчитывает новые значения скидок для покупателей.
  • Дисконтная система подготавливает файлы для всех магазинов сети с новой информацией (см. п.3). Каждый файл записывается по адресу, указанному для файла экспорта для каждого магазина в настройках системы. Если для записи файлов необходимо активировать канал связи с удаленным ресурсом, дисконтная система инициирует процесс подключения к этому ресурсу.
  • В начале рабочего дня (по местному времени) дисконтная система магазина считывает информацию из файла, подготовленного центральным офисом. Файл ищется по адресу, указанному в качестве файла импорта в настройках системы магазина.
  • и т.д.


С чего начать работу

Предлагается следующий порядок работы с программой:

  • Создать новую базу данных
  • Произвести настройку параметров
  • Установить пароль системы
  • Произвести настройку рабочей станции
  • Заполнить таблицу скидок (для офиса)
  • Заполнить классификатор магазинов сети (для офиса)
  • Заполнить классификатор кассовых мест (для магазина)


Настройка/Рабочая станция

Рабочая станция

Используется для настройки параметров работы системы автоматизации при запуске с данной рабочей станции. Эти настройки будут действовать, вне зависимости от конкретного пользователя, вошедшего в систему. Настройка рабочей станции включает в себя следующие параметры:

  • Шрифт для отображения на экране
  • Настройка печати выходных форм
  • При старте автоматически подключаться к базе данных
  • Открывать последнюю базу данных
  • Количество недавно открытых файлов
  • После подключения базы данных открывать пункт меню
  • Другие параметры
  • Настраиваемые формы брать из папки


С чего начать работу/Установить пароль для открытия базы данных

Установить пароль для открытия базы данных

Чтобы установить пароль для открытия определенной базы данных, нужно:

  • Открыть базу данных
  • Выбрать раздел Настройка/Изменить пароль

При вводе пароль отображается в виде звездочек (*). Чтобы увидеть введенное значение, нужно кликнуть мышкой на иконке "Очки" или нажать Ctrl+Tab.


Настройка/Параметры(офис)

Параметры

Настройка параметров базы данных доступна пользователям, для которых полностью разрешена общая возможность корректировки информации. В данном разделе необходимо настроить следующие параметры:

На вкладке Общие:

  • Название организации
  • Размер штрих-кода
  • Штрих-коды в анкетах только из каталога
  • Группы VIP
  • Пороги скидок для групп VIP
  • Определять активность для каждого штрих-кода
  • Аналитические типы в накопительной таблице скидок

Параметры обмена:

  • Тип обмена
  • FTP-сервер
  • Порт
  • Пользователь
  • Пароль

На вкладке Карточка покупателя:

  • ФИО указывать в отдельных полях
  • Подписка на новости
  • Передавать ФИО в магазины
  • Отключить персонифицированный обмен
  • Фиксировать скидки при смене таблицы скидок
  • Дополнительные поля описания
  • Использовать в магазинах
  • Общая сумма покупок
  • Общие суммы покупок рассчитаны за

На вкладке Замена карт:

  • Переход на новые дисконтные карты
  • В диапазоне от ... до ...
  • Заменять карты на кассах с


Настройка/Пользователи и их права

Пользователи и их права

Используется для вызова каталога пользователей базы данных. Расширенное санкционирование доступа позволяет назначить (описать) права пользователей, каждый из которых может иметь свои права и ограничения на просмотр, добавление, корректировку и удаление каждого логического раздела системы. Работа в разделе ведется при помощи меню Пользователи .


Настройка/Установить списки по умолчанию

Установить списки по умолчанию

Для установки списков по умолчанию нужно заполнить следующие параметры настройки списка:

  • Название списка, которое будет выдаваться в перечне настроенных списков
  • Перечень колонок, включенных в список.

При необходимости списки можно настроить вручную. Для этого, находясь в соответствующем списке, например в списке карточек покупателей, нужно нажать правую кнопку мышки и выбрать раздел "Списки". После этого появятся следующие пункты:

  • Исходный список - список, установленный по умолчанию. В случае нажатия (ОК) производится установка списков в исходном виде, заложенном в программе
  • Настройка списка - настройка необходимого списка.


Классификаторы/Магазины сети(офис)

Магазины сети

Раздел доступен пользователям с правом на просмотр магазинов сети и содержит список всех магазинов, которые можно добавлять, корректировать и удалять при помощи меню Магазины сети , а для печати выходных форм использовать меню Формы .

На экране отображается окно, представленное в виде списка с графами:

  • Код - код магазина
  • Название - название магазина
  • Архив - "+", если магазин архивный и " " в противном случае
  • Файл для импорта - полный путь к файлу, из которого берется информация, полученная из магазина.
  • Регион - название региона, к которому относится магазин
  • Подтвержденный экспорт - заполняется автоматически в результате обмена данными между центральным офисом и текущим магазином. Обозначает время последнего удачного экспорта из офиса в данный магазин, т.е. дата/время, о котором из магазина пришло подтверждение получения информации.
  • Последние данные из магазина - заполняется автоматически в результате обмена данными между центральным офисом и текущим магазином. Обозначает время последнего удачного импорта из данного магазина в центральный офис, т.е. дата/время информации, успешно полученной из магазина.
  • Дата файла экспорта - дата создания файла экспорта для магазина.
  • Дата файла импорта - дата создания успешно загруженного в офисную базу данных файла импорта из магазина.

Также с помощью настройки списков может быть отображен столбец Файл для экспорта - полный путь к файлу, в который помещается информация для магазина.

В списке магазины отсортированы по коду. Чтобы произвести сортировку магазинов по другому полю, нужно кликнуть на заголовке данного поля. Если треугольник в заголовке поля расположен углом вниз, коды сортируются по данному полю по возрастанию. Если треугольник направлен вверх, происходит сортировка по убыванию.

В списке можно поменять колонки местами. Для этого нужно кликнуть мышкой на названии колонки и не отпуская кнопки мыши "перетащить" колонку в нужное место. Убрать колонку из списка можно уменьшив ее размеры до нуля. Чтобы изменить внешний вид списка нужно нажать правой кнопкой мыши и выбрать меню Списки/ Настройка списков .

В справочнике работает быстрый подвод по коду магазина. Если текущая дата на компьютере, где ведется БД клиентов больше, чем "Дата импорта", и (текущее время - "Время Ч") больше 60 минут, то строка магазина в списке высвечивается жирным красным шрифтом.


Магазины сети/Меню магазины сети/Добавить(офис)

Добавить

Функция доступна пользователям с правом на добавление магазинов сети. Для создания описания нового магазина нужно заполнить следующие параметры:

  • Код
  • Название
  • Регион
  • Архив
  • Файл экспорта
  • Файл импорта
  • Разница во времени
  • Время "Ч"
  • Примечание
  • Новые карточки покупателей активны


Магазины сети/Меню магазины сети/Изменить(офис)

Изменить

Функция доступна пользователям с правом на изменение магазинов сети. Используется для изменения описания следующих параметров магазина:

  • Код
  • Название
  • Файл экспорта
  • Файл импорта
  • Разница во времени
  • Время "Ч"
  • Примечание
  • Новые карточки покупателей активны
  • Архив


Магазины сети/Меню магазины сети/Удалить(офис)

Удалить

Функция доступна пользователям с правом на удаление магазинов сети. Используется для удаления текущего в списке описания магазина.

Магазин удалить нельзя если:

  • существует карточка покупателя, в которой на вкладке Покупки имеется хотя бы одна покупка из этого магазина.
  • существует хотя бы одна карточка покупателя, в которой этот магазин указан в качестве ответственного или исходящего магазина.


Карточка покупателя(офис)

Карточка покупателя

Карточка покупателя - объект, в котором хранится анкетная информация по покупателю, подробная информация по покупкам покупателя, приобретенным во всех магазинах сети, а также сводная информация, рассчитываемая на основании сделанных покупок и действующей таблицы скидок.

Работа в карточке покупателя ведется при помощи меню Покупатель , Штрих-коды , Заметки и Подписка на новости .

Для удобства работы вся информация в карточке покупателя разделена на вкладки:

  • Описание
  • Доп. описание
  • Штрих-коды
  • Покупки
  • Заметки
  • Подписка на новости


Меню покупатели/Поиск(Справка)

Поиск

Функция доступна пользователям с правом на просмотр карточек покупателей и используется для поиска и отбора карточек покупателей.

Для проведения поиска нужно задать условия поиска и отбора покупателей и кликнуть на кнопке (Отобрать). Результаты поиска отображаются в ветви Найденные покупатели

В списке найденных карточек покупателей доступны следующие функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Поместить карточку покупателя в архив
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск
  • Отметить карточки путем проставления точек в поле слева от списка.
  • Снять все отметки
  • Удалить из списка
  • Включить активность
  • Отключить активность
  • Проставить ответственный магазин
  • Привязать к группе VIP
  • Отвязать от группы VIP
  • Отметить найденные


Меню Покупатели/Группы VIP(офис)

Группы VIP

Пункт отображается, если включен параметр настройки группы VIP и доступен пользователям с правом на просмотр групп VIP.

Параметр регламентирует возможность предоставления скидок по дисконтным картам согласно следующей схеме:

  • Задается список организаций, с которыми заключены договора на корпоративное обслуживание (группы VIP карт);
  • Для каждой организации указывается список дисконтных карт, закрепленных за ней;
  • Для каждой организации задаются правила предоставления скидок;
  • Если дисконтная карточка не привязана ни к одной организации, то скидки по ней предоставляются по накопительной программе согласно общей действующей таблице скидок;
  • Если же дисконтная карточка привязана к некоторой организации (группе VIP), то скидки по ней предоставляются согласно таблице скидок, действующей для этой группы/подгруппы (накопительная система скидок для карточки не действует).

При описании скидок, действующих для некоторой организации (группы VIP), допускаются следующие виды скидок:

  • Фиксированный процент скидки на все товары;
  • Фиксированный процент скидки на товары определенного аналитического типа.

Верхний уровень каталога групп VIP представляет собой список организаций, с которыми заключаются договоры на VIP обслуживание, а также содержит ветвь Найденные группы VIP .

В свою очередь внутри каждой организации информация также представлена в виде ветвей:

  • Покупатели.
  • Акции

Если каталог групп VIP открыт на верхнем уровне, то список групп VIP в правой части окна каталога представлен в виде таблицы со следующими колонками:

  • Код
  • Наименование
  • Полное наименование
  • Регион
  • Статус
  • Дата/время последней корректировки - используются при обмене данными между модулями SLS-ДисконтОф и SLS-ДисконтМаг и содержат дату и время внесения последних корректировок в описание группы VIP или одного из вложенных в нее объектов (дисконтных карт, скидочных акций).

Список упорядочен в алфавитном порядке по значениям столбца Код. В списке работает быстрый подвод по первым символам кода группы VIP. Работа в каталоге групп VIP ведется при помощи меню:

  • Группы VIP
  • Акции


Выгрузка базы данных

Выгрузка базы данных в текстовый файл производится в случае нарушения целостности базы данных в результате сбоев в ПЭВМ.

Чтобы выгрузить информацию, нужно открыть базу данных , из которой следует выгрузить информацию, и выбрать раздел меню Файл/Выгрузить базу данных .

Для выгрузки нужно заполнить параметры для выгрузки базы данных:

  • База данных
  • Текстовый файл

После завершения процедуры выгрузки для получения новой базы данных следует выполнить процедуру Создания базы данных по выгруженной информации .

Примечание.

Для выгрузки база данных должна быть отключена от Сервера приложений (для сетевой версии программы). В противном случае при попытке выгрузки будет выдано сообщение "База данных занята. Ждите ее освобождения."


Создание базы данных по выгруженной информации

Создание базы данных на основе существующей можно произвести только после ее выгрузки .

Чтобы создать базу данных, нужно выбрать раздел Файл/Создать базу данных .

Для создания базы данных нужно заполнить следующие параметры:

  • Текстовый файл
  • База данных


Резервное копирование

Скачки напряжения в электросети и сбои в работе компьютера могут привести к нарушению целостности базы данных. В целях сохранности информации, введенной в системе "SLS-Дисконт", Пользователю настоятельно рекомендуется как можно чаще проводить резервное копирование базы данных. Частота выполнения резервного копирования определяется в зависимости от объема информации, вводимой в систему в течение дня, и может составлять от одного раза в неделю до нескольких раз в день. В идеале рекомендуется хранить несколько резервных копий за последние несколько дней работы. Например, создать пять директорий, соответствующих дням недели, и в конце каждого рабочего дня проводить копирование базы данных в соответствующую директорию.


Открытие базы данных

Чтобы открыть базу данных, нужно в Главном меню выбрать пункт Файл/Открыть.. .


Создание базы данных

Создать базу данных

Чтобы создать новую базу данных, нужно в главном меню выбрать раздел Файл/Создать новую (пустую БД) .

Прежде чем начать работать с новой базой данных, нужно произвести настройку параметров и установить пароль для открытия базы данных .


Закрытие базы данных

Используется для закрытия базы данных. При открытии другой базы данных предыдущая открытая база закрывается автоматически.


Файл/Обмен/Экспорт обновлений в магазины(офис)

Экспорт обновлений в магазины

Для обмена информацией между БД следует провести экспорт информации, кликнув на кнопку (Начать). Далее необходимо отметить магазины, для которых нужно сделать экспорт, в справочнике магазинов, содержащем список магазинов сети (за исключением архивных). Отметки проставляются слева от списка в специальном выделенном поле. Если магазины не отмечены, то выгрузка информации производится для всех магазинов сети.

Для каждого отмеченного магазина (или для всех магазинов) проверяется доступность файла по пути Файл для экспорта.

Если файл недоступен, то сообщение об этом записывается в протокол ошибок экспорта, который имеет имя с наименованием базы данных_export.log. Для такого магазина экспорт не производится.

Если файл доступен, то формируется файл, в который записывается следующая информация:

SLS-Discount System Export To Shop File (номер текущей версии файла обмена)

Строка 001 - параметры настройки системы.

001|A|B|C|D|E|F|G|H|I|J|K|L|M|L|M|L|M|L|M|L|M

Если параметр настройки системы использовать в магазинах отключен, то строка имеет вид:

001|A|B|C|D|E|F|G|H|I|J|K

A - код магазина, для которого формируется файл экспорта (Классификаторы/Магазины сети/Код).

B/С - дата/время последнего успешного импорта из магазина (Классификаторы/Магазины сети/Последние данные из магазина). Дата записывается в формате гг-мм-дд.

D/E - дата/время создания файла экспорта для магазина (т.е. дата/время нажатия кнопки Файл/Обмен информацией между БД/Экспорт обновлений в магазины/Начать). Дата записывается в формате гг-мм-дд.

F - если 1 - параметр включен, пробел - отключен (Классификаторы/Магазины сети/Новые карточки покупателей активны).

G - размер штрих-кода дисконтных карт (Настройка/Параметры/Размер штрих-кода).

H - если 1 - параметр включен, пробел - отключен (Настройка/Параметры/Штрих-коды в анкетах только из каталога).

I - если 1 - параметр включен, пробел - отключен (Настройка/Параметры/Передавать ФИО в магазины).

J - если 1 - параметр включен, пробел - отключен (Настройка/Параметры/Группы VIP).

K - если 1 - параметр включен, пробел - отключен (Настройка/Параметры/Определять активность для каждого штрих-кода).

L - наименование каждого из пяти дополнительных полей описания (Настройка/Параметры/Дополнительные поля описания/Наименование).

M - после каждого дополнительного поля описания если 1 - параметр используется (Настройка/Параметры/Дополнительные поля описания/Использование отлично от «не используется»), если пробел - не используется.

Строка 012 - персонифицированный обмен, пороги скидок для групп VIP и накопительные таблицы скидок с разбивкой по аналитическим типам товаров.

012|A|В|C|D|E|F|G

А = пусто (параметр настройки системы отключить персонифицированный обмен включен).

А = 1 (параметр настройки системы отключить персонифицированный обмен отключен).

В = пусто (параметр настройки системы пороги скидок для групп VIP отключен).

В = 1 (параметр настройки системы пороги скидок для групп VIP(офис) включен).

С = пусто (параметр настройки системы аналитические типы в накопительной таблице скидок отключен).

С = 1 (параметр настройки системы аналитические типы в накопительной таблице скидок включен).

D = пусто (параметр настройки переход на новые дисконтные карты отключен).

D = 1 (параметр настройки переход на новые дисконтные карты включен).

E - значение параметра настройки в диапазоне от ... .

F - значение параметра настройки в диапазоне до ... .

G - значение параметра настройки заменять карты на кассах с .

Строка 009 - информация о Группе VIP.

009|Код|Наименование |Статус|Полное наименование

Код - код Группы VIP.

Наименование - наименование Группы VIP.

Статус - 0 - новая, 1 - активная, 2 - архивная.

Полное наименование - полное наименование Группы VIP.

Строк с кодом 009 столько, сколько имеется групп VIP со статусом «активная».

Замечание: данное правило позволяет передавать в магазин информацию сразу о нескольких акциях для группы VIP. Если для группы VIP описано несколько акций, например 2, таких что период действия второй наступает после завершения первой, то несмотря на то, что дата/время корректировок в описании группы VIP уже не изменяется (если акции описаны одновременно), при наступлении времени действия второй акции информация о ней уже содержится в магазинах.

Строка 010 - информация об акции для VIP группы.

010|Действует с|По|Примечание

Действует с - дата начала акции в формате гг-мм-дд.

По - дата окончание акции в формате гг-мм-дд.

Примечание - примечание по акции.

Выгружается только та акция VIP группы, которая имеет статус «действует» и в период действия которой попадает текущая системная дата. Такая акция для каждой группы может быть только одна. Если ни одна акция не удовлетворяет данным условиям, то формируется строка с пустыми значениями всех полей, кроме первого: 010|||.

Строка 011 - условие действующей скидочной акции для VIP группы. Формируется только в случае, если строка с кодом 010 непуста.

011|Аналитический тип|Скидка|С суммы|Прочие

Аналитический тип - код аналитического типа товаров, на которые распространяется акция.

Скидка - размер скидки на товары, обладающие указанным аналитическим типом.

С суммы - значение поля С суммы из описания условия акции.

Прочие - пустое, если в описании условия акции параметр Прочие отключен, «1» в противном случае.

Строк с кодом 011 столько, сколько имеется условий действующей скидочной акции.

Строка 002 - списки штрих-кодов дисконтных карт, закрепленных за одним покупателем.

002|A|B|C|D|E|F

A - штрих-код дисконтной карточки.

B - активность штрих-кода, 1 - штрих-код активен, пробел - неактивен.

С - код VIP группы, к которой привязан штрих код, пробел - если он не привязан ни к одной VIP группе.

D - значение поля С строки с описанием штрих-кода в карточке покупателя.

E - значение поля До строки с описанием штрих-кода в карточке покупателя.

F - значение поля Сумма покупок строки с описанием штрих-кода в карточке покупателя.

Эти 3 записи повторяются в строке с кодом 002 столько раз сколько дисконтных карт закреплено за покупателем.

Строка 003 - анкетная и сводная информация карточки покупателя.

003|A|B|C|D|E|F|G|H|I|J|K|L|М

Если включен параметр настройки системы отключить персонифицированный обмен , то строка имеет вид:

003|A|B

Если параметр настройки системы отключить персонифицированный обмен отключен, но включен параметр настройки системы передавать ФИО в магазины , то строка имеет вид:

003|A|B|C|D|E|F|G|H|I|J|K|L|М

Если параметры настройки системы отключить персонифицированный обмен и передавать ФИО в магазины отключены, то если магазин, для которого формируется файл, является ответственным для покупателя, то строка имеет вид:

003|A|B|C|D|E|F|G|H|I|J|K|L|М

Если магазин, для которого формируется файл, не является ответственным для покупателя, то строка имеет вид:

003|A|B

А - активность основного штрих-кода дисконтной карточки (1 - карточка активна, пробел - неактивна).

B - общая сумма покупок покупателя.

С - фамилия покупателя (Карточка покупателя/ФИО/значение поля, если параметр ФИО указывать в отдельных полях отключен, и значение первого из трех полей, если включен).

D - дата рождения покупателя в формате гггг-мм-дд.

E - пол покупателя, (1 - женский, пробел - мужской).

F - адрес покупателя.

G - телефон покупателя.

H - e-mail покупателя.

I - имя покупателя (Карточка покупателя/ФИО/значение второго из трех полей, если оно заполнено, независимо от текущего значения параметра ФИО указывать в отдельных полях ).

J - отчество покупателя (Карточка покупателя/ФИО/значение третьего из трех полей, если оно заполнено, независимо от текущего значения параметра ФИО указывать в отдельных полях ).

K - код мобильного телефона покупателя.

L - номер мобильного телефона покупателя.

М - скидка покупателя в переходный период.

Строк с кодом 003 столько, сколько имеется карточек покупателей, таких что Дата/Время последней корректировки больше или равно значения поля Подтвержденный экспорт описания магазина, для которого создается файл экспорта.

Если включен параметр настройки системы группы VIP карт , и в списке штрих-кодов обрабатываемого покупателя есть хотя бы один штрих-код, привязанный к некоторой группе VIP, то все анкетные данные покупателя (C|D|E|F|G|H|I|J|K|L) записываются в строку с кодом 003 независимо от того, является ли магазин, для которого формируется файл, ответственным для данного покупателя. Таким образом, в магазины передаются анкетные данные по всем покупателям из групп VIP.

Строка 004 - таблица скидок. Информация выгружается об одной «самой свежей» таблице скидок со статусом «действует».

004|Дата|Примечание

Дата - дата начала действия таблицы скидок.

Примечание - примечание по таблице скидок.

Строка 005 - информация о скидках из описанной выше таблицы.

005|A|B|C|D|E

A - сумма, начиная с которой покупателю предоставляется скидка.

B - размер скидки.

C - примечание по строке скидки.

D - значение аналитическтого типа из описания скидки, если параметр прочие товары отключен и подстрока «Прочие» в противном случае.

E - пустое, если в описании скидки параметр прочие товары включен, «1» в противном случае.

Строк с кодом 005 столько, сколько строк с описанием скидок относится к действующей таблице скидок.

Строка 008 - список штрих-кодов (каждый штрих-код отдельной строкой), для которых центральным офисом принята анкета, пришедшая из магазина.

008 | Штрих-код

Строк с кодом 008 столько, сколько имеется карточек покупателей, в записи о покупателе которых включен признак Анкета получена импортом и в поле Код магазина экспорта анкеты указан код магазина, для которого формируется файл экспорта.

Кроме того:

  • Если в карточке покупателя поле Штрих-код еще не закрыто от корректировки, то оно закрывается от корректировок.
  • Файл записывается по адресу файл для экспорта для данного магазина. Старый файл, если он есть, удаляется.
  • Дата/время создания файла записываются в графу Дата файла экспорта описания магазина, для которого создается файл экспорта.
  • Каждой внесенной в файл экспорта анкете присваивается статус «отправлена».
  • Если в процессе работы процедуры для какого-либо из обрабатываемых магазинов возникает ошибка «No such file or directory» (в случае обмена по FTP), то информация об ошибке записывается в протокол обмена, и процедура переходит к обработке следующего магазина.
  • Формируется файл ИМЯ_export.log, (где ИМЯ - название текущей базы данных), который содержит дополнительную информацию о количестве покупателей и скидках, экспортируемых в каждый магазин, ошибках экспорта, а также суммированную информацию по всем магазинам. Файл находится в той же директории, где расположена текущая база данных. По каждому магазину в файле отображается следующая информация:
  • Экспортировано покупателей
  • Экспортировано скидок
  • Подтверждено анкет

По всем магазинам:

  • Экспортировано файлов
  • Экспортировано покупателей
  • Подтверждено анкет


Файл/Обмен/Импорт информации из магазинов(офис)

Импорт информации из магазинов

Для обмена информацией между БД следует провести импорт информации, кликнув на кнопку (Начать). Далее необходимо отметить магазины, из которых нужно сделать импорт, в справочнике магазинов, содержащем список магазинов сети (за исключением архивных). Отметки проставляются слева от списка в специальном выделенном поле. Если магазины не отмечены, то выгрузка информации производится из всех магазинов.

o Для каждого отмеченного магазина (или для всех магазинов) проверяется доступность файла по пути Файл импорта. Если файл недоступен, то сообщение об этом записывается в протокол ошибок экспорта, который имеет имя с наименованием базы данных_import.log. Из такого магазина импорт не производится.

o Если файл доступен, то проверяется версия файла импорта. При ее несовпадении с версией процедуры обмена, используемой данным экземпляром программы SLS-ДисконтМаг, на экран выводится сообщение об ошибке: «Неверный формат файла», и загрузка данных из файла не выполняется.

o Проверяется идентичность кода магазина из строки 001 файла импорта и из поля Код описания магазина в классификаторе магазинов сети. Если условие не выполняется, то сообщение об этом записывается в файл ошибок импорта, импорт из файла не производится. Если выполняется, то сравнивается дата/время последней корректировки по покупателям магазина из файла (второе значение дата/время из строки с кодом 001) со значением поля Последние данные из магазина из описания магазина в программе SLS-ДисконтОф. Если эти даты равны, или первая раньше второй, то в окне параметров импорта выводится предупреждающее сообщение: «Новой информации по магазину нет», и импорт не производится.

o Если это не так, то последовательно считывается блок информации из файла импорта.

- При обработке строки с кодом 002 проверяются списки штрих-кодов дисконтных карт, закрепленных за одним покупателем. Если в БД нет ни одного штрих-кода покупателя из списка, то создается карточка покупателя, в которую на вкладку Описание записывается основной штрих-код покупателя, считанный из файла, а также на вкладку Штрих-коды записываются остальные штрих-коды покупателя, если они есть. Полю Дата/время последней корректировки карточки покупателя присваивается значение текущей даты/времени создания карточки. Полям Исходящий магазин, Магазин (исх.) и Ответственный магазин присваивается значение поля Название описания магазина, из которого производился импорт информации. Активность карточки определяется значением параметра настройки системы Новые карточки покупателей активны.

- Если в БД есть хотя бы один штрих-код покупателя из списка, то в карточку покупателя на вкладку Штрих-коды записываются остальные штрих-коды покупателя, если они есть. При этом в создаваемой записи поле Группа VIP не заполняется, параметр Активность включается.

- При обработке строки с кодом 006 информация по покупкам покупателя из файла переписывается в карточку покупателя БД, а также в записи о покупке заполняется поле Дисконтная карта. При этом по каждой покупке проверяется, если все характеристики покупки из файла совпадают с соответствующими характеристиками какой-либо строки покупок в карточке покупателя, код магазина из файла импорта равен коду магазина в строке описания покупки в карточке покупателя и штрих-код дисконтной карты из файла импорта равен штрих-коду в строке описания покупки в карточке покупателя, то повторно информация в БД не пишется.

- Если включен параметр пороги скидок для групп VIP , покупка совершена на карту, привязанную к группе VIP, и дата покупки попадает в период, ограниченный датами С - До (правая граница включается) из описания штрих-кода карты, то на вкладке Штрих-коды значение поля Сумма покупок в описании штрих-кода карты увеличивается на значение поля Сумма с учетом скидки из импортируемой покупки. Полю Дата/время последней корректировки присваивается текущее значение даты/времени.

- Пересчитывается общая сумма покупок покупателя и новое значение записывается в карточку покупателя в поле Общая сумма покупок. Также пересчитывается текущая скидка покупателя в соответствии с действующей таблицей сидок, и если оно отлично от текущего значения, то новое значение записывается в карточку покупателя в поле Текущая скидка. Если покупка выполнена на дисконтную карту со штрих-кодом, привязанным к некоторой группе VIP, то общая сумма покупок в описании карточки покупателя не увеличивается. Полю Дата/время последней корректировки присваивается текущее значение даты/времени.

- При обработке строки с кодом 007 выполняются следующие действия:

§ По штрих-коду из строки осуществляется поиск карточки покупателя. Если карточка не найдена, то строка пропускается и в протокол пишется сообщение об ошибке: «Для импорт анкеты не найден покупатель с кодом №».

§ Если карточка найдена, то:

Если параметр настройки переход на новые дисконтные карты отключен, то проверяется совпадает ли в записи о покупателе значение поля Магазин экспорта анкеты с кодом магазина, из которого производится импорт информации.

o Если не совпадает, то в протокол пишется сообщение об ошибке: «Конфликт анкетных магазинов для покупателя с кодом №» и карточка покупателя пропускается.

o Если совпадает, то проверяется, заполнено ли для данного покупателя поле ФИО.

§ Если заполнено, то карточка покупателя пропускается.

§ Если нет, то анкета покупателя заполняется данными согласно обрабатываемой строке файла обмена, после чего для карточки покупателя в поле Магазин экспорта анкеты проставляется код магазина, из которого производится импорт информации.

Если параметр настройки переход на новые дисконтные карты включен, то по номеру карты, для которого передается анкета, в базе данных ищется соответствующая запись о штрих-коде из поля Штрих-код описания анкеты.

o Если в описании штрих-кода поле Дата выдачи заполнено, то никаких дополнительных действий не производится.

o Если в описании штрих-кода поле Дата выдачи пустое, то выполняются следующие действия:

§ Анкетные данные из файла безусловным образом записываются поверх анкетных данных покупателя, которому принадлежит штрих-код карты из обрабатываемой строки (в том числе заполняется новое поле Информацию получать по). В карточке покупателя в поле Магазин экспорта анкеты проставляется код магазина, из которого получен файл импорта.

§ Значение поля Дата/время заполнения из строки с кодом 007 помещается в поле Дата/время заполнения карточки покупателя.

§ Если в строке с анкетой покупателя с кодом 007 заполнено поле Замена карты старого образца, то в записи с описанием штрих-кода из поля Замена карты старого образца обрабатываемой строки файла импорта отключается параметр Активность.

§ В записи с описанием штрих-кода из поля Штрих-код обрабатываемой строки файла импорта включается параметр Активность.

§ В описание штрих-кода из поля Штрих-код обрабатываемой строки файла импорта в поле Дата выдачи помещается значение поля Дата заполнения анкеты из обрабатываемой строки файла импорта.

§ Штрих-код дисконтной карты из поля Штрих-код обрабатываемой строки файла импорта отмечается как основной штрих-код покупателя и записывается на вкладку Описание в поле Штрих-код.

§ Поле Активность на вкладке Описание принимает значение в соответствии со значением поля Активность записи об основном штрих-коде (параметр Активность включается).

Если включен параметр настройки использовать в магазинах , то при обработке 5 дополнительных полей описания значение каждого из этих полей принимается за значение дополнительного поля описания покупателя с соответствующим номером (от 1 до 5). Т.е. значения этих полей используются для заполнения дополнительных полей описания покупателя, которому сопоставляется импортируемая анкета. При импорте обязательность заполнения дополнительных полей, а также то, используется ли данное поле в настоящий момент или нет, НЕ учитывается. Т.е. значения полей импортируются и сохраняются в описании покупателя в любом случае.

- Полю Дата/время последней корректировки присваивается текущее значение даты/времени.

o Если вся возможная информация из файла успешно записана в БД, то дата/время наиболее свежей информации, успешно импортированной из центрального офиса в данный магазин из файла (первое значение дата/время из строки с кодом 001, т.е. значение поля Последние данные из офиса в параметрах настройки системы SLS-ДисконтМаг) записывается в поле Подтвержденный экспорт в описании магазина в программе SLS-ДисконтОф.

o Дата/время последней корректировки по покупателям магазина из файла (второе значение дата/время из строки с кодом 001) записывается в поле Последние данные из магазина в описании магазина в программе SLS-ДисконтОф).

o Дата/время создания файла экспорта из магазина из файла (третье значение дата/время из строки с кодом 001, т.е. значение поля Дата файла экспорта в параметрах настройки системы SLS-ДисконтМаг) записывается в поле Дата файла импорта описания магазина в программе SLS-ДисконтОф.

o Если в процессе работы процедуры для какого-либо из обрабатываемых магазинов возникает ошибка «No such file or directory» (в случае обмена по FTP), то информация об ошибке записывается в протокол обмена, и процедура переходит к обработке следующего магазина.

Кнопка (Начать) заменяется кнопкой (ОК), нажатие которой позволяет закрыть окно, а кнопка (Отказаться) заменяется кнопкой (Протокол), нажатие которой позволяет отобразить на экране протокол проведения процедуры экспорта информации.

Также формируется файл ИМЯ_import.log, (где ИМЯ - название текущей базы данных), который содержит дополнительную информацию о количестве покупателей и скидках, экспортируемых в каждый магазин, ошибках экспорта, а также суммированную информацию по всем магазинам. Файл находится в той же директории, где расположена текущая база данных.

По каждому магазину:

  • Импортировано покупателей
  • Импортировано покупок
  • Импортировано анкет

По всем магазинам:

  • Импортировано файлов
  • Импортировано покупателей
  • Импортировано покупок
  • Импортировано анкет
  • Пересчитано покупателей


Файл/Обмен/Импорт-экспорт новой информации(офис)

Импорт-экспорт новой информации

Производится импорт информации из всех возможных на текущий момент магазинов в соответствии с правилами, описанными в разделе Файл/Обмен информацией между БД/Импорт информации из магазинов , а также происходит подготовка экспортных файлов для всех магазинов сети в соответствии с правилами, описанными в разделе Файл/Обмен информацией между БД/Экспорт обновлений в магазины .

Подробнее см.

Процедура экспорта-импорта информации для нового магазина,

Процедура экспорта-импорта информации для одного из магазинов сети


Общие команды редактирования

При вводе и корректировке любых полей информации в программе используются общие команды редактирования.

  • Для передвижения курсора от поля к полю служат клавиши:

Tab - переход на следующее поле;

Shift+Tab - переход на предыдущее поле;

Стрелки: налево, направо, вверх, вниз - переход на ближайшее поле в указанном направлении (если достигли границы поля);

Enter - если поле однострочное, то переход на следующее поле, если многострочное, то перенос информации справа от курсора на строку ниже

  • Для передвижения курсора внутри поля:

Стрелки: налево, направо, вверх, вниз;

Home - переход на левую границу текста в строке, на которой стоит курсор;

End - переход на правую границу текста в строке, на которой стоит курсор;

Backspace - для удаления символа слева от курсора;

Del - для удаления символа справа от курсора;

Ctrl+Y - для удаления всей информации внутри поля;

Esc - для отказа от корректировки или ввода информации;

PgDn - для сохранения введенной информации

* - устанавливает текущую дату в поле

  • Для создания, корректировки, удаления объектов:

Ins - добавить

F2 - изменить

Del - удалить

Ctrl+R - пересчет

Ctrl+P - печать


Кард ридер

Работа с устройством для считывания магнитных карт

Настройка кард-ридера в программных модулях "SLS-Дисконт" производится в меню "Настройка -> Рабочая станция". Следует нажать на кнопку "Настройка сканера", открыть вкладку "Кард-ридер" и заполнить следующие параметры:

  • Кард-ридер используется (поле-флажок). Если параметр включен, то кард-ридер будет использоваться на данной рабочей станции.
  • Порт, куда подключен кард-ридер. Значение по умолчанию СОМ1.
  • Поля для настройки режима порта (скорость передачи, четность, количество бит и количество стоп-бит).
  • Таблица настройки префиксов/суффиксов дорожек чтения и выбор дорожки, содержащей код карты.

Все настройки по умолчанию соответствуют настройкам для кард-ридера Cipher MSR 1023. В окне настройки также обеспечена возможность проверки чтения карточек и результатов этого чтения.

В каталоге карточек покупателей в ветвях "Покупатели по штрих-кодам" в программных модулях "SLS-Дисконт" при считывании кода кард-ридером осуществляется подвод к карточке покупателя с соответствующим номером дисконтной карты. Если карточка покупателя найдена, то она открывается на просмотр, если нет, то на экран выводится сообщение: "Карточка покупателя с номером N не найдена", где N - номер дисконтной карты, считанный устройством.

При создании и корректировке карточки покупателя в программе "SLS-ДисконтОф" можно воспользоваться кард-ридером для ввода номера считанной дисконтной карты в поле "Штрих-код". Номер вводится автоматически после провода карточки через кард-ридер, а фокус ввода в данный момент находится в любом из полей описания карточки.

В программе "SLS-Касса" в тех же самых местах программы, где допускается чтение дисконтной карты сканером, можно использовать чтение карточек кард-ридером.


Главное меню

Главное меню системы состоит из пунктов:

  • Файл
  • Покупатели
  • Скидки
  • Классификаторы
  • Настройка
  • Окна
  • Справка


Меню Файл

Файл

Используется для работы с базами данных: создания, открытия, закрытия файлов, обмена информацией между базами данных. Меню содержит следующие пункты:

  • Открыть
  • Закрыть БД
  • Подключиться с другим именем
  • Тестирование базы данных
  • Выгрузить базу данных
  • Создать базу данных по выгруженной информации
  • Создать новую (пустую) базу данных
  • Обмен информацией между базами данных
  • Системная информация
  • Параметры последней корректировки
  • Калькулятор
  • Календарь
  • Список последних открытых файлов
  • Завершение работы


Меню Покупатели(офис)

Покупатели

Встроенный модуль контроля карточек покупателя содержит раздел:

  • Карточки покупателей
  • Группы VIP


Меню Скидки

Скидки

Используется для хранения списка таблиц скидок, а также каталога групп VIP клиентов и содержит пункты:

  • Таблицы скидок
  • Акции групп VIP - отображается если включен параметр настройки группы VIP .


Меню Классификаторы(офис)

Классификаторы

Используется для ведения словаря магазинов сети и регионов и содержит следующие пункты:

  • Магазины сети
  • Регионы


Меню Настройка

Настройка

Используется для настройки параметров работы системы. Настройка параметров необходима для адаптации программы к условиям и принципам работы конкретного предприятия.

Настройка параметров не требует знаний программирования и предназначена, в основном, для включения и выключения различных возможностей программы. Раздел содержит следующие пункты:

  • Рабочая станция
  • Изменить пароль
  • Параметры
  • Пользователи и их права
  • Установить списки по умолчанию


Меню Окна

Окна

Используется для работы с окнами и содержит следующие пункты:

  • Закрыть все окна
  • Список открытых окон


Меню Справка

Справка

Используется для открытия файла справочной системы и вызова пункта о программе


Файл/Открыть

Открыть

Используется для открытия рабочей базы данных. Если вызов функции подключения к базе данных производится, когда система уже подключена к какой-либо базе данных, то сначала система отключается от текущей базы данных, а затем управление передается функции подключения к другой базе данных.

В разделе Настройка/Рабочая станция можно указать базу данных, которая будет автоматически открываться при запуске программы. Для этого нужно заполнить параметр при старте автоматически подключаться к базе данных или открывать последнюю базу данных .

Если с базой данных работали в течение предыдущих сеансов, то ее можно открыть, выбрав из списка последних открытых файлов


Файл/Закрыть БД

Закрыть БД

Используется для закрытия базы данных. Система производит отключение от базы данных, после чего главное меню приводится к виду, отображаемому до подключения к базе данных.


Файл/Подключиться с другим именем

Подключиться с другим именем

Используется для подключения к базе данных с именем и паролем, описанным в каталоге пользователей системы для данной БД.


Файл/Тестирование БД

Тестирование БД

Используется для проверки целостности данных.

Формируется файл ИМЯ_test.log, (где ИМЯ - название текущей базы данных), который содержит список ошибок если таковые были обнаружены в результате тестирования. Для исправления ошибок в базе данных следует выполнить выгрузку базы данных и создание базы данных по выгруженной информации.


Файл/Выгрузить БД

Выгрузить БД

Выгрузка базы данных в текстовый файл производится в случае нарушения целостности базы данных в результате сбоев в работе компьютера.

Для выгрузки базы данных нужно заполнить следующие параметры:

  • База данных
  • Текстовый файл
  • После выгрузки создать БД по выгруженной информации

По окончании работы процедуры формируется файл с расширением .log, содержащий список выгруженных параметров. Просмотреть его можно нажатием кнопки (Протокол). После завершения процедуры выгрузки для получения новой базы данных следует выполнить процедуру создания базы данных по выгруженной информации .

Также возможна выгрузка и создание новой БД через командную строку

Примечание.

Для выгрузки база данных должна быть отключена от Сервера приложений (для сетевой версии программы). В противном случае при попытке выгрузки будет выдано сообщение "База данных занята. Ждите ее освобождения."


Файл/Выгрузить БД/База данных

База данных

Для выгрузки базы данных - имя БД, из которой выгружается информация. По умолчанию отображается имя открытой базы данных. Чтобы изменить имя выгружаемой БД, нужно вызвать стандартный каталог Windows для выбора другого файла БД с расширением .dbx.

Для создания базы данных - имя БД, которая будет создана по выгруженной информации. По умолчанию предлагается файл с именем БД из имени текстового файла, расположенный по тому же пути, что и выгружаемый файл. Чтобы изменить имя создаваемой БД, нужно вызвать стандартный каталог Windows для выбора другого файла БД с расширением .dbx.


Файл/Выгрузить БД/Текстовый файл

Текстовый файл

Для выгрузки базы данных - имя текстового файла с расширением .UNL, в который выгружается информация из БД. По умолчанию имя файла совпадает с именем базы данных, расположенный по тому же пути, что и выгружаемый файл. Чтобы изменить имя файла, нужно вызвать стандартный каталог Windows для выбора другого файла с расширением .unl.

Для создания базы данных - имя текстового файла с расширением .UNL, из которого загружается информация в БД. Чтобы изменить имя файла, нужно вызвать стандартный каталог Windows для выбора другого файла с расширением .unl.


Файл/Выгрузить БД/После выгрузки создать БД по выгруженной информации

После выгрузки создать базу данных по выгруженной информации

При включенном параметре после выгрузки БД в текстовый файл произойдет автоматический вызов функции создания БД по выгруженной информации


Файл/Создать БД по выгруженной информации

Создать БД по выгруженной информации

Используется в случае нарушения целостности базы данных в результате сбоев в работе компьютера. Для создания базы данных нужно заполнить следующие параметры:

  • База данных
  • Текстовый файл

По окончании работы процедуры формируется файл с расширением .log, содержащий список загруженных параметров. Просмотреть его можно нажатием кнопки (Протокол).

Перед созданием БД обязательно нужно выполнить выгрузку старой БД в текстовый файл, выбрав раздел выгрузить базу данных .

После создания базы данных следует установить пароль системы!


Файл/Выгрузить/Загрузить БД через командную строку

Выгрузка и создание БД по выгруженной информации через командную строку

Если команда в командной строке имеет формат «Полный_путь_к_DiscountOffice.exe Полный_путь_к_базе_CENTER.dbx /U», то её выполнение приводит к следующим действиям:

§ Запускается .exe-файл, расположенный по указанному адресу;

§ Запущенная программа открывает базу данных с указанным названием;

§ Открытая база данных выгружается, в директории с текущей базой данных создается по выгруженной информации файл *.unl;

§ По этому файлу в той же директории создается по выгруженной информации новая база данных с тем же названием, что и исходная (перед этим исходная БД удаляется);

§ Программа DiscountOffice.exe закрывается.

Таким образом, выполнение этой команды приводит к тем же результатам, что и последовательное выполнение функций Выгрузить БД и Создать БД по выгруженной информации , вызванных из программы DiscountOffice.exe для базы CENTER.dbx.


Файл/Создать новую (пустую БД)

Создать новую (пустую БД)

Используется для создания новой базы данных для работы с программой. В созданной базе данных выполняется создание всех необходимых структур (таблицы, индексы и т.п.), а также заносится следующая информация:

§ В таблицу логических пользователей базы данных заносится привилегированный пользователь-администратор по умолчанию с именем «admin», данный пользователь не отображается в каталоге пользователей и является универсальным пользователем-администратором базы данных. При создании базы данных пароль для данного пользователя не задается, однако он может быть задан позднее.

После завершения действий по созданию базы данных производится автоматическое подключение к базе данных от имени пользователя admin.


Файл/Обмен информацией между БД(офис)

Обмен информацией между БД

Обмен данными между центральным офисом и каждым магазином проводится через два файла обмена: в один файл система записывает экспортируемую информацию, из другого считывает информацию, записанную второй системой. Данные об именах и месте расположения файлов на дисках компьютеров вносятся в параметры настройки систем, функционирующих в магазинах, и в справочник магазинов (по каждому магазину своя пара файлов), который ведется в центральном офисе. В каждой системе реализуются функции обмена информацией между ними. Эти функции вызываются операторами через меню каждой системы.

Каждая система отвечает за подготовку и запись, а также за чтение информации только на своей стороне. Для того, чтобы подготовленная одной системой информация попала в БД другой системы, в ней также необходимо выполнить функцию "Импорт информации".

Раздел "Обмен информацией между базами данных" используется для:

  • Выполнения процедуры экспорта данных с целью дальнейшего импорта данных в другую базу данных;
  • Выполнения процедуры импорта данных из файла экспорта в базу данных;
  • Выполнения процедуры импорта-экспорта информации из всех магазинов с последующим экспортом обновлений магазинам.

Все значения дат и времени в магазинах записываются в местном времени магазинов. Все значения дат и времени в центральном офисе записываются в местном времени центрального офиса. При передаче информации из центрального офиса в магазин и обратно все даты и времена, импортируемые из удаленных баз данных, приводятся к местному времени.

Внимание!!! При работе с Дисконтной системой каждая база данных, принимающая участие в обмене информацией, должна иметь собственные настройки и уникальные файлы обмена. В центральном офисе и в каждом из магазинов сети необходимо осуществлять работу с одной базой данных, т.к. в противном случае (при работе с копиями) данные могут быть безвозратно утеряны.

Раздел содержит следующие пункты:

  • Импорт-экспорт новой информации
  • Экспорт обновлений в магазины
  • Импорт информации из магазинов

Доступ к разделу "Обмен информацией между базами данных" имеют только пользователи с правами администратора.

Подробнее см.

Процедура экспорта-импорта информации для нового магазина,

Процедура экспорта-импорта информации для одного из магазинов сети

Описание процесса обмена информацией между центральным офисом и магазинами сети

Кроме того, вызов программы SLS-ДисконтОф возможен только для обмена данными .


Файл/Вызов программы только для обмена данными(офис)

Вызов программы только для обмена данными

Осуществляется вызовом приложения программы SLS-ДисконтОф таким образом, что программа выполняет процедуру обмена, не разворачиваясь на экран, а затем прекращает свою работу.

Исполняемый файл приложения программы SLS-ДисконтОф имеет параметр -е и содержит имя файла настроек: DscntOf.exe -e имя_ файла_настроек

Файл настроек отвечает следующим требованиям:

- Текстовый файл в кодировке DOS с расширением «.txt» (например, settings.txt), расположенный по тому же пути, что и исполняемый файл приложения SLS-ДисконтОф.

- В первой строке файла указан полный путь и имя файла базы данных, во второй - имя пользователя, в третьей - пароль пользователя, в четвертой - путь к папке, в которую будет помещен файл протокола.

Если исполняемый файл программы запускается с параметром -е, то по пути, указанному в четвертой строке файла настроек, создается текстовый файл протокола имя_базы.elg, в который будет помещена информация о ходе и результатах работы программы. Если в четвертой строке файла настроек путь не указан, или указан не верно, или файл настроек при запуске программы указан не был, то файл протокола создается в стандартной папке временных файлов текущего пользователя операционной системы Windows.

При вызове исполняемого файла программы с параметром -е выполняются следующие действия:

  • Проверяется доступность указанного в параметрах запуска файла настроек. Если файл недоступен, то программа завершает работу. При этом в лог-файл записывается сообщение «Не найден или недоступен файл настроек.».
  • Проверяется, что в первой строке файла настроек указан путь к файлу базы данных. Если путь указан неверно или заданный файл не является файлом базы данных, то программа завершает работу. При этом в лог-файл записывается сообщение «Неверно указан путь к файлу базы данных».
  • Производится попытка подключения к указанной базе данных с заданным в файле настроек именем и паролем пользователя. Если подключиться не удалось, то программа завершает работу. При этом в лог-файл записывается сообщение «Неверные имя и/или пароль пользователя. Подключиться к базе данных не удалось».

В лог-файл записываются строки «Подключение к базе данных Дата/Время» и «Лог-файл процедуры см. в Путь к лог-файлу», где Дата/Время - текущие системные дата и время, а в Путь к лог-файлу указывается полный путь и имя лог-файла процедуры Импорт-экспорт новой информации . Выполняется вызов процедуры Импорт-экспорт новой информации . При этом на экран визуальный интерфейс программы не отображается. В файлы протоколов данные пишутся по тем же правилам, что и при ручном вызове указанной процедуры. По завершении работы данной процедуры программа записывает в лог-файл строку «Процедура обмена завершена Дата/время», где Дата/Время - текущие системные дата и время, и завершает работу.


Файл/Калькулятор

Калькулятор

Встроенный калькулятор вызывается в разделе Файл либо клавишами Ctrl+Alt+C на любом уровне программы.

Для вычисления нужного значения, в рабочее поле "Формула" заносится математическое выражение с использованием круглых скобок, операций сложения (+), вычитания (-), умножения (*), деления (/) и дополнительных функций, определенных в списке "Показывать список функций и переменных".


Файл/Календарь

Календарь

Открывается календарь на текущий месяц. Пользователь может установить курсор на названии текущего месяца и нажатием левой кнопкой мыши получить список всех месяцев года и самостоятельно выбрать нужный. Кроме того, нажатие левой кнопки мыши на значении года позволяет ввести необходимый для просмотра год.


Файл/Список последних открытых файлов

Список последних открытых файлов

В окне содержится список последних открытых файлов базы данных (не более десяти). Количество файлов задается в настройках рабочей станции. Используется для быстрого открытия файла базы данных.

При выборе файла из списка:

  • Автоматически закрываются все открытые окна
  • Закрывается ранее открытая база данных
  • Открывается выбранная база из списка


Файл/Завершить работу

Завершить работу

Используется для завершения работы программы. Все ранее открытые окна автоматически закрываются, происходит отключение от базы данных и работа приложения завершается.


Бонусная система

Правила работы с бонусами в системе SLS-Дисконт:

- Бонусы накапливаются на дисконтной карте клиента.

- Начисление бонусов выполняется при совершении покупок, регистрируемых на дисконтную карту покупателя, на которой накоплена общая сумма покупок, превышающая некоторый заданный порог. Бонусы начисляются в размере некоторого фиксированного процента от суммы совершаемой покупки, оплаченной наличными деньгами.

- Если на дисконтной карте накоплены бонусы, то они могут использоваться для расчета скидки на товары, при этом сумма бонусов на карте уменьшается на сумму данной скидки. Один бонус принимается равным одному рублю.

- Покупка не может быть оплачена бонусами полностью. Каждый товар каждой позиции чека должен быть оплачен наличными деньгами в сумме, не менее 1 рубля. Т.е. если одна позиция чека содержит 10 товаров, то минимальная сумма оплаты по данной позиции составляет 10 рублей.

- Возврат покупки, оплаченной с использованием бонусов, должен осуществляться в том магазине, где он был приобретен.

- При оформлении возврата покупки, оплаченной с использованием бонусов, возврат денег покупателю производится в том же объеме, в каком наличными деньгами была оплачена покупка. При этом:

o возврат бонусов, составляющих скидку на данную покупку, на дисконтную карту клиента не производится.

o если при покупке возвращаемого товара за него были начислены бонусы, то они списываются с дисконтной карты клиента.


Карточки покупателей(офис)

Карточки покупателей

Раздел доступен пользователям с правом на просмотр карточек покупателей.

Информация в разделе имеет следующую структуру: в левом окне высвечивается дерево покупателей , а в правом список карточек покупателей, соответствующий открытой группе в дереве покупателей.

Работа с карточками покупателей ведется при помощи меню Покупатели и Операции , а для печати выходных форм используется меню Формы .

В списке покупатели отсортированы по алфавиту. Чтобы произвести сортировку по другому полю, нужно кликнуть на заголовке данного поля. Если треугольник в заголовке поля расположен углом вниз, покупатели сортируются по данному полю по возрастанию. Если треугольник направлен вверх, происходит сортировка по убыванию.

В списке можно поменять колонки местами. Для этого нужно кликнуть мышкой на названии колонки и не отпуская кнопки мыши "перетащить" колонку в нужное место. Убрать колонку из списка можно уменьшив ее размеры до нуля. Чтобы изменить внешний вид списка карточек покупателей, нужно нажать правой кнопкой мыши и выбрать меню Списки/ Настройка списков .


Скидки/Таблицы скидок(офис)

Таблицы скидок

Раздел доступен пользователям с правом на просмотр таблиц скидок.

Система скидок является накопительной. Первая строка скидок из описания действующей таблицы скидок задает порог, при преодолении которого в виде единовременной покупки покупателю выдается дисконтная карточка.

Таблиц со статусом «действует» может быть несколько, однако реально действующей будет считаться та таблица со статусом «действует», дата Действует с которой будет «старее» текущей системной даты и максимально приближена к ней. Согласно этой таблице будет пересчитываться размер текущей скидки в карточках покупателей, и именно она будет экспортироваться в файл обмена для магазинов сети.

Возможность назначения разных скидок для товаров разных аналитических типов для накопительной скидочной программы определяется параметром настройки системы аналитические типы в накопительной таблице скидок . На накопительной карте покупателя копится общая сумма покупок независимо от аналитических типов купленных товаров.

В разделе хранится список всех таблиц скидок. Здесь таблицы можно добавлять, корректировать и удалять при помощи меню Таблицы , а для печати выходных форм использовать меню Формы .

Список таблиц представлен в виде списка с графами:

  • Действует с - дата, с которой вводится в действие таблица скидок.
  • Примечание - любой комментарий к таблице.
  • Статус - статус таблицы может принимать любое из трех значений: "архив", "действует" или "проект".
  • Скидки зафиксированы - дата расчета скидок покупателей по данной таблице скидок. Отображается, если включен параметр настройки фиксировать скидки при смене таблицы скидок .

В списке таблицы скидок отсортированы по дате Действует с в порядке возрастания.

В нижней части экрана отображается окно со списком строк, соответствующих текущей таблице из списка таблиц.

  • Скидки - создание, корректировка и удаление строк таблицы скидок.

Список скидок представлен в виде таблицы с графами:

  • Аналитический тип - код аналитического типа из программы SLS-Эксперт. Скидка предоставляется только на товары с данным аналитическим типом. Если поле пустое, то скидка предоставляется на товары, в которых аналитический тип не задан.
  • Прочие товары - скидка распространяется на все товары, не попадающие под другие условия по значению аналитического типа.
  • С суммы - число (сумма в рублях), задающее сумму покупок, начиная с которой покупателю предоставляется скидка.
  • Скидка - размер скидки в %, предоставляемый покупателю.
  • Примечание - можно внести примечание по данной строке.

Столбцы Аналитический тип и Прочие товары отображаются, если включен параметр настройки аналитические типы в накопительной таблице скидок .

Список скидок упорядочен в алфавитном порядке по аналитическим типам, а затем по возрастанию значений С суммы.

В таблице скидок не может быть двух строк с одинаковыми значениями полей Аналитический тип, Прочие товары, С суммы.

Чтобы произвести сортировку таблиц скидок по другому полю, нужно кликнуть на заголовке данного поля. Если треугольник в заголовке поля расположен углом вниз, таблицы скидок сортируются по данному полю по возрастанию. Если треугольник направлен вверх, происходит сортировка по убыванию.

В списке можно поменять колонки местами. Для этого нужно кликнуть мышкой на названии колонки и не отпуская кнопки мыши "перетащить" колонку в нужное место. Убрать колонку из списка можно уменьшив ее размеры до нуля. Чтобы изменить внешний вид списка, нужно нажать правой кнопкой мыши и выбрать меню Списки/ Настройка списка .


Скидки/Акции групп VIP(офис)

Акции групп VIP

Раздел отображается в системе, если включен параметр настройки группы VIP и содержит список всех акции для групп VIP (и условия по ним), которые затем могут быть применены к произвольному набору групп VIP из каталога групп VIP . Акции, созданные в классификаторе, корректируются и удаляются только в нем, внесенные корректировки акций и условий по ним распространяются на все группы VIP, к которым применена данная акция. В описании каждой из групп VIP каталога групп VIP имеется возможность создания индивидуальных акций по группе.

Раздел доступен пользователям с правом на просмотр акций групп VIP.

Список акций для групп VIP представлен в виде списка с графами:

  • Начало - дата начала действия акции.
  • Завершение - дата окончания действия акции.
  • Примечание - примечание по акции.
  • Статус - статус акции.
  • Дата/время последней корректировки - дата/время последней корректировки акции или ее условий. Заполняется системой автоматически при создании и корректировке описания акции, а также при добавлении/корректировке/удалении списка условий по ней. Столбец отображается, если включен параметр настройки системы пороги скидок для групп VIP .

Список акций упорядочен по возрастанию значений столбца Начало.

Работа в списке акций для групп VIP ведется при помощи меню Акции , Группы VIP и Условия .

Для каждой акции в нижней части окна отображаются две дополнительные вкладки:

  • Группы VIP- список групп VIP, на которые распространяется действие акции.
  • Условия предоставления скидок - описание правил предоставления скидок согласно данной акции.

Чтобы произвести сортировку таблиц скидок по другому полю, нужно кликнуть на заголовке данного поля. Если треугольник в заголовке поля расположен углом вниз, таблицы скидок сортируются по данному полю по возрастанию. Если треугольник направлен вверх, происходит сортировка по убыванию.

В списке можно поменять колонки местами. Для этого нужно кликнуть мышкой на названии колонки и не отпуская кнопки мыши "перетащить" колонку в нужное место. Убрать колонку из списка можно уменьшив ее размеры до нуля. Чтобы изменить внешний вид списка, нужно нажать правой кнопкой мыши и выбрать меню Списки/ Настройка списка .


Классификаторы/Регионы(офис)

Регионы

В разделе хранится список всех регионов, к которым относятся магазины сети. Регионы можно добавлять, корректировать и удалять при помощи меню Регионы .

На экране отображается окно, представленное в виде списка с графами:

  • Код - код региона
  • Название - название региона


Настройка/Изменить пароль

Настройка пароля

Используется для замены пароля пользователя, от имени которого произведено подключение к базе данных

Установка пароля

Чтобы установить пароль, нужно выбрать данный пункт меню и вписать пароль в поле «Введите новый пароль» и в поле «Введите новый пароль еще раз для контроля». После этого следует кликнуть на кнопке (Сохранить). Введенный пароль отображается в виде звездочек. Чтобы увидеть настоящий пароль, нужно кликнуть на пиктограмме с очками.

Снятие пароля

Чтобы снять пароль, нужно в поле «Введите старый пароль» заполнить старый пароль, остальные поля оставить пустыми и кликнуть на кнопке (Сохранить).

Изменение пароля

Чтобы изменить пароль, нужно заполнить старый пароль в поле «Введите старый пароль», в поля «Введите новый пароль» и «Введите новый пароль еще раз» заполнить новый пароль и кликнуть на кнопке (Сохранить).


Установка списка по умолчанию/Настройка списка

Настройка списка

На различных уровнях работы в программе пользователь имеет право самостоятельно настроить список информации, представленной на экране, включив в него дополнительные колонки и исключив ненужные.

Для настройки списка нужно правой кнопкой мышки вызвать вертикальное меню, выбрать в нем пункт Списки/Настройка списков.

Чтобы создать новый вид списка, нужно кликнуть на кнопке (Добавить) и заполнить следующие параметры настройки списка:

  • Название списка, которое будет выдаваться в перечне настроенных списков
  • Перечень колонок, включенных в список.

Допускается создание нескольких различных видов списков. Для корректировки и удаления списков предназначены кнопки (Изменить) и (Удалить) соответственно.

Чтобы получить на экране настроенный список, нужно правой кнопкой мыши вызвать вертикальное меню, выбрать в нем пункт Списки и выбрать один из описанных списков. Для перехода к обычному списку нужно выбрать в вертикальном меню пункт Списки/Исходный список.


Окна/Список открытых окон

Список открытых окон

Если открыты какие-либо окна, соответствующие разделам системы, то их заголовки отображаются в разделе Окна.

Пункт используется для быстрого перехода в другое окно.


Окна/Закрыть все окна

Закрыть все окна

Используется для закрытия всех открытых разделов системы, кроме главного окна.


Справка/О программе

О программе

Содержит краткую информацию о названии и версии программного продукта, а также контактную информацию о фирме-изготовителе SoftLand Systems (почтовый и электронный адрес, телефон).


Настройка/Параметры/Переход на новые дисконтные карты(офис)

Переход на новые дисконтные карты

Признак, указывающий на введение программы перехода на новые дисконтные карты. Если параметр включается, то открываются для корректировки параметры в диапазоне от ... до ... и заменять карты на кассах с . Если параметр включается и его значение сохранено, то он закрывается от корректировки.

Если включен ранее пустой параметр Переход на новые дисконтные карты, то при сохранении изменений производятся следующие дополнительные проверки (в скобках приведены сообщения об ошибках):

- Если параметр в диапазоне от ... до ... доступен для корректировки, то хотя бы одна из границ диапазона должна быть заполнена.

- Размерность каждого из полей в диапазоне от ... до ... соответствует размерности поля штрих-кода из параметра настройки размер штрих-кода .

- Обрабатываются все штрих-коды карточек покупателей, размерность которых соответствует размерности поля штрих-кода из параметра настройки размер штрих-кода и проверяется, есть ли среди них хотя бы один штрих-код, значение которого попадает в промежуток из параметра настройки в диапазоне от ... до ... .

o Если такой штрих код найден, на экран выводится сообщение об ошибке: («В базе данных имеются штрих-коды, соответствующие штрих-кодам новых дисконтных карт. Продолжить?») с кнопками (Да) и (Нет). Нажатие (Нет) позволяет отказаться от сохранения изменений параметров настройки.

o При нажатии (Да) или если ни одного штрих-кода не найдено и предыдущие проверки прошли успешно, на экран выводится предупреждающее сообщение: «Вы собираетесь запустить процедуру перехода на новые дисконтные карты. Для всех зарегистрированных в системе накопительных дисконтных карт, чей номер не попадает в диапазон новых дисконтных карт, будет зафиксирована скидка для аналитического типа товаров с кодом 00000001, согласно действующей на текущую дату таблице скидок. Вы подтверждаете переход?» и кнопками (Да) и (Нет). Нажатие (Нет) позволяет отказаться от сохранения изменений параметров настройки. При нажатии (Да) выполняется сохранение изменений параметров настройки и обрабатываются все карточки покупателей ветви Покупатели по именам, в которых значение поля общая сумма покупок > 0. Для каждого такого покупателя по значению поля общая сумма покупок и действующей на момент запуска процедуры пересчета таблице скидок определяется % скидки, который должен предоставляться по такой накопленной сумме для товаров с аналитическим типом 00000001. Вычисленный % скидки записывается в поле скидка перех. периода описания покупателя.

Замечание: дата/время последней корректировки карточки покупателя при этом не обновляется.


Настройка/Параметры/Название организации

Название организации

Полное название фирмы, которое будет распечатываться в заголовке различных форм и документов.


Настройка/Параметры/В диапазоне от ... до ... (офис)

В диапазоне от ... до ...

Диапазон номеров штрих-кодов новых дисконтных карт. Доступен для корректировки, если включен параметр переход на новые дисконтные карты . Если поле доступно для корректировки, то хотя бы одна из границ диапазона должна быть заполнена. Если заполнен параметр настройки размер штрих-кода , то его размерность должна совпадать с размерностью каждого из полей диапазона новых карт.


Настройка/Параметры/FTP-сервер

FTP-сервер

Используется для ввода имени или IP адреса сервера, посредством которого будет производиться обмен данными. Параметр доступен для заполнения/корректировки, если параметр Тип обмена имеет значение FTP.


Настройка/Параметры/Заменять карты на кассах с(офис)

Заменять карты на кассах с

Дата, начиная с которой при сканировании дисконтной карты на кассе будет определяться принадлежность карты к картам «старого» или «нового» образца и для карт «старого» образца будет проводиться процедура замены. Доступен для корректировки, если включен параметр переход на новые дисконтные карты .


Настройка/Параметры/Порт

Порт

Используется для ввода порта, через который осуществляется доступ на FTP-сервер. Значение по умолчанию 21. Параметр доступен для заполнения/корректировки, если параметр Тип обмена имеет значение FTP.


Настройка/Параметры/Пользователь

Пользователь

Используется для задания имени пользователя, которое будет запрашиваться для входа на FTP-сервер. Доступ к разделу Настройки/Параметры имеют только пользователи с правами администратора. Параметр доступен для заполнения/корректировки, если параметр Тип обмена имеет значение FTP.


Настройка/Параметры/Пароль

Пароль

Используется для ввода пароля пользователя. Вводимые символы маскируются символом «*». Параметр доступен для заполнения/корректировки, если параметр Тип обмена имеет значение FTP. Доступ к разделу Настройки/Параметры имеют только пользователи с правами администратора.


Настройка/Пользователи и их права/Пользователи(офис)

Пользователи

Пункт меню доступен пользователям, для которых полностью разрешена общая возможность корректировки. Используется для добавления, корректировки и удаления описаний пользователей в программе и содержит следующие пункты:

  • Добавить
  • Скопировать
  • Изменить
  • Удалить
  • Закрыть


Пользователи/Добавить(офис)(Справка)

Добавить

Для создания описания нового пользователя и его прав нужно заполнить следующие параметры:

  • Имя пользователя
  • Пароль
  • Доступ к системным функциям
  • Общая возможность корректировки
  • Основные разделы


Пользователи/Имя пользователя

Имя пользователя

Произвольное имя пользователя, которое будет запрашиваться при входе в программу. Каждый пользователь должен иметь уникальное имя.


Пользователи/Пароль

Пароль

Пароль пользователя, который будет запрашиваться при входе в программу.

Установка пароля

Чтобы установить пароль, нужно выбрать данный пункт меню и вписать пароль в поле "Введите новый пароль" и в поле "Введите новый пароль еще раз для контроля". После этого следует кликнуть на кнопке (Сохранить). Введенный пароль отображается в виде звездочек. Чтобы увидеть настоящий пароль, нужно кликнуть на пиктограмме с очками.

Снятие пароля

Чтобы снять пароль, нужно в поле "Введите старый пароль" заполнить старый пароль, остальные поля оставить пустыми и кликнуть на кнопке (Сохранить).

Изменение пароля

Чтобы изменить пароль, нужно заполнить старый пароль в поле "Введите старый пароль", в поля "Введите новый пароль" и "Введите новый пароль еще раз" заполнить новый пароль и кликнуть на кнопке (Сохранить).


Новый пользователь/Доступ к системным функциям

Доступ к системным функциям

Может принимать значения запретить или разрешить. Если для пользователя указано значение разрешить, то при подключении к системе данный пользователь сможет получить доступ к ряду функций и разделов системы, недоступных другим пользователям, а именно:

  • Тестирование БД
  • Выгрузить БД
  • Создать БД по выгруженной информации
  • Создать новую (пустую БД)
  • Обмен информацией между БД

В системе SLS-ДисконтМаг доступ к параметрам настройки системы, списку пользователей системы и параметрам последней корректировки имеет только пользователь Admin.


Новый пользователь/Общая возможность корректировки(офис)

Общая возможность корректировки

Может принимать значения: полностью запретить, полностью разрешить, разрешить частично.

Если установлено значение полностью запретить, то пользователь имеет право только на просмотр информации в программе.

Если установлено значение разрешить частично, то права пользователя на корректировку назначаются в основных разделах.

Если для пользователя указано значение полностью разрешить, то при подключении к системе он сможет получить доступ к ряду функций и разделов системы, недоступных другим пользователям, а именно:

  • Параметры последней корректировки
  • Параметры
  • Пользователи и их права

Если установлено значение полностью разрешить и дополнительно разрешен доступ к системным функциям, то пользователь получает права администратора.


Новый пользователь/Основные разделы(офис)

Основные разделы

В окне устанавливаются отдельные права на добавление, корректировку, просмотр и удаление для каждого логического раздела программы.

  • Добавление - пользователь может вводить новую информацию.
  • Корректировка - пользователь может просматривать и корректировкать данный вид информации.
  • Удаление - пользователь может удалить данный вид информации.
  • Просмотр - пользователь может только просматривать информацию без какого-либо ее изменения.

Чтобы изменить значение параметра, нужно в соответствующем поле дважды кликнуть мышкой или нажать на клавишу "Пробел". Вся информация в программе разделена на следующие разделы:

  • Магазины сети
  • Таблицы скидок
  • Карточки покупателей
  • Группы VIP
  • Акции групп VIP


Основные разделы/Магазины сети(офис)

Магазины сети

Просмотр - пользователь может просматривать список магазинов без права каких-либо корректировок.

Добавление - пользователь может добавлять описание нового магазина.

Корректировка - пользователь может просматривать список магазинов и каждый магазин в отдельности, а также корректировать описание любого магазина.

Удаление - пользователь может удалить описание магазина, если он не используется ни в одной из карточек покупателей.


Основные разделы/Таблицы скидок(офис)

Таблицы скидок

Просмотр - пользователь может просматривать список таблиц и список скидок по ним без права каких-либо корректировок.

Добавление - пользователь может добавлять новую скидочную таблицу и добавлять новую скидку в таблицу со статусом Проект.

Корректировка - пользователь может корректировать описание скидочных таблиц и корректировать скидки в таблице со статусом Проект.

Удаление - пользователь может удалять описание скидочных таблиц и скидок в таблице со статусом Проект.


Основные разделы/Карточки покупателей(офис)

Карточки покупателей

Просмотр - пользователь может просматривать каталог карточек покупателей и карточку каждого покупателя в отдельности без права каких-либо корректировок вкладки Описание. При этом пользователь может осуществлять полноценную работу на вкладках Заметки и Подписка на новости.

Добавление - пользователь может добавить описание новой карточки покупателя.

Корректировка - пользователь может корректировать описание карточек покупателей как в общем списке карточек покупателей, так и в каждой карточке в отдельности.

Удаление - право на удаление карточек покупателей не имеет смысла, так как эта операция в системе не предусмотрена.


Основные разделы/Группы VIP(офис)

Группы VIP

Просмотр - пользователь может просматривать каталог групп VIP (полностью или без архивных групп), а также список скидочных акций и список условий предоставления скидок по ним. При этом пользователь может привязывать дисконтные карты к группе VIP и отвязывать их, а также может добавлять к группе VIP новых покупателей при наличии права на добавление карточек покупателей.

Добавление - пользователь может добавить новую группу VIP в каталог, а также оформить новые скидочные акции и новые условия предоставления скидок по любым скидочным акциям.

Корректировка - пользователь может корректировать описание групп VIP, а также скидочных акций и условий предоставления скидок по ним.

Удаление - пользователь может удалить описание группы VIP, а также описание скидочных акций и условий предоставления скидок по ним.


Пользователи/Скопировать(Справка)

Скопировать

Используется для создания нового пользователя на основании описания пользователя, на котором в списке стоит курсор в момент вызова операции.


Основные разделы/Акции групп VIP(офис)

Акции групп VIP

Просмотр - пользователь может просматривать классификатор акций групп VIP (полностью или без архивных акций), а также список условий предоставления скидок по ним. При этом пользователь может привязывать группы VIP в акциям и отвязывать их при наличии права на изменение групп VIP.

Добавление - пользователь может добавить новую акцию для группы VIP в классификатор.

Корректировка - пользователь может корректировать описание акции для группы VIP, а также добавлять/корректировать/удалять условия предоставления скидок по ним.

Удаление - пользователь может удалить описание акции для группы VIP из классификатора.


Пользователи/Изменить

Изменить

Используется для изменения имени текущего пользователя, изменения разрешенных для него действий, а также для задания нового пароля для него.


Новый пользователь/Доступ к операции замены карты(маг)

Доступ к операции замены карты

Может принимать значения запретить или разрешить. Если для пользователя указано значение разрешить, то при подключении к системе данному пользователю доступна операция замены дисконтной карты в карточке покупателя.


Пользователи/Удалить

Удалить

Используется для удаления описания текущего пользователя из списка.


Карточки покупателей/Дерево Покупателей(офис)

Дерево Покупателей

Дерево покупателей доступно пользователям с правом на просмотр карточек покупателей и имеет следующую структуру:

  • Покупатели по именам
  • Покупатели по штрих-кодам
  • Архив
  • Отмеченные покупатели
  • Найденные покупатели
  • Отмеченные штрих-коды


Операции(офис)

Операции

Используется для работы с карточками покупателей и содержит следующие пункты:

  • Поместить в архив
  • Переместить из архива
  • Снять все отметки
  • Включить активность
  • Отключить активность
  • Привязать к группе VIP
  • Отвязать от группы VIP
  • Удалить из списка
  • Проставить ответственный магазин
  • Проставить исходящий магазин
  • Проставить начальную сумму покупок
  • Проставить ФИО
  • Отметить найденные


Покупатели(офис)

Покупатели

Используется для создания, корректировки и отбора карточек покупателей по набору критериев и содержит следующие пункты:

  • Добавить
  • Изменить
  • Просмотр
  • Пересчет
  • Поиск
  • Закрыть


Покупатели/Ветвь Отмеченные покупатели(офис)

Отмеченные покупатели

Раздел доступен пользователям с правом на просмотр карточек покупателей и представляет собой список отмеченных карточек. Данный список хранится до закрытия базы данных, при следующем открытии базы данных он очищается. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Группа VIP - отображается, если включен параметр настройки системы группы VIP карт и содержит наименование группы VIP, к которой привязан основной штрих-код карточки покупателя с вкладки Описание
  • Дата рождения
  • Адрес
  • Телефон
  • Мобильный телефон
  • E-mail
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

Также с помощью настройки списков могут быть отображены следующие столбцы:

  • Ответственный магазин
  • Исходящий магазин

В списке отмеченных карточек покупателей доступны следующие функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Поместить карточку покупателя в архив
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск
  • Снять все отметки
  • Удалить из списка
  • Включить активность
  • Отключить активность
  • Проставить ответственный магазин
  • Проставить начальную сумму покупок
  • Проставить ФИО
  • Выполнить пересчет карточек покупателей.


Покупатели/Ветвь Отмеченные штрих-коды(офис)

Отмеченные штрих-коды

Раздел доступен пользователям с правом на просмотр карточек покупателей и представляет собой список отмеченных штрих-кодов карточек. Данный список хранится до закрытия базы данных, при следующем открытии базы данных он очищается. Список представлен в виде таблицы со следующими колонкам:

  • Штрих-код
  • Активность - отображается, если включен параметр настройки системы определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Группа VIP - отображается, если включен параметр настройки системы группы VIP карт и содержит наименование группы VIP, к которой привязан текущий штрих-код карточки покупателя.
  • Ф.И.О.
  • Дата рождения
  • Адрес
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

В списке штрих-кодов доступны следующие функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск
  • Быстрый поиск карточки покупателя по первым символам штрих-кода
  • Снять все отметки
  • Поместить карточку покупателя в архив
  • Удалить из списка
  • Включить активность
  • Отключить активность
  • Привязать к группе VIP
  • Отвязать от группы VIP
  • Выполнить пересчет карточек покупателей.


Покупатели/Ветвь Покупатели по именам(офис)

Покупатели по именам

Раздел доступен пользователям с правом на просмотр карточек покупателей и представляет собой список всех карточек покупателей (за исключением архивных), отсортированный по именам. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Группа VIP - отображается, если включен параметр настройки системы группы VIP карт и содержит наименование группы VIP, к которой привязан основной штрих-код карточки покупателя с вкладки Описание
  • Дата рождения
  • Адрес
  • Телефон
  • Мобильный телефон
  • E-mail
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

Также с помощью настройки списков могут быть отображены следующие столбцы:

  • Ответственный магазин
  • Исходящий магазин

В списке карточек покупателей доступны функции:

  • Добавить новую карточку покупателя.
  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Отобрать покупателей по совокупности заданных параметров, используя поиск .
  • Быстрый поиск карточки покупателя по первым символам фамилии покупателя.
  • Отметить карточки путем проставления точек в поле слева от списка.
  • Снять все отметки
  • Поместить карточку покупателя в архив
  • Выполнить пересчет карточек покупателей.


Покупатели/Ветвь Архив(офис)

Архив

Раздел доступен пользователям с правом на просмотр карточек покупателей и содержит список всех карточек покупателей, перенесенных в архив из любой ветви. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Группа VIP - отображается, если включен глобальный параметр группы VIP карт и содержит наименование группы VIP, к которой привязан основной штрих-код карточки покупателя с вкладки Описание
  • Дата рождения
  • Адрес
  • Телефон
  • Мобильный телефон
  • E-mail
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

Также с помощью настройки списков могут быть отображены следующие столбцы:

  • Ответственный магазин
  • Исходящий магазин

В списке карточек покупателей доступны функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск .
  • Быстрый поиск карточки покупателя по первым символам фамилии покупателя.
  • Отметить карточки путем проставления точек в поле слева от списка.
  • Снять все отметки
  • Переместить карточку покупателя из архива
  • Выполнить пересчет карточек покупателей.

Нахождение карточки в ветви "Архив" не влияет на процедуру обмена данными между центральным офисом и магазинами сети. Информация об архивности карточки покупателя посредством файлов обмена в магазины сети не распространяется.

Например, если в магазине будет произведена покупка с предъявлением дисконтной карты, то информация об этой покупке после проведения экспорта-импорта информации отразится в карточке покупателя и в центральном офисе, в какой бы ветви ни находилась карточка. В свою очередь, если архивная карточка покупателя будет отредактирована в центральном офисе, то эти корректировки после проведения процедуры обмена данными передадутся в магазины сети.


Покупатели/Ветвь Покупатели по штрих-кодам(офис)

Покупатели по штрих-кодам

Раздел доступен пользователям с правом на просмотр карточек покупателей и представляет собой список всех карточек покупателей (за исключением архивных), отсортированный по штрих-кодам. Список представлен в виде таблицы со следующими колонками:

  • Штрих-код
  • Активность - отображается, если включен параметр настройки системы определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Группа VIP - отображается, если включен параметр настройки системы группы VIP карт и содержит наименование группы VIP, к которой привязан текущий штрих-код карточки покупателя.
  • Ф.И.О.
  • Дата рождения
  • Адрес
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

В списке карточек покупателей доступны функции:

  • Добавить новую карточку покупателя.
  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск .
  • Быстрый поиск карточки покупателя по первым символам штрих-кода.
  • Отметить карточки путем проставления точек в поле слева от списка.
  • Снять все отметки
  • Поместить карточку покупателя в архив
  • Привязать к группе VIP отмеченные штрих-коды.
  • Отвязать от группы VIPотмеченные штрих-коды.
  • Включить активность для отмеченного списка штрих-кодов.
  • Отключить активность для отмеченного списка отмеченные штрих-кодов.
  • Выполнить пересчет карточек покупателей.


Покупатели/Ветвь Найденные покупатели(офис)

Найденные покупатели

Раздел доступен пользователям с правом на просмотр карточек покупателей и представляет собой список карточек покупателей, отобранных в результате поиска . Список хранится до проведения следующего поиска карточек покупателей и представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Группа VIP - отображается, если включен параметр настройки системы группы VIP карт и содержит наименование группы VIP, к которой привязан основной штрих-код карточки покупателя с вкладки Описание
  • Дата рождения
  • Адрес
  • Телефон
  • Мобильный телефон
  • E-mail
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

В списке найденных карточек покупателей доступны следующие функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Поместить карточку покупателя в архив
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск
  • Отметить карточки путем проставления точек в поле слева от списка.
  • Снять все отметки
  • Удалить из списка
  • Включить активность
  • Отключить активность
  • Проставить ответственный магазин
  • Привязать к группе VIP
  • Отвязать от группы VIP
  • Отметить найденные
  • Выполнить пересчет карточек покупателей.


Меню покупатели/Добавить(офис)

Добавить

Функция доступна пользователям с правом на добавление карточек покупателей. Для создания описания новой карточки нужно заполнить следующие параметры:

Анкетные данные:

  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Выдача карты
  • E-mail
  • Телефон
  • Мобильный телефон
  • Информацию получать по

Техническая информация:

  • Штрих-код
  • Активность
  • Магазин (исх.)
  • Дата/Время заполнения
  • Ответственный магазин
  • Примечание

Сводная информация:

  • Начальная сумма покупок
  • Общая сумма покупок
  • Текущая скидка- отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Дата/Время последней корректировки
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .
  • За пред. календарный месяц - отображается, если параметр настройки общая сумма покупок имеет значение «настраивать в карточке покупателя».

Дополнительное описание:

Если в настройках параметров системы заполнены параметры описания дополнительных настраиваемых полей, то эти поля отображаются в карточке покупателя на вкладке Доп. описание. Обязательность заполнения также определяется настройкой параметров.

Анкетная информация либо заполняется оператором вручную, либо передается функцией импорта информации из магазина. Во втором случае в файл экспорта для магазина помещается подтверждение получения анкеты покупателя.

После сохранения новой карточки покупателя текущая системная дата помещается в поле Дата выдачи в запись о соответствующем штрих-коде и на вкладку Штрих-коды.


Меню покупатели/Изменить(офис)(Справка)

Изменить

Функция доступна пользователям с правом на изменение карточек покупателей. Используется для изменения описания следующих параметров карточки покупателя:

Анкетные данные:

  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Выдача карты
  • E-mail
  • Телефон
  • Мобильный телефон
  • Информацию получать по - отображается, если включен параметр настройки переход на новые дисконтные карты .

Техническая информация:

  • Штрих-код
  • Активность
  • Магазин (исх.)
  • Дата/Время заполнения
  • Ответственный магазин
  • Примечание

Сводная информация:

  • Начальная сумма покупок
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Дата/Время последней корректировки
  • Скидка перех. периода - отображается, если включен параметр настройки переход на новые дисконтные карты .

Дополнительное описание:

Если в настройках параметров системы заполнены параметры описания дополнительных настраиваемых полей, то эти поля отображаются в карточке покупателя на вкладке Доп. описание. Обязательность заполнения также определяется настройкой параметров.


Меню покупатели/Просмотр(офис)

Просмотр

Функция доступна пользователям с правом на просмотр карточек покупателей и позволяет открыть текущую в списке карточку покупателя .


Операции/Поместить в архив(офис)

Перенести в архив

Функция доступна пользователям с правом на просмотр карточек покупателей и позволяет перенести карточку покупателя в архив. Операция применяется либо к текущей в списке карточке, либо к списку отмеченных карточек.

Если функция применяется в ветви Покупатели по именам, когда в списке есть отмеченные позиции, то операция работает отдельно по каждой отмеченной карточке покупателя. С карточек, перенесенных в архив, снимаются отметки, сами карточки перестают отображаться в ветви Покупатели по именам.

Если функция применяется в ветви Покупатели по штрих-кодам, когда в списке есть отмеченные позиции, то операция работает отдельно по каждому отмеченному штрих-коду. Со штрих-кодов, перенесенных в архив, снимаются отметки, сами штрих-коды перестают отображаться в ветви Покупатели по штрих-кодам.

Если функция применяется в ветви Найденные покупатели, когда в списке есть отмеченные позиции, то операция работает отдельно по каждой отмеченной позиции. С позиций, перенесенных в архив, снимаются отметки, сами позиции продолжают отображаться в ветви Найденные покупатели.


Операции/Переместить из архива(офис)

Переместить из архива

Функция доступна пользователям с правом на просмотр карточек покупателей и позволяет вернуть карточку покупателя из архива. Операция применяется к текущей в списке карточке или к списку отмеченных карточек. Карточка покупателя возвращается в список карточек ветвей Покупатели по именам и Покупатели по штрих-кодам.


Поля описания карточки покупателя (Справка)

Описание полей карточки покупателя

Карточка покупателя включает в себя следующие параметры:

Анкетные данные:

  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Выдача карты
  • E-mail
  • Телефон
  • Мобильный телефон
  • Информацию получать по

Техническая информация:

  • Штрих-код
  • Активность
  • Магазин
  • Дата/Время заполнения
  • Ответственный магазин
  • Примечание

Сводная информация:

  • Начальная сумма покупок
  • Общая сумма покупок
  • Текущая скидка
  • Дата/время последней корректировки

Дополнительное описание:

Если в настройках глобальных параметров системы заполнены параметры описания дополнительных настраиваемых полей, то эти поля отображаются в карточке покупателя на вкладке Доп. описание. Обязательность заполнения определяется глобальными параметрами.

Анкетная информация либо заполняется оператором вручную, либо передается функцией импорта информации из магазина. Во втором случае в файл экспорта для магазина помещается подтверждение получения анкеты покупателя.


Карточка покупателя/Анкета/Информацию получать по

Информацию получать по

Способ получения информации об акциях компании: по телефону или по e-mail. Заполняется функцией импорта информации из магазинов.


Карточка покупателя/Анкета/ФИО

ФИО

Фамилия, имя и отчество покупателя. Если включен параметр настройки ФИО указывать в отдельных полях , то при заполнении анкетных данных покупателя ввод фамилии, имени и отчества осуществляется в трех отдельных полях: Фамилия, Имя, Отчество. Если параметр отключен, то в карточке покупателя отображается одно поле ФИО.

Замечание: если параметр был отключен, а потом его включили, то для уже имеющихся карточек покупателей в поле Фамилия будет отображаться фамилия, имя и отчество покупателя, а поля Имя и Отчество заполняться не будут. Если параметр был включен, а потом его отключили, то для уже имеющихся карточек покупателей в поле ФИО будет отображаться только фамилия покупателя.


Карточка покупателя/Анкета/Дата рождения

Дата рождения

Дата рождения покупателя. Дата может быть введена вручную или выбрана из календаря, вызываемого нажатием клавиши "Пробел".


Карточка покупателя/Анкета/Пол

Пол

Пол покупателя: мужской, женский.


Карточка покупателя/Анкета/Образование

Образование

Образование покупателя: высшее, неоконченное высшее, среднее, среднее специальное.


Карточка покупателя/Анкета/Адрес

Адрес

Адрес покупателя.


Техническая информация/Штрих-код

Штрих-код

Штрих-код карточки, выданной покупателю. Значение служит уникальным идентификатором покупателя в системе. Размер штрих-кода карточки ограничен 20 символами и может быть жестко определен параметром настройки системы размер штрих-кода .

Штрих-код доступен для корректировки только до момента первого считывания карточки покупателя для экспорта в файл обмена, либо до первого импорта покупок покупателя из магазина. После первого экспорта/импорта информации по карточке покупателя это поле закрывается от корректировки.


Техническая информация/Активность

Активность

Если параметр включен, то карточка покупателя считается активной, если нет, то неактивной, и покупатель с данной карточкой не сможет получить скидку в магазинах.

Если в параметрах настройки системы включен параметр Определять активность для каждого штрих-кода , то при корректировке данного поля производятся следующие действия: если до корректировки параметр был отключен, а после корректировки его включили, то на вкладке Штрих-коды заполняется столбец Активность значением "+" для штрих-кода с вкладки Описание. Если до корректировки параметр был включен, а после корректировки отключен, то на вкладке Штрих-коды столбец Активность очищается для соответствующего штрих-кода.


Техническая информация/Исходящий магазин

Магазин (исх.)

Наименование магазина, где была выдана карточка покупателя. Исходящий магазин заполняется функцией импорта информации из магазина (если он еще не задан) или вручную путем выбора из справочника магазинов.

Наименование исходящего магазина помещается в поле Исходящий магазин в запись о штрих-коде и в карточку покупателя на вкладку Штрих-коды.

Если значение поля изменяется, то при сохранении изменений новое значение записывается в поле Исходящий магазин в описании основного штрих-кода.


Техническая информация/Дата/Время заполнения

Дата/Время заполнения

Дата и время заполнения карточки покупателя.


Техническая информация/Ответственный магазин

Ответственный магазин

Наименование магазина, в который необходимо пересылать контактную информацию по покупателю. Ответственный магазин заполняется функцией импорта информации из магазина (если он еще не задан) или вручную путем выбора из справочника магазинов.


Техническая информация/Примечание

Примечание

Любая дополнительная информация по покупателю.


Сводная информация/За пред. календарный месяц(офис)

За пред. календарный месяц

Отображается, если параметр настройки общая сумма покупок имеет значение «настраивать в карточке покупателя» и определяет механизм расчета общей суммы покупок . Если параметр включен, то общая сумма покупок покупателя рассчитывается на основании покупок, совершенных по данной карте за прошлый календарный месяц. Если отключен, то за весь период работы.

Если значение поля изменено в ходе корректировки покупателя, то:

  • Если до корректировки данный параметр был отключен, а после корректировки его включили, то общей сумме покупок в карточке покупателя присваивается сумма по столбцу Сумма с учетом скидки по всем покупкам из списка вкладки Покупки карточки покупателя, таким что Дата покупки попадает в период, заданный параметром настройки общие суммы покупок рассчитаны за , и штрих-код дисконтной карты из покупки не привязан к группе VIP.
  • Если до корректировки данный параметр был включен, а после корректировки его отключили, то общей сумме покупок в карточке покупателя присваивается значение начальная сумма покупок + сумма по столбцу Сумма с учетом скидки по всем покупкам из списка вкладки Покупки карточки покупателя, таким что штрих-код дисконтной карты из покупки не привязан к группе VIP.


Карточка покупателя/Вкладка Описание(офис)

Описание

Вкладка содержит поля описания карточек покупателя, техническую и сводную информацию. Поля описания вводятся при создании карточки покупателя , в дальнейшем могут быть откорректированы.

Анкетные данные:

  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • E-mail
  • Телефон
  • Мобильный телефон
  • Выдача карты
  • Информацию получать по

Техническая информация:

  • Штрих-код
  • Активность
  • Магазин (исх.)
  • Дата/Время заполнения
  • Ответственный магазин
  • Примечание

Сводная информация (используется при просмотре карточки покупателя):

  • Начальная сумма покупок
  • Общая сумма покупок
  • За пред. календарный месяц
  • Текущая скидка
  • Дата/Время последней корректировки
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

Дополнительное описание:

Если в настройках глобальных параметров системы заполнены параметры описания дополнительных настраиваемых полей, то эти поля отображаются в карточке покупателя на вкладке Доп. описание. Обязательность заполнения определяется глобальными параметрами.

На вкладке доступны просмотр информации и корректировка полей, заполняемых оператором. Штрих-код доступен для корректировки только до момента первого считывания карточки покупателя для экспорта в файл обмена, либо до первого импорта покупок покупателя из магазина. После первого экспорта/импорта информации по карточке покупателя это поле для корректировки закрывается.

Анкетная информация либо заполняется оператором вручную, либо передается функцией импорта информации из магазина. Во втором случае в файл экспорта для магазина помещается подтверждение получения анкеты покупателя.


Карточка покупателя/Вкладка Штрих-коды(офис)

Штрих-коды

Вкладка содержит информацию обо всех штрих-кодах присвоенных покупателю. Работа на вкладке ведется с помощью меню Штрих-коды . Записи упорядочены по штрих-кодам в порядке возрастания. В списке штрих-кодов работает сортировка по любому столбцу вкладки.

Список представлен в виде таблицы со следующими колонками:

  • Штрих-код - номер дисконтной карточки покупателя.
  • Активность - отображается, если включен параметр определять активность для каждого штрих-кода . В столбце отображается «+», если дисконтная карта со штрих-кодом активна.
  • Группа VIP - отображается наименование соответствующей группы VIP клиентов, если включен параметр группы VIP карт .
  • С - дата начала периода действия текущей акции по группе VIP. Отображается, если включен параметр настройки пороги скидок для групп VIP . Поле заполняется системой автоматически и недоступно для ручной корректировки пользователям.
  • До - дата окончания периода действия текущей акции по группе VIP. Отображается, если включен параметр настройки пороги скидок для групп VIP . Поле заполняется системой автоматически и недоступно для ручной корректировки пользователям.
  • Сумма покупок - общая сумма покупок, совершенных по данной дисконтной карте в период, ограниченный датами С и До. Отображается, если включен параметр настройки пороги скидок для групп VIP . Поле заполняется системой автоматически и недоступно для ручной корректировки пользователям.
  • Дата выдачи - дата выдачи дисконтной карточки покупателю. Отображается, если включен параметр настройки переход на новые дисконтные карты .
  • Исходящий магазин - магазин выдачи карты. Если поле пустое, то считается, что карта выдана в центральном офисе. Отображается, если включен параметр настройки переход на новые дисконтные карты .


Карточка покупателя/Вкладка Доп. описание(офис)

Доп. описание

На вкладке отображаются наименования и значения дополнительных настраиваемых полей, если они описаны в настройках параметров системы и заданы их значения в карточке покупателя.


Карточка покупателя/Вкладка Покупки(офис)

Покупки

Вкладка представляет собой список покупок покупателя, приобретенных во всех магазинах сети и составлен в виде таблицы со следующими колонками:

  • Дата - дата совершения покупки.
  • Время - время совершения покупки.
  • Дисконтная карта - штрих-код карты, ссылка на которую установлена в покупке.
  • Магазин - наименование магазина, ссылка на который установлена в покупке.
  • Номер чека - номер чека, ссылка на который установлена в покупке.
  • Штрих-код товара - номенклатурный номер товара.
  • Названия доп. свойств - названия дополнительных свойств товара, характеризующих покупку.
  • Значения доп. свойств - значения дополнительных свойств товара, характеризующих покупку.
  • Количество - количество товара.
  • Цена - цена товара.
  • Сумма - сумма товара.
  • Скидка - скидка, полученная на товар.
  • Сумма с учетом скидки - сумма товара с учетом скидки.

Покупки упорядочены по дате совершения, а в рамках одной даты по времени. В списке покупок работает сортировка по любому столбцу вкладки.

Вкладка заполняется функцией импорта информации из магазинов и доступна оператору только для просмотра.


Карточка покупателя/Вкладка Заметки

Заметки

Здесь можно записать по датам любую дополнительную информацию по взаимоотношениям с покупателем. Заметки упорядочены по дате. В списке заметок работает сортировка по любому столбцу вкладки. Вкладка представляет собой список с полями:

  • Дата - дата заметки.
  • Содержание - содержание заметки.

Работа на вкладке осуществляется с помощью меню Заметки .


Сводная информация/Начальная сумма покупок(офис)

Начальная сумма покупок

Используется для задания начальной суммы покупок для увеличения общей суммы покупок и возможности либо получения большей скидки, согласно действующей таблице скидок, либо для выдачи дисконтной карты с нужным процентом скидки. Заполняется оператором вручную при выполнении операций создания или корректировки карточки покупателя.


Сводная информация/Общая сумма покупок

Общая сумма покупок

Общая сумма покупок (в рублях) - рассчитывается программой как сумма начальной и общей суммы покупок, и на основании информации из магазинов. Закрыто от корректировки.

Если включен параметр настройки группы VIP и для некоторого штрих-кода выполняется операция привязки к группе VIP , то из Общей суммы покупок вычитаются все суммы покупок, оформленных на привязываемый штрих-код. При этом выполняется следующее соглашение: если в списке покупок есть покупки без штрих-кода дисконтной карты, то в такие покупки проставляется привязываемый штрих-код, и их суммы также вычитаются из значения поля Общая сумма покупок описании покупателя.

Если включен параметр настройки группы VIP и для некоторого штрих-кода выполняется операция отвязки от группы VIP , то к Общей сумме покупок прибавляются все суммы покупок, оформленные на отвязываемый штрих-код.


Сводная информация/Текущая скидка

Текущая скидка

Отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен. Размер текущей скидки покупателя (в %) - рассчитывается автоматически после обновления информации по покупкам покупателя на основании значения общей суммы покупок покупателя по правилам предоставления скидок, описанным в БД. Закрыто от корректировки.


Сводная информация/Дата/Время последней корректировки(офис)

Дата/Время последней корректировки

Дата, время последней корректировки или первого заполнения хотя бы одного из полей карточки покупателя. Рассчитывается автоматически (закрыта от корректировки пользователем).


Меню Штрих-коды/Пересчитать суммы покупок по акциям(офис)

Пересчитать суммы покупок по акциям

Пункт меню отображается только в том случае, если включен параметр настройки системы пороги скидок для групп VIP и позволяет пересчитать суммы покупок, совершенных по дисконтной карте в период действия скидочной акции. Функция доступна пользователям с правом на корректировку карточек покупателей.

При вызове операции для текущего штрих-кода выполняются следующие действия:

  • в списке акций группы VIP ищется акция со статусом «действует», в период действия которой попадает текущая системная дата.
  • если подходящая акция найдена, то в строке со штрих-кодом в поля С и До помещаются даты Начало и Завершение, соответственно, из описания акции. Затем в списке покупок в карточке покупателя отбираются покупки, совершенные на карту с данным штрих-кодом в период действия данной акции, и по ним суммируются Суммы с учетом скидки. Полученная величина записывается в поле Сумма покупок описания штрих-кода. В описании покупателя обновляются дата и время последней корректировки. Затем выполняется переход к следующему обрабатываемому штрих-коду.
  • если подходящая акция не найдена, а в строке со штрих-кодом какое-либо из полей С, До, Сумма покупок непустое, то поля С, До и Сумма покупок очищаются, а в описании покупателя обновляются дата и время последней корректировки. Затем выполняется переход к следующему обрабатываемому штрих-коду.


Меню Заметки/Добавить

Добавить

Функция доступна пользователям с правом на просмотр карточек покупателей. Для создания новой дополнительной информации о покупателе нужно заполнить следующие параметры:

  • Дата - дата внесения информации.
  • Содержание - конкретная информация по покупателю.


Поля описания заметки

Описание дополнительной информации о покупателе содержит следующие параметры:

  • Дата - дата внесения информации.
  • Содержание - конкретная информация по покупателю.


Меню Заметки/Изменить

Изменить

Функция доступна пользователям с правом на просмотр карточек покупателей. Используется для изменения описания следующих параметров:

  • Дата - дата внесения информации.
  • Содержание - конкретная информация по покупателю.


Меню Заметки/Удалить

Удалить

Функция доступна пользователям с правом на просмотр карточек покупателей и используется для удаления дополнительной информации по покупателю.


Сводная информация/Скидка переходного периода/Зафиксированная скидка

Скидка перех. периода

Скидка покупателя при смене дисконтной политики компании. Отображается, если включен параметр настройки переход на новые дисконтные карты .

Закрыта от корректировки и рассчитывается автоматически при включении параметра настройки переход на новые дисконтные карты . При этом обрабатываются все карточки покупателей ветви Покупатели по именам, в которых значение поля Общая сумма покупок > 0. Для каждого такого покупателя по значению поля Общая сумма покупок и действующей на момент запуска процедуры пересчета таблице скидок определяется % скидки, который должен предоставляться по такой накопленной сумме для товаров с аналитическим типом 00000001. Вычисленный % скидки записывается в поле Скидка перех. периода описания покупателя.

Зафиксированная скидка

Скидка покупателя при фиксировании скидок по некоторой таблице скидок. Отображается, если включен параметр настройки фиксировать скидки при смене таблицы скидок .

Закрыта от корректировки и рассчитывается автоматически при вызове операции зафиксировать скидки по таблице скидок.


Поиск

Условия поиска и отбора покупателей

К условиям поиска карточек покупателей относятся:

  • Область поиска
  • ФИО
  • Дата рождения
  • Пол
  • Адрес
  • Штрих-код
  • Е-mail
  • Телефон
  • Моб. телефон

Если поиск карточек покупателей осуществляется в центральном офисе (в программе SLS-ДисконтОф), то дополнительно можно задать следующие параметры отбора на вкладке Описание :

  • Активность
  • Выдача карты
  • Ответственный магазин
  • Регионы ответственных магазинов
  • Исходящий магазин
  • Регионы исходящих магазинов
  • Общая сумма покупок
  • Текущая скидка
  • Дополнительные поля описания
  • Подписка на новости
  • Последняя корректировка
  • Дата заполнения
  • Образование
  • Информацию получать по
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

а также использовать параметрвы поиска на вкладках Доп. описание , Подписка на новости и Покупки .


Поиск/Область поиска

Область поиска

Параметр определяет область отбора карточек покупателей и может принимать следующие значения:

  • все покупатели - отбор карточек покупателей ведется среди всех карточек, включая находящиеся в архиве.
  • все кроме архива - карточки покупателей, помещенные в архив, не участвуют в проведении процедуры поиска.
  • только архив - отбор карточек покупателей ведется только среди карточек, находящихся в архиве.

Если поиск осуществляется в магазине, то он ведется только по всем карточкам покупателей.


Поиск/ФИО

Ф.И.О.

Если включен параметр настройки ФИО указывать в отдельных полях , то вместо параметра поиска "ФИО" отображаются 3 поля:

  • Фамилия. Отбор по фамилии или части фамилии покупателя.
  • Имя. Отбор по имени или части имени покупателя.
  • Отчество. Отбор по отчеству или части отчества покупателя.

Каждое поле допускает задание маски в виде шаблона .


Поиск/Информацию получать по

Информацию получать по

Способ получения информации об акциях компании. Может принимать значения: «моб. телефону», «e-mail». Если все флажки отключены, то параметр не накладывает ограничений на поиск покупателей. В случае включения одного или нескольких флажков результатом поиска будут покупатели, имеющие хотя бы один из указанных видов получения информации.


Поиск/Дата рождения

Дата рождения

Диапазон искомых дат рождения покупателей. Результатом поиска будут покупатели, даты рождения которых попадают в заданный интервал.


Поиск/Зафиксированная скидка

Зафиксированная скидка

Диапазон искомого размера зафиксированной скидки покупателя. Результатом отбора будут карточки покупателей, в которых размер зафиксированной скидки попадает в заданный интервал.


Поиск/Пол

Пол

Половая принадлежность покупателя. Может принимать значения: любой, мужской, женский. Если выбрано значение «любой», то отбор будет производиться среди всех покупателей независимо от пола. Если выбрано значение, отличное от «любой», то результатом поиска будут покупатели с заданным полом.


Поиск/Образование

Образование

Образование покупателя. Может принимать значения: «высшее», «неоконченное высшее», «среднее специальное», «среднее». Если все флажки отключены, то параметр не накладывает ограничений на образование искомых покупателей. В случае включения одного или нескольких флажков результатом поиска будут покупатели, имеющие хотя бы одно из указанных образований.


Поиск/Адрес

Адрес

Адрес покупателя. Задается полностью или в виде шаблона .


Поиск/Штрих-код

Штрих-код

Штрих-код карточки покупателя. Задается полностью или в виде шаблона .


Поиск/Шаблон

Шаблон

Шаблон можно задать в следующем виде:

  • ТЕКСТ - ТЕКСТ встречается как полное слово;
  • ТЕКСТ* - начало совпадает с шаблоном, а конец произвольный.
  • *ТЕКСТ* - указанный текст встречается в любом месте названия.
  • *ТЕКСТ - начало слова произвольное, а конец полностью совпадает с шаблоном.
  • * - поле должно быть пустым
  • ** - поле должно быть непустым


Карточка покупателя/Меню покупатель(офис)

Покупатель

Используется для создания и корректировки карточек покупателей и содержит следующие пункты:

  • Добавить
  • Изменить
  • Выдать новую дисконтную карточку
  • Пересчитать сумму покупок
  • Записи
  • Закрыть


Меню покупатель/Записи

Записи

Используется для перемещения по списку покупателей.

Меню содержит следующие пункты:

  • Первая - переход в первую карточку покупателей в списке карточек группы/подгруппы;
  • Предыдущая - переход из текущей карточки в предыдущую карточку покупателя в списке карточек группы/подгруппы;
  • Следующая - переход из текущей карточки в следующую карточку покупателя в списке карточек группы/подгруппы;
  • Последняя - переход в последнюю карточку покупателя в списке карточек группы/подгруппы.


Меню покупатель/Добавить(офис)

Добавить

Функция доступна пользователям с правом на добавление карточек покупателей. Для создания новой карточки нужно заполнить следующие параметры:

Анкетные данные:

  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Выдача карты
  • E-mail
  • Телефон
  • Мобильный телефон
  • Информацию получать по

Техническая информация:

  • Штрих-код
  • Активность
  • Магазин
  • Дата/Время заполнения
  • Ответственный магазин
  • Примечание

Сводная информация:

  • Начальная сумма покупок
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Время последней корректировки
  • Скидка перех. периода

Дополнительное описание:

Если в настройках глобальных параметров системы заполнены параметры описания дополнительных настраиваемых полей, то эти поля отображаются в карточке покупателя на вкладке Доп. описание. Обязательность заполнения определяется глобальными параметрами.


Меню покупатель/Выдать новую дисконтную карточку(офис)

Выдать новую дисконтную карточку

Функция доступна пользователям с правом на изменение карточек покупателей и используется для задания нового штрих-кода карточки покупателя (лучше всего это делать сканированием карточки). Поле для ввода нового штрих-кода имеет длину, заданную параметром настройки системы размер штрих-кода . Ввод штрих-кода иной длины недопустим. Введенное значение записывается в список штрих-кодов на вкладке Штрих-коды карточки покупателя. Если включен параметр определять активность для каждого штрих-кода , то новый штрих-код считается активным.

Если новый штрих-код успешно добавляется в список, то:

  • в описании карточки покупателя полям Дата/Время последней корректировки присваиваются текущие системные дата и время.
  • текущая системная дата помещается в поле Дата выдачи в запись о соответствующем штрих-коде и на вкладку Штрих-коды.


Меню покупатель/Пересчитать сумму покупок(офис)

Пересчитать сумму покупок

Функция доступна пользователям с правом на изменение карточек покупателей и используется для пересчета общей суммы покупок покупателя.

Отображается, если параметр настройки общая сумма покупок имеет значение «настраивать в карточке покупателя».

  • Если в карточке покупателя параметр за пред. календарный месяц отключен, то общая сумма покупок пересчитывается по всем покупкам, зарегистрированным на данного покупателя и совершенным по дисконтным картам, не ссылающимся на группы VIP.
  • Если в карточке покупателя параметр за пред. календарный месяц включен, то полю общая сумма покупок карточки покупателя присваивается сумма по столбцу Сумма с учетом скидки по всем покупкам из списка вкладки Покупки карточки покупателя, таким что Дата покупки попадает в период, заданный параметром настройки общие суммы покупок рассчитаны за , и штрих-код дисконтной карты из покупки не привязан к группе VIP.
  • Если общая сумма покупок в карточке покупателя изменяется, то в поле Дата/время последней корректировки записываются текущие дата/время.


Меню покупатель/Изменить(офис)

Изменить

Функция доступна пользователям с правом на изменение карточек покупателей. Используется для изменения описания следующих параметров:

Анкетные данные:

  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Выдача карты
  • E-mail
  • Телефон
  • Мобильный телефон
  • Информацию получать по- отображается, если включен параметр настройки переход на новые дисконтные карты .

Техническая информация:

  • Штрих-код
  • Активность
  • Магазин
  • Дата/Время заполнения
  • Ответственный магазин
  • Примечание

Сводная информация:

  • Начальная сумма покупок
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Время последней корректировки
  • Скидка перех. периода - отображается, если включен параметр настройки переход на новые дисконтные карты .

Дополнительное описание:

Если в настройках глобальных параметров системы заполнены параметры описания дополнительных настраиваемых полей, то эти поля отображаются в карточке покупателя на вкладке Доп. описание. Обязательность заполнения определяется глобальными параметрами.


Таблицы скидок/Таблицы(офис)

Таблицы

Доступно пользователям с правом на просмотр таблиц скидок и используется для создания, корректировки и удаления таблиц. Меню состоит из пунктов:

  • Добавить
  • Изменить
  • Удалить
  • Зафиксировать скидки. Отображается, если включен параметр настройки фиксировать скидки при смене таблицы скидок .
  • Показывать архивные таблицы
  • Закрыть


Поля описания таблицы скидок(справка)(офис)

Поля описания таблицы скидок

Для описания таблицы скидок необходимо заполнить следующие поля:

  • Действует с
  • Статус
  • Примечание


Поля описания скидки(справка)(офис)

Поля описания скидки

Для описания скидки необходимо заполнить следующие поля:

  • Аналитический тип
  • Скидка
  • Прочие товары
  • Примечание


Таблицы скидок/Таблицы/Добавить(офис)

Добавить

Функция доступна пользователям с правом на добавление таблиц скидок. Для создания описания новой таблицы нужно заполнить следующие параметры:

  • Действует с
  • Статус
  • Примечание


Таблицы скидок/Таблицы/Изменить(офис)

Изменить

Функция доступна для таблиц скидок с пустым полем Скидки зафиксированы пользователям с правом на изменение таблиц скидок. Используется для изменения описания следующих параметров таблицы:

  • Действует с
  • Статус
  • Примечание


Таблицы скидок/Таблицы/Удалить(офис)

Удалить

Функция доступна пользователям с правом на удаление таблиц скидок. Используется для удаления текущей в списке таблицы.

Таблицу скидок нельзя удалить если она имеет статас "действует" или в описании таблицы скидок заполнено поле Скидки зафиксированы.


Таблицы скидок/Таблицы/Показывать архивные таблицы(офис)

Показывать архивные таблицы

Функция доступна пользователям с правом на просмотр таблиц скидок и позволяет переключаться между режимами просмотра списка всех таблиц скидок и списка без архивных таблиц. Список по умолчанию высвечивается без архивных таблиц. Чтобы поменять режим отображения архивных таблиц в списке, нужно выбрать данный раздел еще раз.


Таблицы скидок/Таблицы/Зафиксировать скидки(офис)

Зафиксировать скидки

Используется для пересчета размера скидок покупателей, предоставляемых по текущей таблице скидок, и отображается, если включен параметр настройки фиксировать скидки при смене таблицы скидок . Функция доступна только для таблиц со статусом «действует» и пустым полем Скидки зафиксированы пользователям с правом администратора.

При вызове функции на экран выводится предупреждающее сообщение с текстом:

- «Вы собираетесь запустить процедуру пересчета скидок покупателей для всех зарегистрированных в системе накопительных дисконтных карт по данной таблице скидок. Вы подтверждаете пересчет?», если параметр настройки аналитические типы в накопительной таблице скидок отключен;

- «Вы собираетесь запустить процедуру пересчета скидок покупателей по данной таблице скидок. Для всех зарегистрированных в системе накопительных дисконтных карт будет зафиксирована скидка для аналитического типа товаров с кодом 00000001. Вы подтверждаете пересчет?», если параметр настройки аналитические типы в накопительной таблице скидок включен;

- и кнопками (Да) и (Нет). При нажатии (Да) выполняются следующие действия:

o обрабатываются все карточки покупателей ветви Покупатели по именам в которых значение поля общая сумма покупок > 0.

o для каждого такого покупателя по значению поля общая сумма покупок и таблице скидок, для которой вызван пересчет, определяется % скидки, который должен предоставляться:

§ для всех товаров, если параметр настройки аналитические типы в накопительной таблице скидок отключен;

§ для товаров с аналитическим типом 00000001, если параметр настройки аналитические типы в накопительной таблице скидок включен;

o полю зафиксированная скидка карточки покупателя присваивается максимальное из значений (скидка, вычисленная на предыдущем шаге, и скидка из поля зафиксированная скидка ).

Замечание: дата/время последней корректировки карточки покупателя при этом не обновляется.

o после завершения обработки карточек покупателей производятся следующие дополнительные действия:

§ в описании таблицы скидок полю Скидки зафиксированы присваиваются текущие системные дата/время и обновляются значения полей Изменено, Пользователь.

§ параметру настройки скидки зафиксированы по таблице от присваивается значение поля действует с из описания таблицы скидок.


Таблицы скидок/Скидки/Добавить(офис)

Добавить

Функция доступна пользователям с правом на добавление таблиц скидок. Для создания описания новой скидки нужно заполнить следующие параметры:

  • Аналитический тип- отображается, если включен параметр настройки аналитические типы в накопительной таблице скидок .
  • Прочие товары- отображается, если включен параметр настройки аналитические типы в накопительной таблице скидок .
  • С суммы
  • Скидка
  • Примечание

В таблице скидок не может быть двух строк с одинаковыми значениями полей Аналитический тип, Прочие товары, С суммы.

Добавить новую скидку в действующую таблицу скидок нельзя!


Таблицы скидок/Скидки/Изменить(офис)

Изменить

Функция доступна пользователям с правом на изменение таблиц скидок. Используется для изменения описания следующих параметров таблицы:

  • Аналитический тип - отображается, если включен параметр настройки аналитические типы в накопительной таблице скидок .
  • Прочие товары - отображается, если включен параметр настройки аналитические типы в накопительной таблице скидок .
  • С суммы
  • Скидка
  • Примечание

В таблице скидок не может быть двух строк с одинаковыми значениями полей Аналитический тип, Прочие товары, С суммы.

Изменить скидку в действующей таблице скидок нельзя!


Таблицы скидок/Скидки/Удалить(офис)

Удалить

Функция доступна пользователям с правом на удаление таблиц скидок. Используется для удаления текущей в списке скидки, относящейся к таблице, статус кокторой отличен от "действует".


Таблицы скидок/Таблицы/Действует с(офис)

Действует с

Дата, с которой вводится в действие таблица скидок.

Если включен параметр настройки фиксировать скидки при смене таблицы скидок , то дата начала действия таблицы скидок должна быть уникальной среди всех дат "действует с" всех таблиц скидок.


Таблицы скидок/Таблицы/Статус(офис)

Статус

Статус таблицы, который может принимать одно из трех значений:

  • Архив - таблица скидок действовала ранее
  • Действует - таблица скидок действует на текущую дату
  • Проект - таблица скидок предполагается к вводу в действие

Примечание: в случае создания нескольких таблиц скидок со статусом "действует", реально действующей будет считаться та, которая имеет более позднюю дату "действует с".


Таблицы скидок/Таблицы/Примечание(офис)

Примечание

Любая дополнительная информация по таблице скидок.


Таблицы скидок/Скидки/С суммы(офис)

С суммы

Сумма, начиная с которой действует соответствующая скидка.


Таблицы скидок/Скидки/АТ(офис)

Аналитический тип

Параметр отображается, если включен параметр настройки аналитические типы в накопительной таблице скидок . Код аналитического типа из программы SLS-Эксперт. Позволяет указать, что скидка предоставляется только на товары с данным аналитическим типом. Если поле пустое, то это означает, что скидка предоставляется на товары, в которых аналитический тип не задан. Закрыто от корректировки, если включен параметр прочие товары .


Таблицы скидок/Скидки/Скидка(офис)

Скидка

Размер скидки, предоставляемой покупателю, в %.


Таблицы скидок/Скидки/Прочие товары(офис)

Прочие товары

Параметр отображается, если включен параметр настройки аналитические типы в накопительной таблице скидок . Позволяет указать, что скидка распространяется на все товары, не попадающие под другие условия по значению аналитического типа. Если параметр включен, то поле аналитический тип очищается и закрывается от корректировки.


Таблицы скидок/Скидки/Примечание(офис)

Примечание

Любая дополнительная информация по скидке.


Поля описания магазина/(cправка)(офис)

Поля описания магазина

Для описания магазина необходимо заполнить следующие поля:

  • Код
  • Название
  • Регион
  • Архив
  • Файл экспорта
  • Файл импорта
  • Разница во времени
  • Время "Ч"
  • Примечание
  • Новые карточки покупателей активны


Магазины сети/Меню магазины сети/Закрыть(офис)

Закрыть

Используется для закрытия окна классификатора или каталога.


Поля описания региона/(cправка)(офис)

Поля описания региона

Для описания региона необходимо заполнить следующие поля:

  • Код
  • Название


Классификаторы/Магазины сети/Меню магазины сети(офис)

Магазины сети

Доступно пользователям с правом на просмотр магазинов сети и используется для создания, корректировки и удаления магазинов. Меню содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить
  • Показывать архивные магазины/Не показывать архивные магазины
  • Закрыть


Классификаторы/Регионы/Меню Регионы(офис)

Регионы

Используется для создания, корректировки и удаления регионов и содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить
  • Закрыть


Регионы/Меню Регионы/Добавить(офис)

Добавить

Для создания описания нового региона нужно заполнить следующие поля описания региона:

  • Код
  • Название


Регионы/Меню Регионы/Изменить(офис)

Изменить

Используется для изменения описания следующих параметров региона:

  • Код
  • Название


Регионы/Меню Регионы/Удалить(офис)

Удалить

Используется для удаления текущего в списке описания региона. Регион удалить нельзя если существует магазин, в описании которого задан удаляемый регион.


Поля описания региона/Код(офис)

Код

Код региона. Код должен быть уникальным среди всех кодов регионов.


Поля описания региона/Название(офис)

Название

Наименование региона. Наименование должно быть уникальным среди всех названий регионов.


Поля описания магазина/Код(офис)

Код

Код магазина сети. Используется при подготовке файла обмена информации для магазина, для идентификации информации, полученной из магазина, а также в списке покупок в карточке покупателя. Значение должно быть уникальным среди всех кодов магазинов.

В базах данных офиса и магазина код магазина должен совпадать!


Поля описания магазина/Название(офис)

Название

Наименование магазина.


Поля описания магазина/Регион(офис)

Регион

Регион, на территории которого расположен магазин. Значение выбирается из классификатора регионов.


Магазины сети/Файл экспорта(офис)

Файл экспорта

Полный путь к файлу, в который помещается информация, экспортируемая в магазин.


Магазины сети/Файл импорта(офис)

Файл импорта

Полный путь к файлу, из которого берется информация, полученная из магазина.


Магазины сети/Разница во времени(офис)

Разница во времени

Разница во времени (в часах) между центральным офисом и магазином. Разница считается положительной, если магазин находится восточнее центрального офиса; отрицательной, если магазин находится западнее центрального офиса.


Поля описания магазина/Время "Ч"(офис)

Время "Ч"

Местное время, начиная с которого следует искать новую информацию, подготовленную магазином. Используется для наглядности при проведении процедуры импорта данных из магазинов следующим образом: если текущая дата на компьютере, где ведется БД клиентов больше, чем "Дата импорта", и (текущее время - "Время Ч") больше 60 минут, то строка магазина в списке высвечивается жирным красным шрифтом.


Магазины сети/Примечание(офис)

Примечание

Любая дополнительная информация по магазину.


Карточка покупателя/Меню покупатель(маг)

Покупатель

Используется для просмотра и корректировки карточек покупателей и содержит следующие пункты:

  • Просмотр
  • Поиск
  • Закрыть


Карточка покупателя/Меню Заметки

Заметки

Используется для добавления, корректировки и удаления дополнительной информации по покупателю и содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить
  • Закрыть


Таблицы скидок/Скидки

Скидки

Используется для создания, корректировки и удаления скидок и состоит из пунктов:

  • Добавить
  • Изменить
  • Удалить
  • Закрыть


Файл/Системная информация

Системная информация

Содержит информацию об использовании ресурсов и работе с базой данных для опытных пользователей. Окно отображает информацию по текущей сессии работы пользователя.


Файл/Параметры последней корректировки

Параметры последней корректировки

Пункт активен, если в текущем активном окне системы отображается список каких-либо объектов, и позволяет для текущей в списке позиции просмотреть сведения о дате/времени создания и последней корректировке данного объекта, а также пользователях, выполнивших создание и последнюю корректировку. Пункту также соответствует клавиатурное сокращение клавиш (Ctrl+Shift+I).

Доступ к разделу имеют только пользователи с правами администратора.


Поля описания анкеты покупателя/Штрих-код

Штрих-код

Уникальный код карточки, выданной покупателю. Штрих-код должен имеет длину, заданную параметром настройки размер штрих-кода .

Если включен параметр группы VIP карт , то выбор штрих-кодов, привязанных к группам VIP недоступен.

Если включен параметр штрих-коды в анкетах только из каталога , то при добавлении и корректировке анкеты покупателя штрих-код может быть выбран только из списка штрих-кодов системы.

Если параметр выключен, то дополнительно допустимо задание штрих-кода вручную с помощью кнопки «…», при нажатии которой на экран отображается ветвь Покупатели по штрих-кодам каталога карточек покупателей для выбора штрих-кода. В окне работает подвод по первым символам штрих-кода карточки покупателя.

Если включен параметр настройки переход на новые дисконтные карты , то штрих-код не должен быть привязан к группе VIP и должен принадлежать диапазону новых карт из параметра в диапазоне от ... до ... . Если поле заполняется, то открывается для корректировки поле замена карты старого образца . Если поле очищается, то поле замена карты старого образца также очищается.


Поля описания анкеты покупателя/Замена карты старого образца

Замена карты старого образца

Отображается, если включен параметр настройки переход на новые дисконтные карты . Доступно для корректировки, если в поле штрих-код задан штрих-код дисконтной карты, ссылающийся на карточку покупателя такую, что в списке вкладки Штрих-коды есть хотя бы один штрих-код, не привязанный к группе VIP и его номер не попадает в промежуток из параметра настройки в диапазоне от ... до ... . Если поле доступно, то его заполнение обязательно. Если указанным критериям в карточке покупателя удовлетворяет только 1 штрих-код, то он предлагается в качестве значения по умолчанию и поле закрывается от корректировки.


Поля описания анкеты покупателя/Информацию получать по

Информацию получать по

Способ получения информации об акциях компании: по телефону или по e-mail.


Поиск/Активность

Активность

Активность карточки покупателя. Может принимать значения: да, нет, не важно. Если выбрано значение «не важно», то отбор будет производиться среди всех покупателей независимо от активности карточки. Если выбрано значение, отличное от «не важно», то результатом поиска будут покупатели с заданным состоянием активности карточки на вкладке Описание.

Замечание: всегда производится отбор карточек покупателей по признаку активности основного штрих-кода карточки. Если включен параметр настройки системы определять активность для каждого штрих-кода , то поиск активных/неактивных штрих-кодов можно провести в ветви Покупатели по штрих-кодам с помощью сортировки столбца Активность.


Поиск/Выдача карты

Выдача карты

Может принимать значения: обмен карты старого образца, новая карта. При выборе "обмен карты нового образца" результатами поиска будут покупатели, имеющие новые дисконтные карты, полученные взамен вышедших из оборота, при выборе "новая карта" произойдет отбор покупателей, сразу получивших карточки нового образца.


Поиск/Ответственный магазин(офис)

Ответственный магазин

Ответственный за покупателя магазин. Если задано несколько магазинов, то результом поиска будут покупатели, которым дисконтная карта была выдана в одном из указанных магазинов. Результатами поиска будут покупатели, для которых заданный магазин является ответственным.


Поиск/Регионы ответственных магазинов(офис)

Регионы ответственных магазинов

Регион расположения ответственного магазина. Если задано несколько регионов, то результом поиска будут покупатели, у которых ответственный магазин расположен в одном из заданных регионов.


Поиск/Исходящий магазин(офис)

Исходящий магазин

Исходный магазин выдачи карты. Если задано несколько магазинов, то результом поиска будут покупатели, которым дисконтная карта была выдана в одном из указанных магазинов.


Поиск/Регионы исходящих магазинов(офис)

Регионы исходящих магазинов

Регион расположения исходящего магазина. Если задано несколько регионов, то результом поиска будут покупатели, у которых исходящий магазин расположен в одном из заданных регионов.


Пример экспорта-импорта для нового магазина

Процедура экспорта-импорта информации для нового магазина

В магазине и в офисе параметры, относящиеся ко времени импорта и времени экспорта пока не заполнены.

1) Первичный экспорт из центрального офиса в новый магазин произошел, например 14.04.05 в 13.02. Формируется файл экспорта ne.exp, который имеет вид: Код магазина I Дата/время импорта (Последнее дата время новой информации, успешно полученной из магазина) I Время экспорта, т.е. в нашем случае он выглядит так: Код I Пусто I :50414 I 1302

2) В магазине производится следующая проверка: дата, время экспорта из файла центрального офиса меньше либо равна дате, времени импорта, обозначенных в глобальных параметрах магазина? Т.е. 14.04.05 13.02 меньше чем пусто? Если нет, то пусто записывается в графу «подтвержденный экспорт», а 14.04.05 13.02 в графу «последние данные из офиса» в глобальных параметрах магазина.

3) В магазине 14.04.05 в 13.11 был получен файл от касс или произошла какая-то другая корректировка какой-либо карточки покупателя.

4) Первичный экспорт из магазина в центральный офис произошел, например 14.04.05 в 13.12. Формируется файл экспорта ni.exp, который имеет вид: Код магазина I Дата/время импорта (Последнее дата время новой информации, успешно полученной из центрального офиса) I Дата/время последней корректировки по покупателям (если "свежей" информации нет, то записываются текущие дата/время) I Дата/время формирования файла экспорта (текущие системные дата и время), т.е. в нашем случае он выглядит так: Код I :50414 I 1302 I :050414 I 1311 I :050414 I 1312

5) В офисе происходит следующая проверка: дата, время последней информации магазина из файла меньше ли даты, времени импорта, обозначенных в классификаторе «Магазины сети» для данного магазина? Т.е. 14.04.05 13.11 меньше чем пусто? Если нет, то 14.04.05 13.02 записывается в графу «подтвержденный экспорт», а 14.04.05 13.11 в графу «последние данные из магазина» в офисе в классификаторе «Магазины сети» для данного магазина.

Теперь в магазине в глобальных параметрах установятся следующие значения:

  • в графе «последние данные из офиса» 14.04.05 13.02,
  • в графе «подтвержденный экспорт» пустое значение до тех пор, пока из офиса не придет подтверждение об успешно принятой информации,
  • в графе «дата файла импорта» 14.04.05 13.02,
  • в графе «дата файла экспорта» 14.04.05 13.12.

В центральном офисе в классификаторе «Магазины сети» для данного магазина установятся следующие значения:

  • в графе «подтвержденный экспорт» 14.04.05 13.02,
  • в графе «последние данные из магазина» 14.04.05 13.11,
  • в графе «дата файла экспорта» 14.04.05 13.02,
  • в графе «дата файла импорта» 14.04.05 13.12.


Пример экспорта-импорта для магазина

Пример экспорта-импорта информации для магазина

Перед началом очередного обмена данными в магазине и в офисе параметры, относящиеся ко времени импорта и времени экспорта таковы:

Магазин - раздел Настройка/Параметры

последние данные из офиса 13.03.05 11.00

подтвержденный экспорт 12.03.05 10.00

дата файла импорта 13.03.05 11.00

дата файла экспорта 14.03.05 13.00

Центральный офис - раздел Классификаторы/Магазины сети

подтвержденный экспорт 13.03.05 11.00

последние данные из магазина 14.03.05 12.00

дата файла экспорта 13.03.05 11.00

дата файла импорта 14.03.05 13.00

1) Экспорт из центрального офиса в магазин произошел, например 15.03.05 в 13.00. Формируется файл экспорта Имя1.exp, (где Имя1 - имя файла для экспорта, указанное в параметрах описания магазина). Файл имеет следующий вид: Код магазина I Дата/время импорта (Последнее дата время новой информации, успешно полученной из магазина) I Время экспорта, т.е. в нашем случае он выглядит так: Код I :50314 I 1200 I :50315 I 1300

2) В магазине производится следующая проверка: дата, время экспорта из файла центрального офиса меньше либо равна дате, времени импорта, обозначенных в глобальных параметрах магазина? Т.е. 15.03.05 13.00 меньше чем 13.03.05 11.00? Если нет, то 14.03.05 12.00 записывается в графу «подтвержденный экспорт», а 15.03.05 13.00 в графу «последние данные из офиса» в глобальных параметрах магазина.

3) В магазине 15.03.05 в 14.00 был получен файл от касс или произошла какая-то другая корректировка какой-либо карточки покупателя.

4) Экспорт из магазина в центральный офис произошел, например 15.03.05 в 15.00. Формируется файл экспорта Имя2.exp, (где Имя2 - имя файла для экспорта, указанное в разделе Настройка/Параметры). Файл имеет следующий вид: Код магазина I Дата/время импорта (Последнее дата время новой информации, успешно полученной из центрального офиса) I Дата/время последней корректировки по покупателям (если "свежей" информации нет, то записываются текущие дата/время), т.е. в нашем случае он выглядит так: Код I :50315 I 1300 I :050315 I 1400 I :050315 I 1500

5) В офисе происходит следующая проверка: дата, время последней информации магазина из файла меньше ли даты, времени импорта, обозначенных в классификаторе «Магазины сети» для данного магазина? Т.е. 15.03.05 14.00 меньше чем 15.03.05 13.00? Если нет, то 15.03.05 13.00 записывается в графу «подтвержденный экспорт», а 15.03.05 14.00 в графу «последние данные из магазина» в офисе в классификаторе «Магазины сети» для данного магазина.

В центральный офис из магазина пришло подтверждение получения информации, отправленной из офиса 15.03.05 в 13.00, поэтому экспорт считается успешно проведенным и в классификаторе «Магазины сети» для данного магазина в графе «подтвержденный экспорт» установится значение 15.03.05 13.00, а в графе «последние данные из магазина» 15.03.05 14.00.

Теперь в магазине в глобальных параметрах установятся следующие значения:

  • в графе «последние данные из офиса» 15.03.05 13.00,
  • в графе «подтвержденный экспорт» 14.03.05 12.00 до тех пор, пока из офиса не придет подтверждение об успешно принятой информации,
  • в графе «дата файла импорта» 15.03.05 13.00,
  • в графе «дата файла экспорта» 15.03.05 15.00.

В центральном офисе в классификаторе «Магазины сети» для данного магазина установятся следующие значения:

  • в графе «подтвержденный экспорт» 15.03.05 13.00,
  • в графе «последние данные из магазина» 15.03.05 14.00,
  • в графе «дата файла экспорта» 15.03.05 13.00,
  • в графе «дата файла импорта» 15.03.05 15.00.


Настройка/Параметры/Тип обмена

Тип обмена

Если выбран вариант "FTP", то схема обмена реализуется в предположении, что между компьютерами в центральном офисе и в магазине не существует прямой связи. Предлагается использовать протокол обмена файлами FTP и компьютер-посредник - FTP-сервер, к которому должны иметь доступ компьютеры в центральном офисе и в каждом магазине. При обмене данными каждая система будет считывать для нее другой стороной файл обмена для чтения с FTP-сервера и записывать на него файл обмена для записи. В параметрах настройки всех систем сети задаются имя FTP-сервера, номер порта для связи с ним, имя пользователя и его пароль доступа к FTP-серверу. При работе функции обмена данными в дисконтной системе программа выполняет команду записи или чтения информации с FTP-сервера.

Если выбран вариант "файловый", то вся схема обмена производится без помощи удаленной связи. В этом случае файлы обмена, сформированные программой SLS-ДисконтОф должны быть переданы пользователем в программу SLS-ДисконтМаг самостоятельно, например посредством электронной почты (таким же образом передаются файлы из программы SLS-ДисконтМаг в систему SLS-ДисконтОф).


Классификаторы/Магазины сети/Новые карточки покупателей активны(офис)

Новые карточки покупателей активны

Значение параметра с помощью процедуры экспорта передается в соответствующий магазин. При включенном параметре новые карточки, регистрируемые в кассах магазина, становятся активными в магазине после импортирования информации от касс. В центральном офисе при импорте из магазина новых карточек покупателей в описании покупателя автоматически будет включен параметр активность .


Настройка/Параметры/Новые карточки покупателей активны(маг)

Новые карточки покупателей активны

Закрыто от корректировки вручную, заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, то при импорте информации от касс все полученные новые карточки покупателей автоматически становятся активными.


Настройка/Параметры/Общая сумма покупок(офис)

Общая сумма покупок

Используется для определения механизма расчета значения общей суммы покупок покупателя.

Если выбрано значение «все покупки», то скидка по дисконтной карте предоставляется всем покупателям от общей суммы покупок.

Если выбрано значение «настраивать в карточке покупателя», то скидка по дисконтной карте предоставляется всем покупателям от общей суммы покупок, за исключением тех покупателей, в карточках которых включен параметр за пред. календарный месяц. Таким покупателям скидка по дисконтной карте предоставляется от общей суммы покупок, зарегистрированных на данную карту за прошлый календарный месяц.

Если выбрано значение «настраивать в карточке покупателя», то дополнительно отображается поле общие суммы покупок рассчитаны за .

Если до корректировки значение данного параметра было «все покупки», а после корректировки стало «настраивать в карточке покупателя», то:

o в карточках покупателей отображается параметр за пред. календарный месяц

o в параметрах настройки отображается параметр общие суммы покупок рассчитаны за , которому присваивается предыдущий календарный месяц относительно текущей системной даты.

Если до корректировки значение данного параметра было «настраивать в карточке покупателя», а после корректировки стало «все покупки», то на экран отображается предупреждающее сообщение с текстом: «Изменен порядок расчета общих сумм покупок. Будет выполнен пересчет общих сумм покупок во всех карточках покупателей. Вы подтверждаете изменение порядка расчета?» и кнопками (Да) и (Нет). При нажатии (Да) параметры настройки сохраняются и запускается функция пересчета общей суммы покупок по всем карточкам покупателей. Пересчет выполняется по следующим правилам:

o Обрабатываются все карточки покупателей списка ветви каталога покупателей Покупатели по именам. Для каждой карточки покупателя проверяется, включен ли параметр параметр за пред. календарный месяц . Если да, то он отключается, а полю общая сумма покупок присваивается значение начальная сумма покупок + сумма по столбцу Сумма с учетом скидки по всем покупкам из списка вкладки Покупки карточки покупателя, таким что штрих-код дисконтной карты из покупки не привязан к группе VIP. Если значение поля общая сумма покупок в карточке покупателя изменяется, то:

§ полю Дата/время последней корректировки присваиваются текущие системные дата/время,

§ поле Пользователь принимает значение Пересчет общей суммы покупок.

o В ходе процесса пересчета на экран отображается информационное окно, содержащее следующие поля:

§ Обработано карточек покупателей: N.

§ Пересчитано общих сумм покупок: К.

Где N - общее количество просмотренных карточек покупателей, К - количество карт покупателей, в которых в ходе пересчета было изменено значение поля общая сумма покупок .

o После завершения пересчета карточек покупателей производятся следующие дополнительные действия:

§ во всех карточках покупателей перестает отображаться параметр за пред. календарный месяц .

§ в параметрах настройки перестает отображаться параметр общие суммы покупок рассчитаны за .


Настройка/Параметры/Размер штрих-кода(офис)

Размер штрих-кода

Используется для установки допустимого числа символов новых штрих-кодов карточек покупателей, вводимых в систему. Значение параметра с помощью процедуры экспорта передается в магазины сети. Если значение задано, то новые карточки, регистрируемые в кассах магазинов или созданные в центральном офисе должны иметь указанный размер штрих-кода.

Внимание! При корректировке значения параметра «Размер штрих-кода» происходят следующие изменения. Если первоначально параметр имел значение N, а после редактирования принял значение P, то:

- при создании новой карточки покупателя в центральном офисе допускается присвоение штрих-кодов только длины P.

- после того как с помощью проведения процедуры экспорта значение P будет передано в магазин и в кассовую программу, при создании новой карточки покупателя через кассу или замене карточки покупателя в магазине допускается ввод штрих-кодов только длины P.

- выданные ранее карточки покупателя с размером штрих-кода N будут считаться действующими.

- в центральном офисе для корректировки карточек покупателей, у которых длина штрих-кода отлична от заданной, необходимо параметру "Размер штрих-кода" присвоить значение, соответствующее размеру штрих-кода корректируемой карточки, ввести необходимые изменения, после чего параметру снова присвоить значение P, и только после этого готовить экспортный файл для магазинов.


Настройка/Параметры/Общие суммы покупок рассчитаны за(офис)

Общие суммы покупок расчитаны за

Отображается, если параметр настройки общая сумма покупок имеет значение «настраивать в карточке покупателя». Закрыто от корректировки, заполняется системой автоматически при проведении пересчета общих сумм покупок по покупателям, в которых общие суммы покупок рассчитываются за предыдущий календарный месяц.


Настройка/Параметры/Штрих-коды в анкетах только из каталога (офис)

Штрих-коды в анкетах только из каталога

Если параметр включен, то после проведения процедуры экспорта данных в магазины сети, в магазинах при добавлении и корректировке анкеты покупателя штрих-код может быть выбран только из списка штрих-кодов, имеющихся в системе SLS-ДисконтМаг.


Поиск/Общая сумма покупок

Общая сумма покупок

Диапазон искомой общей суммы покупок покупателя. Результатом отбора будут карточки покупателей, в которых общая сумма покупок попадает в заданный интервал.


Поиск/Текущая скидка

Текущая скидка

Диапазон искомого размера текущей скидки покупателя. Результатом отбора будут карточки покупателей, в которых размер текущей скидки попадает в заданный интервал.


Поместить в описание(офис)

Поместить в описание

Используется для отображения любого из штрих-кодов карточки покупателя на вкладке Описание . Функция активна только на вкладке Штрих-коды и доступна пользователям с правом на изменение карточек покупателей.

При вызове операции выполняются следующие действия:

  • На вкладку Описание записывается штрих-код, на котором установлен курсор в момент вызова операции.
  • На вкладку Описание в поле Магазин (исх.) помещается значение одноименного поля Исходящий магазин из описания штрих-кода, для которого вызвана операция (если оно заполнено).
  • Если включен параметр настройки системы определять активность для каждого штрих-кода , то параметр активность в описании карточки покупателя включается, если штрих-код, к которому применяется операция активен.
  • В поле дата/время последней корректировки записываются текущие дата/время.


Настройка/Параметры/ФИО указывать в отдельных полях(офис)

ФИО указывать в отдельных полях

Если параметр включен, то при заполнении анкетных данных покупателя ввод фамилии, имени и отчества осуществляется в трех отдельных полях: "Фамилия", "Имя", "Отчество" в следующих разделах системы:

  • при заполнении/корректировке ФИО в карточке покупателя
  • отображение ФИО в каталоге покупателей в ветвях Покупатели по именам и Архив
  • отображение ФИО в каталоге групп VIP во всех ветвях раздела Покупатели

Если параметр был отключен, а потом его включили, то для уже имеющихся карточек покупателей в поле Фамилия будет отображаться фамилия, имя и отчество покупателя, а поля Имя и Отчество заполнены не будут. Если параметр был включен, а потом его отключили, то для уже имеющихся карточек покупателей в поле ФИО будет отображаться только фамилия покупателя.

Внимание!!! Параметр, определяющий способ хранения ФИО покупателей рекомендуется настроить перед началом использования системы, так как его переключение может привести к потере части данных о покупателях.


Настройка/Параметры/Фиксировать скидки при смене таблицы скидок(офис)

Фиксировать скидки при смене таблицы скидок

При изменении действующей таблицы скидок покупатель должен получать скидку не меньше, чем он имел по предыдущей действующей таблице скидок до тех пор, пока он не накопит сумму покупок, достаточную для перехода на порог с более высоким % скидки согласно новой действующей таблице скидок.

Если параметр включен, это означает, что скидки зафиксированы по некоторой таблице скидок, дата ввода в действие которой отображается в параметре настройки Скидки зафиксированы по таблице от.

Если параметр включен, то:

  • в классификаторе таблиц скидок отображается функция Зафиксировать скидки для пересчета скидок покупателей.
  • в описании таблицы скидок отображается поле Скидки зафиксированы для хранения даты расчета скидок покупателя по таблице скидок.
  • в карточке покупателя отображается поле зафиксированная скидка для хранения размера скидки покупателя по заданной таблице скидок.


Настройка/Параметры/Подписка на новости(офис)

Подписка на новости

Используется для включения возможности оформления подписки на новости индивидуально для каждого покупателя. Если параметр включен, то в карточках покупателей и в параметрах поиска появляется дополнительная вкладка Подписка на новости.


Настройка/Параметры/Передавать ФИО в магазины(офис)

Передавать ФИО в магазины

Параметр закрыт от корректировки, если включен параметр Отключить персонифицированный обмен. Если параметр включен, то при подготовке файла экспорта из центрального офиса для магазинов в файл безусловно помещается ФИО каждого покупателя. Если параметр отключен, то анкетная информация по покупателям передается только в ответственные магазины.


Настройка/Параметры/Отключить персонифицированный обмен(офис)

Отключить персонифицированный обмен

Используется для отключения возможности обмена анкетными данными покупателей. Если параметр включен, то при подготовке файла экспорта из центрального офиса для магазинов в файл не помещается информация из блока «Анкета» карточки покупателя.

Если параметр включается, то параметр Передавать ФИО в магазины отключается и закрывается от корректировки.


Настройка/Параметры/Дополнительные поля описания(офис)

Дополнительные поля описания

Используется для добавления в карточку покупателя дополнительных полей описания (например, марка транспортного средства), которые будут отображаться в карточке покупателя на вкладке Доп. описания.

В блоке задаются параметры пяти настраиваемых полей. Описание каждого поля задается следующим набором параметров:

  • Использование - поле с выпадающим списком значений - не используется, необязательно, обязательно.

Если выбрано "не используется", то настраиваемое поле в карточке покупателя не отображается.

Если выбрано "необязательно", то при создании и корректировке карточки покупателя поле отображается в карточке, но необязательно для заполнения.

Если выбрано "обязательно", то при создании и корректировке карточки покупателя поле обязательно к заполнению.

  • Наименование. Заполнение обязательно, если в поле Использование указано значение, отличное от "не используется". Указанное наименование будет отображаться в качестве названия дополнительного поля описания в карточке покупателя.


Настройка/Параметры/Использовать в магазинах(офис)

Использовать в магазинах

Используется для работы с дополнительными полями описания в магазинах сети. Если параметр включен, то после проведения процедуры экспорта данных в магазины, в магазине при добавлении и корректировке анкеты покупателя заполнение каждого дополнительного поля определяется значением параметра Использование.


Карточка покупателя/Анкета/Телефон

Телефон

Телефонный номер покупателя.


Вкладка Описание/Мобильный телефон(офис)

Мобильный телефон

Номер мобильного телефона покупателя.


Вкладка Описание/E-mail

E-mail

Адрес электронной почты покупателя.


Карточка покупателя/Вкладка Подписка на новости(офис)

Подписка на новости

На вкладке отображается список магазинов, на новости которых подписался клиент, а также способ получения новостей для каждого магазина. Если клиент подписался на получение новостей каким-либо способом, то в соответствующем столбце отображается "+".

Вкладка представляет собой список с полями:

  • Магазин
  • Телефон
  • E-mail
  • Факс
  • Почта
  • Курьер

Список магазинов подписки упорядочен в порядке добавления позиций. Работа на вкладке осуществляется с помощью меню Подписка на новости .


Вкладка Подписка на новости/Меню Подписка на новости

Подписка на новости

Используется для добавления, корректировки и удаления магазинов подписки и способов получения новостей из них и содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить


Меню Подписка на новости/Добавить(офис)

Добавить

Функция доступна пользователям с правом на просмотр карточек покупателей и используется для добавления магазина в список подписки на новости.

Выбор магазина осуществляется в классификаторе магазинов сети , после чего на экране отображается форма описания способов получения новостей, содержащая следующие параметры:

  • Телефон
  • E-mail
  • Факс
  • Почта
  • Курьер

При добавлении первого в рамках данной операции магазина параметры по умолчанию включены так же, как в строке вкладки Подписка на новости , на которой стоял курсор в момент вызова операции добавления магазина. При добавлении каждого следующего магазина параметры по умолчанию включены так же, как у предыдущего успешно добавленного.


Меню Подписка на новости/Изменить(офис)

Изменить

Функция доступна пользователям с правом на просмотр карточек покупателей и используется для корректировки описания способов получения новостей из магазина.

Если не включен ни один из параметров, определяющий способ получения новостей, то сохранение выполненных изменений не производится.


Меню Подписка на новости/Удалить(офис)

Удалить

Функция доступна пользователям с правом на просмотр карточек покупателей и используется для удаления магазина получения новостей.


Поиск/E-mail

E-mail

Электронный адрес покупателя. Задается полностью или в виде шаблона


Поиск/Телефон

Телефон

Номер телефона покупателя. Задается полностью или в виде шаблона


Поиск/Моб. телефон

Моб. телефон

Номер мобильного телефона покупателя. Задается полностью или в виде шаблона


Поиск/Вкладка Доп. описание(офис)

Дополнительные поля описания

Для каждого включенного в параметрах настройки дополнительного поля описания покупателя в форму задания параметров отбора добавляется одноименный параметр. Эти параметры допускают задание маски в виде шаблона .


Поиск/Вкладка Покупки(офис)

Покупки

На вкладке отображаются следующие поля для задания критериев отбора:

  • С покупками в период с до. Диапазон искомых дат покупок покупателей. Результатом поиска будут карточки покупателей, даты покупок в которых попадают в заданный интервал.
  • № чека. Номер чека покупки покупателя. Результатом поиска будут карточки покупателей, имеющих заданный номер чека в списке покупок.
  • В магазинах. Магазины, в которых совершали покупки искомые покупатели. Результатом поиска будут карточки покупателей, совершивших покупки хотя бы в одном из заданных магазинов.
  • Первая покупка. Диапазон искомых дат первых покупок покупателей. Результатом поиска будут карточки покупателей, значение поля Дата первой покупки из которых попадает в заданный период.
  • В магазине. Магазины, в которых совершали первые покупки искомые покупатели. Результатом поиска будут карточки покупателей, первая покупка в которых в поле Магазин содержит ссылку на любой из магазинов, заданных в данном поле.


Поиск/Вкладка Подписка на новости(офис)

Подписка на новости

На вкладке отображаются следующие поля для задания критериев отбора:

  • Подписка на новости. Если выбрано "не важно", то отбор будет производиться среди всех покупателей независимо от подписки на новости. Если выбрано "да", то отбор будет производиться среди покупателей, подписавшихся на получение новостей из магазинов, заданных в параметре отбора Магазин. Если выбрано "нет", то результатом отбора будет список карточек покупателей, не подписанных на получение новостей никаким образом ни в одном магазине.
  • Магазин. Выбор одного или нескольких значений из классификатора магазинов сети.
  • Способы доставки новостей. Для отмеченных магазинов задается произвольный набор способов доставки новостей. Варианты доставки: телефон, mail, факс, почта, курьер. Карточка покупателя удовлетворяет условиям поиска, если у нее на вкладке Подписка на новости задан хотя бы один магазин из отмеченного списка, у которого набор способов доставки содержит в себе набор, указанный в параметрах поиска.

Пример1: если в поле Магазин задан список магазинов (например, магазины "А" и "В"), и включен флажок "Телефон", то результатом отбора будет являться список тех покупателей, в карточках которых на вкладке Подписка на новости в списке магазинов есть строка с магазином "А" или "В" и включенным флажком "Телефон".

Пример2: если в поле Магазин задан список магазинов, и включено несколько флажков (например, "Телефон" и "E-mail"), то результатом отбора будет являться список тех покупателей, в карточках которых на вкладке Подписка на новости в списке магазинов есть хотя бы одна строка с одним из указанных магазинов, для которого включены оба флажка.


Операции/Снять все отметки(офис)

Снять все отметки

Фенкция доступна в случае, если отмечена хотя бы одна позиция соответствующего списка.

Если функция вызвана из каталога покупателей, то она используется для снятия отметок со всех отмеченных позиций списка карточек покупателей.

Если функция вызвана из классификатора акций групп VIP , то она используется для снятия отметок со всех отмеченных позиций списка доп. вкладки Группы VIP .


Операции/Проставить начальную сумму покупок(офис)

Проставить начальную сумму покупок

Функция доступна пользователям с правом на изменение карточек покупателей и используется для заполнения начальной суммы покупок в выделенном наборе карточек покупателей.

При вызове операции на экране отображается окно с параметром Начальная сумма покупок (руб.).

По окончании работы операции в каждой карточке покупателя из списка отмеченных выполняются следующие действия:

  • в описании карточки полю начальная сумма покупок присваивается значение, заданное в запросе
  • пересчитываются текущая скидкаи общая сумма покупок в соответствии с новым значением начальной суммы покупок и действующей таблицей скидок
  • в поле Дата/время последней корректировки записываются текущие дата/время


Операции/Удалить из списка(офис)

Удалить из списка

Используется для удаления карточки (или штрих-кода карточки) покупателя из списка отмеченных карточек (или штрих-кодов).


Меню покупатели/Пересчет(офис)

Пересчет

Функция доступна пользователям с правом администратора и используется для удаления карточек покупателей, в которых отсутствует ссылка на группу VIP, а также для пересчета общей суммы покупок покупателей.

Если параметр настройки общая сумма покупок имеет значение «все покупки», то общая сумма покупок в карточках покупателей пересчитывается по всем покупкам, зарегистрированным на данного покупатели и совершенным по дисконтным картам, не ссылающимся на группы VIP.

Если параметр настройки общая сумма покупок имеет значение «настраивать в карточке покупателя», то пересчет выполняется следующим образом:

  • По текущей системной дате определяется предыдущий относительно нее календарный месяц и заносится в параметр настройки общие суммы покупок рассчитаны за .
  • Если в карточке покупателя параметр за пред. календарный месяц отключен, то общая сумма покупок пересчитывается по всем покупкам, зарегистрированным на данного покупателя и совершенным по дисконтным картам, не ссылающимся на группы VIP.
  • Если в карточке покупателя параметр за пред. календарный месяц включен, то в карточке покупателя вызывается операция Пересчитать сумму покупок . Т.е. общей сумме покупок карточки покупателя присваивается сумма по столбцу Сумма с учетом скидки по всем покупкам из списка вкладки Покупки карточки покупателя, таким что Дата покупки попадает в период, заданный параметром настройки общие суммы покупок рассчитаны за , и штрих-код дисконтной карты из покупки не привязан к группе VIP.
  • Если общая сумма покупок в карточке покупателя изменяется, то в поле Дата/время последней корректировки записываются текущие дата/время.

В процессе работы функции на экран выводится информационное окно с заголовком «Подождите, идет пересчет…» и следующими данными:

§ Обработано дисконтных карт: N.

§ Пересчитано общих сумм покупок: К.

Где N - общее количество просмотренных штрих-кодов дисконтных карт покупателей, К - количество карт покупателей, в которых в ходе пересчета было изменено значение поля Общая сумма покупок.


Операции/Включить активность(офис)

Включить активность

Фунукция доступна пользователям с правом на изменение карточек покупателей.

Если в параметрах настройки системы параметр определять активность для каждого штрих-кода отключен, то функция доступна в ветвях Отмеченные покупатели и Найденные покупатели и позволяет включить признак активности карточки для всего списка отмеченных или отобранных карточек покупателей.

После применения операции в каждой карточке покупателя из списка проставится признак активности и будет отображаться в поле активность на вкладке Описание и на вкладке Штрих-коды карточки покупателя.

Если в параметрах настройки системы параметр определять активность для каждого штрих-кода включен, и в списке отмечена хотя бы одна карточка покупателя, то функция доступна также в ветви Покупатели по штрих-кодам. Операция применяется последовательно ко всем отмеченным в списке штрих-кодам дисконтных карт и позволяет включить активность в описании одновременно всех отмеченных в списке штрих-кодов. При применении операции в описании каждой карточки покупателя Дата/Время последней корректировки заполняются новыми значениями в соответствии с текущими системными датой и временем. По результатам работы процедуры выдается информационное сообщение вида «Просмотрено карточек N. Изменено карточек К».


Операции/Проставить ФИО(офис)

Проставить ФИО

Функция доступна пользователям с правом на изменение карточек покупателей и используется для заполнения ФИО в выделенном наборе карточек покупателей.

При вызове операции на экране отображается окно, содержащее следующие параметры:

  • Ф.И.О. Если параметр настройки системы ФИО указывать в отдельных полях отключен, то отображается одно поле. Если включен, то отображаются три поля, заполнение первого из которых обязательно.
  • Перезаписывать заполненные ФИО. Если параметр включен, то действия функции распространяются на все отмеченные карточки, если отключен, то только на те, в которых поля Ф.И.О. не заполнены.

По окончании работы операции в каждой карточке покупателя из списка отмеченных (либо для тех из отмеченных, у которых не заполнено поле Ф.И.О.) выполняются следующие действия:

  • в описании карточки полю/полям Ф.И.О. присваивается значение, заданное в запросе
  • в поле Дата/время последней корректировки записываются текущие дата/время


Операции/Отключить активность(офис)

Отключить активность

Если в параметрах настройки системы параметр определять активность для каждого штрих-кода выключен, то функция доступна в ветвях Отмеченные покупатели и Найденные покупатели и позволяет отключить признак активности карточки для всего списка отмеченных или отобранных карточек покупателей.

Замечание. Использовать операцию следует очень внимательно, так как после проведения процедуры обмена в магазинах сети покупателям, имеющим неактивные карточки, скидки НЕ предоставляются.

Если в параметрах настройки системы параметр определять активность для каждого штрих-кода включен, и в списке отмечена хотя бы одна карточка покупателя, то функция доступна также в ветви Покупатели по штрих-кодам для пользователей с правом изменения карточек покупателей. Операция применяется последовательно ко всем отмеченным в списке штрих-кодам дисконтных карт и позволяет включить активность в описании одновременно всех отмеченных в списке штрих-кодов. При применении операции в описании каждой карточки покупателя Дата/Время последней корректировки заполняются новыми значениями в соответствии с текущими системными датой и временем. По результатам работы процедуры выдается информационное сообщение вида «Просмотрено карточек N. Изменено карточек К».


Операции/Пересчитать суммы покупок по акциям(офис)

Пересчитать суммы покупок по акциям

Пункт меню отображается только в том случае, если включен параметр настройки системы пороги скидок для групп VIP и позволяет пересчитать суммы покупок, совершенных по дисконтным картам в период действия скидочной акции. Функция доступна пользователям с правом на корректировку карточек покупателей.

При вызове операции для каждого штрих-кода из списка выполняются следующие действия:

  • в списке акций группы VIP ищется акция со статусом «действует», в период действия которой попадает текущая системная дата
  • если подходящая акция найдена, то в строке со штрих-кодом в поля С и До помещаются даты Начало и Завершение, соответственно, из описания акции. Затем в списке покупок в карточке покупателя отбираются покупки, совершенные на карту с данным штрих-кодом в период действия данной акции, и по ним суммируются Суммы с учетом скидки. Полученная величина записывается в поле Сумма покупок описания штрих-кода. В описании покупателя обновляются дата и время последней корректировки. Затем выполняется переход к следующему обрабатываемому штрих-коду.
  • если подходящая акция не найдена, а в строке со штрих-кодом какое-либо из полей С, До, Сумма покупок непустое, то поля С, До и Сумма покупок очищаются, а в описании покупателя обновляются дата и время последней корректировки. Затем выполняется переход к следующему обрабатываемому штрих-коду.


Операции/Проставить отв. магазин(офис)

Проставить ответственный магазин

Функция доступна пользователям с правом на изменение карточек покупателей и позволяет присвоить ответственный магазин из перечня магазинов сети для списка отмеченных или отобранных карточек покупателей.

При вызове операции на экране отображается окно для задания магазина. По окончании работы операции в каждой карточке покупателя из списка отмеченных выполняются следующие действия:

  • в описании карточки полю ответственный магазин присваивается значение, заданное в запросе
  • в поле Дата/время последней корректировки записываются текущие дата/время


Операции/Проставить исх. магазин(офис)

Проставить ответственный магазин

Функция доступна пользователям с правом на изменение карточек покупателей и позволяет присвоить исходящий магазин из перечня магазинов сети для списка отмеченных или отобранных карточек покупателей.

При вызове операции на экране отображается окно для задания магазина. По окончании работы операции в каждой карточке покупателя из списка отмеченных выполняются следующие действия:

  • в описании карточки полю исходящий магазин присваивается значение, заданное в запросе
  • в поле Дата/время последней корректировки записываются текущие дата/время


Операции/Отметить найденные

Отметить найденные

Функция доступна пользователям с правом на просмотр карточек покупателей и приводит к проставлению отметок для всех отобранных карточек покупателей.


Поиск/Последняя корректировка(офис)

Последняя корректировка

Диапазон искомых дат последней корректировки карточек покупателей. Результатом поиска будут карточки покупателей, даты последних корректировок которых содержатся в заданном периоде.


Поиск/Дата заполнения(офис)

Дата заполнения

Диапазон искомых дат заполнения карточек покупателей. Результатом поиска будут карточки покупателей, дата заполнения карточек которых попадает в заданный интервал.


Настройка/Параметры/Определять активность для каждого штрих-кода(офис)

Определять активность для каждого штрих-кода

Если параметр отключен, то активность определяется на уровне карточки покупателя в целом. Если параметр включен, то в карточке покупателя для каждого штрих-кода активность устанавливается индивидуально.

Если параметр был отключен, а потом его включили, то штрих-коды, относящиеся к карточкам покупателей, в описании которых включен параметр Активность, становятся активными, а штрих-коды, относящиеся к карточкам покупателей, в описании которых отключен параметр Активность, - неактивными.

Если параметр был включен, а потом его отключили, то карточки покупателей, в описании которых на момент отключения параметра был включен параметр Активность, остаются активными, а карточки покупателей, в описании которых на момент отключения параметра параметр Активность был отключен, остаются неактивными.

Если параметр включен, то в системе выполняются следующие дополнительные действия:

  • в карточке покупателя на вкладке Штрих-коды после столбца Штрих-код отображается столбец Активность - в котором стоит «+», если дисконтная карта со штрих-кодом активна.
  • в карточке покупателя на вкладке Штрих-коды в меню Штрих-коды карточки покупателя доступен пункт меню Отключить/включить. Позволяет отключить и включить дисконтную карту со штрих-кодом из текущей позиции списка вкладки Штрих-коды карточки покупателя.
  • в каталоге покупателей в ветвях Покупатели по штрих-кодам и Отмеченные штрих-коды в меню Операции отображаются пункты Включить активность и Отключить активность.
  • в ветвях Покупатели по штрих-кодам и Отмеченные штрих-коды каталога покупателей после столбца Штрих-код отображается столбец Активность.

При отключении параметра описанные выше объекты перестают отображаться.


Настройка/Параметры/Пороги скидок для групп VIP(офис)

Пороги скидок для групп VIP

Параметр доступен для включения только в случае, если включен параметр группы VIP , и регламентирует возможность назначения скидок для VIP групп в зависимости от накопленной суммы покупок за период действия скидочной акции. При включении параметра для всех ранее заведенных штрих-кодов дисконтных карт, закрепленных за группами VIP, поля описания штрих-кода С, До и Сумма покупок имеют пустые значения, а для всех ранее заведенных условий по акциям для групп VIP параметр Прочие выключен и поле С суммы не заполнено.


Настройка/Параметры/Группы VIP(офис)

Группы VIP

Параметр определяет возможность работы с организациями, с которыми заключены договора на корпоративное обслуживание (группы VIP карт). Для каждой организации указывается список дисконтных карт, закрепленных за ней, а также задаются правила предоставления скидок. Если дисконтная карточка не привязана ни к одной организации, то скидки по ней предоставляются по накопительной программе согласно общей действующей таблице скидок. Если же дисконтная карточка привязана к некоторой организации (группе VIP), то скидки по ней предоставляются согласно таблице скидок, действующей для этой группы/подгруппы (накопительная система скидок для карточки не действует).

При описании скидок, действующих для некоторой организации (группы VIP), допускаются следующие виды скидок:

  • Фиксированный процент скидки на все товары;
  • Фиксированный процент скидки на товары определенного аналитического типа.

При описании условий предоставления скидки, аналитические типы задаются кодами, которые назначены указанным объектам в системе SLS-Эксперт. При этом названия классов, типов и признаков в модулях системы SLS-Дисконт нигде не отображаются.

Если параметр выключен, то включить его можно без ограничений. При его включении:

- В основном меню программы в разделе Скидки становится доступным новый пункт Группы VIP.

- В описании прав пользователя в таблице «Основные разделы» становится доступна новая строка Группы VIP (по умолчанию все права в этой строке отключены).

- В карточке покупателя на вкладке Штрих-коды отображается столбец Группа VIP.

- В ветви Покупатели по штрих-кодам каталога покупателей отображается столбец Группа VIP.

Если параметр включен, то его отключение доступно только в случае если каталог «Группы VIP» пустой. При отключении параметра описанные выше объекты перестают отображаться.


Настройка/Параметры/АТ в накопительной таблице скидок(офис)

Аналитические типы в накопительной таблице скидок

Параметр доступен для включения только в случае, если включен параметр пороги скидок для групп VIP и определяет возможность задания скидок в зависимости от аналитического типа товара в накопительной таблице скидок.

При включении параметра выполняются следующие действия:

o В описании скидки, предоставляемой начиная с некоторой пороговой суммы, в таблице накопительных скидок отображаются поля аналитический тип и прочие товары

o В карточках покупателей поле текущая скидка не отображается.

o В списке карточек покупателей столбец Текущая скидка не отображается.

Кроме того, во всех ранее заведенных таблицах накопительных скидок в описании каждой скидки:

- поле аналитический тип пустое.

- параметр прочие товары включен.

При отключении параметра выполняются следующие действия:

o В описании скидки, предоставляемой начиная с некоторой пороговой суммы, в таблице накопительных скидок поля аналитический тип и прочие товары не отображаются. Данные об описанных скидках перестают отображаться в системе, но ранее введенные сведения из базы данных не удаляются.

o В карточках покупателей отображается поле текущая скидка

o В списке карточек покупателей отображается столбец Текущая скидка.


Операции/Привязать к группе VIP(офис)

Привязать к группе VIP

Пункт меню отображается только в случае, если в включен параметр настройки системы Группы VIP карт , и в списке отмечена хотя бы одна карточка покупателя. Пункт доступен пользователям с правом изменения карточек покупателей.

Операция применяется последовательно ко всем отмеченным в списке штрих-кодам дисконтных карт. Штрих-коды, которые уже привязаны к некоторым группам, операцией не обрабатываются. После выбора группы, к которой следует привязать штрих-код, карточка покупателя отображается в списке покупателей выбранной группы VIP. В этой карточке из общей суммы покупок вычитаются все суммы покупок, оформленных на штрих-код, для которого вызвана операция привязки к группе VIP. При этом выполняется следующее соглашение: если в списке покупок некоторой карточки, содержщей несколько штрих-кодов есть покупки без штрих-кода дисконтной карты, то в такие покупки проставляется штрих-код (первый из обработнных для данной карточки), и их суммы также вычитаются из общей суммы покупок в описании покупателя. При применении операции в описании карточки покупателя поле Дата/Время последней корректировки заполняется новым значением в соответствии с текущими системными датой и временем. По результатам работы процедуры выдается информационное сообщение вида «Просмотрено карточек N. Изменено карточек К».


Операции/Отвязать от группы VIP(офис)

Отвязать от группы VIP

Пункт меню отображается только в случае, если включен параметр настройки системы Группы VIP карт , и в списке отмечена хотя бы одна карточка покупателя. Пункт доступен пользователям с правом изменения карточек покупателей.

Операция применяется последовательно ко всем отмеченным в списке штрих-кодам дисконтных карт. Штрих-коды, которые не привязаны ни к каким группам, операцией не обрабатываются. При применении операции карточка покупателя удаляется из списка покупателей группы VIP, в карточке покупателя к общей сумме покупок прибавляются все суммы покупок, оформленные на штрих-код, для которого вызвана операция отвязки от группы VIP. Кроме того, в описании карточки покупателя покупателя Дата/Время последней корректировки заполняются новыми значениями в соответствии с текущими системными датой и временем. По результатам работы процедуры выдается информационное сообщение вида «Просмотрено карточек N. Изменено карточек К».


Меню Штрих-коды/Привязать к группе VIP(офис)

Привязать к группе VIP

Пункт меню отображается только в случае, если включен параметр настройки системы группы VIP карт .

Функция доступна пользователям с правом на изменение карточек покупателей. При применении операции выполняются следующие действия:

  • После выбора группы, к которой следует привязать штрих-код, карточка покупателя отображается в списке покупателей выбранной группы VIP.
  • В этой карточке из общей суммы покупок вычитаются все суммы покупок, оформленных на привязываемый штрих-код. При этом выполняется следующее соглашение: если в списке покупок есть покупки без штрих-кода дисконтной карты, то в такие покупки проставляется привязываемый штрих-код, и их суммы также вычитаются из общей суммы покупок в описании покупателя.
  • Пересчитывается текущая скидка покупателя.
  • В поле дата/время последней корректировки записываются текущие дата/время.
  • Автоматически вызывается операция пересчета суммы покупок по акциям


Меню Штрих-коды/Отвязать от группы VIP(офис)

Отвязать от группы VIP

Пункт меню отображается только в случае, если включен параметр настройки системы группы VIP карт , а курсор стоит на позиции со штрих-кодом, который привязан к группе VIP.

Функция доступна пользователям с правом на изменение карточек покупателей. При применении операции выполняются следующие действия:

  • Карточка покупателя удаляется из списка покупателей группы VIP.
  • В этой карточке к общей сумме покупок прибавляются все суммы покупок, оформленные на отвязываемый штрих-код.
  • Пересчитывается текущая скидка покупателя.
  • Если в строке со штрих-кодом заполнены поля С, До и Сумма, то они очищаются.
  • В поле дата/время последней корректировки записываются текущие дата/время.


Меню Штрих-коды(офис)

Штрих-коды

Используется работы со штрих-кодами, оформленных на карточку покупателя и содержит пункты:

  • Поместить в описание
  • Отключить/Включить
  • Привязать к группе VIP
  • Отвязать от группы VIP
  • Пересчитать суммы покупок по акциям


Меню Штрих-коды/Отключить/Включить(офис)

Отключить/Включить

Пункт отображается, если в параметрах настройки системы включен параметр определять активность для каждого штрих-кода . Функция доступна пользователям с правом на изменение карточек покупателей.

Операция позволяет отключить и включить активность штрих-кода дисконтной карты из текущей позиции списка вкладки Штрих-коды карточки покупателя.

При вызове операции выполняются следующие действия:

  • Если штрих-код, для которого вызывается операция, является основным, то параметр активность в описании карточки покупателя отключается/включается соответственно.
  • В поле дата/время последней корректировки записываются текущие дата/время.


Группы VIP/Ветвь Найденные Группы VIP(офис)

Найденные группы VIP

Раздел доступен пользователям с правом на просмотр групп VIP и представляет собой список групп VIP, отобранных в результате поиск . Список хранится до проведения следующего поиска групп VIP и представлен в виде таблицы со следующими колонками:

Если каталог групп VIP открыт на верхнем уровне, то список групп VIP в правой части окна каталога представлен в виде таблицы со следующими колонками:

  • Код
  • Наименование
  • Полное наименование
  • Статус
  • Дата/время последней корректировки - дата/время внесения последних корректировок в описание группы VIP или одного из вложенных в нее объектов (дисконтных карт, скидочных акций).

В списке найденных групп VIP доступна функция:

  • Спозиционироваться в дереве


Группы VIP/Ветвь Покупатели(офис)

Покупатели

Просмотр ветвей Покупатели любой из групп VIP доступен только пользователям с правом на просмотр карточек покупателей. Ветвь Покупатели содержит список покупателей с дисконтными картами, закрепленными за организацией. Дерево покупателей любой из групп VIP содержит следующие ветви:

  • Все - полный список покупателей, относящихся к группе VIP.
  • Отмеченные - в списке отображаются только позиции, отмеченные в списках других ветвей.
  • Последний поиск - в списке отображаются позиции, отобранные в результате последней операции поиска


Группы VIP/Меню Группы VIP/Спозиционироваться в дереве(офис)

Спозиционироваться в дереве

Функция позволяет перейти в ветвь Группы VIP каталога групп VIP на позицию с описанием соответствующей группы VIP.


Группы VIP/Ветвь Акции(офис)

Акции

Просмотр ветвей Акции любой из групп VIP доступен пользователям с правами на просмотр групп VIP. В верхней части окна отображается список акций, согласно которым в разные периоды времени предоставляются скидки по дисконтным картам группы VIP, в нижней части окна - список условий предоставления скидок по акции, на позиции с которой стоит курсор в верхнем списке.

Акции, созданные в классификаторе акций групп VIP выделяются в списке голубым цветом фона. Для них недоступны операции корректировки и удаления акций, а также операции добавления/корректировки/удаления условий предоставления скидок.

Список скидочных акций представлен в виде таблицы со следующими колонками:

  • Начало - дата, с которой акция вводится в действие.
  • Завершение - дата, до которой действует акция (включительно).
  • Примечание - произвольное описание акции.
  • Статус - статус таблицы может принимать любое из трех значений: Проект, Действует или Архив.
  • Суммы по картам пересчитаны на дату - дата/время последнего пересчета сумм покупок по акциям. Заполняется системой автоматически при выполнении операции пересчета суммы покупок по акциям из списка покупателей группы VIP.
  • Дата/время последней корректировки - дата/время последней корректировки акции или ее условий. Заполняется системой автоматически при:

создании и корректировке описания акции для группы VIP

добавлении , корректировке и удалении списка условий по данной акции.

Список скидочных акций отсортирован по дате начала действия акции.

Работа со списком скидочных акций осуществляется при помощи меню Акции

В нижней части экрана список условий предоставления скидок по акции представлен в виде таблицы с графами:

  • Аналитический тип - код аналитического типа товаров.
  • С суммы - общая сумма покупок за период действия акции, после достижения которой предоставляется скидка по условию. Столбец отображается, если включен параметр настройки системы пороги скидок для групп VIP .
  • Скидка - размер скидки на товары, обладающие указанным аналитическим типом.

Список упорядочен по значению столбца Аналитический тип, а в рамках одного аналитического типа по возрастанию значений столбца С суммы. В списке условий предоставления скидок работает сортировка по любому столбцу.

Работа со списком условий предоставления скидок по акции осуществляется при помощи меню Условия .


Группы VIP/Меню Группы VIP(офис)

Группы VIP

Используется для работы в каталоге групп VIP и содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить
  • Поиск
  • Показывать архивные группы/Не показывать архивные группы


Группы VIP/Меню Акции(офис)

Акции

Используется для работы со скидочными акциями в каталоге групп VIP клиентов или в классификаторе акций групп VIP и содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить
  • Показывать архивные акции/Не показывать архивные акции
  • Перейти в классификатор акций


Группы VIP/Меню Группы VIP/Добавить(офис)

Добавить

Функция доступна пользователям с правом на добавление групп VIP. Для создания описания новой группы VIP нужно заполнить следующие параметры:

  • Код
  • Наименование
  • Полное наименование
  • Регион
  • Статус

После выполнения операции обновляются Дата/время последней корректировки для новой группы VIP.


Группы VIP/Меню Группы VIP/Изменить(офис)

Изменить

Функция доступна пользователям с правом на изменение групп VIP. Используется для изменения описания следующих параметров группы VIP:

  • Код
  • Наименование
  • Полное наименование
  • Регион
  • Статус

После выполнения операции обновляются Дата/время последней корректировки для откорректированной группы VIP.


Группы VIP/Меню Группы VIP/Удалить(офис)

Удалить

Функция доступна пользователям с правом на удаление групп VIP только для групп со статусом «новая» и пустым списком дисконтных карт.

При удалении группы VIP она также удаляется из списков всех доп. вкладок Группы VIP описаний акций, в которых она использовалась в классификаторе акций групп VIP .


Группы VIP/Меню Группы VIP/Перейти в классификатор акций(офис)

Перейти в классификатор акций

Функция активна только в том случае, если в списке акций группы VIP курсор позиционирован на акции, созданной в классификаторе акций (выделена голубым цветом фона) и доступна пользователям с правом на просмотр акций групп VIP. Используется для открытия окна классификатора акций групп VIP с подводом курсора к соответствующей акции.


Группы VIP/Меню Группы VIP/Архив(офис)

Показывать архивные группы/Не показывать архивные группы

Функция доступна пользователям с правом на просмотр групп VIP и используется для отображения или скрытия в списке каталога архивных групп VIP.


Группы VIP/Меню Группы VIP/Код(офис)

Код

Код группы VIP. Используется для однозначной идентификации групп VIP в «офисной» и «магазинных» базах данных, поэтому значение кода должно быть уникально в рамках списка групп VIP. Закрывается от корректировки пользователем, если группа уже хотя бы раз была записана в файл экспорта.


Группы VIP/Меню Группы VIP/Регион(офис)

Регион

Регион расположения группы VIP клиентов.


Группы VIP/Меню Группы VIP/Наименование(офис)

Наименование

Наименование группы VIP. Можно указать, например, наименование организации, с которой заключается договор на VIP обслуживание.


Группы VIP/Меню Группы VIP/Полное наименование(офис)

Полное наименование

Полное наименование группы VIP.


Группы VIP/Меню Группы VIP/Статус(офис)

Статус

Статус группы VIP. Возможные значения: новая (группа находится в процессе создания), активная (группа полностью описана, информация о ней должна распространяться в магазины сети), архивная (группа больше не используется, при экспорте в магазины сведения о такой группе не передаются). Если группа уже хотя бы раз была записана в файл экспорта, то ее статус нельзя изменить на новый.


Поля описания группы VIP(справка)(офис)

Поля описания группы VIP

Для описания групп VIP клиентов необходимо заполнить следующие поля:

  • Код
  • Наименование
  • Полное наименование
  • Регион
  • Статус


Группы VIP/Ветвь Покупатели/Все(офис)

Все

Список карточек покупателей, содержащих хотя бы один штрих-код, привязанный к группе VIP, отсортированный по штрих-коду в порядке возрастания. В ветви работает подвод по первым символам штрих-кода покупателя. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Активность - отображается, если включен параметр определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Дата рождения
  • Телефон
  • E-mail

Также с помощью настройки списков могут быть отображены следующие столбцы:

  • Адрес
  • Архив - отображается «+», если отображается «+», если карточка покупателя находится в архиве.

В списке карточек покупателей доступны функции:

  • Добавитьновую карточку покупателя к данной группе VIP клиентов.
  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Пересчитать карточки покупателей.
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск .
  • Быстрый поиск карточки покупателя по первым символам фамилии покупателя.
  • Отметить карточки путем проставления точек в поле слева от списка.
  • Снять все отметки
  • Пересчитать суммы покупок по акциям


Группы VIP/Ветвь Покупатели/Отмеченные(офис)

Отмеченные

Список позиций некоторой группы VIP, отмеченных в списках других ветвей. Список хранится до закрытия базы данных, при следующем открытии базы данных он очищается. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Активность - отображается, если включен параметр определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Дата рождения
  • Телефон
  • E-mail

Также с помощью настройки списков могут быть отображены следующие столбцы:

  • Адрес
  • Архив - отображается «+», если карточка покупателя находится в архиве.

С отмеченными карточками покупателей группы VIP можно производить следующие действия:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Пересчитать карточки покупателей.
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск .
  • Снять все отметки
  • Удалить из списка
  • Пересчитать суммы покупок по акциям


Группы VIP/Ветвь Покупатели/Последний поиск(офис)

Последний поиск

Список карточек покупателей, отобранных в результате поиска хранится до проведения следующего поиска карточек покупателей. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Активность - отображается, если включен параметр определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Дата рождения
  • Телефон
  • E-mail

Также с помощью настройки списков могут быть отображены следующие столбцы:

  • Адрес
  • Архив - отображается «+», если карточка покупателя находится в архиве.

Со списком найденных карточек покупателей группы VIP можно производить следующие действия:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Пересчитать карточки покупателей.
  • Отобрать покупателей по совокупности заданных параметров, используя поиск .
  • Снять все отметки
  • Удалить из списка
  • Отметить найденные
  • Пересчитать суммы покупок по акциям


Группы VIP/Меню Акции/Добавить(офис)

Добавить

В каталоге групп VIP функция доступна пользователям с правом на добавление групп VIP.

В классификаторе акций групп VIP функция доступна пользователям с правом на добавление акций групп VIP.

Для добавления скидочной акции необходимо заполнить форму для описания новой акции, содержащую следующие поля:

  • Начало
  • Завершение
  • Примечание
  • Статус

Период действия создаваемой акции не должен пересекаться с периодами действия других акций той же группы VIP.

Если новая акция успешно добавляется в список акций, то в описании акции обновляются Дата/время последней корректировки.

Если новая акция создавалась в каталоге групп VIP , то в описании группы VIP обновляются Дата/время последней корректировки.


Группы VIP/Меню Акции/Изменить(офис)

Изменить

В каталоге групп VIP функция активна для акций, имеющих белый цвет фона, и доступна пользователям с правом на изменение групп VIP.

В классификаторе акций групп VIP функция доступна пользователям с правом на изменение акций групп VIP.

Для изменения описания скидочной акции необходимо отредактировать форму описания акции, содержащую следующие поля:

  • Начало/Завершение
  • Примечание
  • Статус

Период действия акции не должен пересекаться с периодами действия других акций той же группы VIP.

Если акция корректировалась в каталоге групп VIP , то в описании группы VIP и в описании скидочной акции обновляются Дата/Время последней корректировки.

Если акция корректировалась в классификаторе акций групп VIP , и доп. вкладка Группы VIP содержит непустой список групп VIP, а в процессе корректировки было изменено хотя бы одно из полей Начало, Завершение, то в списке акций каждой из групп VIP, на которые распространена редактируемая акция, период действия корректируемой акции не должен пересекаться с периодами действий прочих акций по данной группе.

Если акция успешно откорректирована, то для акции обновляются Дата/время последней корректировки.

Кроме того, в каждой из групп VIP, на которые распространена акция в списке акций отображаются обновленные данные и для акции обновляются Дата/время последней корректировки.

Если статус акции изменяется с «активная» или «архивная» на «новая», то для каждой из групп VIP, на которые распространена данная акция, значение поля Суммы по картам пересчитаны на дату автоматически очищается.


Группы VIP/Меню Акции/Удалить(офис)

Удалить

В каталоге групп VIP функция активна для акций со статусом новая, имеющих белый цвет фона, и доступна пользователям с правом на удаление групп VIP.

В классификаторе акций групп VIP функция доступна пользователям с правом на удаление акций групп VIP для акций со статусом новая.

Удаление производится после подтверждения, и в описании соответствующей группы VIP обновляются Дата/время последней корректировки.


Группы VIP/Меню Акции/Архив(офис)

Показывать архивные акции/Не показывать архивные акции

В каталоге групп VIP функция доступна пользователям с правом на просмотр групп VIP и используется для отображения или скрытия в списке каталога архивных скидочных акций для групп VIP клиентов.

В классификаторе акций групп VIP функция пользователям с правом на просмотр акций групп VIP и используется для отображения или скрытия в списке классификатора архивных скидочных акций для групп VIP клиентов.


Поля описания скидочной акции(справка)(офис)

Поля описания акции

Для описания скидочной акции для группы VIP клиентов необходимо заполнить следующие поля:

  • Начало
  • Завершение
  • Примечание
  • Статус


Ветвь Акции/Меню Акции/Начало/Завершение(офис)

Начало/Завершение

Начало. Дата, начиная с которой действует акция.

Завершение. Дата, до которой действует акция (включительно).

Если акция создается/корректируется в каталоге групп VIP, то период действия создаваемой акции не должен пересекаться с периодами действия других акций той же группы VIP.


Ветвь Акции/Меню Акции/Примечание(офис)

Примечание

Произвольное описание скидочной акции.


Ветвь Акции/Меню Акции/Статус(офис)

Статус

Может принимать одно из значений: новая, активная, архивная. Действующую акцию нельзя удалить, а также нельзя добавлять/изменять/удалять ее условия проведения.


Группы VIP/Ветвь Акции/Меню Условия(офис)

Условия

Используется для работы с условиями предоставления скидок по скидочным акциям в каталоге групп VIP клиентов или в классификаторе акций групп VIP и содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить


Группы VIP/Ветвь Акции/Меню Условия/Добавить(офис)

Добавить

В каталоге групп VIP функция доступна пользователям с правом на изменение групп VIP и активна для акций со статусом новая, имеющих белый цвет фона.

В классификаторе акций групп VIP функция доступна пользователям с правом на изменение акций групп VIP для акций со статусом новая.

Для добавления условия по скидочной акции необходимо заполнить форму для описания нового условия, содержащую следующие поля:

  • Аналитический тип
  • Прочие
  • Скидка
  • С суммы

В списке условий не должно быть строк с таким же значением набора полей Аналитический тип + Прочие товары + С суммы, как в создаваемом условии.

Если новое условие было создано в каталоге групп VIP , то в описании группы VIP и в описании скидочной акции обновляются Дата/Время последней корректировки.

Если новое условие было создано в классификаторе акций групп VIP , то Дата/время последней корректировки обновляется в описании скидочной акции классификатора акций групп VIP , а также в описании данной акции в каталоге групп VIP для каждой из групп VIP, перечисленных на доп. вкладке группы VIP .


Группы VIP/Ветвь Акции/Меню Условия/Изменить(офис)

Изменить

В каталоге групп VIP функция доступна пользователям с правом на изменение групп VIP и активна для акций со статусом новая, имеющих белый цвет фона.

В классификаторе акций групп VIP функция доступна пользователям с правом на изменение акций групп VIP для акций со статусом новая.

Для изменения описания условия по скидочной акции необходимо отредактировать форму описания условия, содержащую следующие поля:

  • Аналитический тип
  • Прочие
  • Скидка
  • С суммы

В списке условий не должно быть строк с таким же значением набора полей Аналитический тип + Прочие товары + С суммы, как в корректируемом условии.

Если условие корректировалось в каталоге групп VIP , то в описании группы VIP и в описании скидочной акции обновляются Дата/Время последней корректировки.

Если условие корректировалось в классификаторе акций групп VIP , то Дата/время последней корректировки обновляется в описании скидочной акции классификатора акций групп VIP , а также в описании данной акции в каталоге групп VIP для каждой из групп VIP, перечисленных на доп. вкладке группы VIP .


Группы VIP/Ветвь Акции/Меню Условия/Удалить(офис)

Удалить

В каталоге групп VIP функция доступна пользователям с правом на изменение групп VIP и активна для акций со статусом новая, имеющих белый цвет фона.

В классификаторе акций групп VIP функция доступна пользователям с правом на изменение акций групп VIP для акций со статусом новая.

Если условие удалялось в каталоге групп VIP , то в описании соответствующей группы VIP и в описании скидочной акции обновляются Дата/Время последней корректировки.

Если условие удалялось в классификаторе акций групп VIP , то Дата/время последней корректировки обновляется в описании скидочной акции классификатора акций групп VIP , а также в описании данной акции в каталоге групп VIP для каждой из групп VIP, перечисленных на доп. вкладке группы VIP .


Поля описания условия скидочной акции(справка)(офис)

Поля описания условия скидочной акции

Для описания условия скидочной акции для группы VIP клиентов необходимо заполнить следующие поля:

  • Аналитический тип
  • Прочие
  • Скидка
  • С суммы


Меню Условия/Аналитический тип(офис)

Аналитический тип

Код аналитического типа товаров, для которого описывается условие по скидочной акции. В списке условий не должно быть условий для товаров одного и того же аналитического типа. Поле закрыто от корректировки, если включен параметр прочие .


Меню Условия/Прочие(офис)

Прочие

Если параметр включен, то условие применяется для товаров в том случае, если их аналитический тип не подходит под другие условия акции. При включении параметра поле аналитический тип автоматически очищается и закрывается от корректировки.


Меню Условия/Скидка(офис)

Скидка

Размер скидки на товары, обладающие заданным аналитическим типом. Допускается нулевое значение скидки.


Меню Условия/С суммы(офис)

С суммы

Порог общей суммы покупок, совершенных за время действия акции, после достижения которого предоставляется скидка по данному условию. Допускается нулевое значение суммы.


Параметры описания магазина/Архив(офис)

Архив

Используется для переноса магазина в архив и активен только при корректировке описания магазина. Если магазин архивный, то для него выполняются следующие правила:

  • отменяется условие: если текущая дата на компьютере, где ведется БД клиентов, больше, чем «Дата файла импорта», и (текущее время - «Время Ч») больше 60 мин, то строка магазина в списке высвечивается жирным красным шрифтом.
  • при проведении процедуры экспорта/импорта информации он не отображается в списке магазинов, открывающемся при вызове пунктов меню Экспорт обновлений в магазины и Импорт информации из магазинов.
  • при проведении процедуры экспорта/импорта информации он не обрабатывается, и данные для него не экспортируются при вызове пункта меню Импорт-экспорт новой информации. Информация об этом записывается в протокол экспорта данных .


Меню Магазины сети/Архив(офис)

Показывать архивные магазины/Не показывать архивные магазины

Функция доступна пользователям с правом на просмотр магазинов сети и позволяет переключаться между режимами просмотра списка всех магазинов и списка без архивных магазинов. Список по умолчанию высвечивается без архивных магазинов. При выборе пункта меню Показывать архивные магазины на экране отображается список всех магазинов сети. При повторном выборе данного пункта меню на экране отображается список только тех магазинов, в описании которых параметр Архив отключен.


Акции групп VIP/Вкладка Группы VIP(офис)

Группы VIP

Вкладка содержит список групп VIP клиентов, на которые распространяется действие скидочной акции. Работа на вкладке ведется с помощью меню Группы VIP . Записи упорядочены по кодам групп VIP в порядке возрастания. В списке групп VIP работает сортировка по любому столбцу вкладки и фильтр по отмеченным/отобранным позициям.

Список представлен в виде таблицы со следующими колонками:

  • Код - уникальный код группы VIP.
  • Наименование - наименование группы VIP.
  • Статус - статус группы VIP.


Акции групп VIP/Вкладка Условия предоставления скидок(офис)

Условия предоставления скидок

Вкладка содержит список условий предоставления скидок по акции. Работа на вкладке ведется при помощи меню Условия .

Список представлен в виде таблицы с графами:

  • Аналитический тип - код аналитического типа товаров.
  • С суммы - общая сумма покупок за период действия акции, после достижения которой предоставляется скидка по условию. Столбец отображается, если включен параметр настройки системы пороги скидок для групп VIP .
  • Скидка - размер скидки на товары, обладающие указанным аналитическим типом.

Список упорядочен по значению столбца Аналитический тип, а в рамках одного аналитического типа по возрастанию значений столбца С суммы. В списке условий предоставления скидок работает сортировка по любому столбцу.


Акции групп VIP/Меню Группы VIP(офис)

Группы VIP

Раздел доступен пользователям с правом на просмотр акций групп VIP и используется для работы со списком групп VIP клиентов, на которые распространяется действие акции. Меню содержит следующие пункты:

  • Добавить
  • Скопировать
  • Удалить
  • Спозиционироваться в дереве
  • Поиск
  • Снять все отметки
  • Отметить все


Акции групп VIP/Меню Группы VIP/Добавить(офис)

Добавить

Функция доступна пользователям с правом на изменение акций групп VIP и правом на изменение групп VIP, и используется для добавления одной или нескольких групп VIP в список групп, на которые распространяется действие акции.

При вызове функции на экран отобразится окно с каталогом групп VIP, в котором допускается проставление и снятие отметок в списке групп VIP. В каталоге групп VIP доступны все операции по созданию/корректировке групп VIP в соответствии с правами пользователя, а также операция отбора групп по набору критериев. Окно каталога также содержит кнопки (Выбрать) и (Отказаться). Нажатие (Выбрать) приводит к сохранению отмеченных позиций списка на доп. вкладку Группы VIP соответствующей акции. При этом для каждой вновь добавленной группы VIP выполняется следующая проверка:

§ Период действия акции, в список групп VIP которой добавляется данная группа, не должен пересекаться с периодами действий прочих акций, перечисленных в ветви Акции у данной группы в каталоге групп VIP.

Т.е. акция может быть применена к группам, если в период действия данной акции в этих группах не действуют другие акции.

Для каждой из групп VIP, добавленных к акции, в каталоге групп VIP данная акция отображается в ветви Акции данной группы и в соответствующей строке поле Суммы по картам пересчитаны на дату очищается.


Акции групп VIP/Меню Группы VIP/Скопировать(офис)

Скопировать

Функция доступна пользователям с правом на изменение акций групп VIP и правом на изменение групп VIP и используется для копирования списка групп VIP у другой акции.

При вызове функции на экран отобразится окно со списком акций групп VIP. Для каждой соответствующей группы VIP выполняется следующая проверка:

§ Период действия акции, в список групп VIP которой добавляется данная группа, не должен пересекаться с периодами действий прочих акций, перечисленных в ветви Акции у данной группы в каталоге групп VIP.

Т.е. акция может быть применена к группам, если в период действия данной акции в этих группах не действуют другие акции.

Для каждой из групп VIP, добавленных к акции, в каталоге групп VIP данная акция отображается в ветви Акции данной группы и в соответствующей строке поле Суммы по картам пересчитаны на дату очищается.


Акции групп VIP/Меню Группы VIP/Удалить(офис)

Удалить

Функция доступна пользователям с правом на изменение акций групп VIP и правом на изменение групп VIP, и используется для удаления одной или нескольких групп VIP из список групп, на которые распространяется действие акции.

Для удаляемых групп VIP соответствующая акция удаляется из списка акций данной группы в каталоге групп VIP. Если операция вызвана по списку отмеченных позиций, то она выполняется для каждой из отмеченных VIP групп.


Акции групп VIP/Меню Группы VIP/Спозиционироваться в дереве(офис)

Спозиционироваться в дереве

Функция доступна пользователям с правом на просмотр групп VIP и позволяет перейти в окно каталога групп VIP на позицию с описанием соответствующей группы VIP.


Акции групп VIP/Меню Группы VIP/Поиск(офис)

Поиск

Используется для проведения отбора по набору критериев групп VIP в каталоге групп VIP и в классификаторе акций групп VIP на доп. вкладке Группы VIP .

Для проведения поиска нужно задать условия поиска групп VIP и кликнуть на кнопке (Отобрать).

Если поиск проводится в каталоге групп VIP , то результаты поиска отображаются в ветви .

Если поиск проводится в классификаторе акций групп VIP , то результаты поиска отображаются доп. вкладке Группы VIP в режиме фильтрации "Результаты поиска".


Акции групп VIP/Меню Группы VIP/Поиск/Параметры поиска(офис)

Условия поиска и отбора групп VIP клиентов

К условиям поиска групп VIP относятся:

  • Наименование
  • Полное наименование
  • Статус
  • Регион


Меню Группы VIP/Поиск/Параметры поиска/Наименование(офис)

Наименование

Наименование группы VIP. Задается полностью или в виде шаблона .


Меню Группы VIP/Поиск/Параметры поиска/Полное наименование(офис)

Полное наименование

Полное наименование группы VIP. Задается полностью или в виде шаблона .


Меню Группы VIP/Поиск/Параметры поиска/Статус(офис)

Статус

Статус группы VIP. Может принимать значения: новая, активная, архивная. Если все флажки отключены, то параметр не накладывает ограничений на значение статуса искомых групп. В случае включения нескольких флажков результатами поиска будут группы VIP, имеющие один из указанных статусов.


Меню Группы VIP/Поиск/Параметры поиска/Регион(офис)

Регион

Регион расположения группы VIP клиентов. Если для отбора задано несколько регионов, то результом поиска будут группы VIP, в описании которых есть один из указанных регионов. Если включен параметр «не заполнен», то результом поиска будут группы VIP, в описании которых регион не указан.


Акции групп VIP/Меню Группы VIP/Отметить все(офис)

Отметить все

Используется для проставления отметок для всех позиций списка доп. вкладки Группы VIP .


С чего начать работу/Создать новую базу данных

Создать новую базу данных

Чтобы создать новую базу данных, нужно в главном меню выбрать пункт Файл/Создать новую (пустую БД) .

Прежде чем начать работать с новой базой данных, нужно:

  • Произвести настройку параметров
  • Установить пароль для открытия базы данных


С чего начать работу/Заполнить классификатор кассовых мест

Заполнить классификатор кассовых мест

В данном разделе магазины можно добавлять, корректировать и удалять при помощи меню Кассовые места , а для печати выходных форм использовать меню Формы .

На экране отображается окно, представленное в виде списка с графами:

  • Идентификатор - идентификатор кассового места в магазине.
  • Файл импорта - полный путь к файлу, из которого считывается информация о покупках покупателей, сделанных через данную кассу.
  • Последняя покупка - дата и время последней покупки, успешно считанной из файла импорта данной кассы. Поле заполняется автоматически после успешного импорта информации от кассы. Доступ к полю имеют только пользователи с правами администратора.


Открыть базу данных

Чтобы открыть базу данных, нужно в Главном меню выбрать пункт Файл/Открыть.. .


С чего начать работу/Заполнить классификатор магазинов сети

Заполнить классификатор магазинов сети

В данном разделе магазины можно добавлять, корректировать и удалять при помощи меню Магазины сети , а для печати выходных форм использовать меню Формы .

На экране отображается окно, представленное в виде списка с графами:

  • Код - вводится код магазина
  • Название - вводится название магазина
  • Файл для импорта - полный путь к файлу, из которого берется информация, полученная из магазина. Заполняется оператором, поле обязательно для заполнения.
  • Последний экспорт - заполняется автоматически в результате обмена данными между центральным офисом и текущим магазином
  • Последний импорт - заполняется автоматически в результате обмена данными между центральным офисом и текущим магазином


Как установить пароль

Чтобы установить пароль для открытия определенной базы данных, нужно:

  • Открыть базу данных
  • Выбрать раздел Настройка/Пароль системы .

При вводе пароль отображается в виде звездочек (*). Чтобы увидеть введенное значение, нужно кликнуть мышкой на иконке "Очки" или нажать Ctrl+Tab.


Рабочая станция/Шрифт для отображения на экране

Шрифт для отображения на экране

В параметре задается шрифт, в котором отображается вся информация на экране. Справа расположена кнопка (Изменить), позволяющая вызвать диалог выбора шрифта.


Рабочая станция/Настройка печати

Настройка печати

В данном пункте задаются настройки для печати отчетов на принтере и для экспорта файлов.

Настройка печати производится на следующих вкладках:

  • Общие
  • Страница
  • Автосохранение
  • RTF
  • HTML
  • EXCEL
  • Текстовый файл


Рабочая станция/При старте автоматически подключаться к базе данных

При старте автоматически подключаться к базе данных

Используется для задания базы данных, которая будет автоматически вызываться при запуске системы. В поле отображается полный путь к базе данных. Справа расположена кнопка (Изменить), позволяющая открыть стандартный каталог Windows для выбора файла базы данных с расширением .dbx.


Рабочая станция/Открывать последнюю базу данных

Открывать последнюю базу данных

Используется для автоматического открытия последней базы данных, с которой осуществлялась работа в течение предыдущего сеанса.


Рабочая станция/После подключения базы данных открывать пункт меню

После подключения базы данных открывать пункт меню

Используется для задания раздела системы, который будет открываться на экране после подключения к базе данных. Раздел выбирается из следующего списка:

  • не указано
  • каталог покупателей
  • каталог групп VIP
  • классификатор таблиц скидок
  • классификатор магазинов сети
  • классификатор регионов


Рабочая станция/Другие параметры

Другие параметры

  • Показывать разделительные полосы - при включенном параметре в списке карточек покупателей строки разделяются горизонтальными линиями.
  • Использовать картинки в меню и списках - при включенном параметре при вызове пунктов главного меню в системе отображаются изображения, соответствующие некоторым пунктам.
  • При вызове окон показывать максимизированными: окна с основными списками/окна с основными карточками - при включенных параметрах окна со списками и карточками, соответственно, открываются с максимально возможным размером. Параметр отключен и закрыт от корректировки, если включен параметр Сохранять положение и размеры окон.
  • Сохранять положение и размеры окон - при включенном параметре положение и размеры окон будут сохранены при следующем подключении к системе с данной рабочей станции. Параметр отключен и закрыт от корректировки, если включен параметр При вызове окон показывать максимизированными.
  • Включить панели инструментов - при включеннном параметре в системе отображаются иконки, соответствующие основным разделам системы.
  • При старте выводить окно Wizard'a - при включенном параметре каждый раз при вызове программы отображается окно Wizard'a, в котором выбирается база данных для открытия.
  • Показывать результаты поиска сразу - при включенном параметре после завершения процедуры поиска пользователь немедленно перенаправляется в список с отобранными записями. Если же параметр отключен, то перед переходом в данный список пользователь должен закрыть окно с кратким отчетом о ходе процедуры поиска (время, количество отобранных и просмотренных записей и т.п.), нажав в нем кнопку (Закрыть).
  • Спрятать заголовок главной формы - при включенном параметре в системе отображается заголовочная строка с названием фирмы, имя базы данных и версия программы.
  • Картинки на вкладках - при включенном параметре на вкладках карточки покупателя указываются соответствующие пиктограммы (если они имеются).
  • Показывать горячие клавиши на вкладках - при включенном параметре на вкладках карточки покупателя указываются соответствующие клавиши.
  • Отключить режим drag&drop - при включенном параметре в дереве групп товаров нельзя переносить группы и подгруппы с помощью мышки.
  • Запрашивать имя файла при экспорте списков в Excel - при включенном параметре при экспорте списков в Excel отображается окно, содержащее стандартный каталог Windows для задания имени файла экспорта. По умолчанию предлагается название из заголовочной строки экспортируемого списка.


Рабочая станция/Настраиваемые формы брать из папки

Настраиваемые формы брать из папки

Пользователь с правами администратора имеет возможность создать собственную папку для отчетов (*.frm файлы), указав полный путь к ней в данном поле, например C:\SLS-Discount\Reports\User1. При подключении пользователя-администратора к базе данных все дополнительные формы будут по умолчанию браться из указанной папки.

Для пользователей системы, не имеющих права администратора, настраиваемые формы всегда берутся и папки forms, которая размещена в директории, где установлена программа.


Рабочая станция/Количество недавно открытых файлов

Количество недавно открытых файлов

Используется для установки количества файлов, соответствующих базам данных, с которыми осуществлялась работа в течение предыдущих сеансов. Список последних открытых файлов отображается в меню Файл после пункта Калькулятор.


Общие/Заголовок выходной формы на экране

Заголовок выходной формы на экране

Используется для выделения заголовка отчета при его выводе на экран. Параметр может принимать одно из нескольких значений:

  • Нормальный - без выделения.
  • Жирный
  • Курсив
  • Жирный курсив


Общие/Выделение цветом

Выделение цветом

Позволяет установить цвет заголовка при печати выходной формы на экране.


Общие/Заголовок выходной формы при печати

Заголовок выходной формы при печати

Используется для выделения заголовка отчета при его печати на принтере. Параметр может принимать одно из нескольких значений:

  • Нормальный
  • Жирный
  • Курсив
  • Жирный курсив


Страница/Положение и вид номера страницы

Положение и вид номера страницы

В параметре выбирается место размещения на листе номера страницы и один из предлагаемых видов номера страницы.

Чтобы отменить печать номера страницы, нужно включить параметр "Не печатать номера страниц".


Страница/Разбивать листы в ширину по границам колонок

Разбивать листы в ширину по границам колонок

При печати отчета на принтер, если выходная форма не умещается по ширине на лист бумаги, она будет распечатана на нескольких листах.

Если параметр включен, то колонка, которая полностью не умещается на листе, будет напечатана на следующем листе.

Если параметр отключен, часть колонки будет напечатана на одном листе, а часть - на другом.


Страница/Автоматически сжимать форму по ширине

Автоматически сжимать форму по ширине

  • Автоматически сжимать форму по ширине до одного листа - если параметр включен, то для отчета, который по ширине не умещается на листе бумаги, автоматически может быть изменен шрифт, размеры колонок и др.
  • Автоматически сжимать форму по ширине в пределах 1/2 листа - если параметр включен, то для отчетов, которые занимают меньше страницы, автоматически могут быть изменены шрифт, размеры колонок и пр.

Если параметр отключен, то широкие отчеты не сжимаются.


Общие/Открывать все формы в одном окне

Открывать все формы в одном окне

Параметр устанавливается либо в настройках рабочей станции (см. параметры печати выходных форм), либо непосредственно в созданной печатной форме документа, отчета, справки и т.д. (в параметрах по умолчанию Ctrl+F2), и позволяет, находясь в печатной форме, открывать любые сохраненные на диске формы для печати в одном окне.


Меню Формы(офис)

Формы

Специально для системы SLS-Дисконт разработан язык программирования SLS-Report , предназначенный для создания дополнительных выходных форм - различных отчетов, актов, справок и т.д. на основании информации из БД системы SLS-Дисконт.

Для создания файлов дополнительных выходных форм с помощью языка SLS-Report, используется редактор программ Far, Norton Commander и т.д., а также более мощный текстовый редактор Office Editor, бесплатно предоставляемый компанией SoftLand Systems.

Файлы, созданные с использованием языка, должны иметь расширение *.frm.

Одна из особенностей языка SLS-Report - контекстная зависимость переменных. Все внутренние переменные, доступные пользователю, разбиты на условные группы - контексты, которые соответствуют определенным разделам системы SLS-Дисконт. К примеру, контекст «карточка покупателя» объединяет все данные по отдельно взятому покупателю и т.д.

В соответствии с контекстом, дополнительные формы могут быть распечатаны из следующих разделов системы SLS-Дисконт для Windows:

  • Карточки покупателей
  • Таблицы скидок
  • Магазины сети

Для того, чтобы прикрепить описание дополнительной формы к одному из выше описанных разделов необходимо перейти в этот раздел и выбрать раздел Формы/Настройка форм .

Внимание: контекст дополнительной формы должен соответствовать выбранному разделу (описание контекстов см. в файле документации SLS-Report.doc).

Теперь, если в соответствующем разделе системы SLS-Дисконт войти в меню Формы, либо нажать Ctrl+P (Печать), то среди прочих форм появится название дополнительной формы.


Меню Формы(маг)

Формы

Специально для системы SLS-Дисконт разработан язык программирования SLS-Report , предназначенный для создания дополнительных выходных форм - различных отчетов, актов, справок и т.д. на основании информации из БД системы SLS-Дисконт.

Для создания файлов дополнительных выходных форм с помощью языка SLS-Report, используется редактор программ Far, Norton Commander и т.д., а также более мощный текстовый редактор Office Editor, бесплатно предоставляемый компанией SoftLand Systems.

Файлы, созданные с использованием языка, должны иметь расширение *.frm.

Одна из особенностей языка SLS-Report - контекстная зависимость переменных. Все внутренние переменные, доступные пользователю, разбиты на условные группы - контексты, которые соответствуют определенным разделам системы SLS-Дисконт. К примеру, контекст «карточка покупателя» объединяет все данные по отдельно взятому покупателю и т.д.

В соответствии с контекстом, дополнительные формы могут быть распечатаны из следующих разделов системы SLS-Дисконт для Windows:

  • Карточки покупателей
  • Таблицы скидок
  • Кассовые места

Для того, чтобы прикрепить описание дополнительной формы к одному из выше описанных разделов необходимо перейти в этот раздел и выбрать раздел Формы/Настройка форм .

Внимание: контекст дополнительной формы должен соответствовать выбранному разделу (описание контекстов см. в файле документации SLS-Report.doc).

Теперь, если в соответствующем разделе системы SLS-Дисконт войти в меню Формы, либо нажать Ctrl+P (Печать), то среди прочих форм появится название дополнительной формы.


Карточки покупателей/Формы

Карточки покупателей

Раздел содержит список дополнительных форм, созданных в контексте "Карточка покупателя". Для того чтобы добавить, изменить или удалить описание формы, воспользуйтесь пунктом меню Формы .

Любую форму из данного списка можно получить (распечатать) внутри карточки покупателя, воспользовавшись разделами "Формы" или "Печать" (Ctrl+P).


Таблицы скидок/Формы

Таблицы скидок

Раздел содержит список дополнительных форм, созданных в контексте "Таблицы скидок". Для того чтобы добавить, изменить или удалить описание формы используется пункт меню Формы .

Любую форму из данного списка можно получить (распечатать) внутри карточки товара, воспользовавшись разделами "Формы" или "Печать" (Ctrl+P).


Магазины сети/Формы

Магазины сети

Раздел содержит список дополнительных форм, созданных в контексте "Магазины сети". Для того чтобы добавить, изменить или удалить описание формы, воспользуйтесь пунктом меню Формы .

Любую форму из данного списка можно получить (распечатать) внутри карточки товара, воспользовавшись разделами "Формы" или "Печать" (Ctrl+P).


Кассовые места/Формы

Кассовые места

Раздел содержит список дополнительных форм, созданных в контексте "Кассовые места". Для того чтобы добавить, изменить или удалить описание формы, воспользуйтесь пунктом меню Формы .

Любую форму из данного списка можно получить (распечатать) внутри карточки товара, воспользовавшись разделами "Формы" или "Печать" (Ctrl+P).


Меню Формы/Настройка форм(Справка)

Формы

Используется для присоединения, изменения и удаления описания дополнительной формы в определенном разделе системы.

1. Выберите раздел программы SLS-Дисконт, к которому вы хотите прикрепить настраиваемую форму (файл *.frm).

2. Воспользуйтесь разделом Формы/Настройка форм в выбранном разделе программы.

Меню содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить


Меню Формы/Настройка форм/Формы/Добавить(Справка)

Добавить

Используется для присоединения дополнительной формы к определенному разделу системы. Описание дополнительной формы содержит следующие поля:

  • Название формы - под этим названием отчет будет предлагаться пользователю в меню "Формы".
  • Файл - имя текстового файла с описанием формы. Файл должен иметь расширение *.frm и лежать в настраиваемой папке для отчетов - см. настройки рабочей станции в программе SLS-Дисконт.

После добавления описания настраиваемой формы в соответствующий раздел программы, название данной формы появится в меню "Формы" данного раздела.


Меню Формы/Настройка форм/Формы/Изменить(Справка)

Изменить

Чтобы изменить название дополнительной формы или прикрепить другой файл описания *.frm, необходимо откорректировать следующие поля:

  • Название формы
  • Файл


Меню Формы/Настройка форм/Формы/Удалить

Удалить

Используется для удаления описания дополнительной формы из списка.


Настройка форм/Формы/Добавить/Название формы

Название формы

Название - название дополнительной формы, удобное пользователю, которое будет выводиться в меню "Формы".


Настройка форм/Формы/Добавить/Файл

Файл

Файл - имя текстового файла с описанием формы. Файл должен иметь расширение *.frm и лежать в настраиваемой папке для отчетов - см. настройки рабочей станции в программе SLS-Дисконт.


Настройка отчетов с помощью языка SLS-Report

Разработанный компанией SoftLand Systems язык программирования SLS-Report, предназначен для создания внешних (дополнительных) выходных форм на основе имеющейся информации из баз данных системы SLS-Дисконт (Магазин, Офис).

Поддержка и развитие языка SLS-Report обусловлены необходимостью иметь возможность дополнительной настройки различных справок и отчетов в SLS-программах с учетом специфики деятельности отдельно взятого предприятия. Наличие такого инструмента как SLS-Report намного эффективнее, чем программирование форм на заказ, поскольку оно дает пользователю возможность самостоятельно настраивать нужные формы, независимо от производителя программного продукта.

Для создания файлов дополнительных выходных форм с помощью языка SLS-Report, используйте любой текстовый редактор, поддерживающий кодировку ASCII. Файл с описанием формы должен иметь расширение *.frm и размещаться в папке forms, которая, в свою очередь, находится в директории, где установлена программа SLS-Дисконт. Вы также можете использовать текстовый редактор Office Editor, разработанный специалистами компании SoftLand Systems. Текстовый редактор Office Editor вы можете бесплатно скачать на сайте компании SoftLand Systems www.sls.ru .

Полное описание языка SLS-Report к программе SLS-Дисконт находится в файлах SLSReportDiscount.doc и SLSReportPartI.doc, которые размещены в папке, где установлена программа.

Для добавления формы в список настраиваемых форм:

  • Выберите раздел программы SLS-Дисконт, к которому вы хотите прикрепить настраиваемую форму (файл *.frm).
  • Воспользуйтесь пунктом Формы/Настройка форм в выбранном разделе программы. Меню содержит следующие пункты:

Добавить

Изменить

Удалить

  • Добавьте описание дополнительной формы. Описание дополнительной формы содержит следующие поля:

Название формы - под этим названием отчет будет предлагаться пользователю в меню «Формы».

Файл - имя текстового файла с описанием формы. Файл должен иметь расширение *.frm и лежать в настраиваемой папке для отчетов - см. настройки рабочей станции в программе SLS-Дисконт.

  • После добавления описания настраиваемой формы в соответствующий раздел программы, название данной формы появится в меню "Формы" данного раздела.


Рабочая станция/Настройка печати/общие

Общие

Вкладка содержит общие параметры печати выходных форм. К ним относятся:

  • Заголовок выходной формы на экране
  • Выделение цветом
  • Заголовок выходной формы при печати
  • Полный заголовок на всех листах
  • Межстрочный интервал
  • Печать в несколько колонок
  • При сохранении файлов печати на диск предлагать длинные имена
  • Открывать все формы в одном окне


Рабочая станция/Настройка печати/Автосохранение

Автосохранение

Вкладка содержит параметры автосохранения:

  • Автоматически сохранять новые формы после их создания
  • Директория, в которой сохраняются формы


Рабочая станция/Настройка печати/RTF

RTF

Вкладка содержит параметры экспорта в формате Excel:

  • Директория, куда экспортировать файлы
  • Выбирать директорию перед экспортом
  • Показывать результат после экспорта
  • Шрифт фиксированного размера


Рабочая станция/Настройка печати/HTML

HTML

Вкладка содержит параметры экспорта в формате Excel:

  • Директория, куда экспортировать файлы
  • Выбирать директорию перед экспортом
  • Показывать результат после экспорта
  • Разбивать таблицы по
  • Стилевой файл
  • Файл, вставляемый ...


Рабочая станция/Настройка печати/EXCEL

EXCEL

Вкладка содержит параметры экспорта в формате Excel:

  • Директория, куда экспортировать файлы
  • Выбирать директорию перед экспортом
  • Показывать результат после экспорта
  • Шрифт фиксированного размера
  • При старте автоматически подключаться к базе данных
  • Открывать последнюю базу данных
  • Количество недавно открытых файлов


Рабочая станция/Настройка печати/Текстовый файл

Текстовый файл

Вкладка содержит параметры печати текстового файла:

  • Директория, куда экспортировать файлы
  • Выбирать директорию перед экспортом
  • Кодировка
  • Символ-разделитель
  • Ограничитель строк


Общие/Полный заголовок на всех листах

Полный заголовок на всех листах

Если параметр включен, то на каждом листе будет печататься полный заголовок выходной формы.


Общие/Межстрочный интервал

Межстрочный интервал

Используется для определения следующей величины: сколько в процентном отношении составляет высота горизонтальных линий от высоты строки. Параметр может принимать значения в интервале от 10 до 100%. 10% - минимальный межстрочный интервал. 100% - максимальный межстрочный интервал.


Общие/При сохранении файлов печати на диск предлагать длинные имена

При сохранении файлов печати на диск предлагать длинные имена

Если параметр включен, то при сохранении файла предлагается имя, включающее номер, дату документа и наименование контрагента. Если параметр отключен, то при сохранении предлагается имя вида "sprxxxx", где хххх - порядковый номер.


Рабочая станция/Настройка печати/Страница

Страница

Вкладка содержит параметры страницы для печати:

  • Размер левого, правого, верхнего, нижнего поля листа в сантиметрах
  • Печать вертикально/горизонтально
  • Шрифт
  • Разбивать листы в ширину по границам колонок
  • Автоматически сжимать форму по ширине
  • Если возможно, печатать два экземпляра на лист
  • Положение номера страницы
  • Вид номера страницы


Страница/Лист вертикально/горизонтально

Лист вертикально/горизонтально

Используется для задания положения листа.


Страница/Размер полей листа

Размер полей листа

Используется для задания размер полей в сантиметрах.


Страница/Шрифт

Шрифт

Используется для выбора шрифта печати текста. При нажатии на кнопку "..." появляется окно, в котором выбираются шрифт, начертание и размер.


Общие/Печатать в несколько колонок

Печатать в несколько колонок

  • Количество колонок - задается "по описанию" или от 1 до 9
  • Интервал между колонками - задается от 0 до 9


Страница/Если возможно, печатать два экземпляра на лист

Если возможно, печатать два экземпляра на лист

Если параметр включен, то будут печататься два экземпляра на одном листе.


Автосохранение/Автоматически сохранять новые формы после их создания

Автоматически сохранять новые формы после их создания

Если параметр включен, то новые формы автоматически сохраняются на диске.


Автосохранение/Директория, в которой сохраняются формы

Директория, в которой сохраняются формы

Используется для задания директории, в которую будут сохраняться выходные формы. Для выбора нужно кликнуть на кнопке (Обзор), войти в директорию и указать любой файл из нее.


RTF/Директория, куда экспортировать файлы

Директория, куда экспортировать файлы

Используется для задания директории, в которую будут экспортироваться файлы. Нужно кликнуть на кнопку (Обзор) и выбрать директорию и любой файл из нее.


RTF/Выбирать директорию перед экспортом

Выбирать директорию перед экспортом

Если параметр включен, то перед экспортом файла будет предлагаться выбрать директорию.


RTF/Показывать результат после экспорта

Показывать результат после экспорта

Если параметр включен, то на экран выводится содержимое файла экспорта.


RTF/Шрифт фиксированного размера

Шрифт фиксированного размера

Выбирается шрифт, начертание и размер для печати в файле экспорта.


HTML/Разбивать таблицы по

Разбивать таблицы по...строк на страницу

Если указано 0, то вся таблица печатается на одной странице.


HTML/Стилевой файл

Стилевой файл

Полный путь и имя стилевого файла.


HTML/Файл, вставляемый ...

Файл, вставляемый ...

Имена соответствующих файлов. Для выбора нужно кликнуть на кнопку (Обзор).


EXCEL/Результат экспорта - книга Excel

Результат экспорта - книга Excel

Если параметр включен, то результатом экспорта будет файл Excel. Если параметр отключен, то результатом экспорта будет текстовый файл с разделителями.


EXCEL/Передавать в Excel картинки

Передавать в Excel картинки, начертание шрифтов, объединять ячейки

Параметр включается для передачи картинок, шрифтов, объединения ячеек.


EXCEL/Перенос по словам длинных строк в ячейках

Перенос по словам длинных строк в ячейках

Если параметр отключен, то содержимое ячейки будет печататься в одну строку.


Текстовый файл/Кодировка

Кодировка

Выбирается один из трех вариантов кодировки:

  • Windows
  • DOS
  • Unicode


Текстовый файл/Ограничитель строк

Ограничитель строк

Выбирается ограничитель строк. Напротив выбранного значения нужно установить галочку.


Текстовый файл/Символ-разделитель

Символ-разделитель

Выбирается один из предлагаемых симоволов-разделителей. Напротив выбранного значения нужно установить галочку.