Назначение программы

Программа Сервер приложений предназначена для обеспечения совместной работы сетевых приложений фирмы СофтЛенд Системз с базами данных.

Для работы программы "Сервер приложений" настоятельно рекомендуется использовать Windows NT Server 4.0 с сервис-паком не ниже 4, Windows 2000, Windows 2003 или Windows XP с соответствующими сервис-паками. При использовании Windows 95/98/Me возможна неустойчивая работа сети, причем зависит это не от версии Windows, а от конкретного экземпляра.

Для удаленного управления Сервером приложений может использоваться вспомогательная программа Монитор .

Сервер приложений должен быть запущен в течение всего времени работы прикладных программ. Для этого можно включить его в Startup или вызывать вручную перед запуском основных программ.

Поскольку программа "Сервер приложений" обычно обслуживает не одного пользователя, то не рекомендуется запускать на том компьютере, где она работает, ресурсоемкие приложения - скринсэйверы, игры, процедуры дефрагментации дисков и т.п. В противном случае скорость обслуживания остальных клиентов может сильно упасть.

После установки Сервера приложений требуется произвести его настройку и сохранить ее . При последующих вызовах Сервера приложений он будет использовать сохраненные настройки. В любой момент можно изменить введенные настройки. В тех случаях, когда для учета изменений надо перезапустить программу, выдается соответствующее сообщение.

Сервер приложений может запускаться как обычная задача и в "невидимом" режиме, в том числе и до подключения пользователя к Windows. Подробнее см. в "Специальные варианты запуска".


Первоначальная настройка

Перед тем, как начать использовать программу Сервер приложений, надо выполнить ее первоначальную настройку. Для этого надо:

1. Запустить программу Сервер приложений.

2. Подключить к серверу приложений хотя бы одну базу данных. См. Меню "Файл" Добавить базу данных .

3. Выбрать сетевой протокол для работы. Остальные параметры можно оставить без изменений и настроить их при необходимости потом . См. Установка параметров работы

4. Запомнить установки. См. Меню "Настройка" Сохранить конфигурацию

5. Можно поправить настройку копирования баз данных (см. Меню "Настройка" ), хотя по умолчанию копирование настроено достаточно разумно.


Информация на экране

Окно программы Сервер приложений разделено на три части (в программе Монитор каждая из этих частей соответствует отдельному окну):

1. В правой части экрана (в программе Монитор - закладка "Общая") находится Состояние сервера

  • Слева от "Состояние сервера" находится индикатор работы пользователей. Если он зеленого цвета, то все в порядке. Изменение цвета на желтый или красный служит индикатором задержек обслуживания. Более подробно см. "Анализ очереди".
  • "Адрес IPX (NetBIOS или IP)" - сетевой адрес задачи Сервера приложений. Если разрешена одновременная работа на нескольких протоколах, то справа от адреса находится переключатель отображаемого адреса.
  • "Кэш кб" - использование внутреннего кэша программы. "Всего" - общий объем, "Занято" - сколько используется в данный момент.
  • "Прочтено из кэш %" - Процент чтений из баз данных, которые были выполнены без обращения к диску.
  • "Запр./сек" - Количество запросов от рабочих станций за последнюю секунду.
  • "Загр. %" - Процент времени, которое сервер приложений тратит на обслуживание запросов прикладных задач.
  • "Буферов приемных" - количество внутренних буферов для получения запросов через сеть. Каждый из буферов предназначен для кратковременного хранения запроса пользователя. "Тек." - текущее количество свободных буферов, "Мин" - минимальное значение, которое было за время работы. Программа автоматически увеличивает количество буферов по мере необходимости. Если сервер приложений работает не на серверной версии WIndows (например Windows 95/98 или NT Workstation), то возможное количество этих буферов ограничено.
  • "Буферов запросов" - количество внутренних буферов для хранения запросов до их полной обработки. "Тек." - текущее количество свободных буферов, "Мин" - минимальное значение, которое было за время работы.
  • "Ошибки в сети" - здесь регистрируются ошибки, зафиксированные оборудованием. При ненулевом значении требуется произвести тестирование оборудования и соединений сети.
  • "Ошибки в блоках" - при передачи запросов по сети каждый из них сопровождается контрольной суммой. Если контрольная сумма запроса отличается от расчетной, то это регистрируется в данном поле. При ненулевом значении следует выполнить тестирование оборудования, соединений сети и памяти компьютера.

"Ошибки связи" - если прикладная программа передала запрос на сервер приложений или сервер приложений ответил на запрос, а соответствующий запрос или ответ не дошел до адресата, то возникает переповтор. В этом поле располагается счетчик таких переповторов. Для того, чтобы получить более подробную информацию о переповторах надо или кликнуть мышкой по этому окну, или выбрать пункт меню "Анализ" "Ошибки связи с пользователями"

2. В левой части экрана (в программе Монитор - закладка "Пользователи и базы") находится список баз данных, подключенных к серверу приложений.

Если с какими то из них в данный момент работают, то ниже базы данных располагается список пользователей этой базы данных.

Для каждого из пользователей отображается название его компьютера или имя (если он уже подключился к базе данных), сетевой адрес и время подключения.

При работе по протоколу IPX сетевой адрес имеет стандартный вид <номер сети> : <номер адаптера> : <номер сокета>.

При работе по NetBIOS сетевой адрес начинается с трех символов (обычно, "CL0"), дальше идет номер адаптера и номер протокола в квадратных скобках. Для пользователей, подключенных через Terminal Service, имя NetBIOS начинается с буквы "T".

Для пользователей, работающих по протоколу UDP/IP, указывается их IP адрес. Если они работают через Terminal Service, то после адреса стоит буква "T" и номер их терминальной сессии.

Если перед именем базы данных находится значок [image] , то при последнем тестировании копии базы данных были ошибки. Дополнительная информация о копировании и тестировании в разделе "Существующие копии баз данных"

3. В нижней части экрана (в программе Монитор - закладка "Детали") находится дополнительная информация для базы данных или пользователя на котором расположен курсор.

Для баз данных это:

  • размер базы данных в килобайтах
  • номер текущей транзакции. Этот номер увеличивается при корректировках содержимого базы данных.
  • Максимальный размер TTS (килобайт). Это максимальный размер файла транзакции, который создается при записи изменений в базу данных для отката к предыдущему состоянию при неуспешном завершении записи.
  • "Монопольное использование" - этот индикатор появляется только если база данных захвачена одной из задач монопольно и подключение к ней других пользователей запрещено.

Для пользователей:

  • "От последнего запроса прошло" - время, прошедшее с момента последнего обращения пользователя к базе данных.
  • Номер текущей транзакции. У пользователей, которые производят запись в базу данных, этот номер на единицу больше номера транзакции базы данных.
  • Состояние пользователя. Может иметь значение "чтение" или "запись". Если поле пустое, то пользователь в данный момент просто смотрит на экран.
  • Захваченные записи. Список адресов записей, которые монопольно заняты данным пользователем. Обычно это документы, которые в данный момент корректируются.

  • Работа с программой осуществляется с помощью верхнего меню (см. "Меню Файл" , "Анализ" , "Действия" и "Настройка" ).

При нажатии правой кнопки мыши в списке баз данных появляется дополнительное меню, которое позволяет перейти в разделы "Анализ очереди" и "Существующие копии баз данных" . Если в момент нажатия правой кнопки курсор мыши указывает на строку с базой данных, то в дополнительном меню активизируется пункт "Скопировать текущую базу данных" .

При интенсивной работе пользователей, работа с меню может идти медленно, поскольку основное время тратится на обслуживание запросов пользователей. В этом случае лучше использовать "горячие клавиши".


Меню "Файл"

  • Добавить базу данных

Служит для добавления к списку обслуживаемых баз новой базы данных. По умолчанию можно одновременно обслуживать до 16 баз данных. При необходимости это количество можно увеличить (см. Установка параметров работы ).

  • Открыть ранее закрытую базу данных

Этот пункт меню позволяет вновь активизировать неактивную базу данных.

  • Скопировать текущую базу данных

Если курсор стоит на базе данных и копирование баз "по запросу" не запрещено, то выбор этого пункта запустит копирование указанной базы. Копирование может начаться не сразу, а через одну-две минуты - в зависимости от установленных режимов копирования.

  • Закрыть текущий объект

При выборе этого пункта меню закрывается (после предупреждения) база данных или пользователь, на котором стоит курсор. База данных закрывается в два этапа. Сначала она делается неактивной (отображается на экране серым цветом), но остается в списке обслуживаемых баз данных. При повторном выборе этого пункта меню она удаляется из списка обслуживаемых баз данных.

  • Найти пользователя

При выборе этого пункта появляется окно со списком активных пользователей, в котором можно найти пользователя по имени или по сетевому адресу.

  • Найти базу данных

При выборе этого пункта появляется окно со списком подключенных к Серверу приложений баз данных, в котором можно найти базу данных по названию или по полному пути к базе данных.

  • Отключить неактивных пользователей

При выборе этого пункта появляется окно, в котором можно установить время, в течении которого от пользователя не поступало запросов. По умолчанию там стоит 20 минут. Если такие пользователи есть, то нажатие кнопки "Отключить" позволит отключить их от сервера приложений.

Если в качестве времени поставить 0, то будут отключены все пользователи, которые работают в данный момент.

  • Перезапустить Сервер приложений

При выборе этого пункта меню работа сервера приложений завершается, а затем он вновь запускается. Это можно использовать после внесения изменений в настройку для того, чтобы эти изменения начали действовать

  • Завершить работу

Завершает работу сервера приложений. См. также Старт и завершение работы


Меню "Анализ"

  • Анализ очереди

Если при работе прикладных программ возникают задержки с обслуживанием, то это может быть связано с тем, что кто-то из пользователей выполняет большие объемы корректировок базы данных. Вызов этого пункта меню позволяет понять кто и почему задерживает обслуживание. Подробнее см. в Анализ очереди

  • Ошибки связи с пользователями

При работе сервера приложений он обменивается с рабочими станциями информацией. При этом может возникать ситуация при которой или запрос от станции не доходит до сервера приложений, или ответ от сервера приложений не доходит до станции. Это вызывает повторные запросы, что уменьшает скорость работы системы. При выборе этого пункта меню Вы получите статистику таких ситуаций по рабочим станциям. В статистике для каждой рабочей станции, которая работала с момента запуска сервера приложений, указывается количество сбоев передачи (Всего), количество сбоев при посылке (WS-->Serv), при передаче (Serv-->WS) и время сбора статистики. Подробнее

  • Статистика работы

При выборе этого пункта меню можно увидеть в графическом режиме распределение памяти в данный момент и загрузку сервера за последние 7 минут. Хотя дополнительная нагрузка на компьютер в режиме просмотра статистики не очень велика, не рекомендуется оставлять этот режим надолго.

  • Статистика работы пользователей.

При выборе этого пункта меню можно увидеть информацию о работе всех подключенных к серверу пользователей за последние 5 минут.Хотя дополнительная нагрузка на компьютер в режиме просмотра этой статистики не очень велика, не рекомендуется оставлять этот режим надолго. Подробнее

  • Просмотреть журнал сообщений сервера

При запуске и выключении программы сервера приложений, а также при возникновении ошибочных ситуаций, информация об этом записывается в специальный журнал (файл Sls_Serv.log, который находится там же, где и сама программа). Данный пункт меню позволяет просмотреть этот журнал.

  • Просмотреть файл ошибок базы данных

При возникновении ошибок при работе пользователей с базами данных информация об этих ошибках пишется в файл <имя базы данных>.err, который находится в той же директории, что и база данных. Когда курсор стоит на имени базы данных, этот пункт меню позволяет просмотреть файл ошибок. Если такого файла нет, то просмотр не вызывается.

Если используются "скрытые" базы данных , то соответствующий err-файл находится в той же директории, где находится файл связи (*.dby). Для его просмотра можно выбрать просмотр журнала сообщений сервера (F3) и через меню "Файл" > "Открыть другой ASCII-файл для просмотра " открыть соответствующий err-файл.

  • Просмотреть протокол событий на сервере

Просмотр ранее полученного протокола событий на сервере. Этот протокол получается в меню "Действия" > " Протоколирование событий на сервере ". Файл создается при завершении протоколирования.

  • Просмотреть DUMP памяти

Просмотр ранее полученного дампа памяти. Он получается в меню " Действия " > " Dump памяти ".

  • Просмотреть протокол анализа очереди.

Просмотр ранее полученного протокола анализа очереди. Подробнее об этом протоколе см. в начале этого раздела и в описании анализа очереди .


Меню "Действия"

  • Сбросить статистику

На экране сервера приложений отображается статистика его работы. При необходимости можно с помощью этого пункта меню начать сбор статистики с начала.

  • Запретить подключение новых пользователей

При выборе этого пункта меню новые пользователи не могут подключиться к серверу приложений. Это может быть полезным при выполнении каких-нибудь системных работ, когда подключение новых пользователей нежелательно. При включении этого режима центральное окно меняет окраску.

  • Ограничить подключения к текущей базе

При выборе этого пункта появляется окно, в котором можно установить ограничения для пользователей при работе с той базой данных, на которой стоит курсор. Если курсор стоит на пользователе, то ограничения касаются той базы данных, с которой он работает, то есть с ближайшей базы выше по списку. Подробнее

  • Таймер автоматической обработки

Выбор этого пункта меню позволяет запустить задание для обработки базы данных по таймеру. Например, выполнить выгрузку и загрузку базы данных ночью. Подробнее .

  • Протоколирование событий на сервере

Это вспомогательный режим работы, который можно использовать для анализа причин некорректного обслуживания пользователей. При его включении информация обо всех запросах от пользователей и ответов на них записывается в текстовый файл Sls_serv.dbg, который располагается там же, где и программа сервера приложений. Если такой файл уже есть, то информация дописывается к нему, если нет - то создается новый файл. Следует отметить, что обычно размер файла sls_serv.dbg растет очень быстро, поэтому не стоит включать этот режим более чем на пару минут.При включении этого режима центральное окно меняет окраску.

Подробнее... .

  • Dump памяти

Выбор этого пункта меню создает файл Sls_serv.dmp, который содержит информацию о внутренным состоянии сервера приложений.


Меню "Настройка"

  • Установка параметров работы

Настройка используемых протоколов и буферов. Подробнее...

  • Настройка копирования баз данных

Программа сервер приложений позволяет автоматически создавать копии баз данных, которые подключены к серверу приложений. При создании копии базы данных пользователи могут продолжать работать с базой как обычно - копирование идет в фоновом режиме. Подробнее...

  • Настройка обработки событий.

Программа сервер приложений позволяет запускать внешние программы при возникновении некоторых событий. В качестве внешней программы можно использовать практически любую программу.

Например, она может отправить письмо по e-mail о произошедшем событии администратору. Или послать сообщение на его компьютер, или выполнить еще какие-то действия. Подробнее...

  • Настройка режимов транзакций

Позволяет несколько увеличить быстродействие, за счет уменьшения дополнительных действий по обеспечению целостности баз данных. Перед изменением этих настроек обязательно прочтите соответствующий раздел справки.

  • Сохранить конфигурацию

После настройки сервера приложений следует с помощью этого пункта меню сохранить настройки для автоматического восстановления при последующих запусках. Настройки сохраняются в файле Sls_Serv.cfg, который находится в той же директории, где и сама программа сервера приложений.

  • Создать файлы связи для скрытых баз данных.

Если администратор системы хочет ограничить доступ обычных пользователей к файлам баз данных, то он может использовать этот пункт меню. Подробнее .

Следующая группа пунктов меню управляет отображением Сервера приложений на экране.

  • Сервер приложений работает как обычная задача

При запуске программы она показывается на экране. После завершения инициализации Сервера приложений, он автоматически минимизируется. Кнопка "Сервер приложений" остается на панели задач.

  • Сворачивать Сервер приложений в трей

Этот пункт меню недоступен в Windows 95/98/Me, поскольку они не поддерживают работу с треем.

Сервер приложений запускается также, как и в первом случае, однако, при минимизации кнопка на панели задач не показывается. Сервер приложений отображается в трее (рядом с часами). Текущее состояние сервера приложений отображается цветом иконки. Для того, чтобы открыть окно Сервера приложений, надо или дважды кликнуть по иконке в трее, или выбрать соответствующий пункт меню на правой кнопке мыши.

  • Запускать Сервер приложений в "невидимом" режиме.

Сервер приложений запускается без отображения на экране, на панели задач и в трее. В диспетчере задач он виден. Если он запускается в сеансе пользователя, то при завершении сеанса или при завершении работы Windows он автоматически закрывается, отключая всех активных пользователей.

В этом режиме единственный способ управления работой Сервера приложений (например, подключение новой базы данных или отключение пользователя) - это вызов программы Monitor .

При запуске Сервера приложений можно использовать два параметра: R (или Remote) и V (или Visible). Например:

Sls_Serv.exe Visible

При запуске с параметром R Сервер приложений стартует в "невидимом" режиме. При запуске с параметром V - как обычная задача.

Эти параметры имеют приоритет перед пунктом, выбранным через меню.

Поэтому если выбрать в меню запуск в "невидимом" режиме, то для того, чтобы появилась возможность отменить этот режим, надо запустить Сервер приложений с параметром V. Перед этим надо завершить работу "невидимого" экземпляра Сервера приложений, если он уже запущен. Это можно сделать программой Monitor или через диспетчер задач.

О режимах работы см. так же в разделе "Специальные варианты запуска"


Ограничения на подключение к базе данных.

Здесь можно задать ограничения по адресам рабочих станций или по именам пользователей на работу с конкретной базой данных. Описание использования этих ограничений находится дальше .

В верхней части экрана показано имя базы данных, для которой устанавливаются ограничения. Это та база, на которой (или на одном из пользователей которой) стоял курсор в момент вызова пункта меню "Ограничить подключения к текущей базе".

Экран разделен по вертикали на две части.

В правой части экрана задается режим работы с базой данных:

  • Могут работать все. Этот режим установлен по умолчанию для всех баз данных. При его выборе нет никаких ограничений по работе с данной базой.

  • Новые не подключаются. При выборе этого режима запрещено подключение любых новых пользователей к базе данных. Те пользователи, которые с ней работают в данный момент, продолжают работать. Однако, как только какой-нибудь из этих пользователей отключится от базы, подключиться к ней опять он не сможет. Этот режим можно использовать для того, чтобы дать доработать тем, кто сейчас работает с этой базой данных.

  • Отключить всех. При выборе этого режима запрещено подключение пользователей к базе данных. Все пользователи, которые в данный момент работают с базой данных, будут отключены от нее сразу после установки этого режима.

  • В соответствии со списком. При выборе этого режима разрешение или запрещение работы с базой данных будет выполняться в соответствии со списком пользователей, который находится в левой части окна. Список пользователей для каждой базы данных свой.

В левой части экрана находится список пользователей, который используется для ограничений если режим работы с базой задан как в соответствии со списком . Список может быть "белым" или "черным" в зависимости от выбранного типа списка.

Если список "белый", то работа с базой данных разрешена только тем пользователям, которые включены в данный список.

Если список "черный", то работа с базой данных разрешена всем, кроме тех, кто включен в данный список.

Для каждого пользователя в списке задается хотя бы одно поле - "адрес пользователя" и/или "имя пользователя".

  • Адрес пользователя - это или IP-адрес его компьютера (если пользователь работает с Сервером приложений по UDP/IP) или MAC-адрес его сетевого адаптера (если пользователь подключен по NetBIOS). Адрес пользователя виден в списке пользователей на основном экране Сервера приложений.

  • Имя пользователя.

Если в настройках программы (Склад, Касса и т.д.) не включено расширенное санкционирование доступа, то есть программа при запуске не спрашивает имя и пароль пользователя, то "имя пользователя" совпадает с тем, которое он имеет на своем компьютере в Windows (Windows-имя). Например, "Администратор", "Владелец" и т.д.

Если расширенное санкционирование включено, то "имя пользователя" - это то имя, которое он вводит при подключении к программе. При этом до того, как пользователь ввел свое имя, его имя видно на Сервере приложений как Windows-имя, а после подключения к программе меняется на имя в программе.

Для работы со списком можно использовать следующие операции:

  • Добавить пользователя в список (Ins) - для добавления нового пользователя в список,
  • Корректировать запись пользователя (F2 или двойной клик по записи) - для внесения изменений в описание пользователя.
  • Удалить пользователя из списка (Del) - для удаления записи из списка.
  • Кнопка Очистить список - для удаления всех записей из списка.

При добавлении или корректировке записи пользователя появляется окно редактирования записи.

После завершения корректировки можно сохранить ее результаты нажатием кнопки Сохранить изменения, или отказаться от корректировок нажатием кнопки Оставить как было. При сохранении изменений они начинают действовать сразу - перезапуска Сервера приложений не требуется.


Описание пользователя при ограничении доступа

Это окно используется для описания пользователя в списке ограничения доступа .

  • Для ограничения использовать имя, а не адрес. Этот флажок служит для указания того, какое из приведенных ниже полей будет использоваться при ограничении доступа данного пользователя.

  • Адрес. В этом поле надо указать адрес компьютера пользователя.

Если для связи с ним используется протокол UDP/IP, то адрес должен быть введен как ХХХ.ХХХ.ХХХ.ХХХ. Например, 10.0.0.12. Адрес должен вводиться без лишних пробелов и нулей. Например, 10.0.0.12, но не 10 . 0 .0.12 или 010.000.000.012

Если для связи с пользователем используется протокол NetBIOS, то адрес должен быть 12-значным MAC-адресом сетевого адаптера компьютера.

Адрес пользователя виден на основном экране Сервера приложений. Если поставить курсор на нужного пользователя, а после этого вызвать "Действия > Ограничить подключения к текущей базе", то сразу откроется окно добавления и поле "Адрес" в нем будет заполнено автоматически.

  • Имя. В этом поле надо записать имя пользователя - или его Windows-имя (имя, с которым он подключен к Windows) или его имя в программе SLS.

Имя пользователя видно на основном экране Сервера приложений. Если поставить курсор на нужного пользователя, а после этого вызвать "Действия > Ограничить подключения к текущей базе", то сразу откроется окно добавления и поле "Имя" в нем будет заполнено автоматически.

Кнопка Сохранить сохраняет запись, кнопка Отказаться позволяет отказаться от внесения изменений.


Использование ограничений доступа к базам данных

Ограничения на подключение к базе данных описано в соответствующем разделе справки . Этот раздел описывает как эти ограничения использовать.

Вся информация об ограничениях хранится в файле SLS_Serv.ogr, который находится в той же папке, где и программа SLS_Serv.exe. В этом файле хранится информация только о тех базах данных, для которых установлено ограничение. Если база данных отключается от Сервера приложений, то информация о ее ограничениях удаляется из файла ограничений при первой возможности.

В списке пользователей пользователь может быть включен по его адресу или по его имени. Включение по адресу предпочтительней, поскольку оно ограничивает любой доступ к базе с указанного компьютера.

Если в сети используется динамическая выдача IP-адресов, или данный пользователь подключается через терминальный доступ, то надо использовать ограничение по имени.

При динамической выдаче IP-адресов в качестве имени лучше всего указывать Windows-имя пользователя, то есть то имя, с которым он подключен к Windows.

Если пользователь подключен через терминальный доступ, то его IP-адрес соответствует IP-адресу терминального сервера, а Windows-имя - его имени на терминальном сервере. В этом случае стоит использовать его имя в SLS-программе. Правда, при этом будет проблема с его добавлением в "белый" список. Для "черного" списка проблем нет.

При установке ограничений доступа основная сложность состоит в составлении списка пользователей, если этот список должен использоваться. Для упрощения этой процедуры можно использовать следующий метод.

  • Составление "черного" списка.

При работе пользователей поставить курсор на того пользователя (в списке пользователей нужной базы), которому надо запретить работу с базой данных, и выбрать "Действия > Ограничить подключения к текущей базе".

Появится окно ограничений для текущей базы и, если этого пользователя в списке еще нет, то сразу откроется окно описания пользователя с заполненными полями "Имя" и "Адрес".

Надо нажать кнопку "Сохранить" для добавления пользователя к списку.

Если это первый пользователь в списке, то надо выбрать "Тип списка" равный "Черный - кому запрещена работа с базой" и "Режим работы с базой" равный "в соответствии со списком".

После этого нажать кнопку "Сохранить изменения". Пользователь будет добавлен к "черному списку" и тут же отключен от базы данных.

Далее можно поставить курсор на следующего пользователя, которому надо запретить доступ, и повторить процесс.

  • Составление "белого списка".

Для того, чтобы при составлении "белого списка" можно было использовать такой же полуавтоматический режим, как и для черного, надо до конца формирования списка оставить "Режим работы с базой" равным "Могут работать все". Тогда можно будет поочередно добавлять из общего списка всех пользователей. Если же сразу поставить "Режим работы с базой" равным "в соответствии со списком", то после занесения первого пользователя в список, все остальные будут отключены от базы данных как отсутствующие в "белом списке".

Все остальные действия соответствуют описанным выше, за исключением того, что "Тип списка" надо установить в "Белый - кому разрешена работа с базой" после занесения всех пользователей.


Поиск пользователя или базы данных

Для упрощения поиска в списке пользователей и баз данных (если их очень много) можно использовать режим поиска.

  • Поиск пользователей

При поиске пользователей в окне высвечивается список активных в данный момент пользователей, отсортированный по алфавиту. Для быстрого подвода курсора можно начать набирать нужное имя в поле поиска. Можно также перемещаться по списку стрелками вверх и вниз или PgDn и PgUp.

Клавиша F5 позволяет изменить режим поиска. Список пересортируется в порядке возрастания сетевых адресов и подвод курсора будет выполняться по адресу.

Нажатие кнопки "Перейти" закроет окно поиска и спозиционирует курсор в основном окне на найденного пользователя.

  • Поиск баз данных

При поиске баз данных в окне высвечивается список имен подключенных к Серверу приложений баз данных, отсортированный по алфавиту. Для быстрого подвода курсора можно начать набирать нужное имя в поле поиска. Можно также перемещаться по списку стрелками вверх и вниз или PgDn и PgUp.

Клавиша F5 позволяет изменить режим поиска. Список пересортируется в порядке возрастания полных путей к базам данных и подвод курсора будет выполняться по этому списку.

Нажатие кнопки "Перейти" закроет окно поиска и спозиционирует курсор в основном окне на найденную базу данных.


Просмотр файлов

Окно просмотра файлов предназначено для оперативного просмотра файлов, в которых протоколируются различные события. Это файл протокола работы сервера приложений SLS_SERV.LOG и файлы ошибок отдельных баз данных. Вызывается окно из меню "Анализ" из соответствующих его пунктов.

В окно поднимается около 2000 последних записей протокола. Если этого недостаточно, то можно использовать любой текстовый редактор, который позволяет просматривать текстовые файлы в кодировке DOS. Это может быть Far, Norton Commander и им подобные оболочки, или стандартная программа Блокнот, входящая в комплект поставки Windows. В последнем случае надо в меню "Правка/Шрифт" выбрать фонт Terminal или любой другой, который соответствует кодировке DOS (ASCII).

В окне просмотра файлов можно выбрать любой шрифт, который позволяет лучше читать файл. Рекомендуется Courier с размером 8.

  • Меню Файл

Это меню содержит два пункта:

"Открыть другой ASCII-файл для просмотра" - Для просмотра файлов протоколов об ошибках в базах данных, протоколирования событий и т.п. можно использовать Norton, Far или открыть их с помощью этого пункта меню. Для выбора нужного типа файла используйте "Типы файлов" в стандартном диалоге открытия файла.

Можно также просматривать файлы сообщений об ошибках в базах данных (<имя базы>.err), если используются "скрытые базы данных". В этом случае соответствующий файл создается не в директории, где находится база данных (эта директория недоступна для пользователя), а в директории, где расположен файл связи (<имя базы>.dby).

"Завершить просмотр" - Закрыть окно просмотра

  • Меню шрифт

С помощью этого пункта меню можно изменить шрифт для отображения на экране. Рекомендуется выбирать мноширинный шрифт, например, Courier.


Протоколирование событий на сервере

Протоколирование включается для определения причин неправильной работы сервера приложений или сети. В этом режиме в файл протокола пишется информация обо всех приходящих от клиентов запросах, об ответах сервера на них и о событиях на сервере. Включение этого режима несколько замедляет работу сервера приложений. При включенном режиме протоколирования экран сервера приложений подкрашен зеленым (или желтым - если одновременно запрещено подключение новых пользователей) цветом для индикации режима.

При выборе этого пункта меню появляется окно для установки параметров протоколирования.

  • Размер протокола ограничен. Если этот переключатель выключен, то файл протокола не ограничен по размеру. Следует отметить, что при интенсивной работе файл протокола может расти очень быстро - например, один гигабайт в минуту. Поэтому при неограниченном размере протокола не следует включать протоколирование надолго.

  • Максимальная длина файла ХХХХ мегабайт. Если "Размер протокола ограничен, то здесь указывается максимальная длина файла протокола. Когда файл достигнет указанных размеров, то удаляется предыдущий файл с именем SLS_SERV.DBB и текущий файл протокола из SLS_SERV.DBG переименовывается в SLS_SERV.DBB, а файл SLS_SERV.DBG создается вновь для продолжения протоколирования.

Таким образом может быть два файла: с расширением DBB - предыдущая часть протокола и с расширением DBG - текущий протокол.

Если протокол не ограничен по размеру, то данное поле игнорируется и весь протокол пишется в один файл с именем SLS_SERV.DBG

  • Стирать предыдущий протокол. Если этот переключатель включен, то перед началом протоколирования ранее созданный протокол будет удален. Если нет - то протоколирование просто продолжится .

При нажатии кнопки "Начать протоколирование" сервер приложений начинает протоколирование в указанном режиме. Изменения режима протоколирования автоматически сохраняются для последующего использования даже если от включения протокола отказались.

Если пункт меню "Протоколирование событий на сервере" выбрать при включенном протоколе, то протоколирование прекратится. При этом на экране появится сообщение о местонахождении полученных файлов протокола.


Меню "Шрифт"

Это меню предназначено для изменения шрифта, которым отображается информация в программе. Это изменение может потребоваться при неверном отображении русских текстов.

Как правило, настройка шрифтов не требуется.

  • Изменить шрифт (Change Font) - вызов диалога выбора шрифта.

  • Шрифт по умолчанию (Default Font) - программа автоматически выберет кириллизованный фонт, установленный на Вашем компьютере.


Анализ очереди

При работе сервера приложений он обрабатывает запросы пользователей. Некоторые запросы обрабатываются моментально, некоторые требуют значительного времени на обработку. При этом есть запросы, которые не могут быть выполнены до завершения других запросов. В этом случае они становятся в очередь.

Для обеспечения удобства работы пользователей желательно, чтобы запрос обслуживался не более 3-х секунд. Если же время обслуживания больше, то это может быть вызвано или большим временем выполнения самого запроса или тем, что перед ним в очереди стоит большой запрос.

При вызове окна Анализ очереди в верхней части экрана "Проблемный пользователь" находится информация о пользователе, который является причиной задержки, а в нижней "Запросы в очереди" - все те, кто ждет завершения его запроса.

Настройка (задержка в очереди).

Времена задержки, которые определяют возникновение проблем, можно настроить с помощью параметров внизу окна. При этом основным является значение первого ("желтого") параметра.

Если поставить галочку в поле "Сигнализировать звуком", то при включении красной лампочки сервер приложений будет каждые 4 секунды давать звуковой сигнал. Если установлена звуковая карта, то проигрывается звук "exclamation". Если звуковой карты нет или для вышеуказанного звука не установлен звуковой файл, то работает встроенный динамик системного блока.

Включить протоколирование

Проблемных пользователей. Если этот флажок включен, то при возникновении задержки более предусмотренной (зажглась красная лампочка), в протокол SLS_SERV.DBA записывается информация о пользователе, который стал причиной задержки.

Событий при возникновении проблем. Если этот флажок включен, то в этот же протокол происходит запись приходящих от пользователей запросов и ответов на них Сервера приложений. Запись начинается при загорании красной лампочки и продолжается до загорания зеленой лампочки.

Протоколирование включено если хоть один из упомянутых выше флажков установлен.

Максимальная длина протокола. Если в этом поле написано некоторое число, то при достижении файлом SLS_SERV.DBA соответствующего размера, он переименовывается в SLS_SERV.DBC и создается новый файл протокола SLS_SERV.DBA. Таким образом суммарный объем файла протокола ограничен независимо от времени его ведения.

Анализ загруженности системы. Если в этом поле стоит галочка, то в директории, где установлен SLS_SERV.EXE, создается текстовый файл SLS_SERV.DLD, в который каждые 10 минут записывается статистика работы сервера приложений.

Включать этот анализ нужно только тогда, когда есть вопросы по работе системы и специалисты из СофтЛенд Системз попросили Вас об этом.

В остальное время этот анализ должен быть выключен, поскольку он немного снижает быстродействие, а неограниченное увеличение файла протокола (около 10 килобайт в час) будет съедать дисковое пространство


Ошибки связи с пользователями.

В этом окне видна статистика переповторов при посылке информации от сервера приложений к рабочим станциям и обратно. Статистика собирается с момента запуска программы Сервера Приложений.

В первой графе расположен номер сетевого адаптера рабочей станции. Во второй - имя пользователя, который подключался с нее в последний раз.

Третья, четвертая и пятая графы содержат количество переповторов для данной рабочей станции "всего", "от рабочей станции к серверу" и "от сервера к рабочей станции".

В последней графе находится суммарное время работы данной рабочей станции. Если станция подключена в данный момент, то время идет. Если отключена, то стоит.

Кнопка "Записать в файл" служит для сохранения информации в текстовом файле.

При необходимости, статистику можно начать с начала. Для этого надо выбрать пункт главного меню сервера приложений "Файл/Сбросить статистику (F10)".

При нормальной работе сети переповторов не должно быть совсем, или их должно быть немного. Большое количество переповторов заметно снижает быстродействие.

Если для какой-нибудь рабочей станции количество переповторов велико, то, возможно, есть проблема с ее сетевой картой или с кабелем.

Если переповторы идут по всем станциям, то, возможно проблемы с центральным HUB'ом или с кабельной системой в целом.


Статистика работы пользователей

В этом окне виден список пользователей, которые работают в данный момент.

В верхней части окна находятся элементы управления для отображения этого списка.

  • Обновление. Здесь можно выбрать периодичность обновления информации в окне. По умолчанию тут стоит "раз в 5 секунд", что позволяет не очень сильно загружать сервер.

  • Обновить. При нажатии этой кнопки происходит однократное обновление информации независимо от того, что установлено в предыдущем пункте.

  • Отключить пользователя. При нажатии этой кнопки выдается вопрос об отключении. При положительном ответе пользователь, на котором установлен курсор, отключается от базы данных.

  • График. Если эта кнопка нажата, то в нижней части экрана отображается в графическом режиме активность текущего пользователя за последние 5 минут.

  • Фильтрация по базам данных. По умолчанию в списке отображаются все пользователи, которые работают в данный момент с любыми базами данных Сервера приложений. Можно указать в этом окне какую-нибудь базу данных и в окне отобразятся только те пользователи, которые с ней работают. Примечание: При просмотре статистики из программы Монитор, надо перед этим зайти на закладку "Пользователи и базы" для того, чтобы прочелся список баз данных.

Центральную часть окна занимает таблица, отображающая статистику по работающим пользователям.

  • Пользователь. Имя пользователя

  • Адрес станции. Для пользователей, работающих через UDP/IP здесь записан IP адрес их компьютера. Для пользователей, подключенных по NetBIOS, адрес состоит из трех или четырех-символьного префикса, за которым идет MAK-адрес станции. Для протокола IPX здесь через двоеточие указывается номер сети и MAC-адрес компьютера.

  • Запросов. В этой колонке отображается общее количество запросов, полученных от пользователя за последние 5 минут.

  • Чтение. В нормальном режиме прикладные программы читают информацию из базы данных не более, чем секунду подряд. Если программа читает информацию дольше, то это может привести к задержке завершения транзакции (записи) других пользователей. В этой колонке отображается суммарное время "длинных" чтений за последние 5 минут.

  • Запись. В этой колонке отображается суммарное время транзакций (записи в базу) за последние 5 минут.

  • Посл.запрос. В этой колонке отображается время, прошедшее от последнего запроса, полученного от пользователя.

Информация в таблице может быть отсортирована по любой из колонок. Для этого достаточно нажать мышкой на заголовок соответствующей колонки. По умолчанию, записи отсортированы по количеству запросов.

В нижней части экрана отображается график активности текущего пользователя (выбранного в списке). График показывает количество запросов пользователя за последние 5 минут. Под графиком располагается полоса с расшифровкой выполняемых действий. Значение цветов на этой полосе приведено справа.


Установка параметров работы

1. Выбор сетевого протокола

В верхней части экрана отображаются сетевые протоколы, найденные на компьютере. Для работы надо выбрать хотя бы один из них. При необходимости можно отметить несколько протоколов. Если есть возможность, то лучше использовать один протокол для всех компьютеров, входящих в сеть, особенно, если для работы сервера приложений используется Windows 95/98 или не серверные версии Windows (например NT Workstation). Это связано с ограниченностью сетевых ресурсов на них.

  • Протокол IPX отображается только если установлена клиентская часть Novell NetWare. При его наличии с сервером приложений могут работать как рабочие станции с операционной системой Windows, так и с операционной системой MS-DOS.

Для протокола IPX можно ввести дополнительную информацию.

Номер сокета - сокет, на котором будет работать Сервер приложений. Если это поле оставлено пустым, то сокет будет выбран автоматически.

Для DOS программ - если этот флажок установлен, то если одновременно включен и IPX и NetBIOS, то старые программы (в первую очередь - DOS-программы) будут работать с IPX. Если флажок не установлен, то работа будет вестись по одному из протоколов NetBIOS.

  • Протокол UDP/IP позволяет работать со всеми станциями, на которых настроен протокол TCP/IP. Следует отметить, что DOS-овские версии программ не могут работать по этому протоколу.

Для протокола UDP/IP можно ввести дополнительную информацию.

Порт - порт, по которому Сервер приложений слушает запросы от рабочих станций. Если это поле оставленно пустым, то порт будет выбран автоматически.

Кнопка IP адрес... . Если компьютер имеет несколько IP адресов, то по умолчанию запросы слушаются по всем этим адресам. Если требуется запретить работу с каким-нибудь адресом (например, этот адрес смотрит в интернет), то можно это сделать нажав эту кнопку.

  • Протокол NetBIOS отображается для всех протоколов, в которых установлена его поддержка. Для каждого из них показывается номер его логического адаптера и оценка скорости работы.

Оценка скорости работы производится путем очень приблизительного измерения посылок и приемов сетевых пакетов по каждому из протоколов. Поскольку измерение приизводится при каждом запуске программы, то цифры могут меняться - отражается только тенденция. Если скорость работы равна 0, то это значит, что данный NetBIOS не поддерживает передачи отдельных пакетов и использоваться не может.

При работе под Windows NT/2000/XP/2003 справа от каждого протокола NetBIOS приведено его название для Windows 9x и NT.

Если нет особых соображений, то можно попробовать выбрать первый попавшийся протокол NetBIOS и запустить прикладную программу для проверки видимости этого протокола на другом компьютере. Если протокол виден не везде, то надо или добавить недостающий протокол на проблемных компьютерах ("Пуск/Настройка/Панель управления/Сеть"), или отметить дополнительный протокол в сервере приложений.

2. Размер кэш.

Кэш - это область памяти, предназначенная для ускорения операций с базой данных. В ней запоминается прочтенные с диска блоки базы данных, что дает возможность при последующих к ним обращениях читать данные не с диска, а из памяти.

Синим шрифтом написаны размер физической памяти и ее свободный объем при старте сервера приложений. Значительную часть физической памяти занимает Windows, кроме того некоторая память потребуется при работе Windows.

Размер кэш не должен превышать 1/3 - 3/4 от свободного объема. Если взять слишком большой размер, то кэш расположится не в физической памяти, а в своп-файле на диске и вместо ускорения работы произойдет ее замедление.

3. Контроль при чтении.

Если этот флажок включен, то при чтении блоков из базы данных Сервер приложений проверяет правильность прочтенного блока. И, если контроль не прошел, то работа с базой данных прекращается. Аналогичный контроль есть и при записи в базу данных, причем он производится всегда.

В случае, если все-таки надо работать с испорченной базой данных, можно снять флажок и отключить контроль при чтении.

По умолчанию контроль при чтении включен.

4. Максимальное количество баз данных

Если требуется, чтобы сервер приложений обслуживал более 16 баз данных, то здесь можно указать требуемое количество.

5. Максимальное количество пользователей

Если требуется, чтобы сервер приложений обслуживал более 20 пользователей одновременно, то здесь можно указать требуемое количество.

6. Одна задача на каждой рабочей станции.

Если этот флажок включен, то при запуске задачи, работающей с сервером приложений, проверяется нет ли уже такой же задачи, запущенной с той же рабочей станции ранее. Если такая задача есть, то она завершается. Данная ситуация может возникнуть по двум причинам: или на рабочей станции запускается вторая задача, или предыдущая задача не завершилась корректно, например, из-за перезагрузки Windows.

7. Время до отключения неактивных станций

При начале работы прикладной программы, она регистрируется на сервере приложений, а при завершении - отключается от него. Если отключения не было - завис Windows, компьютер выключили не через кнопку "Пуск", сбой по питанию, то пользовательостается в таблице сервера приложений. Его можно или удалить вручную, или проставить в этом поле количество минут до автоматического отключения.

Автоматическое отключение работает следующим образом. Если с рабочей станции не поступало ни одного запроса в течение заданного количества минут, то на нее посылается несколько проверочных запросов. Если рабочая станция не откликается, то соответствующий пользователь отключается от сервера приложений.

Следует отметить, что на некоторых экземплярах Windows 95/98, неактивная в данный момент задача не получает управления по запросам из сети. Поэтому возможно ложное срабатывание автоотключения. В этом случае его можно отключить, указав 9999 в качестве значения.

8. При работе использовать ...... приоритет

Этот параметр автоматически выбирается в зависимости от версии Windows. Если он неправильно установлен, то или чтение идет очень медленно (в прикладной программе строчки разворачиваются по 1-2 секунды), или очень медленно идет запись (короткая запись длится 4-8 секунд).

Для того, чтобы вернуться к автоматически выбранному значению этого параметра, достаточно установить параметр в "Выбрать автоматически". При сохранении параметров будет сделан выбор и установится нужное значение.

9. Дополнительно

Эта кнопка позволяет выбрать программу, которая автоматически запустится сразу после старта сервера приложений. Там же можно настроить систему предупреждения о нехватке места на диске, где расположены базы данных. Подробнее см. в "Дополнительные настройки"


Таймер автоматической обработки.

Использование таймера позволяет отложить запуск программы для обработки базы данных на удобное для пользователей время.

Использовать таймер имеет смысл только для запуска заданий, которые требуют монопольного использования базы данных, подключенной к серверу. Таймер позволяет автоматически отключить базу данных перед началом обработки и подключить ее обратно после завершения обработки.

В остальных случаях проще запускать нужную программу обычным планировщиком Windows.

Таймер может быть установлен только для одного задания. До начала времени, указанного в таймере, задание можно изменить или отменить.

Для того, чтобы задание можно было выполнить, надо обязательно заполнить поля "Начало" (время должно быть больше текущего), "база данных" и "какую программу вызывать". Названия тех полей, которые надо заполнить, подсвечиваются красным цветом.

Если все поля заполнены, то становится активной кнопка "Сохранить"

  • Начало. С помощью этих полей можно установить дату и время начала обработки. При этом справа отображается для контроля время, оставшееся до запуска программы.

  • База данных. Здесь можно выбрать одну из баз данных, подключенных к Серверу приложений.

  • Отключить базу от Сервера приложений. Если этот флажок включен, то база данных перед началом обработки отключается от Сервера приложений. Если к этому моменту она уже была неактивной, то ничего не происходит.

  • Какую программу вызывать. С помощью кнопки справа от этого поля можно выбрать программу, которая будет запускаться по таймеру.

  • Параметры для вызываемой программы. В этом поле можно указать параметры, передаваемые программе при вызове. Если нужно, то можно использовать символ "#". При вызове программы он заменится на путь и имя базы данных, выбранные в поле "База данных".

  • Рабочая папка вызываемой программы. С помощью кнопки справа от этого поля можно выбрать рабочую папку для вызываемой программы. Обычно хватает значения, установленного по умолчанию.

  • Подключить базу к серверу. Если этот флажок включен, то после завершения работы программы, вызванной таймером, база данных, заданная в поле "База данных", будет подключена к Серверу приложений.

Подключение произойдет только если программа выполнится с кодом возврата 0, т.е. без ошибок.

Если Сервер приложений перезапускается во время выполнения программы, то программа продолжает выполнение, но подключения базы данных по завершении программы не произойдет

  • Кнопка "Сохранить". Эта кнопка сохраняет задание. В списке баз данных, рядом с той базой, для которой назначено задание, появляется пиктограмма часов. До запуска задания она белая, после запуска - зеленая.

Эта пиктограмма остается зеленой до конца выполнения задания.

Если флажок "Подключить базу к серверу" включен, то концом выполнения задания считается завершение запущенной программы.

Если флажок "Подключить базу к серверу" не включен, то концом выполнения задания считается запуск программы по таймеру.

Задание будет выполнено в указанное время, если Сервер приложений будет в это время работать.

Если Сервер приложений в указанное время не работал, но был запущен не позднее, чем через 10 минут после того, как время наступило, то задание будет выполнено.

Если пройдет более 10 минут, то задание считается просроченным и не выполняется.

В любом случае, информация о запуске задания заносится в "Журнал сообщений сервера", который можно просмотреть через "Анализ > Журнал сообщений сервера".

  • Кнопка "Отказаться". Нажатие этой кнопки завершает настройку таймера без сохранения результатов.

  • Кнопка "Отменить задание". Нажатие этой кнопки сбрасывает установленные параметры и сохраняет "пустое" задание, которое не будет выполняться.


Настройка обработки событий

Программа Сервер приложений позволяет запускать внешние программы при возникновении некоторых ситуаций.

Обрабатываемые события:

  • После копирования, если тестирование обнаружило ошибки.

Ситуация возникает после создания копии базы данных при включенном тестировании. Если при тестировании обнаружились ошибки, то будет запущена указанная для обработки этого события программа.

При описании параметров, передаваемых программе обработки, можно использовать символ "#". При запуске программы этот символ будет заменен на путь и имя соответствующей копии базы данных

  • После копирования (и тестирования, если включено) в любом случае

Ситуация возникает после создания копии базы данных. Если было включено тестирование данной копии, то после этого тестирования. Программа запускается в любом случае, независимо от того, запускалось ли тестирование и были ли обнаружены ошибки при тестировании.

При описании параметров, передаваемых программе обработки, можно использовать символ "#". При запуске программы этот символ будет заменен на путь и имя соответствующей копии базы данных

Постоянно отслеживаемые события.

Нижеперечисленные события могут возникнуть в любой момент времени. Соответствующая программа будет запущена в первый раз сразу после наступления события. После этого в течение заданного интервала будет проверяться не устранена ли причина возникновения события. Если не устранена, то через заданный интервал программа будет вызвана повторно.

В качестве внешней программы можно использовать программу для пердачи сообщения администратору по e-mail или другим способом.

  • Если есть хоть одна база данных с ошибками после тестирования

Ситуация возникает, если хоть одна из подключенных к Серверу приложений баз данных имеет ошибки после тестирования последней ее копии (отмечена красным восклицательным знаком в списке баз данных)

  • Если кончается память на дисках

Ситуация возникает, если в " Настройка > Установка параметров работы > Дополнительно " включен флажок контроля дисковой памяти. Как только хоть на одном из дисков, где находятся базы данных, доступной памяти станет меньше, чем задано в настройках, будет запущена соответствующая внешняя программа.

При описании параметров, передаваемых программе обработки, можно использовать символ "#". При запуске программы этот символ будет заменен на список дисков с недостаточной памятью. Например:

D:, F: (диски отделяются друг от друга сиволами запятая и пробел)

  • Если возникли задержки в очереди обработки

Ситуация возникает если в очереди обработки возникли задержки больше установленного предела ("красная лампочка"). В первый раз программа запускается сразу после возникновения события. Дальше она будет запускаться с заданным интервалом, если в течение этого интервала были задержки.

  • Если при работе с базой данных возникли ошибки в блоках

Ситуация возникает если при работе с какой-нибудь из баз данных был прочтен (или была сделана попытка записать) блок данных с ошибками в структуре.

В первый раз программа запускается сразу после возникновения события. Дальше она будет запускаться с заданным интервалом, если в течение этого интервала указанная ситуация опять возникла.

Назначение полей.

  • Обрабатываемые события.

Это список событий, которые Сервер приложений позволяет обрабатывать. Те события, обработка которых включена, выделены в списке жирным шрифтом. При установке курсора на одно из событий, в нижней части окна высвечиваются параметры для его обработки.

  • Обработка включена.

Если этот флажок включен, то событие считается обрабатываемым. При возникновении соответствующей ситуации будет сделана попытка запустить указанную ниже программу. Контроль на ее наличие и правильность параметров отсутствует.

  • Выполнять не чаще, чем

Это поле присутствует только для постоянно отслеживаемых событий. С его помощью устанавливается интервал для повторения запуска программы обработки.

  • Какую программу вызывать.

С помощью кнопки справа от этого поля можно выбрать программу, которая будет запускаться при возникновении события.

  • Параметры для вызываемой программы.

В этом поле можно указать параметры, передаваемые программе при вызове.

  • Рабочая папка вызываемой программы.

С помощью кнопки справа от этого поля можно выбрать рабочую папку для вызываемой программы. Обычно хватает значения, установленного по умолчанию.

  • Кнопка "Сохранить".

После нажатия этой кнопки все сделанные изменения сохраняются.

Изменения вступают в силу сразу после сохранения.

  • Кнопка "Отказаться".

При нажатии этой кнопки все сделанные изменения отменяются и настройки остаются прежними.


Настройка режимов транзакций.

Прежде чем изменять настройку режимов транзакций, прочтите, пожалуйста, этот раздел.

Обычно сервер приложений записывает изменения в базу данных в пять этапов.

1) Исходное состояние всех изменяемых блоков записывается в файл с расширением PRE.

2) Этот файл закрывается и выдается команда Windows переписать всю информацию этого файла на жесткий диск.

3) В основной базе данных изменяются блоки данных.

4) Основная база данных закрывается, для Windows выдается команда записи всей информации на жесткий диск, после чего база данных вновь открывается.

5) Файл PRE, созданный в пункте 1, удаляется.

Такая схема обновления базы данных дает возможность восстановления ("отката") базы при каких-либо проблемах с изменением.

Вместе с этим, действия, связанные с созданием вспомогательных файлов, открытием и закрытием файлов и .т.п., занимают какое-то время. Поэтому на устойчиво работающем компьютере, оснащенном UPS, можно несколько ускорить работу сервера приложений, отменив часть вспомогательных действий.

1. Нормальный режим транзакций

В этом режиме все работает по описанной выше схеме. Почти всегда при аварийных завершениях работы Windows удается сохранить базу данных.

2. В транзакции не создается PRE-файл

Из вышеописанной схемы убираются пункты 1, 2 и 5. При аварийном завершении работы (например, выключение питания) в момент изменения базы данных, в базе данных могут возникнуть ошибки. Если аварийное завершение произойдет между транзакциями (записью в базу данных), то база не пострадает.

3. Нет PRE-файла и сохранение на диск не чаще раза в минуту.

В этом режиме выполняется только пункт 3, т.е. изменение базы данных. В таком режиме работает большинство программ Windows, однако он не вполне безопасен с точки зрения сохранности базы данных.

Поскольку Windows осуществляет реальную запись на жесткий диск не сразу, а по своему разумению, то аварийное завершение работы (например, выключение компьютера не через кнопку "Пуск") может привести к ошибкам в базе данных даже через значительное время после внесения исправлений и, даже, после завершения работы с программой.

Чтобы этого не происходило, в данном режиме осуществляется принудительное закрытие / сброс информации на жесткий диск / открытие файла базы данных не по концу каждой транзакции, а приблизительно раз в минуту (если за это время в базе данных были изменения).

Если нажать кнопку "Сохранить", то Сервер приложений сразу переходит в новый режим работы - его перезапуска не требуется.


Дополнительные настройки...

Автозапуск после старта сервера приложений

Здесь можно указать программу, которая должна быть запущена автоматически после того, как запустился сервер приложений. Такой программой может быть любая прикладная программа, которая работает с Сервером приложений - Склад, Бухучет, Касса, Кассовый сервер и т.п.

  • Какую программу вызывать

С помощью кнопки "Обзор" можно выбрать нужную программу

  • Параметры вызываемой программы

Если вызываемой программе требуется передать какие-нибудь параметры, то из можно ввести в это поле. Нужны ли параметры и какие см. в описании соответствующей программы.

  • Рабочая директория вызываемой программы

Если для нормальной работы вызываемой программы требуется установка для нее рабочей директории, то с помощью кнопки "Обзор" можно указать эту директорию. Нужна ли рабочая директория и какая см. в описании соответствующей программы.

Предупреждение о том, что на диске мало места

  • Показать предупреждение на сервере

Если на диске, где находится какая-нибудь из обслуживаемых баз данных останется меньше свободного места, чем задано, то на экране сервера приложений возникнет предупреждение об этом. Это предупреждение будет оставаться на экране до тех пор, пока места на диске остается меньше, чем требуется. Пользователи в этом случае продолжают работать как всегда - это сообщение для администратора системы.

  • Блокировать запись в базу и показать предупреждение пользователям.

Если на диске остается меньше места, чем указано здесь, то при попытке пользователя выполнить запись в базу данных он получит сообщение о нехватке места и будет отключен. Читать базу данных можно без ограничений.

См. также "Установка параметров работы".


Настройка копирования баз данных

Копирование баз данных является необходимым элементом работы с ними. Наличие копии позволяет при неполадках с основной базой данных восстановиться с копии. Количество копий зависит от размеров баз данных и имеющейся емкости дисков. Считается, что следует иметь не менее трех копий каждой из баз за разные периоды времени.

Программа сервер приложений позволяет настроить схему копирования в соответствии с требованиями пользователя и автоматически выполнять копирование баз данных. При этом работа пользователей с базой данных почти не замедляется во время копирования.

Окно настройки копирования доступно через меню "Настройка" и состоит из трех закладок:

  • Общая настройка

В этом окне указывается директория, в которой будут создаваться копии баз данных, периодичность копирования и количество копий, которое надо сохранять. Эти настройки применяются ко всем базам данных, для которых не установлены индивидуальные настройки. При подключении новой базы к серверу приложений она автоматически включается в список копируемых баз данных.

  • Индивидуальные настройки

Окно содержит список баз данных, которые в данный момент подключены к серверу приложений. При установке на какую-нибудь из баз данных курсора, внизу появляются ее индивидуальные настройки (если они есть). При отключении базы от сервера приложений ее индивидуальные настройки теряются. При последующем ее подключении она будет копироваться с общими настройками.

  • Существующие копии баз данных

В этом окне находится список существующих на данный момент копий баз данных. Список состоит из трех уровней. На первом уровне расположены имена файлов баз данных. На втором - для каждого из имен полный путь к исходной базе данных. На третьем - для каждой из исходных баз данных список ее копий, отсортированный по времени копирования.

Системные администраторы могут найти дополнительную информацию о копировании в разделе Технические подробности .


Общая настройка

Окно общей настройки имеет следующие элементы:

  • Основная директория для копирования

Здесь указывается путь к директории, в которой будут создаваться все копии. Эта директория может находиться как на том компьютере, где находится сервер приложений, так и на другом компьютере. В последнем случае этот компьютер должен быть всегда включен при работе сервера приложений, иначе копирование будет невозможно.

По умолчанию создается поддиректория с именем "COPY" внутри той директории, где находится SLS_SERV.EXE. При желании можно в любой момент изменить эту директорию нажав кнопку рядом с окном.

  • Периодичность копирования

Ежегодно - База данных копируется раз в год при первом включении после 31 декабря

Ежеквартально - Раз в квартал при первом включении после конца предыдущего квартала.

Ежемесячно - Раз в месяц при первом включении в следующем месяце

Раз в неделю - При первом включении в понедельник

Каждый день - При первом включении на следующий день

Каждые 4 часа - Каждый день в 4, 8, 12, 16, 20 и 24 часа

Каждый час - После начала каждого часа

Каждые 30 минут - Два раза в час в 00 и 30 минут.

Копирование по запросу - если количество сохраняемых копий равно 0, то копирование "по запросу" запрещено. Иначе пользователь может в любой момент времени сделать копию базы данных с помощью меню "Файл/Копирование текущей базы данных", или нажав правую кнопку мыши на нужной базе данных и выбрав пункт "Создать копию базы данных" из появившегося меню.

Если указано несколько периодов копирования, например, Ежегодно и Ежемесячно, то каждый месяц будут создаваться ежемесячные копии, а раз в год - годовая копия.

Для каждого из периодов копирования можно указать количество сохраняемых для него копий. Например, если для Ежедневного копирования задать 5 копий, то в первый день будет создана первая копия, во второй - дополнительно к ней вторая и т.д. На пятый день будет создано пять копий. На шестой день новая копия заместит собой самую старую из существующих копий.

  • Тестирование после копирования

Если здесь стоит галочка, то после копирования базы данных автоматически производится тестирование полученной копии. Результат тестирования можно увидеть в разделе "Существующие копии баз данных" .

Процесс тестирования при не очень больших размерах базы данных (до 100 Мбайт) занимает несколько минут. Если сервер приложений не выключается на ночь, то копирование и тестирование будут идти ночью, не мешая работе.

Рекомендуется использовать автоматическое тестирование, т.к. оно позволяет заблаговременно узнать о том, что база данных требует реорганизации. Если же базы данных имеют очень большие размеры или автоматическое тестирование мешает работе, то этот режим можно отключить.

  • Приоритет процесса копирования и тестирования

По умолчанию копирование и тестирование копии базы данных происходят в отдельном процессе, который выполняется только при простое основной задачи. Этот приоритет назван "низкий".

При использовании "среднего" приоритета, процесс тестирования имеет приоритет на 1 меньше, чем основная задача.

"Обычный" приоритет выполняет тестирование одновременно с основной задачей с тем же приоритетом, который имеет Сервер приложений.

Если требуется производить копирование и тестирование максимально быстро, пусть даже с небольшим замедлением работы пользователей, то следует использовать "обычный" приоритет. Это имеет смысл если база данных имеет большой размер и копируется и тестируется каждые 30 минут.

При использовании "низкого" приоритета замедление работы пользователей минимально, но и копирование и тестирование могут идти значительно дольше.

Примечания:

Копии создаются только в те дни, когда идет работа с сервером приложений. Если, например, с ним не работали неделю, то при включении сервера приложений создастся не семь копий за все предыдущие дни, а только одна за последний день.

Если после создания последней копии, с базой данных не работали, то новые копирования выполняться не будут. Это обеспечивает сохранность предыдущих копий от перезаписи одной и той же копией. При возобновлении работы с базой данных копирование возобновляется.

Если не выполнять настройку копирования, то по умолчанию для всех баз данных установлено создание пяти ежедневных копий, т.е. копий за последние 5 дней.


Индивидуальные настройки

В верхней части этого окна расположен список баз данных, с которыми работает сервер приложений. При передвижении курсора по нему в нижней части экрана появляются индивидуальные настройки для копирования текущей базы данных.

Индивидуальные настройки полностью совпадают с общими настройками , за исключением того, что появляется дополнительный переключатель "Для этой базы данных использовать общие настройки". Если он включен, то данная база будет копироваться так, как описано в общих настройках.


Существующие копии баз данных

В этом окне находится информация о копиях баз данных, которые есть в данный момент.

Для облегчения поиска нужной копии используется трехуровневый список.

На первом уровне находятся имена файлов баз данных. По умолчанию это SKLADSLS, хотя Вы можете создавать базы данных с любыми именами. В этом случае на первом уровне будет находится список всех различных имен Ваших баз данных.

На втором уровне для каждого из имен баз данных находится список директорий, в которых есть базы с таким именем. Например, если у Вас есть две базы данных с именем SKLADSLS, одна из которых находится в директории C:\SKLAD\, а вторая в C:\SKLADOLD, то на втором уровне для имени SKLADSLS Вы увидите две записи:

C:\SKLAD\skladsls.dbx

C:\SKLADOLD\skladsls.dbx

На третьем уровне для каждой конкретной базы данных находится список существующих копий этой базы данных. Список отсортирован по дате и времени копирования. Возле каждой из копий находится одна из пиктограмм:

- При тестировании этой копии ошибок не обнаружено.

- Тестирование копии не выполнялось или не было проведено до конца.

- При тестировании копии были обнаружены ошибки.Рядом написано количество обнаруженных ошибок.

Если курсор стоит на строке в списке копий базы, то в нижней части экрана появляется информация о местоположении этой копии на диске. Кроме того, появляется дополнительные кнопки "Просмотреть результаты тестирования", "Тестировать" и "Восстановить".

Кнопка "Просмотреть результаты тестирования" активна только если при тестировании были обнаружены ошибки. При ее нажатии показываются результаты теста.

Кнопка "Тестирование" позволяет провести тестирование копии.

Кнопка "Восстановление" осуществляет восстановление базы данных с выбранной копии.

Внимание! При восстановлении базы данных с копии вся информация, введенная в базу данных после даты копирования ПРОПАДЕТ. Используйте восстановление только в случае, если нет другого способа восстановить информацию.


Скрытые базы данных.

При обычной работе сервера приложений пользователи должны иметь права на доступ к директориям, где находятся файлы баз данных. Это необходимо для того, чтобы пользователь мог выбрать для открытия нужную ему базу данных.

Иногда для улучшения защищенности системы требуется полностью запретить доступ пользователям к директориям с файлами баз данных.

Для того, чтобы пользователи могли работать с базой данных не имея доступа к директории, где она находится, нужно использовать этот пункт меню. После его выбора на экране отображается таблица, в которой перечислены все файлы баз данных, подключенных в данный момент к серверу приложений.

Эта таблица содержит три колонки:

  • Колонка, в которой ставится отметка о необходимости генерации файла связи для данной базы.
  • Имя базы данных - Колонка с полным путем и именем базы данных
  • Файл связи - Колонка с именем файла связи, который будет сгенерирован для данной базы. Как правило, это имя совпадает с именем файла базы данных. Если к серверу подключено несколько одноименных баз, находящихся в разных директориях, то к имени добавляется "~" и номер, чтобы все имена в колонке были различными.

Кроме того есть кнопки:

  • "Отметить все" - все базы данных отмечаются для создания файлов связи.
  • "Снять все отметки" - Отметка снимается со всех баз данных.

Для установки/снятия отметок на конкретных базах данных можно установить курсор на нужную базу данных и нажать ПРОБЕЛ, или просто кликнуть по нужной строчке мышкой.

  • "Отказаться" - отказаться от создания файлов связи.
  • "Создать" - Создать файлы связи. В поддиректории Links, которая располагается внутри директории, где находится sls_serv.exe, для каждого из отмеченных файлов, создается файл связи. Это обычный текстовый файл с расширением DBY. В нем содержится информация о сетевом адресе сервера приложений и имени и пути к соответствующей базе данных (как она видна на экране сервера приложений).

Полученные файлы связи можно расположить в любой открытой для пользователей директории. Пользователям достаточно иметь права на чтение в этой директории. Сама директория (или директории) может находиться на любом из компьютеров в сети.

Если Windows-овская прикладная программа открывает такой файл как обычную базу данных, то по имеющейся в файле связи информации она вызывает сервер приложений и получает доступ к реальной базе данных, подключенной к серверу приложений.

В этом режиме могут работать только сетевые версии программ. Если требуется однопользовательский режим работы, например, тестирование или выгрузка базы данных, то администратор должен подключаться к реальной базе данных, а не к файлу связи.

При изменении сетевого адреса сервера приложений или местоположения баз данных требуется повторное создание файлов связи.


Технические подробности

Этот раздел предназначен для системных администраторов. Знакомство с ним не обязательно для работы.

  • Копирование баз данных

Все копии баз данных, с которыми работает сервер приложений, находятся в директории, которая задана в поле Основная директория для копирования в общих настройках .

Дальнейшая структура директорий содержит три уровня:

1) Внутри основной директории, по мере необходимости, сервер приложений создает поддиректории с фиксированными именами:

YEAR - для ежегодных копий

3_MONTHS - для ежеквартальных копий

MONTH - для ежемесячных копий

WEEK - для еженедельных копий

DAY - для ежедневных копий

4_HOURS - для копий каждые 4 часа

HOUR - для часовых копий

30_MIN - для тридцатиминутных копий.

USER - для копий по запросу.

2) Внутри каждой из этих поддиректорий находятся поддиректории, имена которых совпадают с именами соответствующих баз данных. Причем для одноименных баз данных, которые располагаются в разных директориях, создаются дополнительные цифровые расширения. Например, если у Вас есть две базы данных с именем SKLADSLS, одна из которых находится в директории C:\SKLAD\, а вторая в C:\SKLADOLD, то будут созданы две поддиректории:

SKLADSLS

SKLADSLS.1

3) Каждая из таких поддиректорий содержит текстовый файл с именем db_name.inf. В этом файле в первой строке написан путь и имя исходного файла базы данных, копии которого содержатся в данной директории. Кроме того здесь находятся поддиректории с числовыми именами "1", "2" и т.д., в которых и содержатся копии базы данных. Количество этих поддиректорий определяется количеством сохраняемых копий, заданным в общих или индивидуальных настройках.

Программа сервер приложений создает все вышеупомянутые поддиректории и файлы, но никогда их не уничтожает. Поэтому, если Вы решили, например, вместо пяти копий сохранять три, и изменили соответствующим образом настройки программы, то "ротация" копий будет происходить в поддиректориях "1", "2" и "3", а поддиректории "4" и "5" останутся без изменений.

Если с базой данных давно не работали и существует копия с датой большей, чем дата последних изменений в базе данных, то эта база больше не копируется. Как только с базой данных опять начнут работать, копирование возобновится.

В процессе копирования сначала определяется место, куда надо копировать базу данных. После этого в найденной директории удаляется старая копия для того, чтобы освободить место на диске для копирования. Само копирование состоит из двух этапов. Сначала база данных копируется в файл с именем <имя базы данных>.db- (например, SKLADSLS.DB- ). Если копирование успешно дошло до конца, то полученный файл копии переименовывается в <имя базы данных>.dbx (например, SKLADSLS.DBX). Это позволяет отличить незавершенную по каким-то причинам копию от завершенной. В списке копий базы данных показываются только завершенные копии.

Если в процессе копирования возникли какие-нибудь ошибки, то копирование прекращается, а сообщение об ошибке пишется в системный файл сервера приложений SLS_SERV.LOG, который находится в той же директории, что и программа. Этот файл можно просматривать любым текстовым редактором, который понимает текстовые файлы в кодировке ASCII (DOS), или нажав клавишу F3 в основном окне сервера приложений.

Поскольку никто постоянно не следит за работой сервера приложений, системному администратору имеет смысл хотя бы раз в неделю заглядывать в этот файл.

Информация о настройке копирования общей и индивидуальной хранится в двоичном файле SLS_SERV.CPY, который находится в той же директории, что и SLS_SERV.EXE.

  • Диагностическая информация

При возникновении ситуаций, которые требуют анализа, диагностическую информацию можно получить в следующих файлах:

В директории, где находится SLS_SERV.EXE

SLS_SERV. DBA - файл протокола анализа очереди (текущий). Получается при включении протоколирования в "Анализе очереди" .

SLS_SERV. DBC - предыдущая часть протокола

SLS_SERV. DBG - файл протокола событий на сервере приложений. Получается при включении " Протоколировния событий на сервере " (Меню "Файл").

SLS_SERV. DBB - предыдущая часть протокола

SLS_SERV. DMP - содержимое внутренних регистров сервера приложений. Получается при выборе в меню " Файл " пункта "Dump памяти".

SLS_SERV. LOG - файл, в котором находится информация о работе с Сервером приложений - Включении/выключении, сообщения об ошибках.

В директории каждой из баз данных

<Имя базы>.ERR - Сообщения об ошибках при работе с этой базой данных.

Если используются "скрытые" базы данных , то этот файл находится не в той директории, где находится база данных (*.DBX), а в той директории, где находится ссылка на нее (*.DBY). Если для разных пользователей используются ссылки, находящиеся в разных местах, то и ошибки для каждого из них будут писаться в соответствующей директории.

  • Настройки

В директории, где находится SLS_SERV.EXE расположены следующие настроечные файлы:

SLS_SERV.CFG - Информация из " Установки параметров работы ".

SLS_SERV.CPY - Информация из " Настройки копирования ".

SLS_SERV.JOB - Информация о настройках запуска заданий по таймеру

SLS_SERV.EVN - Информация о настройках обработки событий

В Registry в разделе HKEY_CURRENT_USER\Software\Softland Systems\SLS_SERV находится информация о режимах протоколирования .

Все перечисленные выше диагностические и настроечные файлы (кроме sls_serv.cpy) - обычные текстовые файлы формата ASCII (DOS).

  • Использование протоколов

В прикладной программе (например SLS-Склад) можно установить сетевой протокол, по которому программа будет работать с Сервером приложений. Для этого в прикладной программе надо вызвать "Файл > Системная информация" и нажать в появившемся окне кнопку "Настройка".

На экране появится окно настройки рабочей станции. В верхней части окна будет отображаться список доступных на данной станции протоколов.

Если настройка производится после подключения к базе данных, т.е. когда программе известен адрес Сервера приложений, то под таблицей доступных протоколов имеется кнопка "Тестирование скорости связи".

После ее нажатия происходит проверка связи на всех протоколах, которые есть на данной рабочей станции, и в то же время включены на Сервере приложений. После завершения тестирования можно двойным кликом в первой колонке выбрать наилучший протокол. Этот протокол становится "протоколом по умолчанию" для данной рабочей станции.

Скорость (и возможность) связи зависит от конфигурации сети и от того, какие версии Windows установлены на рабочей станции и на Сервере приложений. Если они разные, то работа по некоторым протоколам может быть невозможна.

При подключении к базе данных, рабочая станция пытается подключиться по "протоколу по умолчанию". Если это не удается, то она последовательно перебирает все доступные протоколы, пока не найдет тот, по которому возможна связь. Этот перебор может занимать достаточно большое время (от 10 секунд до минуты). Поэтому при возникновении больших задержек от появления на экране окна программы до приглашения на ввод пароля (или открытия базы), надо попробовать в первую очередь установить правильный "протокол по умолчанию".

Если используется протокол UDP/IP, то проблема с медленным запуском может быть связана с неверной настройкой DNS. Имеет смысл проверить, что команда PING с параметром "имя компьютера сервера" нормально работает на рабочей станции.


Старт и завершение работы

Во время запуска программы сервера приложений происходит открытие файлов баз данных. Если файл, описанный в конфигурации не найден или не может быть открыт по каким-то другим причинам, то сообщение об этом выводится на экран и записывается в журнал. Сообщение держится на экране не более 5 секунд, после чего закрывается автоматически.

Если после запуска сервера приложений в течение 5 секунд не нажимались какие-нибудь клавиши, то задача автоматически минимизируется.

При завершении работы программы всегда задается вопрос о том надо ли завершать работу и, если есть подключенные пользователи, то надо ли их отключать. При отрицательном ответе на любой из этих вопросов сервер приложений продолжает работу.

Если происходит закрытие Windows при работающем сервере приложений, то он выдает на экран сообщение о том, что Windows заканчивает работу и спрашивает надо ли закрывать сервер приложений. При отрицательном ответе закрытие Windows прекращается и работа продолжается. Если ответа не поступило в течение 5 секунд, то работающие пользователи отключаются и сервер приложений закрывается. После этого продолжается закрытие Windows.


Специальные варианты запуска

Сервер приложений можно запускать несколькими способами.

  • Обычный запуск

Сервер запускается на компьютере как обычная задача. В этом случае имеет смысл включить его в Автозагрузку, что гарантирует запуск сразу после старта Windows и подключения пользователя к Windows. Сервер приложений после старта и инициализации сворачивается и выглядит как кнопка в панели задач. Иконка сервера меняется на лампочку зеленого, желтого или красного цвета в зависимости от степени загрузки сервера. Это позволяет контролировать состояние сервера не разворачивая его во весь экран.

Такой режим запуска рекомендуется для небольших сетей, в которых нет выделенного сетевого сервера.

Когда пользователь на этом компьютере завершает сеанс работы в Windows, презагружается или завершает работу Windows, Сервер приложений высвечивает окно с вопросом о том, надо ли завершить работу. Если на вопрос не ответить в течение 10 секунд, то все завершится автоматически. Если отказаться от завершения работы Сервера приложений, то закрытие Windows прекратится.

  • Сворачивать Сервер приложений в трей

Все работает так же, как описано в предыдущем пункте, однако, при минимизации окна Сервера приложений кнопка в панели задач пропадает. Иконка, соответствующая состоянию работы Сервера приложений, отображается в системном трее около часов.

  • Запуск в режиме удаленного доступа

Если есть выделенный сетевой сервер и требуется управление Сервером приложений с другого компьютера, то сервер приложений можно запустить следующим образом:

SLS_Serv.exe Remote

(см. также описание пунктов меню "Настройка" )

Параметр Remote можно или добавить в командную строку иконки запуска, или сделать командный файл, из которого будет вызываться программа сервера приложений с параметром Remote.

При таком запуске Сервер приложений запускается "невидимым" - на экране нет его окна, на панели задач нет его кнопки. Однако в списке диспечера задач он присутствует.

Для управления работой запущенного таким образом Сервера приложений используется дополнительная программа Монитор (Monitor.exe). Она должна находиться в той же директории, где находится Sls_Serv.exe, иначе она не сможет установить с ним связь.

Программа Монитор может быть запущена на любом из компьютеров сети, с которого видна директория, где находится Sls_Serv.exe, и в этой директории есть права на чтение и запись. Работа с программой Монитор описана в разделе "Вспомогательная программа Monitor".

Такой режим запуска рекомендуется для случаев, когда удобнее управлять работой Сервера приложений дистанционно.

В режиме удаленного доступа при завершении работы (или сеанса) Windows, Сервер приложений получает от Windows предупреждение об этом и нормально завершается. Никаких вопросов на экране при этом не появляется.

  • Запуск сервера приложений до подключения пользователя к серверу.

Для того, чтобы Сервер приложений мог работать до подключения пользователя к Windows (т.е. когда на экране висит приглашение "Нажмите Ctrl+Alt+Del"), надо сделать следующее.

Вызвать Планировщик Заданий (Task Sheduler). Он находится в Панели управления Windows (Control Panel) , или в Проводнике Windows (Explorer) - в конце раздела "Мой компьютер".

Создать новое задание. Указать там в качестве выполняемой программы Sls_Serv.exe, в качестве времени выполнения - "при загрузке компьютера". Указать пользователя, от чьего имени будет запущен сервер приложений, и его пароль. На последней закладке проставить "Дополнительные параметры" и в командной строке после вызова SLS_Serv.exe добавить через пробел параметр Remote.

После этого Сервер приложений будет запускаться в "невидимом" режиме сразу после старта компьютера до подключения пользователя. Если пользователь подключится, то Сервер приложений будет продолжать работу. При завершении сеанса пользователя (т.е. возврата на экран "Нажмите Ctrl+Alt+Del") Сервер приложений не завершится, а будет по-прежнему работать.

Управлять работой Сервера приложений в таком режиме можно только с помощью программы Монитор (см. предыдущий пункт).

Этот режим рекомендуется если Сервер приложений работает на выделенном сервере Windows.

Как уже говорилось в этом режиме, начало сеанса Windows (т.е. подключение пользователя) и его завершение (отключение пользователя) на работу Сервера приложений не влияют. При завершении работы Windows Сервер приложений не получает от Windows сообщения об этом, поэтому его работа завершается без записи в протокол сервера приложений о завершении. Если в этот момент кто-то из пользователей ведет запись в базу данных, то результатом может быть порча базы данных.

Поэтому настоятельно рекомендуется при выключении сервера Windows:

1) Завершить работу Сервера приложений программой Монитор.

2) Завершать работу сервера Windows не просто выключением питания, а через "Завершение работы" (Shut down).


Дополнительная программа Monitor

  • Программа Монитор.

Программа Монитор предназначена для дистанционного управления Сервером приложений.

Для нормальной работы программы Монитор:

1) Сервер приложений должен быть запущен в "невидимом" режиме , т.е. с параметром Remote.

Если при запуске программы Монитор Сервер приложений еще не был запущен, и программа Монитор запускается на том же компьютере, где установлен Сервер приложений, то Монитор запустит его самостоятельно. При этом Сервер приложений будет запущен из той же директории, где находится Monitor.exe и в правильном режиме.

Поэтому для упрощения настроек можно в автозагрузку включать не SLS_Serv.exe, а Monitor.exe.

2) Программы Sls_serv.exe и Monitor.exe должны быть запущены из одной и той же директории.

3) Программа Monitor.exe должна иметь права на чтение и запись в эту директорию.

Для уменьшения загрузки Сервера приложений немного изменен внешний вид интерфейса. Если программа Монитор запущена, то загрузка Сервера приложений увеличивается на 1 процент по сравнению с обычным режимом.

Меню программы Монитор почти полностью соответствует меню Сервера приложений.См. Меню "Файл" , "Анализ" , "Действия" , "Настройка" .

Единственным отличием является пункт "Завершить работу сервера приложений" в меню "Файл". У него убрана горячая клавиша Alt+X (теперь она завершает работу Монитора) и добавлена возможность не только завершить работу Сервера приложений, но и перезапустить его, что требуется иногда при изменении настроек.

В главное меню добавлен пункт "Монитор", который состоит из трех пунктов:

  • Сворачивать монитор в трей. Этот пункт будет невидим при запуске под Windows 95/98 и ME, поскольку они не позволяют управлять треем.

Если этот пункт не отмечен, то при сворачивании Монитора, программа сворачивается как обычная задача с кнопкой на панели задач. При этом в трее там, где у Windows обычно находятся часы, светится пиктограмка в виде лампочки, которая отображает текущее состояние Сервера приложений. Пиктограмка присутствует, конечно, только в тех версиях Windows, где это возможно. Для того, чтобы развернуть Монитор, можно использовать или кнопку на панели задач, или дважды кликнуть по пиктограмке в трее, или через меню на правой кнопке мышки над пиктограмкой.

Если этот пункт отмечен, то кнопка в панели задач не отображается, и открыть окно Монитора можно только через пиктограмку.

По умолчанию этот пункт меню включен. Текущее состояние запоминается в реестре и восстанавливается при перезапуске программы.

  • При запуске второго монитора закрываться.

Если этот пункт меню включен, то при запуске второго экземпляра программы Монитор (возможно, на другом компьютере), предыдущий экземпляр программы автоматически закроется.

Если этот пункт меню не включен, то в описанной выше ситуации, предыдущий экземпляр программы продолжит работать, а новый экземпляр выдаст сообщение о невозможности запуска и прекратит работу.

В обоих случаях существенно только состояние этого пункта у той программы, которая названа "предыдущей".

По умолчанию этот пункт меню включен. Текущее состояние запоминается в реестре и восстанавливается при перезапуске программы.

  • Завершить сеанс связи Alt+X.

При выборе этого пункта меню программа Монитиор заканчивает работу. Завершение программы Монитор никак не отражается на работе Сервера приложений.


Обнаружение неисправностей

При возникновении непонятного поведения сервера приложений - медленная работа, большое время обслуживания пользователей и т.п. надо сделать следующее.

1. Кликнуть мышкой по "Состояние сервера" или выбрать из меню "Анализ" пункт Анализ очереди . Выяснить что делает "Проблемный пользователь" и или отключить его, или дождаться завершения его задания.

2. Если все-таки непонятно в чем дело, то выполнить следующие действия

3. С помощью меню "Действия" / Dump памяти получить внутреннее состояние сервера приложений.

4. Включить секунд на 30 - 60 Протоколирование событий на сервере , а затем выключить его.

5. Упаковать файлы sls_serv.dmp и sls_serv.dbg, которые были получены в п.п. 3 и 4 в директории, где находится sls_serv.exe и переслать их в СофтЛенд Системз для анализа. При этом надо также по-возможности подробно описать ситуацию, в которой были получены эти файлы.

6. Если было включено постоянное протоколирование событий и/или анализа очереди, то надо передать для анализа все файлы вида SLS_SERV. D*, т.е.

SLS_SERV. DBA

SLS_SERV. DBB

SLS_SERV. DBC

SLS_SERV. DBG

SLS_SERV. DMP