<Назначение программы>

Программа SLS-Касса (Kassa_W.exe) предназначена для проведения продаж и списания товаров с использованием кассовых аппаратов из базы данных SLS-Склад.

Программа SLS-Касса может работать под управлением Windows 98 / NT / 2000 / XP / 2003 / Vista. Специфических требований к памяти и быстродействию нет.

Программа SLS-Касса существует в двух модификациях - SLS-Касса и SLS-Касса Плюс. В данной справке описывется полный вариант программы (SLS-Касса Плюс). Те места, которые касаются только версии Плюс, отмечены значком

При работе программа может использовать следующее оборудование:

  • ККМ, поддерживаемые общим драйвером АТОЛ, например, фискальные регистраторы Феликс. Полный перечень поддерживаемых драйвером ККМ можно узнать в фирме АТОЛ ( www.atol.ru ).

  • ККМ, поддерживаемые драйвером ФР А-4 фирмы Штрих-М, например, фискальные регистраторы Штрих ФРК. Полный перечень поддерживаемых драйвером ККМ можно узнать в фирме Штрих-М ( http://ww.shtrih-m.ru ).

  • Фискальные регистраторы Мебиус. Фирма АРЕС-КОМПАНИ ( http://ares-company.ru )

  • ККМ АМС-100К с драйвером CHON100K.DLL, разработанным ООО Версия-Т ( http://www.vtsoft.ru )

  • ККМ АМС-100Ф с драйвером CHON100.DLL, разработанным ООО Версия-Т ( http://www.vtsoft.ru )

  • Сканеры штрих-кодов любых моделей

  • Кардридеры, подключаемые через RS-232

  • Табло покупателя, подключаемое через RS-232. Могут также использоваться табло покупателя, подключаемые через USB, если у них есть драйвер, создающий виртуальный COM-порт. Поддерживается табло POSUA с USB и COM подключениями.

  • Для печати товарных чеков можно использовать любой принтер, имеющий драйвер Windows.

Если используемый фискальный регистратор позволяет печатать больше 28 символов в строке, то товарные чеки можно печатать не только на принтере, но и прямо на фискальном регистраторе.

Программа работает совместно со следующими программами:

  • SLS-Склад любых версий, начиная с SLS-Склад Стандарт. В программе SLS-Склад ведется список товаров, оформляются приходы, назначаются цены. SLS-Касса не может работать без какой-нибудь версии SLS-Склад

  • SLS-Дисконт. При использовании этой программы обеспечивается работа с персональными дисконтными картами накопительного типа.

  • SLS-Эквайринг. При использовании этой программы для платежей можно использовать банковские карты.

  • SLS-Кассовый сервер. При использовании этой программы настройки Кассовых программ, обновления номенклатуры и запись в базу данных могут выполняться централизовано, не мешая работе кассира.

Установка программы и быстрая первоначальная настройка описаны в разделе " Установка и Мастер первоначальной настройки "

Полная настройка программы SLS-Касса описана в разделе "Настройка программы"

В разделе Работа кассира описан порядок работы кассира

В разделе Переход с ДОС описаны основные отличия этой версии программы SLS-Касса от ее ДОСовского варианта.

Технические детали реализации см. в разделе " Технические детали ".


Установка и Мастер первоначальной настройки

Установка программы выполняется запуском файла Setup_Kassa.exe. Далее надо следовать инструкциям установщика.

Программу Касса рекомендуется устанавливать непосредственно на компьютерах, которые будут использоваться как рабочие места кассиров. В этом случае они могут продолжать работу даже если есть какие-то проблемы в локальной сети (если она используется).

До первого запуска программы Касса рекомендуется в программе SLS-Склад установить необходимые Глобальные параметры, создать нужные склады (места учета товаров), и хоть одну карточку товара с ценой продажи и ненулевым количеством на том складе (складах) откуда программа Касса будет производить продажи

При первом запуске программы Касса, появляется окно "Упрощенная настройка программы Касса". Мастер первоначальной настройки позволяет сразу выбрать минимально необходимые параметры работы и создать описание одного рабочего места и одного пользователя программы Касса.

Можно отказаться от использования Мастера и сделать нужные настройки вручную (см. Первоначальные настройки ), однако Мастер позволяет сделать это проще.

Полные воможности настройки доступны в программе Касса через меню по клавише F10. (см. Настройка программы ).

Мастер первоначальной настройки вызывается, если программа Касса не нашла сохраненных ранее настроек. Если требуется его повторный вызов, то надо или удалить ранее сделанные настройки целиком, или удалить в них строчку WorkPlace = <номер рабочего места>.

В зависимости от выбранного места хранения настроек , настройки хранятся или в текстовом файле Kassa_W.ini (по умолчанию), или в реестре Windows в HKEY_CURRENT_USER \ Software \ SoftLand Systems \ Kassa. Текстовый фал можно корректировать Блокнотом, а реестр - программой regedit.

Мастер первоначальной настройки

Работа с мастером начинается с окна, в котором нужно выбрать:

  • Конфигурация программ. Тут надо указать как будет работать программа Касса - самостоятельно или с дополнительной программой Кассовый сервер.

Работа БЕЗ программы Кассовый сервер. Этот пункт надо выбирать, если у Вас нет программы Кассовый сервер и программа Касса все настройки делает сама.

Программа Кассовый сервер будет работать на этом же компьютере. Если программа Кассовый сервер будет работать на этом же компьютере, то все пути к файлам (база данных и т.д.) у нее будут такие же, как и у программы Касса. В этом случае Мастер первоначальной настройки сразу настроит все необходимые параметры и для Кассы и для Кассового сервера.

Программа Кассовый сервер будет работать в этой же локальной сети. В этом случае Мастер первоначальной настройки сделает все настройки и для Кассы и для Кассового сервера. Однако, перед началом работы надо будет в настройках Кассового сервера вручную указать путь к базе данных и папке связи.

Программа Кассовый сервер будет работать в другом (удаленном) месте. Эта конфигурация используется в том случае, если Кассовый сервер будет работать в центральном офисе, программа Касса - в магазине, который находится в другом месте. Кассовый сервер будет готовить для Кассы информацию о товарах и загружать в базу данных продажи программы Касса. В этом случае Мастер первоначальной настройки настраивает только параметры программы Касса. Настройки Кассового сервера делаются в ручном режиме в центральном офисе.

В зависимости от выбранной "Конфигурации программ", меняется содержимое экранов настройки Мастера и его рекомендации по выбору параметров.

  • Путь и имя базы данных. Часть настроек программы Касса локальные - от них зависит только работа самой программы. Эти настройки хранятся на том компьютере, где работает программа Касса. От других настроек зависит как работа программы Касса, так и взаимодействие с базой данных. Эти настройки хранятся в базе данных программы Склад. Если в этом пункте указана база данных, то Мастер выполняет как локальные, так и общие настройки. Если база не указана, то он может сохранить только локальные настройки. Общие настройки придется делать вручную в программе Кассовый сервер.

После заполнения этих двух пунктов надо нажать кнопку "Дальше >>" и начнется собственно настройка.

Настройки рабочей станции

  • Номер рабочего места. Здесь надо указать произвольное число (например, 1), которое будет использоваться как идентификатор кассового места в программе. Если программа работает с Кассовым сервером, то это же число должно быть записано в описании этого рабочего места.

  • Режим работы. Здесь надо выбрать один из возможных режимов программы Касса. Исходно устанавливается предпочтительный режим в соответствии с выбранной ранее Конфигурацией программ.

Настройки рабочей станции (продолжение).

  • Тип используемой ККМ. Здесь надо выбрать тип фискального регистратора, с которым будет работать программа Касса. Если она будет использоваться без фискального регистратора, то можно выбрать "Работать без испоьзования ККМ". Для работы с фискальным регистратором будет нужен драйвер от его производителя. Этот драйвер обычно приложен к фискальному регистратору на CD. Его также можно взять на сайте производителя.

  • Использование сканера штрих-кодов. Если предполагается для ввода товаров использовать сканер штрих-кодов, то здесь можно указать его тип и подключение. Если сканер подключается "в разрыв клавиатуры", то рекомендуется выбрать "Подключен в разрыв клавиатуры (определяется по скорости)". Если он подключается к COM-порту (или создает виртуальный СОМ-порт), то нужно выбрать "Подключен через СОМ-порт".

Отличить эти два типа сканеров достаточно просто - сканер, подключаемый "в разрыв клавиатуры" передает прочтенный штрих-код в любые программы - Word, Excel, Блокнот, то есть при сканировании в них появляется текст с номером штрих-кода.

  • Путь к папке связи с Кассовым сервером. Это поле видно только если в Конфигурации программ выбран режим работы с Кассовым сервером. Тут надо указать произвольную папку, через которую программа Касса будет обмениваться информацией с Кассовым сервером. Если Кассовый сервер работает на этом же компьютере, или в локальной сети, то в его настройках должна быть указана эта же папка. Если Кассовый сервер работает удаленно, то в его настройках указывается какая-то своя папка, а нужные для обмена файлы передаются между папкой Кассы и папкой Кассового сервера вручную - с курьером, по e-mail и т.д.

Следующие страницы настройки ( 3 и 4 ) появляются только если была указана база данных - это настройки, которые должны храниться в ней.

Описание в базе данных программы Склад.

  • Название рабочего места для отчетов. Здесь можно указать произвольное название. Например, "Касса 1", "Касса гастрономии" и т.д.

  • Какие цены использовать для продаж. Здесь нужно выбрать цену, по которой товары будут продаваться программой Касса. Для выбора доступны три цены из карточки товара и любые цены из прайс-листов, которые описаны в программе Склад.

  • Обслуживаемые отделы. Это поле видно только если в программе Склад включено использование нескольких складов (мест учета товаров). В нем надо выбрать один или несколько складов, с которых будут вестись продажи. В программе Касса эти склады будут видны как "отделы".

Описание пользователя программы Касса.

  • Имя кассира для подключения к программе. Здесь надо ввести имя, которое кассир будет вводить в ответ на запрос имени и пароля при начале работы с программой Касса. Рекомендуется не использовать длинных имен (например, "Семенов-Тяньшанский") - кассиру будет неудобно вводить его каждый раз. Можно ограничиться каким-нибудь цифровым именем - "1", "2" и т.д.

  • Права для работы с программой Касса. При выборе прав справа от поля отображается краткий комментарий. Для работы с ККМ (пробития чеков) не обязательно выбирать "Кассир". Пробивать чеки может пользователь с любыми правами (см. описание следующего поля).

  • Продажи учитывать на карточке. При пробитии чека, в базе данных программы Склад создается расходная накладная для списания товара. В заголовке этой накладной должен быть указан покупатель, на которого производится списание. Именно этого покупателя надо указать в этом поле, чтобы пользоватнль мог пробивать чеки.

Обычно для каждого кассира создается своя карточка покупателя. В этой карточке должно быть заполнено только поле "Краткое название" и "Валюта учета" должна быть "РУБ.". Остальные поля не обязательны для заполнения.

При продажах и создании расходной накладной на карточке покупателя возникает долг. Можно в платежах этой карточки отмечать сдачу кассиром денег. Тогда по балансу карточки можно будет контролировать продажи и полученные от кассира деньги.

После заполнения всех полей и нажатия кнопки "Дальше >>" появляется экран с итоговыми настройками. Если все правильно, то нажатие кнопки "Записать" приведет к запоминанию всех настроек.

В папке, где установлена программа Касса создастся файл с названием "Окончание настройки.txt". Если в Windows есть программа для просмотра таких файлов (обычно это Блокнот), то он будет показан на экране.

В этом файле написано что надо сделать для завершения настроек. Например, если требуются какие-то дополнительные настройки в программе Кассовый сервер. В файле есть также краткое описание работы в выбранном режиме.


Первоначальные настройки

В этом разделе кратко описаны те минимальные настройки, которые надо выполнить для работы программы Касса. Те поля и вкладки в настройках, которые не упомянуты в этом разделе, можно оставить со значениями "по умолчанию".

Полное описание настроек можно посмотреть в разделе Настройка , или нажав F1 в любом из окон настроек.

Работа без Кассового сервера (обычный режим).

Настройка состоит из двух разделов - Настройка рабочей станции и Настройка системы (база данных).

В первом разделе настраивается режим работы данной рабочей станции и ее оборудования - фискального регистратора, сканера штрих-кодов и т.п.

Во втором разделе настраивается взаимодействие касс с объектами базы данных - используемые цены, склады, права кассиров и т.п.

Сначала выполняются Настройки рабочей станции:

1) При первом запуске программы появится окно с неактивными полями и надписью "Касса не работает".

2) Нажать клавишу F10 и в появившемся меню выбрать пункт "Настройка".

На вкладке "Общие":

3) Заполнить поле "Номер рабочего места". Например, ввести туда 1 или заводской номер ККМ, установленной на этом рабочем месте. Если с базой данных будет работать несколько программ Касса (сетевая версия), то у всех них в поле "Номер рабочего места" должны быть разные номера.

4) В поле "Режим работы" выбрать "Напрямую с базой данных" или "Автономный - база данных только для обмена".

В первом режиме программа Касса непосредственно работает с базой данных и сразу записывает туда результаты продаж.

Второй режим предпочтительней для однопользовательских версий программы Касса. В этом режиме база данных захватывается только для обновления номенклатуры и записи продаж по команде кассира, то есть можно это делать утром в начале работы и вечером - в конце. Все остальное время база данных свободна для использования ее в программе Склад. В сетевых версиях программ Склад и Касса первый режим предпочтительней.

5) В поле "Путь и имя базы данных для работы без Кассового сервера" надо выбрать нужную для работы базу данных (ту, с которой работает программа Склад).

На вкладке "Фискальный регистратор":

6) В поле "Тип используемой ККМ" надо выбрать тип фискального регистратора, с которым будет работать данное кассовое место. Можно выбрать "Работать без использования ККМ", если фискальный регистратор не предполагается использовать.

При использовании фискальных регистраторов фирмы Атол и Штрих, на компьютере надо установить драйвер соответствующего аппарата. Драйвер прилагается к аппарату. Его также можно бесплатно скачать на сайте производителя.

Для ФР Мебиус в папку, где находится программа Касса (Kassa_W.exe) надо положить файл MoebiusLib.dll (драйвер Мебиус). Его можно получить у фирмы производителя аппарата.

Для ККМ АМС-100 в папку, где находится программа Касса (Kassa_W.exe) надо положить файл chon100.dll (АМС-100Ф) или chon100K.dll (АМС-100К). Эти драйвера можно купить в фирме "Версия-Т".

7) Сохранить настройки.

8) После сохранения настроек появится окно для ввода имени и пароля. В качестве имени надо ввести Admin, а пароль оставить пустым. Если в программе Склад установлен пароль системы (для имени Admin), то надо указать именно этот пароль.

Теперь можно выполнить Настройки системы (база данных).

9) Нажать клавишу F10 и выбрать пункт "Настройка". Появится меню из двух пунктов "Рабочая станция / Система (база данных)" . Надо выбрать "Система (база данных)".

На вкладке "Общие для всех касс":

10) В поле "Какие цены использовать на кассах" выбрать одно из доступных значений - цену из карточки товара или прайс-листа.

11) В поле "Тип кассовой накладной" выбрать один из доступных типов для расходных накладных. Например, "Наличный расчет".

На вкладке "Рабочие места кассиров":

12) Через меню "Действия с описаниями" добавить описание нового рабочего места (можно просто нажать клавишу Insert).

13) В описании рабочего места кассира заполнить следующие поля:

  • поле "Название для меню и отчетов". Это произвольный текст, например, Касса 1.

  • поле "Номер рабочего места". Это должен быть тот же номер, что и в настройках кассового места (см. пункт 3).

  • если в программе Склад включена работа с несколькими складами, то будет видно поле "Обслуживаемые отделы". С помощью кнопки справа от него надо добавить хоть один склад из базы данных, по которому будет производиться списание товаров программой Касса.

14) Если рабочих мест несколько, то добавить их описания (см. пункт 12).

На вкладке "Пользователи и их права":

16) Через меню "Действия с описаниями" добавить описание нового пользователя (можно просто нажать клавишу Insert).

17) В описании пользователя заполнить следующие поля:

  • поле "Имя для подключения к системе". Это то имя, которое кассир будет вводить при подключении к программе Касса.

  • поле "Права для касс" можно выбрать "Администратор". Это дает все права на операции с кассой и на настройки в системе.

  • поле "Учет наличности на карточке". Здесь надо выбрать одну из карточек покупателей в базе данных программы Склад, или создать нового покупателя (например, с именем "Касса"). При создании новой карточки покупателя в ней достаточно заполнить только "Краткое название".

На этого покупателя в базе данных программы Склад будут создаваться расходные накладные на проданные товары. В этой же карточке можно будет отмечать сданные кассиром после смены деньги. Если поле "Учет наличности на карточке" не заполнено, то работа с кассой для данного пользователя будет заблокирована.

18) Если пользователей программы Касса должно быть несколько, то добавить их описания (см. пункт 16).

19) Сохранить все изменения.

20) Обновить номенклатуру и подключиться к программе Касса с именем одного из пользователей, введенных в пункте 17.

ВАЖНОЕ ЗАМЕЧАНИЕ.

Для того, чтобы какие-то товары появились в программе Касса и можно было с ней работать, надо выполнить три условия:

  • В базе данных программы Склад должна быть создана хоть одна карточка товара.

  • Для этого товара должна быть установлена ненулевая цена, которая используется при продаже этого товара (см. пункт 10).

  • Должен быть хоть один приход этого товара. Если в программе Склад включена работа с несколькими складами, то приход должен быть на склад, указанный как обслуживаемый отдел (см. пункт 13).

Работа с Кассовым сервером.

В этом случае настройки делаются почти так же, как описано выше. Отличия:

В Настройке рабочей станции пункты 4 и 5 выполняются следующим образом.

4) В поле "Режим работы" выбрать "Через Кассовый сервер"

5) В поле "Путь к папке связи с Кассовым сервером" надо указать папку, через которую будет осуществляться обмен информацией с программой Кассовый сервер. Эта же папка указывается и в программе Кассовый сервер.

Пункты 8 и 9 не выполняются. Можно просто закрыть программу Касса после выполнения пункта 7.

Все Настройки системы (база данных) ( пункты 10 - 20 ) делаются не в программе Касса, а в программе Кассовый сервер.

После завершения настроек в Кассовом сервере надо в нем сделать обновление номенклатуры, запустить программу Касса и подключиться к ней с именем одного из пользователей, введенных в пункте 17.


Работа кассира.

В этом разделе описана работа кассира.

Для работы кассира достаточно клавиатуры. Мышка для работы не требуется, хотя ее можно использовать.

Навигация

Для перемещения курсора между отдельными полями кроме стандартных Tab и Shift+Tab можно использовать стрелки. Стрелка вправо перемещает курсор в ближайшее поле справа, стрелка вверх - к ближайшему полю сверху и т.д.

Для перемещения в списках используются клавиши со стрелками, PgDn, PgUp, Home и End.

Выполнение действий.

Для того, чтобы можно было работать без мышки, изменен интерфейс окон. В нем отсутствуют кнопки и меню. Вместо этого используется следующий механизм.

На каждом экране в нижней части окна высвечивается подсказка со списком действующих в данный момент клавиш и их назначением. Для выбора соотвествующего действия достаточно нажать клавишу, указанную синим цветом в подсказке.

Если используется мышь, то вместо нажатия клавиши на клавиатуре можно кликнуть по надписи (синим цветом) в подсказке.

Обозначения клавиш в подсказке.

В дальнейшем для обозначения клавиатурных комбинаций используется следующее соглашение.

Одиночная клавиша обозначается текстом, написанным на ней. Например, Esc, Enter, PgDn и т.д.

Если участвуют две клавиши, то они соединяются знаком плюс.

Например, Ctrl+Enter означает, что надо нажать клавишу Ctrl и, не отпуская ее, нажать клавишу Enter. После этого отпустить обе клавиши.

Ctrl+D означает, что надо нажать клавишу Ctrl и, не отпуская ее, нажать D и т.д.

Дальше


Подключение

После запуска программы для начала работы кассир должен подключиться. Для этого на экран выдается окно для ввода имени и пароля.

  • Имя. Здесь надо ввести имя, присвоенное данному кассиру в настройках "Пользователи и их права". При вводе имени заглавные и строчные буквы не различаются. Например, для имени Кассир можно ввести и кассир и кАсСир.

  • Пароль. Здесь надо ввести пароль, присвоенный данному кассиру в настройках "Пользователи и их права". При вводе пароля заглавные и строчные буквы различаются. Например, Abc и abc - это два разных пароля. Если пароль в настройках не установлен, то это поле надо оставить пустым.

При вводе символы пароля заменяются на * , для того, чтобы пароль нельзя было подсмотреть. Если требуется все-таки увидеть какой пароль введен (скажем, программа не принимает введенный пароль), то справа от поля пароль находится кнопка [image] . Если ее нажать (без использования мышки достаточно нажать Ctrl+Tab), то введенный пароль станет видимым. Повторное нажатие этой кнопки (или Ctrl+Tab) опять скроет пароль.

  • Запомнить имя для следующего подключения. Если этот флажок включен, то введенное имя (но не пароль) запомнится и при следующем подключении в поле Имя будет сразу появляться запомненое имя.

Для включения или выключения этого флажка можно кликнуть по нему мышкой или нажать клавишу F2.

После завершения ввода имени и пароля можно нажать клавишу Enter для подключения или Esc для отказа от подключения.

Если кассир сменяется во время работы программы, то он может переподключиться через меню F10 - пункт "Подключиться с другим именем".

Дальше


Главный экран.

После подключения к программе начинается работа.

В верхней части экрана находится табло для покупателя ( 1 ). На нем при работе отображается общая сумма чека, а в остальное время сообщение, заданное в настройках ("Табло покупателя").

Рядом находятся часы ( 2 ) и текущее состояние программы ( 3 ). "Лампочка" горит зеленым при работе с базой данных.

Строка статуса ( 4 ) содержит информацию о скидке (если она есть) и дежурном администраторе (если используется учет продаж по сотрудникам [image] ).

В информации о текущем чеке ( 5 ) перечислены все покупки, которые к этому моменту введены в чек. Колонка "Доп.свойства" присутствует только если в программе Склад включена работа с дополнительными свойствами.

Если включен учет по сотрудникам в режиме "Продавец в каждой покупке", то появляется еще одна колонка "Продавец", в которой для каждой покупки записан продавец.

Если в настройках программы выбрана работа с несколькими отделами, то между ( 5 ) и ( 6 ) появится дополнительное окно для выбора отдела.

В нижней части экрана ( 6 ) находится информация о текущей покупке. Здесь кассир может выбрать товар, установить для него нужное количество и т.п.

Последняя строчка экрана ( 7 ) содержит подсказку - какие команды в данный момент доступны кассиру.

Дальше


Продажа (выбор товаров для чека)

Для выбора товара кассир может использовать несколько способов.

  • Сканер штрих-кодов. Если просканировать штрих-код товара, то программа найдет его и поместит в нижней части экрана как текущую покупку. Курсор при этом переместится в поле "количество", где по умолчанию будет стоять 1.

Если после этого просканировать следующий товар, то предыдущая покупка перепишется из нижней части экрана в основной экран - запишется в чек. То есть для последовательного ввода товаров в чек достаточно просто сканировать товары один за другим.

Если надо ввести большое количество одного и того же товара (скажем, 10 творожных сырков), то вместо того, чтобы сканировать их друг за другом, можно просканировать первый из них и в поле "количество" вместо 1 ввести с клавиатуры 10. После этого можно сканировать следующий товар - он "протолкнет" текущую покупку в чек.

  • Поиск по штрих-коду. Если по какой-то причине сканер штрих-кодов не читает код, то можно ввести этот код вручную. Для этого нужно нажать клавишу F10 (вызов меню) и выбрать пункт "Поиск по штрих-коду". Можно этот пункт меню вызвать просто нажатем Ctrl+D.

Появится окно для ввода штрих-кода. Там надо ввести цифры штрихкода с этикетки и нажать Enter для поиска.

  • Поиск вручную. Если у товара нет штрих-кода, или сканер не используется, то кассир может выбрать нужный товар по одному из признаков - название, номер карточки товара, номенклатурный номер или цена, в зависимости от настроек.

Для выбора того, по какому признаку искать, надо переместить курсор в соответствующее поле. Например, для поиска по названию - в поле "Название". После этого надо нажать клавишу ПРОБЕЛ или первую букву искомого названия товара.

Появится окно выбора товара по названию:

В самой верхней строке для справки приведено время последнего обновления списка номенклатуры. Если оно выполнялось сегодня, то только время, а если не сегодня, то дата и время.

В таблице расположен список товаров, отсортированный по названиям. Для поиска нужного товара можно листать его стрелками (по одной строчке), клавишами PgUp, PgDn (страница вверх/вниз) и Home, End (в начало/конец списка).

Можно также начать набирать нужное название. Тогда под списком появится дополнительная панель для набора и по мере ввода названия курсор в списке будет передвигаться к нужному месту.

В нижней части экрана отображается полное название текущей позиции и дополнительная информация о ней.

Нажатие клавиши F7 покажет на экране табличку с полной информацией о товаре, на котором в данный момент установлен курсор.

После того, как курсор в списке товаров окажется на нужном товаре, можно нажать Enter для выбора этого товара.

Если в базе данных включена работа с дополнительными свойствами и Enter нажат на позиции, которая их имеет, то появится дополнительное окно выбора нужного свойства. В нем надо будет выбрать нужное свойство (цвет, размер и т.п.).

Поиск вручную для других признаков (номер карточки товара, цена, номенклатурный номер) выполняется так же, как описано выше. Для начала поиска надо стрелками влево/вправо выбрать окно с нужным признаком и нажать пробел или первый символ нужного значения.

Дальше


Продажа (корректировка чека)

  • Корректировка текущей позиции.

Пока покупка находится в нижней части экрана (текущая покупка), кассир может свободно менять выбранный для нее товар и количество. При необходимости он может отказаться от нее совсем. Для этого надо нажать клавишу F6 и подтвердить удаление.

  • Корректировка ранее введенной покупки.

Если при наборе чека оказалось, что какая-то позиция введена неверно - не тот товар, неправильное количество, покупатель отказался от покупки, то имеется возможность внести исправления в уже введенные позиции.

Для этого используется меню F10 . Надо нажать клавишу F10 и выбрать пункт "Удалить покупку" (если включен режим указания продавца в каждой покупке, то "Удалить покупку или изменить продавца").

После этого курсор перейдет в список покупок чека. Надо стрелками вверх/вниз поставить курсор на нужную покупку и нажать клавишу Del для удаления строчки из чека (или клавишу F8 для изменения продавца). После предупреждения об удалении покупка будет удалена. После выполнения всех требуемых удалений, надо нажать Esc и вернуться в обычный режим работы

Если покупатель не отказался от покупки, а нужно было изменить товар или количество, то после удаления неверной записи нужно выбрать правильный товар и указать правильное количество так, как это делается обычно.

  • Отказ от чека

Если требуется сбросить весь чек (скажем, покупатель отказался от покупок), то кассиру следует вызвать меню (нажать клавишу F10) и выбрать в нем пункт "Отказ от чека". После предупреждения о сбросе чека, все покупки чека сбросятся и касса будет готова к работе с новым покупателем.

Примечание:

"Отказ от чека" возможен только если в нижней части экрана ("текущая покупка") ничего нет. Если там еще находится какой-нибудь товар, то надо или сбросить его клавишей F6, или нажать Entet, чтобы он перешел в чек. После этого можно нажимать F10 и отказываться от чека.

  • Запрет самостоятельных корректировок.

Если в настройках прав кассиру запрещено самостоятельное изменение чека, то при попытке изменения программа потребует ввести для подтвержденя имя и пароль администратора (или кассира-администратора). Они вводятся так же, как и при первоначальном подключении к системе, но действуют только на время корректировки чека. Как только программа вернется в обычный режим работы, возобновится действие имени и пароля кассира, введенных при начале работы.

Дальше


Продажа (печать чека)

После того, как все покупки набраны в чек (последняя покупка может еще быть внизу в области "текущей покупки"), кассир должен нажать клавишу PgDn для выполнения расчета с покупателем и печати чека.

Появится следующее окно.

В верхней части экрана отображается информация для покупателя - сумма чека, внесенные деньги и сдача.

Кассир может ввести с помощью цифровой клавиатуры сумму, полученную от покупателя. При этом автоматически расчитается сдача.

Если включен учет продаж по сотрудникам, то в нижней части экрана высвечивается панель для ввода Продавца и/или Администратора. Для ввода или изменения Продавца надо нажать клавишу F7, а для ввода или изменения Администратора - клавишу F8.

Кассиру доступны следующие действия:

  • Напечатать чек. Для этого надо нажать клавишу Enter.

  • Вернуться к корректировке чека. Если покупатель отказался от покупок (скажем, забыл дома деньги) или передумал что-то брать, или решил докупить что-то еще, то нажатием клавиши Esc кассир может вернуться в режим работы с чеком и отказаться от него, что-то убрать или что-то добавить. См. раздел Корректировка чека .

  • Без сдачи. Если нажать клавишу F2, то в поле "оплачено" запишется сумма чека.

  • Тип оплаты. Если в настройках рабочего места разрешен прием безналичных платежей (по банковской карте), то нажатием клавиши * кассир может выбрать тип оплаты - наличный или безналичный. По умолчанию для каждого чека принимается наличный платеж.

При выборе безналичного платежа в Х и Z отчетах этот платеж будет проходить отдельной строкой и не будет добавляться в графу "деньги в кассе".

Если программа Касса работает совместно с SLS-Эквайринг, то перед печатью чека с безналичной оплатой произойдет запрос к программе Эквайринг, которая потребует прочесть банковскую карту и проведет авторизацию в банке. В случае положительного ответа, произойдет печать чека и слипов, после чего информация о платеже будет отмечена в базе данных программы Склад.

Если программа SLS-Эквайринг не используется, то кассир должен выполнить авторизацию и списание средств с банковской карты с помлщью банковского терминала и только потом нажимать Enter для печати чека.

  • Специальные режимы печати чека. Эти режимы доступны только сотрудникам с правами администратора и кассира-администратора. Поэтому информации о них в строке посказки нет. Для специальных режимов печати чека надо вместо клавиши Enter нажать Ctrl+Enter. Появится меню из двух строчек:

- Пробить чек, но не списывать из базы. Товар из чека фискализируется на ККМ, но не будет списан из базы данных.

- Списать из базы, не пробивая чек. Фискальный чек не пробъется, но товар спишется из базы данных.

Оба эти режима предназначены только для экстренных ситуаций. Например, списание из базы данных выполнилось, а чек не фискализировался, или наоборот.

Дальше


Возвраты

  • Возврат вручную

Для выполнения возврата товара, кассир должен до начала набора товара нажать клавишу F10 (меню) и выбрать пункт "Чек на возврат товара". На табло в верхней части экрана высветится слов "Возврат". Далее набор и печать чека выполняются точно так же, как и при продаже.

После окончания печати чека на возврат, программа автоматически вернется в нормальный режим работы.

  • Возврат по предыдущим чекам

Имеется вторая возможность - возврат по ранее пробитому чеку. Для этого кассир должен в меню по F10 выбрать пункт "Возврат по предыдущим чекам". Появится окно с информацией о ранее пробитых чеках (только продажи).

Строчки упорядочены по возрастанию даты и времени.

В первой колонке находится номер чека (его можно увидеть на бумажном чеке, принесенном покупателем). Во второй - сумма чека (она должна совпадать с суммой бумажного чека, принесенного покупателем). Далее идет колонка с датой и временем.

Нужный чек можно найти или листая этот список, или вызвав окно поиска по номеру чека нажатием клавиши Пробел.

После того, как курсор установлен на нужный чек, можно нажать клавишу Enter и в главном окне сформируется чек на возврат всего товара, проданного по выбранному чеку. При необходимости, кассир может удалить те позиции, которые не возвращаются. Далее все делается так же, как описано при продаже.

Дальше


Прочие операции (меню F10)

Помимо собственно продаж и возвратов, кассир может выполнить ряд дополнительных операций. Для этого он должен нажать клавишу F10 и выбрать один из предлагаемых пунктов меню. Количество доступных пунктов зависит от текущего режима работы и прав, которые предоставлены кассиру.

  • Ручные скидки F5. Этот пункт меню доступен, если в настройках базы данных введена таблица скидок и кассиру дано право их давать. При выборе этого пункта меню (или нажатия клавиши F5) на экране появляется список доступных скидок. Кассир должен выбрать ту из них, которая соответствует ситуации (скажем, пенсионерам до 11 утра). Выбранная скидка будет применена ко всем покупкам чека.

  • Поиск по штрих-коду Ctrl+D. При выборе этого пункта меню (или нажатия клавиш Ctrl+D) на экране появится окно для ручного ввода штрих-кода, который, например, не прочелся сканером штрих-кодов.

  • Поиск по # номеру Ctrl+E. Для мелких товаров, на которые не помещаются нормальные наклейки со штрих-кодами, можно завести в базе данных коды, начинающиеся с символа #. Например, #123. Для их быстрого поиска можно использовать этот пункт меню.

  • Проверка цены товара F7. Нажатие клавиши F7 позволяет кассиру отсканировав код товара получить информацию о нем - цену, наличие и т.п. В отличие от обычного сканирования, найденный товар не попадает в чек - это чисто информационный режим.

Если вместо кода товара просканировать дисконтную карту, то вместо информации о товаре появится информация о дисконтной карте - ее статус и текущая скидка по ней.

Клавиша F7 работает только если область текущей покупки (в нижней части экрана) пустая, т.е. там нет никакого товара.

Если товар в области текущей покупки есть, то по клавише F7 высвечивается информация об этом товаре. Ввода кода товара или сканирования при этом не требуется.

При выборе товара вручную, нажатие клавиши F7 показывает информацию о том товаре, на котором в данный момент стоит курсор в окне выбора товара.

  • Открыть денежный ящик. Если к ККМ подключен денежный ящик, то его можно открыть этой командой.

  • Положить деньги в денежный ящик. При выборе этой команды появляется окно для ввода вкладываемой суммы. Внесенная сумма фиксируется в ККМ и учитывается при печати строки "деньги в кассе" в X и Z-отчетах.

  • Взять деньги из денежного ящика. При выборе этой команды появляется окно для ввода изымаемой суммы. Изъятая сумма фиксируется в ККМ и учитывается при печати строки "деньги в кассе" в X и Z-отчетах.

  • Печать товарного чека на принтере. Этот пункт меню позволяет выбрать любой чек из ранее пробитых и напечатать по нему товарный чек (на принтере или ККМ, в зависимости от настроек).

  • Печать копии чека на ККМ. Этот пункт меню позволяет выбрать любой чек из ранее пробитых и напечатать его копию на ККМ. Эта копия начинается с текста "Копия чека" и не является фискальным документом.

  • Печать ЦЕННИКОВ. Этот пункт меню появляется только если в папке, где находится программа Kassa_W.exe, создать папку с именем FORMS и поместить в нее описания ценников, созданные программой Cennik.exe. При выборе этого пункта появляется окно печати ценников .

  • Обновление номенклатуры. Этот пункт меню доступен, если касса не работает совместно с Кассовым сервером. Для занесения в программу Касса информации об обновлениях по номенклатуре и ценам в базе данных, кассир должен выбрать этот пункт. Если касса работает в автономном режиме, то одновременно с обновлением номенклатуры поисходит запись о продажах, сделанных кассой со времени последнего обновления.

  • X и Z-отчеты. При выборе одного из этих пунктов на ККМ снимается X или Z-отчет. Х-отчет - отчет о текущем состоянии продаж (его можно снимать в любое время). Z-отчет - закрытие смены и фискализация соответствующих сумм. Этот отчет обычно снимают раз в сутки.

  • Работа с чековой лентой. При проведении продаж и возвратов, все выполненные операции фиксируются в электронной чековой ленте программы Касса. Для просмотра этой чековой ленты, получения отчетов по ней и других операций смотри соответствующий раздел .

  • Завершение работы Alt+X. Выбор этого пункта меню (или нажатие клавиш Alt+X) приводит к завершению работы программы Касса. Этот пункт меню доступен только при закрытом чеке.

  • Подключение с другим именем. С помощью этого пункта меню при смене кассира можно переподключиться не завершая работу программы.

  • Установить имя администратора. Этот пункт меню доступен только если включен учет продаж по сотрудникам и в настройках указано, что учет по администраторам должен использоваться. При выборе этого пункта меню появляется список администраторов, из которого можно выбрать нужного. Выбранный администратор сохраняется до выхода из программы, или до выбора другого администратора.

Если программа Касса работает с Кассовым сервером, то администратор может быть выбран на нем сразу для всех касс магазина.


Печать ценников

конецформыначалоформыДля того, чтобы из программы Касса можно было печатать ценники, надо в той папке, где установлена программа Kassa_W.exe, создать папку с именем FORMS и поместить в нее файлы описания ценников. Эти файлы создаются программой Ценник (Cennik.exe) и имеют расширение "cen".

Если есть папка FORMS и в ней есть описания ценников, то в программе Касса в меню по F10 появляется дополнительный пункт "Печать ценников". Он дает возможность выбрать нужные товары, указать какой ценник надо печатать и напечатать нужное количество экземпляров.

При создании описаний ценников надо иметь в виду, что в кассовой программе нет всей информации по карточке товара, поэтому в ценнике будут печататься только следующие поля:

  • Вся фиксированная (не зависящая от базы) информация -

фиксированные тексты,

линии,

прямоугольники,

дата и время печати и т.п.

  • По карточке товара ("текст из базы данных") можно печатать -

название товара,

номенклатурный номер (и штрих-код по нему),

номер карточки товара,

единицу измерения,

цену.

Если в описании ценника использовать те поля карточки товара, которых нет в кассовой программе, то они напечатаны не будут.

Для упрощения работы, можно скопировать со складского компьютера на компьютер с программой Касса программу настройки ценников (она не привязана к электронному ключу). Это три файла Cennik.exe, Cennik.cnt и Cennik.hlp. Если в настройках программы Ценник указать папку FORMS как папку с этикетками, то можно будет оперативно корректировать внешний вид ценников.

Главное окно печати ценников выглядит следующим образом:

  • Какие ценники печатать. Здесь надо указать какой вид ценника надо использовать для печати. Для выбора нужного ценника надо нажать F5, выбрать из открывшегося списка нужный ценник и нажать Enter.

  • Количество экземпляров. По умолчанию предлагается печать каждого из ценников в одном экземпляре. Изменить количество можно тремя способами:

Нажать F6 и в появившемся окне указать требуемое количество для всех ценников. Это количество проставится во всех уже выбранных позициях товаров и будет ставиться для всех вновь добавляемых.

Нажать F7. Для всех уже выбранных товаров проставится остаток из DAT-файла. То есть для каждого товара будет напечатано столько ценников, сколько его осталось. Для вновь добавляемых товаров также будет ставиться их остаток.

Для того, чтобы поставить количество для какого-то товара вручную, надо поставить курсор на этот товар и нажать F2. Появится окно для ввода нужного количества.

  • Список товаров.

Добавление. Для добавления в этот список товаров, по которым надо печтать ценники, нажмите Ins. Если в настройках рабочего места данной кассы указано несколько отделов, или возможен выбор товаров по нескольким критериям, то появится окно:

В этом окне можно нажатием любой цифры (например, 1) указать нужный отдел, а нажатием ПРОБЕЛА выбрать нужную сортировку показываемого списка товаров. После этого можно нажать Enter для показа списка товаров по выбранному отделу и в нужной сортировке.

Появляется список выбора товара - такой же, как и при обычной работе кассира. Выбранный товар заносится в список товаров для печати.

Примечание. Если товар имеет несколько разных штрихкодов, то надо выбирать запись об этом товаре с тем штрих-кодом, который должен быть напечатан.

Удаление. Для удаления товара из списка, надо поставить на него курсор и нажать Del. После подтверждения удаления позиция будет удалена.

После завершения выбора товаров, установки для них количества ценников и выбора формата ценника, можно нажать PgDn для печати ценников.

Появится вопрос о том надо ли до печати показать ценники на экране.

Если ответить Да (Enter), то ценники будут показаны на экране, а далее можно выбрать нужный принтер и напечатать их.

Если ответить Нет (Esc), то ценники будут напечатаны на принтер, установленный в Windows по умолчанию.

Примечание. Если для печати надо использовать принтер не установленный по умолчанию, то можно для каждого формата ценника в программе Ценник (Cennik.exe) указать необходимый принтер и задать там его параметры.


<Работа с чековой лентой - Главное окно>

Работа с чековой лентой может использоваться для просмотра списка продаж, восстановления накладных в базе данных и прочих системных нужд. Для работы с чековой лентой имеет смысл подключить мышку.

В окне находится список всех покупок, которые были произведены в кассовом модуле. Синим цветом выделены служебные строки - записи о подключении кассира, о снятии Z и X-отчетов и т.п.

Для каждой записи о покупке заполняются следующие графы:

Время, дата, номер чека - заполняются для первой покупки каждого чека.

Отд. - Номер отдела, в который пробит чек.

Сумма чека - Для первой покупки чека здесь стоит сумма всего чека.

Товар - Первые 17 символов названия товара.

Кол-во, Цена, Сумма - Количество, цена и сумма покупки.

БД - Знак + в этой графе означает, что эта запись уже внесена в базу данных. В базе данных для каждого рабочего места есть запись о последней записанной покупке. Покупка считается внесенной в базу данных, если ее дата и время меньше даты и времени последней записанной покупки.

В нижней части экрана находится несколько вспомогательных полей для текущей покупки.

Карточка/Номенкл. - номер карточки товара или номенклатурный номер для товара.

Касса - Номер кассы, на которой пробит чек.

Контр.лента - Номер контрольной ленты (Z-отчета), на которой находится этот чек.

Работа с контрольной лентой осуществляется с помощью меню, которое состоит из следующих пунтов.

  • Файл. Здесь выполняются общие действия.

  • Отчеты. Здесь можно получить отчет по продажам за любой период и протестировать состояние контрольной ленты.

  • Поиск. Здесь собраны команды для поиска записей в чековой ленте по разным критериям.

  • Отметить. Здесь находятся команды для выделения части информации на контрольной ленте. По отмеченным записям можно получать отчеты, экспортировать их в виде RES-файла и загружать в базу данных.

  • Действия. Здесь находятся команды, которые позволяют выгружать информацию в RES-файлы, загружать ее в базу данных, менять "последнюю загруженную" запись в базе данных. Прежде чем использовать эти команды, следует ознакомиться с соответствующим разделом справки и понять что они делают.


<Работа с чековой лентой - Файл>

Работа с чековой лентой - Файл.

Данный пункт меню содержит следующие подпункты.

  • Открыть другой RES-файл. С помощью этого пункта меню можно не выходя из "Работы с чековой лентой" перейти к другому рабочему месту и другому RES-файлу.

  • Шрифт Здесь можно выбрать шрифт для показа на экран, если шрифт, установленный по умолчанию Вас не устраивает.

  • Восстановить шрифт "по умолчанию"

  • Завершить работу с чековой лентой. Просмотр чековой ленты завершается.


<Работа с чековой лентой - Отчеты>

В этом меню есть три пункта:

  • Отчет за ..... Если в момент выбора меню, курсор стоит на записи за какое-то число, то получается отчет за это число. Для того, чтобы получить отчет за другое число, надо предварительно поставить курсор на запись с нужной датой. Для этого можно использовать листание списка покупок или Поиск.

Если одна или несколько записей отмечены, то, независимо от положения курсора, отчет получается по отмеченным записям.

В отчете подводятся общие итоги, итоги по кассирам, по отделам и т.п. по записям заданного периода.

  • Тест информации за...

Информация, которая попадает в тест, выбирается также, как и для отчетов.

Тестирование применяется если надо найти причину несоответствия Z-отчета кассового аппарата (фискального регистратора) и отчета по электронной чековой ленте.

При пробитии покупок кассовый модуль получает информацию о номере контрольной ленты и номере текущего чека из кассового аппарата.

При тестировании просматриваются все записи и проверяется, что номера чеков увеличиваются от чека к чеку строго на 1. Если это выполняется, то в электронной чековой ленте присутствуют все записи, которые записывались в кассовый аппарат.

Примеры ошибок, возникающих в чеке.

Возможны случаи, когда фискальный регистратор сообщил о нормальном завершении фискализации, программа включила чек в электронную чековую ленту, а на фискальном регистраторе этот чек по каким-то причинам потерялся - в электронной чековой ленте возникнет два чека с одинаковыми номерами.

В любом случае, можно восстановить недостающую информацию по физической контрольной ленте - просто посмотреть что там пробито в недостающих чеках. После этого в складской программе можно сделать дополнительную расходную накладную на эти товары или скорректировать кассовую расходную накладную.

  • Протокол ошибок на кассе. При работе кассового модуля ведется протоколирование включений и выключений кассового модуля, аннулирований чеков, сообщений об ошибках и прочей информации, связанной с работой кассового модуля. Этот протокол ведется в файле с именем <номер кассы>.LOG, который находится в той же директории, где файл электронной чековой ленты Kassa.Res.

Если в директории, где находится просматриваемый RES-файл, есть файл <номер кассы>.LOG, то данный пункт меню становится активным и его выбор открывает протокол приблизительно в том месте (по дате и времени), на котором стоит в данный момент курсор.


<Работа с чековой лентой - Поиск>

При нажатии одной из кнопок поиска, в нижней части экрана появляется дополнительная панель поиска. Если ни одна из кнопок не нажата, то панель поиска исчезает.

В левой части панели указывается критерий поиска, правее - окно для ввода поискового запроса и две кнопки - "Искать вверх" и "Искать вниз". Кнопки становятся активными как только поисковый запрос позволит начать поиск.

При нажатии "Поиск вверх" ищется позиция, отвечающая критериям поиска, которая находится выше текущей позиции. При нажатии "Поиск вниз" - ниже.

Критерии поиска

  • Поиск по дате. Надо ввести нужную дату и нажать кнопку поиска вверх или вниз. В отличие от всех остальных поисков, при поиске вверх находится не любая запись с искомой датой, а самая первая из них, т.е. курсор остановится на первой записи от этой даты. Аналогично, при поиске вниз находится последняя запись за эту дату.

  • Поиск по названию товара. Надо ввести любое слово или часть слова. Поиск ведется по 17 символам названия, которые есть в контрольной ленте. Если используются дополнительные свойства, то поиск ведется и по ним.

  • Поиск по номеру чека. Ищется чек с заданным номером.

  • Поиск по сумме. Ищется запись, в полях цена или сумма которой, находится указанное число. Поиск также включает в себя полную сумму чека, которая записана в колонке "Сумма чека".

  • Поиск по коду товара. Ищется запись у которой код товара или номер карточки начинается с заданных символов.


<Работа с чековой лентой - Отметить>

Работа с чековой лентой - Отметить.

Данный пункт меню предназначен для установки или снятия выделения для группы последовательных записей. По отмеченным записям можно получать отчет, проводить тестирование, экспортировать или загружать их в базу данных.

  • Отметить текущую запись как начало. Текущая запись отмечается как первая запись среди отмеченных. Если к этому моменту конечная запись уже отмечена и находится ниже текущей, то диапазон отмеченных записей выделяется на экране темно-зеленым цветом. Если конечная запись еще не отмечена, или находится выше текущей, то отметка запоминается, но на экране ничего не меняется.

  • Отметить текущую запись как конец. Текущая запись отмечается как последняя запись среди отмеченных. Если к этому моменту первая запись уже отмечена и находится выше текущей, то диапазон отмеченных записей выделяется на экране темно-зеленым цветом. Если первая запись еще не отмечена, или находится ниже текущей, то отметка запоминается, но на экране ничего не меняется.

  • Снять отметки. Ранее сделанное выделение отмеченных записей отменяется.


<Работа с чековой лентой - Действия>

Этот пункт меню предназначен для выполнения действий, которые могут внести изменения в базу данных, поэтому их надо выполнять осторожно, предварительно ознакомившись с этим разделом.

  • Загрузка в базу данных информации за... Этот пункт меню позволяет загрузить в базу данных информацию из чековой ленты. Обычно он используется для повторного ввода расходных кассовых накладных, если с существующими накладными есть какие-то проблемы (например, их случайно удалили).

Перед загрузкой следует убедиться, что в складской базе данных нет соответствующих накладных. Если при загрузке окажется, что такая накладная уже есть, то информация в ней будет задвоена.

Если в момент выбора меню, курсор стоит на записи за какое-то число, то в загрузке будут участвовать все записи за это число. Для того, чтобы загрузить записи за другое число, надо предварительно поставить курсор на запись с нужной датой. Для этого можно использовать листание списка покупок или Поиск .

Если одна или несколько записей отмечены, то, независимо от положения курсора, загружаться будут все отмеченные записи.

  • Изменить "последнюю запись в БД". При занесении покупок в базу данных или при импорте их из касс с режимом экспорт/импорт, кассовый сервер запоминает последнюю записанную в базу данных покупку. Это дает возможность загружать в базу только ту информацию, которой в ней еще нет.

Если по каким-то причинам требуется изменить эту запись, то достаточно установить курсор на нужную запись и выбрать этот пункт меню. Все записи, которые располагаются после текущей записи будут считаться еще не введенными в базу.

При загрузке в базу информации (см. пункт 1 этого раздела). Значение "последней записи" не принимается во внимание - загружается все, что выбрано для загрузки. После загрузки, если последняя загруженная запись находится после "последней записи", то она становится новой "последней записью". Если последняя загруженная запись находится до "последней записи", то "последняя запись" не меняется.

  • Выгрузка информации в файл за... Записи за указанное число или отмеченные выгружаются в один или несколько RES-файлов. Отдельный файл создается для каждого кассового аппарата. Имя файла состоит из номера кассового аппарата и расширения RES. Файл создается в директории связи.


<Настройка программы>

Для работы кассира достаточно использования клавиатуры. Для проведения настройки лучше подключить к компьютеру мышь.

После первого запуска программы требуется выполнить ее настройку. Для этого надо нажать клавишу F10 и выбрать в меню пункт "Настройка...". Настройка состоит из двух разделов, описание которых приведено ниже.

Если для настройки доступны оба раздела, то появляется промежуточное меню выбора. Если доступна только настройка рабочей станции, то соответствующий раздел открывается сразу.

  • Рабочая станция. Настройка рабочей станции относится, в основном, к настройке работы со вспомогательным оборудованием и дополнительными программами. Все настройки рабочей станции хранятся не в базе данных, а в реестре компьютера, на котором запускается программа Касса.

  • База данных (система). Этот раздел доступен только администраторам и только при работе с базой данных. С его помощью настраивается работы Касс, права пользователей и т.п. Настройки сохраняются в базе данных.

Если программа Касса работает совместно с Кассовым сервером или автономно в режиме экспорта / импорта, то все настройки этого раздела выполняются на Кассовом сервере - в программе Касса они недоступны.


Настройка рабочей станции.

Настройка рабочей станции состоит из семи закладок:

  • Общие. Описание данного рабочего места.
  • Фискальный регистратор. Описание используемого фискального регистратора.
  • Сканер. Настройка сканера для работы с программой Касса.
  • Кард-ридер. Настройка кард-ридера для работы с программой Касса.
  • Табло покупателя. Описание внешнего табло покупателя, подключенного к кассовому компьютеру.
  • SLS-Дисконт. Подключение к системе SLS-Дисконт для совместной работы.
  • SLS-Эквайринг. Подключение к системе SLS-Эквайринг для совместной работы.


Закладка Общие

На этой закладке определяется режим работы программы Касса и ее внешний вид.

  • Номер рабочего места. Здесь должен быть указан номер данного рабочего места (до восьми цифр). Этот же номер должен быть указан в настройке описания рабочего места кассира в разделе База данных (система). В качестве этого номера можно использовать заводской номер ККМ, хотя это не обязательно.

  • Сохранять продажи ХХ дней. Информация о продажах (электронная чековая лента) сохраняется в файле с именем, совпадающим с номером рабочего места и с расширением RES. Туда записывается информация о всех продажах, возвратах, снятии Z и X-отчетов и т.п. С течением времени размер этого файла увеличивается. Для того, чтобы размер оставался разумным, используется эта настройка. Каждый раз при запуске программа Касса проверяет размер этого файла, и, если он превысил некоторый предел, укорачивает его так, чтобы в нем осталась информация за последние ХХ дней.

  • Режим работы. Здесь можно выбрать один из режимов работы программы Касса.

  • Автономный экспорт - импорт. В этом режиме предполагается, что программа Касса установлена на отдельном компьютере и не имеет доступа к базе данных. Информация о товарах и ценах поступает к ней в виде файла, а результаты работы (информация о продажах) от нее передается так же файлом. Обмен файлами между автономной Кассой и центральным офисом можно делать через e-mail, или передавая файлы с курьером.

  • Автономный - база данных только для обмена. Этот режим имеет смысл использовать в тех случаях, когда не предполагается постоянное подключение программы Касса к базе данных. Например, база данных на ноутбуке, с которым переиодически приезжает курьер. Или программа Касса однопользовательская и монопольно занимает базу данных, и программа Склад тоже однопользовательская. В этом режиме программа Касса подключается к базе данных только для обновления номенклатуры и записи информации о продажах при выборе кассиром соответствующего пункта меню F10.

  • Напрямую с базой данных. Программа касса работает непосредственно с базой данных и производит запись продаж по мере пробития чеков.

  • Через кассовый сервер. В этом режиме обновление номенклатуры и запись продаж в базу данных выполняет программа Кассовый сервер. Программа Касса работает автономно и по запросам от Кассового сервера автоматически производит обновление номенклатуры и запись продаж не мешая работе кассира.

Этот же режим рекомендуется при автономной работе программы Касса. В этом случае программы Склад и Кассовый сервер, а также база данных установлены в центральном офисе, а программа Касса работает в удаленном магазине. Подробнее все настройки описаны в разделе Автономная работа программы Касса .

  • Путь и имя базы данных для работы без кассового сервера. Это поле доступно, если установлен один из режимов, в котором программа должнв подключаться к базе данных. С помощью кнопки справа от поля нужно выбрать файл базы данных.

  • Путь к папке связи с кассовым сервером. Это поле доступно, если выбран режим работы с Кассовым сервером. С помощью кнопки справа от поля надо выбрать любой файл в папке, предназначенной для обмена информацией с Кассовым сервером. Эта же папка должна быть указана в настройках программы Кассовый сервер.

  • Кнопка Настройка шрифтов и цветов . Здесь можно выбрать шрифты, которые будут использоваться для работы кассира в программе. Можно изменять сам шрифт и его стиль, а также настроить цвета для курсора выбора товаров.

  • Кнопка Настройка печати форм. С ее помощью можно настроить печать товарных чеков на принтере. Все настройки полностью совпадают с аналогичной настройкой в программе Склад.

  • Кнопка Место для сохранения локальных настроек. Программа Касса может сохранять свои настройки в реестре Windows (HKEY_CURRENT_USER \ Software \ SoftLand Systems \ Kassa), или в файле Kassa_W.ini, который располагается в той же папке, где программа Kassa_W.exe. При нажатии этой кнопки можно выбрать любой из этих вариантов. При изменении места сохранения с реестра на файл, или наоборот, текущие значения настроек автоматически переписываются в новое место.

  • Флажок Разрешить запускать более одного экземпляра программы. По умолчанию этот флажок выключен и на одном рабочем месте можно запустить только один экземпляр программы Касса.

  • Режим отображения. Здесь доступны три режима для отображения программы Касса на экране.

  • Полноэкранный. В этом режиме программа Касса разворачивается во весь экран, включая область Taskbar (где находится кнопка "Пуск", кнопки задач и часы). При попытке переключиться на другую задачу фокус автоматически возвращается программе Касса. Этот режим позволяет исключить случайное сворачивание задачи кассиром или переход к работе с другой задаче.

  • Развернутое окно Windows. В этом режиме программа Касса запускается как полностью развернутое окно Windows. Никаких отличий от обычных задач в этом режиме нет.

  • Окно Windows. В этом режиме программа Касса запускается как обычная задача Windows в окне с размерами, заданными по умолчанию.

  • Флажок Показывать переключение клавиатуры. Если этот флажок включен, то в нижнем правом углу окна программы Касса появляется индикатор состояния клавиатуры Ru / En. Флажок автоматически включается при выборе Полноэкранного режима отображения, поскольку стандартный индикатор в этом режиме не виден.

  • Флажок Использовать экранную клавиатуру. Экранную клавиатуру можно включить при наличии сенсорного экрана для того, чтобы не использовать для работы обычную клавиатуру и мышь. Если этот флажок включен, то справа от основного окна программы показывается экранная клавиатура , на которой расположены цифровые клавиши, стрелки управления курсором и прочие служебные клавиши.

  • Панель быстрого выбора товаров. Помимо обычных способов выбора товара - сканером штрих-кодов, по названию, по номенклатурному номеру, номеру карточки и цене, можно создать панель с кнопками, при нажатии которых будет выбираться заданный для каждой кнопки товар.

Этот режим можно использовать для быстрого набора в чек ограниченного набора штучных товаров. Возможны два варианта работы - панель быстрого выбора может использоваться совместно с обычным выбором, или полностью заменять другие способы выбора товаров.

Если включено использование панели быстрого выбора, то становится активной кнопка Настройка панели. Нажатие этой кнопки позволяет описать клавиши быстрого выбора и связанные с ними товары .


Автономная работа программы Касса.

Если имеется центральный офис, который занимается приходованием товара, назначением цен и передачей товаров в магазины, и один или несколько удаленных от офиса магазинов, в которых ведутся только продажи, и не требуется собственный учет, то можно использовать автономный режим работы программы Касса (экспорт / импорт).

Настройка этого режима выполняется следующим образом.

В офисе:

В программе Склад создается отдельный склад (место хранения) для каждого удаленного магазина и туда передаются актами передачи товары, которые отправляются в каждый из магазинов.

В программе Кассовый сервер создаются описания для каждой из касс удаленных магазинов. Каждой кассе присваивается уникальный "номер рабочего места". В списке обслуживаемых отделов указываются склады (места хранения), которые соответствуют магазинам, где расположены кассы. Режим работы выбирается "Автономно ( экспорт / импорт )".

В программе Кассовый сервер указывается "папка связи кассового сервера и касс", через которую будет осуществляться обмен информацией с кассами.

В магазинах:

В программе Касса в настройках указывается тот же "номер рабочего места", который задан в ее описании в Кассовом сервере и на локальном диске указывается какая-нибудь "папка связи" для обмена с Кассовым сервером. Для упрощения работы, лучше для этого создать новую пустую папку и использовать ее только для обмена. Режим работы выбирается "Автономно - экспорт/импорт".

Работа в этом режиме:

1) В офисе в программе Кассовый сервер выполняется обновление номенклатуры для касс. Кассовый сервер создает в "папке связи" для каждой удаленной кассы файла <номер рабочего места>.NE-. Например, для кассы, у которой в описании задан "номер рабочего места" 00000001, будет создан файл 00000001.NE- .

Файл <номер рабочего места>.NE- содержит описания товаров, коды и цены для программы Касса

2) Этот файл передается в удаленный магазин по e-mail, с курьером на флешке или дискете, или другим способом.

3) В магазине файл копируются в "папку связи", описанную в программе Касса.

При работе программы Касса она автоматически обновляет номенклатуру на ту, которая нашлась в папке связи (файл ne-) и удаляет этот файл.

В программе Касса в любой момент кассир может записать результаты продаж. Для этого он должен выбрать в меню "F10 > Записать продажи (создать файл KAS)". В папке связи программа Касса создаст файл с результатами продажи.

4) Файл <номер рабочего места>.KAS передается в офис по e-mail, с курьером на флешке или дискете, или другим способом.

5) В офисе файл KAS копируется в "папку связи", описанную в Кассовом сервере, после чего Кассовый сервер автоматически записывает продажи в базу данных.

Далее цикл повторяется.

Возможные варианты работы:

В приведенном выше описании предполагается, что обмен информацией делается с некоторой периодичностью, скажем ежедневно. И при каждом обмене выполняется одновременно обновление номенклатуры и передача информации о прошедших продажах.

В принципе, это не обязательно. Можно передавать обновления номенклатуры, скажем, раз в несколько дней, а результаты продаж получать несколько раз в день. Или наоборот - номенклатуру обновлять часто, а результаты продаж получать редко.


Экранная клавиатура

Экранная клавиатура предназначена для использования с сенсорным экраном монитора. При ее использовании можно не устанавливать на рабочем месте кассира обычную клавиатуру.

При выборе этого режима в подсказках внизу экрана также появляются кнопки, которые можно нажимать для выбора нужных действий. Например:

Кроме сенсорных кнопок в отдельных случаях (меню, списки товаров и т.п.) имеются полосы прокрутки и пункты меню. При использовании сенсорного экрана для того, чтобы выбор из меню и прокрутку списков было удобно делать, можно изменить настройки оформления Windows. Для этого на свободном месте десктопа надо нажать правую кнопку мыши, выбрать "Свойства" и на вкладке "Оформление" увеличить размер "полосы прокрутки".

Высота кнопок в подсказках и высота пунктов меню в программе Касса устанавливается равной размеру полосы прокрутки.


Панель быстрого выбора товаров

Панель быстрого выбора позволяет выбирать товар простым нажатием заранее запрограммированной кнопки.

На панели быстрого выбора может находиться до 10 закладок, на каждой из которых можно запрограммировать до 20 кнопок. Если все кнопки, или все закладки не помещаются на экране, то появляются полосы прокрутки. Поскольку использование прокрутки для выбора товара замедляет выбор, то не все из 200 возможных кнопок стоит использовать. Максимальное количество закладок и кнопок на закладке (чтобы все помещалось на панели без прокрутки) зависит от размера кнопок.

Окно настройки панели быстрого выбора товаров выглядит так:

  • Максимальная ширина закладки. Ширина задается в пикселах. Если название закладки не помещается в указанную ширину, то оно пишется в несколько строк. Чем меньше ширина, тем больше закладок (до 10 штук) поместится на экране без использования прокрутки.

  • Ширина кнопки. Ширина задается в пикселах. Если название кнопки не помещается в указанную ширину, то оно пишется в несколько строк. Чем меньше ширина, тем больше кнопок (до 10 штук в два ряда) поместится на экране без использования прокрутки.

В нижней части окна находится сама панель быстрого выбора товаров.

Если в настройках установлено совместное использование быстрого и обычного выбора, то в левой части панели находится иконка включения/выключения быстрого выбора (с зеленым треугольником). При работе нажате на эту иконку (или клавиши F3) позволяет показать или спрятать панель.

На панели есть заготовки для закладок и кнопок. Если кликнуть левой кнопкой мыши по какой-нибудь закладке или кнопке, то откроется окно редактирования свойств , в котором можно ввести текст названия, задать для него шрифт и т.д.

Нажатие правой кнопки мыши на закладке или кнопке вызывает контекстное меню с тремя пунктами:

- Корректировать. Открывает окно редактирования свойств.

- Переместить. Позволяет изменить место закладки в списке закладок, или переместить кнопку на другое место. Кнопка может быть перемещена как на эту же, так и на другую закладку.

- Удалить (Очистить). Удаляет описание кнопки, или очищает название закладки и удаляет все кнопки на ней.


Настройка шрифтов и цветов.

Программа позволяет настроить шрифты и цвета для работы:

  • Табло покупателя (верхняя часть экрана кассира)
  • Списка для выбора товаров
  • Основного экрана кассира


Настройка шрифтов и цветов - Табло

  • Шрифт для табло. Нажав эту кнопку можно выбрать шрифт, которым будет отображаться информация в верхней части экрана кассира (табло). Можно выбрать сам шрифт, его размер, стиль и цвет.

  • Цвет фона для табло. Нажав эту кнопку можно выбрать цвет фона для табло.

  • Восстановить исходные цвета. Нажав эту кнопку можно вернуть цвет шрифта и табло к исходным (заданным по умолчанию) цветам.

Результат настройки отображается в верхней части экрана.


Настройка шрифтов и цветов - Выбор товара

Настройка цветов и шрифтов - Выбор товара

На этом экране можно настроить шрифты и цвета для режима выбора товаров из списка.

В верхней части экрана приведен пример того, как будет выглядеть список товаров после настроек.

  • Кнопка Шрифт для окна выбора товаров. С ее помощью можно выбрать шрифт, его стиль и размер.

  • Цвет букв и фона (Выберите тип корректируемой записи). В окне выбора товаров могут отображаться записи разных типов:

- Основные записи товара (обычный товар)

- Дополнительные записи товара (дополнительный код)

- Товар со скидками по приказу

Для каждого типа записи можно настроить цвет шрифта и фона для записи в списке и цвет шрифта и фона для этой записи, когда она находится под курсором.

В данном окне выбирается тип записи, для которой будет делаться настройка.

  • Образец невыбранного товара. Снизу от этой записи отображается текст данного типа записи с текущими настройками цветов.

Еще ниже - две кнопки Цвет букв и Цвет фона. С их помощью можно установить желаемые цвета для записи данного типа, когда она отображается в списке не под курсором.

  • Образец текста и курсора. Снизу от этой записи отображается текст данного типа записи с текущими настройками цветов.

Еще ниже - две кнопки Цвет букв и Цвет фона. С их помощью можно установить желаемые цвета для записи данного типа, когда она находится под курсором. Фактически Цвет фона - это цвет курсора, когда он находится над этой записью.

  • Кнопка Восстановить исходные цвета. Нажатие на эту кнопку возвращает цвета всех типов записей к исходным (заданным по умолчанию).


Настройка шрифтов и цветов - Основной экран.

На этом экране можно настроить шрифт, его стиль и размер для отображения на основном экране кассира, в меню и т.д.

В верхней части экрана показан "подвал" основного экрана кассира. Здесь можно видеть как будут выглядеть вносимые изменения.

Кнопка Шрифт для основного экрана позволяет выбрать желаемый шрифт.


Закладка Фискальный регистратор.

Здесь настраивается работа с фискальным регистратором, подключенным к компьютеру.

  • Тип используемой ККМ. Это поле может иметь одно из значений:

Работать без использования ККМ. Если выбран этот режим, то программа имеет полную функциональность - позволяет набирать товар в чеки, списывать продажи из базы данных, печатать товарные чеки и т.п. Единственное, что отключено - пробитие фискальных чеков на ККМ. Этот режим может использоваться при обучении кассиров, или при торговле, если использование при этом фискального регистратора не является обязательным по закону.

Демо-режим - чеки показываются на экране. Этот режим полностью аналогичен предыдущему за исключением того, что чеки, полученные при продажах и возвратах показываются на экране. Режим предназначен для обучения кассиров и ознакомления с программой в демо-версии.

Общий драйвер Атол 5.17. Используется при работе с аппаратами производства АТОЛ (например, Феликс). Для работы должен быть установлен общий драйвер Атол. Список аппаратов, поддерживаемых этим драйвером, можно узнать на сайте производителя. Общий драйвер Атол устанавливается на компьютер в соответствии с инструкцией, приложенной к драйверу.

Драйвер ШТРИХ-М "ФР 4.6". Используется при работе с аппаратами производства ШТРИХ-М (например, Штрих ФРК). Для работы должен быть установлен общий драйвер Штрих-М. Список аппаратов, поддерживаемых этим драйвером, можно узнать на сайте производителя. Драйвер Штрих-М устанавливается на компьютер в соответствии с инструкцией, приложенной к драйверу.

ФР Мебиус. Используется при работе с фискальными регистраторами Мебиус производства АРЕС-КОМПАНИ. Драйвер представляет из себя файл с именем MoebiusLib.dll. Этот файл надо поместить в ту же папку, где находится программа Kassa_W.exe.

АМС-100К. Используется при работе с кассами АМС-100К с драйвером Chon100K.dll производства компании Версия-Т.

Драйвер представляет из себя файл с именем Chon100K.dll. Этот файл надо поместить в ту же папку, где находится программа Kassa_W.exe. На кассе АМС-100К надо включить режим "есть сеть" и установить номер устройства в соответствии с инструкцией, приложенной к драйверу. К драйверу также должен быть приложен "код поставщика" - это кодовое число, которое должно быть своим для каждого конкретного экземпляра кассового аппарата. Для работы программы Касса с данным аппаратом это кодовое число должно быть введено с помощью кнопки "Настройка драйвера" (см. ниже). Там же надо указать СОМ-порт, к которому подключен аппарат.

АМС-100Ф. Используется при работе с кассами АМС-100Ф с драйвером Chon100.dll производства компании Версия-Т.

Драйвер представляет из себя файл с именем Chon100.dll. Этот файл надо поместить в ту же папку, где находится программа Kassa_W.exe. На кассе АМС-100Ф надо включить режим "есть сеть" в соответствии с инструкцией, приложенной к драйверу. К драйверу также должен быть приложен "код поставщика" - это кодовое число, которое должно быть своим для каждого конкретного экземпляра кассового аппарата. Для работы программы Касса с данным аппаратом это кодовое число должно быть введено с помощью кнопки "Настройка драйвера" (см. ниже). Там же надо указать СОМ-порт, к которому подключен аппарат.

  • Кнопка Настройка драйвера. При нажатии этой кнопки появляется окно настройки драйвера соответствующего аппарата. Описание настроек см. в описании драйвера, которое приложено к нему.

Для демо-режима и для работы без использования ККМ в окне настройки можно задать номер смены (контрольной ленты) и номер последнего чека. Эти значения используются при последующей печати чеков. Номер смены и чека запоминаются для текущего номера рабочего места (см. закладку Общие ).

  • Флажок Автоматически устанавливать в ФР дату и время с компьютера.

Если этот флажок включен и фискальный регистратор позволяет устанавливать на нем дату и время, то при снятии Z-отчетов или если время на фискальном регистраторе отличается от времени компьютера более, чем на 2 минуты, происходит автоматическая установка часов фискального регистратора по часам компьютера.

По умолчанию этот флажок включен.

  • Флажок Включить постоянное протоколирование.

Если этот флажок включен, то в файл <номер рабочего места>.ERR записываются все команды, передаваемые программой в фискальный регистратор. Если флажок выключен, то протоколируются только те команды, при выполнении которых фискальный регистратор выдал ошибку. По умолчанию этот флажок выключен.

  • Режим печати покупок в чеке. Это поле может иметь одно из четырех значений:

Название товара не более одной строки. Если ККМ позволяет печатать длинные названия товаров, то выбор этого режима позволит отводить под название не более одной сточки в чеке.

Название товара полностью. Если ККМ позволяет печатать длинные названия товаров, то на чеке будет печататься полное название товара.

Название товара не печатать. Если ККМ позволяет печатать позиции чека без наименования, и это экономит бумагу, то при выборе данного режима название товара печататься не будет.

Печатать только общую сумму чека. При выборе этого режима на чеке печатается только итоговая сумма без детализации по покупкам. Это можно использовать, если чек нужен только как фискальный документ и прикладывается к нормальному документу, где перечислены все купленные товары.

  • Безналичные платежи. Это поле может иметь два значения - Включены и Выключены. Если безналичные платежи включены, то при проведении платежа кассир имеет возможность выбрать тип оплаты - наличная или безналичная. В итоговых отчетах (X и Z) эти платежи разделяются. Если совместно с программой Касса используется программа SLS-Эквайринг, то одновременно происходит проведение безналичных платежей через эквайринговый процессинговый центр и делаются соответствующие записи в базе данных программы Склад.

  • Режим печати чеков.

Печатать чек по мере добавления покупок. В этом режиме покупки печатаются на ККМ по мере их набора кассиром. После расчета с покупателем остается только допечатать "хвостовик" чека - сумму, сдачу и признак фискализации.

Печатать весь чек целиком при завершении набора. В этом режиме кассир сначала полностью формирует чек на компьютере, а печатается он весь целиком после расчета с покупателем.

Второй режим предпочтительней, поскольку в случае любых корректировок в чеке они делаются до начала печати чека. В первом режиме иногда может потребоваться перепечатать все уже напечатанные ранее позиции.

  • Флажок Добавлять в название номенклатурный номер.

Если включить этот флажок, то при печати чека на ККМ перед названием будет печататься номенклатурный номер товара. Если у товара нет номенклатурного номера, то будет напечатан номер карточки товара. По умолчанию этот флажок выключен.

  • Флажок Добавлять в название номер карточки товара.

Если включить этот флажок, то при печати чека на ККМ перед названием будет печататься номер карточки товара. Например, "[123456]". По умолчанию этот флажок выключен.

  • Флажок Суммировать количества при сканировании.

Если включить этот флажок, то при добавлении покупок с помощью сканера штрих-кодов, если добавляемый товар совпадает с тем, который только что сканировался, происходит увеличение количества ранее отсканированного товара. При сканировании другого товара ранее отсканированный товар заносится в чек. Увеличение количества выполняется только если ранее отсканированный товар находится в нижней части экрана и еще не переписан в чек. По умолчанию этот флажок выключен.

Если в "Режиме печати чеков" установлено "Печатать весь чек целиком при завершении набора", то при включенном флажке "Суммировать количества при сканировании", при добавлении покупки в чек (переносе ее в верхнюю часть экрана) происходит поиск такой же покупки среди ранее введенных. Если такая же покупка уже есть, то новая строчка в чек не добавляется, а просто увеличивается количество в ранее введенной покупке.

При выборе товара:

  • Флажок При выборе товара показывать только основные записи.

По умолчанию этот флажок выключен и в списках выбора товаров показываются все записи товара - как основные (черным цветом), так и с дополнительные - с дополнительными штрих-кодами для этого товара (синим цветом). Если флажок включить, то во всех списках (кроме списка по штрих-кодам) будут показываться только основные записи товаров, что упростит кассиру поиск нужного товара.

  • Флажок Показывать все товары общим списком без разделения по отделам.

Если включена работа с несколькими отделами, то в обычном режиме на экране выбора товаров присутствует поле "Отдел:" и кассир должен до выбора товара вручную выбрать соответствующий отдел. При ручном выборе товара в списках выбора видны только товары указанного отдела.

Если этот флажок включен, то поле "Отдел:" отсутствует. При ручном выборе товара все товары показываются в общем списке. В этом же списке есть отдельная графа "Отд.", в которой видно к какому отделу принадлежит товар. По умолчанию этот флажок выключен.

  • Флажок Не показывать "Нажмите любую клавишу для начала работы со следующим покупателем".

Это сообщение показывается после того, как напечатался чек. Оно дает возможность оставить видимым экран с оплаченной суммой и сдачей. Если флажок включен, то программа Касса переходит в режим работы со следующим покупателем сразу после пробития чека.

  • Кнопка Проверка связи.

После того, как выполнена настройка драйвера ККМ, можно нажать на эту кнопку. Если все настройки сделаны правильно, то на экране появится окно с заводским номером ККМ, номером текущей смены и чека. Если что-то не так, то появится сообщение об ошибке, выданной драйвером.


Закладка Сканер

Эта закладка предназначена для работы со сканером штрих-кодов.

  • Режим работы сканера штрих-кодов

Не используется. Программа не будет работать со сканером штрих-кодов.

Подключен в разрыв клавиатуры (определяется по скорости). Сканер при сканировании штрих-кода передает его в компьютер как будто этот код набран на клавиатуре. Для определения того, что это именно штрих-код, программа засекает время его ввода. Если время меньше того, которое требуется для ввода этого кода оператором с клавиатуры, то считается, что он прочтен сканером.

Для настройки порога срабатывания используется дополнительное поле Интервал. В этом поле задается время (в миллисекундах) за которое сканер должен успеть передать штрих-код, чтобы он опознался как штрих-код. Значение по умолчанию равно 50.

Корректировать код по состоянию клавиатуры. Если этот флажок включен, то при чтении штрих-кода он корректируется в соответствии с состоянием регистров клавиатуры. Эта коррекция имеет смысл только при чтении кодов, содержащих буквы. Например, если в коде содержится буква s, то при включенном русском регистре клавиатуры сканер передаст ее как ы. Если при этом включен Caps Lock, то получится Ы. При включенном флажке корректировки независимо от режимов клавиатуры будет прочтена буква s.

Подключен в разрыв клавиатуры (определяется по префиксу 02). Большинство сканеров, подключаемых в разрыв клавиатуры, позволяют программировать префикс (символ или символы, которые передаются перед каждым штрих-кодом). Если запрограммировать для сканера префикс 02 шестнадцатиричное (STX), то можно выбрать этот режим работы. Программирование делается с помощью служебных штрих-кодов, которые находятся в руководстве, приложенном к сканеру. Там же описана процедура настройки префикса. В этом режиме также доступен флажок "Корректировать код по состоянию клавиатуры" (описание см. выше).

Подключен через СОМ-порт. Этот режим используется, если сканер включен в СОМ-порт (RS-232) или подключен через USB для которого драйвер создал виртуальный СОМ-порт. Для настройки надо выбрать нужный СОМ-порт в поле Порт, куда подключен сканер. Поля Скорость передачи, Четность, Количество бит и Стоп-биты по умолчанию совпадают с теми, которые установлены по умолчанию у большинства сканеров. Если требуется, то их можно изменить в соответствии с документацией к сканеру.

  • Проверка настроек. После выполнения настроек можно нажать кнопку Начать для начала тестирования. Далее в соответствии с инструкциями, появляющимися на экране, надо просканировать какой-нибудь штрих-код и посмотреть на результат. Если все нормально, то настройка закончена.


Закладка Кард-ридер

Программа может работать с кард-ридером, подключенным через СОМ-порт (RS-232). Кард-ридер можно использовать для работы с SLS-Дисконт, если дисконтные карты имеют магнитную полосу. Обычно проще использовать дисконтные карты со штрих-кодом, поскольку для их чтения достаточно иметь сканер штрих-кодов, который используется для работы с товарами.

  • Использовать кард-ридер. При включении этого флажка программа будет поддерживать чтение информации с кард-ридера.

  • Параметры RS-232. Здесь надо указать Порт, к которому подключен кард-ридер. Остальные параметры - Скорость передачи, Четность, Количество бит и Стоп-биты по умолчанию совпадают с теми, которые установлены по умолчанию у большинства кард-ридеров. Если требуется, то их можно изменить в соответствии с документацией к кард-ридеру.

  • Настройка кард-ридера

Читать трек N. Здесь надо указать на каком треке магнитной карты записана требуемая информация.

Ограничители треков. В этой таблице указаны стартовые и стоповые ограничители треков. В большинстве случаев эту настройку менять не придется, но, при необходимости, здесь можно указать параметры из документации к кард-ридеру.

  • Проверка настроек. После выполнения настроек можно нажать кнопку Начать для начала тестирования. Далее в соответствии с инструкциями, появляющимися на экране, надо прочесть какую-нибудь карту с магнитной полосой и посмотреть на результат. Если все нормально, то настройка закончена.


Закладка Табло покупателя

В программе Касса основная информация для покупателя (сумма чека, сдача и т.п.) отображается на экране крупными символами. Для этого режима здесь можно настроить два параметра "Текст между чеками" и "Текст при неактивной кассе" (см. ниже).

При необходимости, программа позволяет подключить к компьютеру электронное табло покупателя.

  • Текст между чеками. Здесь можно ввести текст, который будет отображаться на табло после завершения работы с покупателем, до начала обслуживания нового покупателя.

  • Текст при неактивной кассе. Здесь можно ввести текст, который будет отображаться на табло при неактивной кассе, т.е. если к программе Касса еще не подключился пользователь (кассир) или программа находится в режиме настройки.

Оба текста всегда отображаются на экранном табло программы. Если к компьютеру подключено электронное табло, то эти же тексты будут отображаться на нем.

  • Использовать табло покупателя. Если этот флажок включен, то программа будет отображать на электронном табло информацию о текущей покупке, а при расчете - общую сумму и сдачу.

Программа поддерживает табло, подключенные к COM-порту компьютера (кнопка "Подкл.через СОМ-порт") и табло POSUA, подключаемое через USB (кнопка "Табло POSUA").

Подключение через COM-порт.

Для выбора этого способа должна быть нажата кнопка "Подкл.через СОМ-порт".

  • Параметры RS-232. Здесь надо указать Порт, к которому подключено табло. Остальные параметры - Скорость передачи, Четность, Количество бит и Стоп-биты по умолчанию совпадают с теми, которые установлены по умолчанию у большинства электронных табло. Если требуется, то их можно изменить в соответствии с документацией к табло.

  • Набор команд. Программа может передавать информацию на электронное табло в одном из форматов Firich, DSP800, Epson или AEDEX. Надо выбрать систему команд, которую поддерживает данное электронное табло.

  • Ширина строки. Количество символов, которое отображается в строке электронного табло.

  • Строк. Количество строк на электронном табло. Программа может работать с однострочными или двухстрочными табло. Если строк на табло больше двух, то программа будет использовать первые две строки.

  • Кодировка. В зависимости от того, какую кодировку требует табло, здесь можно выбрать кодировку ASCII (DOS) или ANSI (Windows).

  • Кнопка Проверка настроек. После завершения настройки табло можно нажать эту кнопку. Если все настроено верно, то на табло отобразится тестовый текст.

Табло POSUA.

Для выбора этого способа должна быть нажата кнопка "Табло POSUA".

  • Кнопка Проверка работы.

Для работы с табло POSUA никаких настроек не требуется. Достаточно положить драйвер для работы c POSUA (файл LPOS_VFD_LCD.dll) в папку, где установлена программа Kassa_W.exe. Этот файл должен быть на диске, приложенном к табло. Его также можно скачать с сайта производителя табло.

При нажатии кнопки происходит тестовое отображение на табло.


Закладка SLS-Дисконт

Эта закладка используется для совместной работы программы с SLS-Дисконт.

Режим работы с Дисконтом.

  • Дисконт выключен. Программа Касса работает без использования дисконтной системы

  • SLS-Дисконт. Этот флажок используется для включения совместной работы программы Касса и программы SLS-Дисконт. Если флажок включен, то при начале работы программа проверяет наличие информации о дисконтных картах, подготовленной программой SLS-Дисконт. Если этой информации нет, то работа программы Касса прекращается с выдачей соответствующего сообщения.

  • VT:Дисконт. Этот флажок используется для включения совместной работы программа Касса с дисконтной системой VT:Дисконт разработки ООО Версия Т.

Для работы с SLS-Дисконт настраиваются следующие параметры:

  • Путь и имя файла со скидками из программы Дисконт. В этом поле надо выбрать путь и имя файла, в котором SLS-Дисконт будет передавать информацию программе Касса. До того, как это делать, надо в настройках программы SLS-Дисконт задать путь и имя этого файла и выполнить его создание. После этого в данном поле с помощью кнопки, расположенной справа от него, надо выбрать этот файл.

  • Префикс кода покупателя. Для того, чтобы программа Касса могла отличить коды дисконтных карт от кодов товара, надо чтобы все дисконтные карты имели код, начинающийся с одинаковых символов (одинаковый префикс). Кроме того, требуется чтобы префикс кодов дисконтных карт не совпадал с префиксом кода какого-нибудь товара. Рекомендуемое значение префикса - 27.

  • Если сумма чека больше минимальной и карточки нет.

В SLS-Дисконт можно указать некоторую пороговую сумму, после которой можно предложить покупателю дисконтную карту. Это поле может иметь одно из трех значений:

Можно пробить чек и без карточки. В этом случае программа ничего не делает при сумме чека больше минимальной.

Просто предупредить о необходимости выдать карточку. В этом случае при пробитии чека с суммой, больше минимальной, кассиру выдается напоминание о том, что надо предложить клиенту дисконтную карту. Кассир может это сообщение проигнорировать.

Пароль администратора для продолжения - выдачи карточки или отказа. В этом случае кассиру выдается сообщение о том, что надо предложить клиенту карточку. Если у кассира нет прав администратора или кассира-администратора, то он должен пригласить администратора для выдачи клиенту карточки или отказа от выдачи карточки. До ввода пароля администратора или кассира-администратора пробить чек невозможно.

  • Округлять скидку до. В этом поле можно указать округление цены товара после применения к ней дисконтной скидки. Если это поле пустое, или там стоит 0.01, то округление не выполняется. Если в нем указать 0.1, то цены будут округляться до 10 копеек, если 1, то до рубля. Возможно задание произвольных значений. Например, 0.25 будет округлять до ближайшего из 0 копеек, 25 копеек, 50 копеек или 75 копеек.

Для работы с VT:Дисконт настраиваются следующие параметры:

  • IP-адрес VT:Дисконт Магазин. Здесь указывается IP-адрес компьютера, на котором работает программа VT:Дисконт Магазин.

  • Порт. Здесь указывается IP порт, указанный в настройках VT:Дисконт Магазин

  • Номер кассы в VT:Дисконт Магазин. Здесь указывается номер данного рабочего места в описании в программе VT:Дисконт Магазин.

  • Округлять скидку до. В этом поле можно указать округление цены товара после применения к ней дисконтной скидки. Если это поле пустое, или там стоит 0.01, то округление не выполняется. Если в нем указать 0.1, то цены будут округляться до 10 копеек, если 1, то до рубля. Возможно задание произвольных значений. Например, 0.25 будет округлять до ближайшего из 0 копеек, 25 копеек, 50 копеек или 75 копеек.


Закладка SLS-Эквайринг

Эта закладка используется для настройки совместной работы с программой SLS-Эквайринг (использование банковских карт для оплаты покупок).

  • Флажок Включить работу с SLS-Эквайринг. Включает совместную работу с SLS-Эквайринг.

Если в " Настройке базы данных " сделаны описания для эквайринга, а этот флажок не включен, то программа SLS-Касса будет предполагать, что кассир осуществляет банковские транзакции вручную с помощью банковского терминала. При этом будут выдаваться напоминания о необходимости провести транзакцию, дать слип на подпись покупателю и т.д.

При ручных банковских транзакциях в базе данных информация будет почти такой же, как при работе с SLS-Эквайринг. Отличие только в том, что информация о результате проведении транзакции и сумме, списанной с карты, менее достоверна при ручных транзакциях (все это на совести кассира), и нет информации о типе и номере банковской карты.

  • Путь к папке связи с SLS-Эквайринг. В этом поле надо выбрать папку связи, через которую будет производиться обмен информацией с программой SLS-Эквайринг. Эта же самая папка должна быть указана как папка связи в настройках SLS-Эквайринга.


Настройка база данных (система)

Окно настройки содержит закладки:

  • Товары. Настройка режимов работы программы SLS-Касса с товарами
  • Общие для всех касс. Настройка связи между объектами базы данных SLS-Склад и программой SLS-Касса.
  • Рабочие места кассиров. Описание кассовых мест, которые используются при работе.
  • Пользователи и их права. Описание пользователей программы Касса и их прав.
  • Эквайринг. Настройка отображения платежей по банковским картам в базе данных программы SLS-Склад.


<Закладка "Товары">

  • Символ ограничитель в названии. Обычно на кассовых чеках место для названия товара ограничено. Для того, чтобы названия на чеках распечатывались по возможности без обрезания посреди слова, можно указать в этом поле символ, отличный от "?". Если поставить, например, пробел, то при печати чеков будет браться только первое слово названия (текст до первого пробела).

  • Использовать второе наименование. Если в Глобальных параметрах программы Склад включена возможность ввода второго наименования для товара, то галочка в этом поле приведет к тому, что на чеках будет печататься второе наименование товара. Если это наименование для данного товара не заполнено, то вместо него будет печататься как обычно основное название.

  • Срок возврата товара ХХ дней. При подготовке списка номенклатуры для кассового рабочего места, в этот список включаются только те товары, у которых есть цена продажи и положительный остаток в соответствующем отделе. Если в этом поле стоит число больше нуля и меньше 365, то в список также включаются товары, которые закончились не более, чем ХХ дней назад. Это дает возможность делать возврат через кассу для проданного полностью товара и продавать товар, который вчера кончился, а сегодня еще не успели его оприходовать.

Если значение этого поля 0, то в список включается только номенклатура, которая есть в наличии, если значение больше 365, то включается вся номенклатура, независимо от фактического остатка.

  • Загружать товары, у которых нет приходов. Это поле касается только пользователей SLS-Склад Стандарт или тех, у кого в Глобальных параметрах не включено использование нескольких мест хранения. Если здесь стоит галочка, то в список номенклатуры включаются все товары, у которых есть цена продажи, даже если в их карточках нет ни одной операции.

  • Запись информации о продажах по сотрудникам. Это поле видно только при включении в программе Склад режима учета по сотрудникам.

  • Продавцы. Здесь можно включить учет по продавцам. Если выбрано "указывать обязательно", то перед пробитием каждого чека кассир должен будет обязательно выбрать из списка сотрудников того продавца, который обслуживал данного покупателя. Если выбрано "указывать не обязательно", то кассир не обязательно должен указывать продавца перед пробитием чека. Продавец остается выбранным только на один чек.

При выборе "продавец в каждой покупке" у кассира будет возможность указать не одного продавца на весь чек, а своего продавца для каждой покупки чека. Если в программе Склад включен учет по аналитическим признакам товара, то при выборе товара, в аналитическом типе которого стоит признак "продавец обязателен", программа будет требовать обязательно указать продавца для данного товара.

  • Флажок "Для товаров без аналитического типа продавец обязателен". Этот флажок действует только если для продавцов включен учет "продавец в каждой покупке". Если этот флажок включен, то для товаров без аналитического типа (или для всех товаров, если в программе Склад не включен учет по аналитическим признакам), продавец будет обязательным. Если флажок выключен, то кассир может указать подавца, а может и не указывать.

  • Администраторы. Здесь можно включить учет по администраторам. Если учет включен, то к моменту пробития чека должен быть указан дежурный администратор зала. Это можно сделать в программе Кассовый сервер, в самой программе Касса (через меню F10) или непосредственно перед пробитием чека. Если администратор указан, то он остается выбранным до явного изменения или до завершения работы программы Касса.

  • Кассир как участник продажи устанавливается автоматически при подключении его в начале работы с программой

  • Кнопка Системная информация позволяет открыть окно для настройки системных параметров - размера кэш, сетевого протокола для работы с Сервером приложений и т.д. Как правило, настройки, принятые "по умолчанию", обеспечивают нормальную работу Кассового сервера.

  • Административные скидки. Здесь можно настроить использование произвольной скидки, предоставляемой администратором. Для этого надо

  • в поле Карта администратора ввести код специальной карточки администратора, которая будет давать возможность ввести такую скидку.
  • в поле Округл. можно указать округление цены после предоставления скидки. Например, 1.00 приведет к округлению до одного рубля, а 0.50 - до 50 копеек.
  • в поле Максимальная скидка можно поставить верхний предел для администраторской скидки в процентах.
  • если в программе Склад включена работа со скидками по приказу, то добавляется еще одно поле Максимальная скидка по приказу. В нем ставится максимальная скидка для товаров, которые уже имеют скидку по приказу.


Системная информация

Доступ к окну "Системная информация" осуществляется через "Настройка > База данных (система) > Закладка товары".

Здесь отображается информация о работе с базой данных и можно выполнить настройки для сетевой работы, если требуется изменить те, которые были выбраны автоматически.

Использовать эти настройки имеет смысл только для работы с базой данных, т.е. в режимах "Автономный - база данных только для обмена" или "Напрямую с базой данных".

В окне показываются текущие системные настройки.

  • Статистика за ... Время, в течение которого собиралась статистика, отображенная в этом окне. По умолчанию, это время, прошедшее с момента запуска программы.

  • Пользователь. Имя, под которым программа видна в Сервере приложений.

  • Файл базы данных. Путь и имя базы данных, с которой идет работа и ее текущий размер.

  • Буфера приемные. Количество буферов, выделенных для приема информации от Сервера приложений. Min и Tek - минимальное количество свободных буферов, за время сбора статистики и их текущее количество.

  • Буфера запросов. Количество буферов, выделенных для передачи информации к Серверу приложений. Min и Tek - минимальное количество свободных буферов, за время сбора статистики и их текущее количество.

  • Запросов/сек. Количество запросов в секунду от программы. Max - максимальное за время сбора статистики. Tek - текущее количество.

Качество работы сети.

  • Ошибок приема/передачи. При работе сетевой версии - это количество ошибок приема/передачи, обнаруженных аппаратно.

  • Ошибок контрольной суммы. При работе сетевой версии - это количество блоков, которые были нормально приняты аппаратно, но имели неверную контрольную сумму (т.е. были искажены при передаче).

В обоих случаях ошибки устраняются автоматической перепосылкой запроса, но вся работа из-за этого замедляется.

Общая статистика

  • Выполнено транзакций. Количество транзакций (сеансов записи) в базу данных.

  • Номер текущей транзакции. Общее количество транзакций, выполненых всеми программами, работающими с этой базой данных.

  • Количество блоков кэш. Количество оперативной памяти, выделенной для кэширования базы данных программой.

  • Занято блоков кэш. Сколько оперативной памяти для кэширования используется в данный момент.

  • Количество сбросов кэш. При сетевой работе кэш сбрасывается, если становится невозможно поддержать его состояние актуальным. Например, если другая станция выполнила большую транзакцию. После сброса кэш начинает заполняться заново по мере обращений к базе данных.

Работа с базой данных

  • Запись блока. Количество блоков, записанных в базу данных за время сбора статистики.

  • Чтение блока. Количество блоков прочтенных из базы данных и из кэш за время сбора статистики.

  • Чтение блока из базы. Количество блоков, которые не были найдены в кэш и реально читались из базы данных.

  • Взято из кэш %. Сколько процентов чтения из базы данных заменилось чтением из кэш.

Текущее состояние.

  • Чтение. Значение 1 означает, что рабочая станция в данный момент находится в состоянии чтения. 1/2 - завершает чтение.

  • Запись. Значение 1 означает, что рабочая станция выполняет транзакцию, т.е. находится в состоянии записи в базу данных.

Захваченные записи.

В выпадающем списке перечислены записи, которые программа защищает в данный момент от удаления и корректировки. Как правило, это заголовки накладных, с которыми работает кассовый сервер.

Кнопки

  • Закрыть окно. Завершает просмотр статистики.

  • Сброс статистики. Вся статистика начинает собираться с нуля.

  • Настройка. Открывает окно настройки системных параметров программы.

В верхней части окна расположен список сетевых протоколов, обнаруженных на данном компьютере.

Ниже расположено окно настройки размера кэш для программы. Увеличение размера кэш больше установленных по умолчанию трех мегабайт может ускорить работу программы. Зависимость между размером кэш и быстродействием не линейная. Так увеличение этого размера с 3-х до 30 мегабайт вызовет ускорение не более, чем в полтора раза.

ВНИМАНИЕ! Над окном расположена надпись синими буквами о количестве свободной оперативной памяти, доступной при старте программы. Размер кэш не должен быть больше, чем 1/3 - 1/2 от этого значения. Иначе Windows расположит кэш не в памяти, а на диске в файле подкачки. Как результат, вместо ускорения получится замедление работы.

Если программа сетевая и подключена к базе данных.

Слева от списка протоколов синим флажком отмечен тот протокол, по которому идет работа с Сервером приложений. Двойным кликом напротив любого протокола можно переместить флажок на этот протокол. Тогда при следующем открытии базы данных программа попытается использовать новый протокол. Если попытка не удастся, то будет проверяться возможность работы на всех других протоколах, до тех пор, пока не найдется протокол, на котором удастся установить связь с Сервером приложений.

В правой нижней части окна находится список протоколов, которые отмечены в настройке Сервера приложений. Там же находится кнопка Тестирование скорости связи. При ее нажатии программа в течение одной секунды по каждому из протоколов посылает тестовые пакеты, на которые Сервер приложений сразу отвечает. Количество пакетов, которыми удалось обменяться за секунду, отображается в списке протоколов в колонке Скорость. Чем больше число в этой колонке, тем быстрее идет обмен на данном протоколе. На не очень древних компьютерах Скорость должна выражаться 3-х или 4-х значным числом.


<Закладка "Общие для всех касс">

  • Какие цены использовать на кассах. В этом поле надо указать цены, которые будут использоваться на кассах при продаже товаров. В списке выбора есть три цены из карточки товара (учетная и две цены продажи) и цены из всех прайс-листов, созданных в программе SLS-Склад.

  • Тип кассовой накладной. Поскольку кассовые расходные накладные создаются автоматически, то в этом поле надо указать один из типов расходных накладных, определенных в программе SLS-Склад. Обычно здесь указывается "Наличный расчет", хотя можно в складской программе создать новый тип с названием, допустим, "Продажи через кассу" и использовать его.

  • Каждая покупка отдельная строка накладной. Если этот флажок включен, то в расходной кассовой накладной в базе данных каждая продажа записывается как отдельная строка. При этом накладная соответствует по покупкам контрольной чековой ленте. Если флажок выключен, то при создании расходной кассовой накладной производится "сворачивание" покупок по товарам. Для каждого проданного товара создается только одна строка. При этом количество в этой строке равно полному количеству проданного товара, сумма - равна общей сумме продаж этого товара, а цена получается как количество деленное на сумму. Т.е. цена - это средняя цена продаж данного товара.

  • Разрешить продажи с нулевой ценой. Если этот флажок включен, то в список номенклатуры, передаваемой в программу Касса, будут включены товары с нулевой ценой. Включать этот флажок имеет смысл только, если есть товары, которые прилагаются к основному товару бесплатно (например, сим-карта к телефону), но нужен их количественный учет.

Независимо от того, включен этот флажок, или выключен, при добавлении товара с нулевой ценой, товар списывается в базе данных (в операции расхода цена нулевая), печатается в товарном чеке, но не пробивается на фискальном регистраторе.

  • Режим печати чеков. Здесь возможны три значения:

Все покупки с наименованием - на чеке будет печататься каждая покупка и наименование соответствующего товара

Все покупки без наименования - на чеке будет печататься фискализирующая пробивка для каждой покупки, но название товара печататься не будет. При этом уменьшается расход чековой ленты.

Без покупок - только общая сумма чека - На чеке будет печататься только одна фискализирующая пробивка на полную сумму чека. Это имеет смысл, если одновременно печатается товарный чек, в котором все покупки полностью расписаны.

  • Печать скидок на чеке. Этот пункт касается только печати скидок , если скидки не используются, то его значение безразлично. Действие различных вариантов этого пункта зависит от типа используемой ККМ. Не на всех аппаратах есть возможность реализовать все варианты полностью.

Не печатать СКИДКИ на чеке. Информация по скидкам видна на компьютере, все позиции чека пробиваются с учетом скидки, но на чеке про скидки ничего не печатается.

Печ. РУБ.+ % крупно - В заголовке чека печатается информация о проценте скидки и ее сумме. Все позиции чека пробиваются с учетом скидки (т.е. с меньшей ценой).

Печ. РУБ+ % мелко. - Аналогично предыдущему пункту, но на некоторых кассовых аппаратах информация уместится в одну строку вместо двух.

Только % - Печатается только процент скидки.

Только РУБ. - Печатается только сумма скидки.

  • Печатать количество. Если в этом поле стоит галочка, то на чеке для каждой покупки печатается дополнительная информация - цена за единицу товара и его количество. Действие различных вариантов этого пункта зависит от типа используемой ККМ. Не на всех аппаратах есть возможность реализовать все варианты полностью.

  • Печатать сдачу. Если в этом поле стоит галочка, то после чека печатается дополнительно сумма, полученная от покупателя и выданная ему сдача. Действие различных вариантов этого пункта зависит от типа используемой ККМ. Не на всех аппаратах есть возможность реализовать все варианты полностью.

  • Печатать фамилию кассира. Если в этом поле стоит галочка, то на чеке дополнительно печатается слово "Кассир" и его фамилия из " описания пользователей ".Действие различных вариантов этого пункта зависит от типа используемой ККМ. Не на всех аппаратах есть возможность реализовать все варианты полностью.

  • Отдельный чек в каждый отдел. Если в этом поле стоит галочка и касса обслуживает несколько отделов (см. " Рабочие места кассиров "), то все покупки автоматически сортируются по отделам и печатается отдельный чек для каждого отдела. После всех чеков печатается общая сумма.

  • Печатать название отдела. Если в этом поле стоит галочка, то в заголовке чека печатается название соответствующего отдела. Действие различных вариантов этого пункта зависит от типа используемой ККМ. Не на всех аппаратах есть возможность реализовать все варианты полностью.

  • Скидки. В этом поле настраивается до 10 скидок, которые кассир может давать в ручном или автоматическом режиме. Подробнее о скидках см. в разделе Скидки .

Ограничение прав пользователей с типом "Кассир".

Этот раздел позволяет запретить кассирам выполнять некоторые действия самостоятельно.

  • Запретить корректировать текущий чек. При необходимости изменить количество товара в уже введенной позиции, удалить какую-нибудь позицию, аннулировать чек и т.п., кассир получит сообщение, что для выполнения этого действия необходимо ввести пароль администратора (или кассира-администратора) и приглашение на ввод. Кассир должен подозвать администратора, чтобы тот выполнил требуемое действие.

  • Запретить работу с чековой лентой и отчеты. Пункты главного меню "Работа с чековой лентой" и "Получение Х и Z отчетов" будут недоступны для кассира.

  • Запретить работу с предыдущими чеками. В кассовой программе есть возможность просмотреть список уже пробитых чеков и сделать на их базе чеки на возврат или напечатать товарные чеки. Если это запрещено, то соответствующие пункты меню для кассира недоступны

  • Настройка вида товарных чеков. Кассовая программа позволяет кроме обычных чеков печатать на принтере товарные чеки. Эта кнопка позволяет настроить внешний вид этих товарных чеков.

  • Настройка заголовка чека. При работе с программой SLS-Касса Windows-версии эта кнопка не используется.


<Скидки>

Назад к закладке "Общие для всех касс".

В кассовой программе можно установить до 10 скидок, которые применяются ко всем покупкам чека.

Можно описать три вида скидок, которые по разному учитываются в складской программе.

  • Это скидки уменьшающие цену продажи, которые кассир выбирает вручную с помощью меню.

  • Скидки, которые отражаются в складской базе данных и могут выбираться через меню или через штрих-код.

  • Скидки, которые отражаются в складской базе данных и применяются автоматически в зависимости от суммы чека. Эти скидки можно также выбирать с помощью меню или штрих-кода.

Скидки всех типов можно использовать одновременно, но применяется к каждому из чеков только одна из них.

  • Скидки, связанные с уменьшением цены.

Для их включения надо в разделе "Скидки..." ввести описание каждой из скидок. При этом заполняются следующие поля:

"Название скидки" - название для меню кассира, позволяющее ему выбрать нужную скидку. Например, "До 10 утра".

"Скидка" - процент скидки (целое число)

"Округлять до" - здесь можно указать округление при расчете скидок. Например, 1.00 - округлять до рублей; 0.50 - до 50 копеек; 0.10 - до 10 копеек. Если не указано ничего, то округляется до 1 копейки.

В карточке каждого кассира ("Пользователи и их права") в поле "Может ли изменять цену продажи" надо поставить "ДА" - иначе выбор скидок из меню будет ему недоступен.

Если требуется печатать информацию о скидке на чеке, то надо в разделе "Настройка системы/Режим печати чека" установить в поле "Печатать ли скидку в чеке" значение "ДА".

При работе кассира в режиме подготовки чека у него появится возможность нажав клавишу F5 вызвать меню с установленными администратором скидками. Кроме того в нем будет строка "Убрать скидку". Выбранная скидка будет относиться ко всем покупкам чека, независимо от того, когда она была установлена - перед началом, в процессе или после набора покупок.

Скидка действует только в пределах чека. После его пробивки или аннулирования скидка автоматически сбрасывается.

Информация о скидках накапливается в "Работе с чековой лентой" и в отчете по чековой ленте можно узнать о сумме скидок за день.

В складской программе в накладных товары списываются по ценам со скидками, а информации о сумме скидок не ведется.

  • Скидки, учитываемые в складской программе.

До начала настройки кассовой программы надо в складской программе завести специальные карточки товаров - скидки. Для этого лучше всего создать отдельную группу товаров. В каждой карточке следует заполнить поля:

"Наименование товара" - название для меню кассира, позволяющее ему выбрать нужную скидку. Например, "До 10 утра".

"Ед.изм" - здесь указывается процент скидки в виде "-XX%". Например, -10% -скидка в 10%. Знак минус перед цифрой обязателен. Все символы вводятся без пробелов.

"Номенклатурный номер" - необязательное поле. Если в него ввести некоторый штрих-код, то кассир сможет выбирать скидку с помощью сканера штрих-кодов.

Для включения скидок в кассовую программу надо в разделе "Скидки..." ввести описание каждой из скидок. При этом заполняются следующие поля:

"Название скидки" - ссылка на складскую карточку со скидкой. В это поле вводится текст "sNNNNNN", где NNNNNN - номер карточки товара. Например, s31 означает, что соответствующая скидка описана в карточке номер 31.

Вместо "s" можно использовать "f". Например, f31. В этом случае изменится отображение данной скидки в складской программе (см. ниже)

"Скидка" - в данном случае содержимое этого поля игнорируется.

"Округлять до" - здесь можно указать округление при расчете скидок. Например, 1.00 - округлять до рублей; 0.50 - до 50 копеек; 0.10 - до 10 копеек. Если не указано ничего, то округляется до 1 копейки.

Если требуется печатать информацию о скидке на чеке, то надо в разделе "Настройка системы/Режим печати чека" установить в поле "Печатать ли скидку в чеке" значение "ДА".

В карточке каждого кассира ("Пользователи и их права") в поле "Может ли изменять цену продажи" можно поставить "ДА" или "Нет".

Если стоит "ДА", то при работе кассира в режиме подготовки чека у него появится возможность нажав клавишу F5 или F2 вызвать меню с установленными администратором скидками. Кроме того в нем будет строка "Убрать скидку". Выбранная скидка будет относиться ко всем покупкам чека, независимо от того, когда она была установлена - перед началом, в процессе или после набора покупок.

Если стоит "Нет", то кассир может выбирать скидки только с помощью сканера штрих-кодов. Для того, чтобы он мог отказаться от выбранной ранее скидки, следует в складской программе завести скидку с единицей измерения -0% и каким-либо штрих-кодом, который должен быть у каждого кассира.

Скидка действует только в пределах чека. После его пробивки или анулирования скидка автоматически сбрасывается.

Информация о скидках накапливается в "Работе с чековой лентой" и в отчете можно узнать о сумме скидок за день.

Если описание скидки начинается с символа "s", то в складской программе все товары учитываются по своим ценам продажи, а в конце расходной накладной добавляется по одной строке на каждый процент скидки, в которой видна суммарная скидка за день. Общая сумма накладной при этом соответствует сумме, пробитой на кассовом аппарате.

Если описание скидки начинается с символа "f", то в складской программе все товары будут учтены по реальной цене продажи с учетом примененной скидки. Никаких дополнительных строк в этом случае в расходной накладной не создается.

  • Автоматические скидки

Автоматические скидки устанавливаются и настраиваются так как описано в пункте 2. Единственное отличие состоит в том, что при заполнении карточки товара для скидки надо в полях "Цены продажи" указать пороговые значения для включения скидок. В первой цене продажи указывается сумма, начиная с которой действует данная скидка, а во второй - сумма, начиная с которой действие скидки прекращается. Если начальная сумма указана, а конечная нет, то считается что скидка действует от начальной цены и далее.

Пороговые суммы всегда указываются в рублях независимо от того как называется валюта соответствующего поля.

При подготовке чека кассиром после каждой введенной покупки автоматически проверяется сумма чека. Если она оказалась в диапазоне одной из заданных скидок, то эта скидка автоматически устанавливается.

Кассир имеет возможность в любой момент выключить или включить режим автоматических скидок.

В случае, если автоматические скидки в зависимости от суммы чека надо давать не всем, а только предъявителям дисконтной карты, имеется дополнительная возможность включения/выключения автоматических скидок.

Для этого надо завести в складской программе карточку товара с некоторым номенклатурным номером. Остальные поля этой карточки товара безразличны. Этот номенклатурный номер должен быть нанесен на все дисконтные карты.

Таким образом, дисконтные карты не будут персональными и накопления продаж на них не будет. То есть этот вариант занимает промежуточное положение между скидочными картами на фиксированный процент и полноценной дисконтной системой с персональным учетом.

В одной из строк описания скидок надо добавить строчку, где в поле "Название скидки" надо написать DNNNNNN, где NNNNNN - номер соответствующей карточки товара. Например, D155, если карточка имеет номер 155.

Если после этого кассир просканирует код, который совпадает с соответствующим номенклатурным номером, то для текущего чека включатся автоматические скидки. После печати или аннулирования чека, автоматические скидки выключатся.

Назад к закладке "Общие для всех касс".


<Настройка вида товарных чеков>

При печати товарного чека на принтере, основная часть товарного чека формируется автоматически.

Она содержит дату и время печати, номер кассового аппарата, номер контрольной ленты и номер чека. После этого идет таблица, содержащая наименования товаров (до 120 символов), цену продажи, количество и сумму по каждому товару. В конце таблицы печатается итоговая строка.

В начале товарного чека (перед таблицей) можно вставить произвольный текст ("первый заголовок"). Например, название магазина, телефоны и т.п.

В конце товарного чека (после таблицы) можно вставить, например, текст с гарантийными обязательствами, подписи, место для печати и т.п.("последний подвал").

Если в товарном чеке много позиций и он не умещается на одном листе, то можно также добавить тексты, которые будут печататься в начале каждого листа ("промежуточный заголовок"), кроме первого - в начале первого листа всегда печатается "первый заголовок".

Можно также добавить тексты, которые будут печататься в конце каждого листа ("промежуточный подвал"), кроме последнего, где всегда печатается "последний подвал".

  • С помощью полей "Что показывать и редактировать" можно выбрать один из текстов. При этом в верхней части поля редактирования пишется соответствующий заголовок..

  • Пропустить в начале ХХ строк. Если требуется оставить в начале страницы свободное место, например, для типографского логотипа, то здесь можно указать число пропускаемых строк.

  • Печатать ХХ экземпляров. Если указать здесь число большее 1, то будет напечатно ХХ экземпляров товарного чека.

  • Печатать товарный чек на ККМ, а не на принтере. Если ширина чека ККМ больше 28 символов в строке, то можно включить этот флажок. В этом случае товарный чек будет печататься в нужном количестве экземпляров сразу после фискального чека. Если флажок выключен, то товарный чек печатается на принтере, который назначен в Windows принтером по умолчанию.

  • Печатать в названии товара номенклатурный номер. Если этот флажок включен, то при печати товарного чека после названия добавляется номенклатурный номер товара. Например, "=4902030060503=". Для товаров, у которых нет номенклатурного номера, печатается номер карточки товара

  • Печатать в названии товара номер карточки. Если этот флажок включен, то при печати товарного чека после названия добавляется номер карточки товара. Например, "[Код: 12345]".

Если в программе Склад включен учет продаж по сотрудникам, то появляются дополнительные флажки.

  • Не печатать имя кассира. Если этот флажок включен, то на товарном чеке не будет печататься "Кассир: ФИО". По умолчанию флажок выключен.

  • Не печатать имя продавца. Если этот флажок включен, то на товарном чеке не будет печататься "Продавец: ФИО". По умолчанию флажок выключен.


<Закладка "Рабочие места кассиров">

На этой закладке содержатся описания всех кассовых рабочих мест.

Для каждого рабочего места отображаются его название, тип подключения и номер рабочего места.

В список можно добавлять новые описания, корректировать или удалять старые. Это делается или через меню "Действия с описаниями" или с помощью правой кнопки мыши, или "горячими" клавишами (они перечислены в меню).

Как создается и корректируется описание рабочего места описано в следующем разделе.


<Рабочее место кассира>

Настройка рабочего места кассира содержит две закладки:

  • Рабочее место кассира. См. описание ниже.

  • Индивидуальные настройки

  • Название для меню и отчетов. Здесь можно написать произвольный текст, который будет отображаться на экране для данного рабочего места. Например, "Касса № 2", "Ночная касса", "Касса у окна" и т.п.

  • Номер рабочего места. Здесь должен быть указан тот же номер, который задан в программе Касса в настройке рабочего места.

  • Автоблокировка кассы через... минут. Если в этом поле стоит не 0, то через соответствующее количество минут неактивности, программа Касса покажет на экране окно подключения кассира и заблокируется до ввода правильного имени и пароля. Программа считается неактивной, если не открыто никаких окон и нет покупок в чеке.

  • Табло покупателя на экране. Если в этом поле стоит галочка, то в кассовой программе на экране будет отображаться крупными цифрами текущая сумма чека, а перед пробитием чека - сумма чека, полученные от покупателя деньги и сдача.

  • Запись покупки при заполнении количества. После выбора кассиром товара, курсор в кассовой программе устанавливается в поле "Количество". Если здесь стоит галочка, то при нажатии Enter в поле "Количество", покупка попадает в чек. Если галочки нет, то курсор переходит в поле "Стоимость", где кассир, в соответствии с настройкой его прав , может изменить стоимость для соответствующего изменения цены или количества.

  • Контроль остатка. Это поле позволяет управлять контролем за остатком товара при продажах через кассу. Тип контроля устанавливается для всех товаров, продающихся через данную кассу, независимо от того, что указано в складской базе данных в карточках этих товаров.

Возможно три варианта:

Контроль остатка выключен. Независимо от того, есть данный товар в наличии (по базе данных) или нет - покупка пробивается безо всяких вопросов. Обычно этот режим используется при продажах по системе универсамов, или когда к моменту пробивки чека товар уже отобран и заведомо есть в наличии. Понятно, что говорить покупателю о том, что в базе товара нет и поэтому мы не можем его продать, нельзя.

Контроль остатка с предупреждением. В этом случае при пробивке большего, чем есть по базе данных количества, кассиру выдается предупреждение о том, что столько пробить нельзя и сколько этого товара осталось. В зависимости от ситуации, кассир может или скорректировать пробиваемое количество, или все-таки пробить исходное количество. Этот режим обычно используется тогда, когда к моменту пробития чека товар еще не отложен. При появлении предупреждения, можно выяснить есть ли на самом деле товар и пробить то количество, которое есть реально.

Строгий контроль остатка. Все делается аналогично предыдущему пункту, но кассир не может пробить больше, чем есть по базе данных. Он может или отказаться от пробивки вообще, или пробить столько, сколько написано в базе данных.

Варианты поиска товаров.

Помимо поиска товаров с помощью сканера штрих-кодов, который включен всегда, у кассира есть возможность искать нужный товар в базе данных вручную:

- по названию товара (также включен всегда), Кассир отбирает товар из списка, отсортированного по названиям товаров.

- по номенклатурному номеру. Кассир выбирает товар из списка, отсортированного по номенклатурному номеру из карточки товара.

- по цене. Кассир выбирает товар из списка, отсортированного по возрастанию цен. Поскольку обычно товаров с одинаковой ценой немного, то это позволяет быстро найти нужный товар.

- по номеру карточки. Кассир выбирает товар по номеру карточки товара. Поскольку номера карточек уникальны и заполняются автоматически, то их можно использовать как коды для ручного выбора.

  • Основное поле поиска. Здесь можно указать какое из полей поиска является основным, т.е. полем "по умолчанию". Для поиска по другим включенным полям поиска кассиру надо будет перейти в них и только потом начинать поиск.

  • Печать товарного чека на принтер. Это поле позволяет настроить способ печати товарного чека на обычном принтере дополнительно к основному фискальному чеку кассового аппарата. Возможны четыре варианта:

- Не печатать. В этом случае товарный чек не печатается, а в меню кассовой программы нет соответствующих пунктов.

- Печатать всегда автоматически. Товарный чек всегда печатается одновременно с печатью фискального чека на кассовом аппарате.

- Задавать вопрос перед печатью. Перед началом печати каждого чека кассовый модуль спрашивает кассира "Печатать товарный чек?". В зависимости от ответа, товарный чек или печатается, или не печатается.

- Печатать только по запросу кассира. В этом случае кассир после печати обычного чека может через меню кассовой программы вызвать список пробитых чеков и для любого из них напечатать товарный чек. Для этого в настройках ограничений для кассиров (см. ограничение прав кассиров ) не должен быть включен запрет на просмотр предыдущих чеков.

- Печатать для продаж автоматически. В этом случае товарный чек автоматически печатается, но только для продаж. Для возвратов товарный чек не печатается.

  • Карточка для учета по ККМ.

Если это поле не пустое, то независимо от того, какая карточка для списания товара указана у кассира (см. Права пользователей ), весь товар по данному рабочему месту списывается на указанного контрагента. При этом расход учитывается не по кассирам, а по рабочим местам. Для очистки этого поля достаточно поставить в него курсор и нажать Ctrl+Y.

  • Обслуживаемые отделы.

Если программы Склад имеет версию больше, чем Стандарт и в ее Глобальных параметрах включен учет по нескольким местам хранения (складам), то здесь надо выбрать хотя бы один склад, который будет обслуживаться данным рабочим местом.

Например, учет в складской программе ведется по двум складам "Подсобка" и "Торговый зал". Товар передается в торговый зал актами передачи. Тогда для кассовой программы надо указать один отдел "Торговый зал", по которому она будет создавать расходные накладные для списания товара.

Если учет ведется раздельно по, скажем, складам "Галантерея" и "Продукты питания", то надо создать два отдела, куда кассир будет пробивать чеки.

Для каждого отдела имеется свой справочник номенклатуры для ручного поиска товара, но поиск по штрих-коду ведется во всех отделах и, после того, как товар найден, кассовая программа автоматически устанавливает нужный отдел.

Количество отделов не может быть больше, чем допускает используемый фискальный регистратор. В любом случае оно не может быть больше 14.

  • Пропускать товары, которые уже есть. Этот флажок присутствует только если в программе Склад включена работа с дополнительными свойствами товаров (поразмерный учет).

Если этот флажок включен, то при создании DAT-файла, товары, которые уже были записаны по предыдущим складам (тем, которые в списке обслуживаемых отделов находятся выше), не попадают в список номенклатуры второй раз.

Это можно использовать при переходе на учет по дополнительным свойствам. Если создать склад, на который будут передаваться товары, переведенные на новую схему учета, и поставить его в списке первым, то этот товар в списке номенклатуры для касс будет присутствовать только один раз - по первому отделу.


<Индивидуальные настройки>

Здесь присутствуют настройки, описанные ранее в разделе " Общие для всех касс ".

Если в какой-нибудь группе установить флажок "Индивидуально", то для данного рабочего места можно поставить настройки, отличающиеся от общих.

При снятии этого флажка, соответствующие настройки вернутся к тому состоянию, которое установлено для всех рабочих мест.


<Закладка "Пользователи и их права">

На этой закладке отображается список пользователей кассовой подсистемы.

Для каждого пользователя отображаются его имя для подключения, уровень прав при работе и внутренний идентификатор имени.

Если включен учет продаж по сотрудникам, то добавляется еще одна колонка - сотрудник. В ней указана фамилия сотрудника и в скобках его роль в системе учета сотрудников.

В список можно добавлять новых пользователей, корректировать или удалять старых. Это делается или через меню "Действия с описаниями" или с помощью правой кнопки мыши, или "горячими" клавишами (они перечислены в меню).

Как создается и корректируется описание пользователя описано в следующем разделе.


<Описание пользователя>

  • Имя для подключения к системе. Здесь указывается имя, которое пользователь должен вводить при подключении к системе. Для кассиров имеет смысл вводить простые имена, состоящие только из цифр, поскольку их проще набирать. Если имя содержит буквы, то при подключении заглавные и строчные буквы считаются одинаковыми.

  • Пароль. Если пароль не установлен, то при подключении достаточно оставить поле "Пароль" пустым. Если пароль содержит буквы, то заглавные и строчные буквы считаются различными. Кроме букв и цифр в пароль можно включать функциональные клавиши (F1..F10), а также использовать с ними Ctrl и Shift.

Пользователь с правами администратора может менять пароли у остальных пользователей в случае, если они забудут пароль. Если забыть пароль администратора, то восстановить его будет невозможно.

  • Штрих-код. Если в этом поле записать штрих-код карточки сотрудника, то в программе Касса при подключении к программе и при запросе разрешения администратор, можно просто просканировать этот штрих-код.

  • Тип пользователя. Пользователь может иметь один из трех типов, в зависимости от необходимости ограничить его права.

- Администратор. Это пользователь, обладающий всеми правами в кассовой подсистеме.

- Кассир-администратор. Это пользователь, который имеет все права, кроме корректировки прав пользователей.

- Кассир. Это пользователь, который не имеет прав на настройку системы и может дополнительно ограничиваться в правах на работу с кассовым модулем. (см. раздел Закладка "Общие для всех касс"

Для нормальной работы хватает одного пользователя с типом администратор. Пользователи с другими типами создаются только если есть необходимость в разграничении прав.

  • Только просмотр чековой ленты. Этот флажок виден только для пользователей с правами "Кассир-администратор". Если он включен, то для данного пользователя в "Работе с чековой лентой" доступен только просмотр и получение справок - корректирующие действия запрещены.

  • Карточка сотрудника. Если в программе Склад включен учет продаж по сотрудникам, то появляется дополнительное поле. В нем надо с помощью кнопки, расположенной справа от поля выбрать карточку, с которой будет связан данный пользователь программы Касса.

  • Учет наличности на карточке. При списании кассовым модулем товара из складской базы данных создается расходная накладная. Здесь надо указать на какую карточку списывать товар, проданный данным пользователем. Для каждого кассира можно создать свою карточку, тогда в складской программе на этой карточке будут собираться все продажи данного кассира. В конце смены можно в разделе "платежи" отметить сданные им деньги.

Если в этом поле не указана карточка, то данный пользователь не сможет работать с кассовым модулем. Для того, чтобы очистить поле, достаточно поставить в него курсор и нажать Ctrl+Y.

Иногда предпочтительней вести учет не по кассирам, а по рабочим местам. В этом случае можно указать карточку для списания в соответствующем поле в описании рабочего места.

  • Имя для печати на чеке. Если в настройках рабочего места стоит галочка "Печатать фамилию кассира" , то в этом поле можно указать текст, который будет печататься на чеках. Если поле не заполнено, то вместо него будет печататься "имя для подключения к системе" (см.выше).

  • Может давать скидки вручную. Если здесь установлена галочка и скидки настроены, то в касовом модуле кассиру будет доступно меню назначения скидок. Если галочки нет, то возможно использование только автоматических скидок или скидок по штрих-кодам. (см. Скидки )

  • При изменении "Стоимости". При пробивке покупки есть три основных показателя - цена, количество и стоимость. Обычно, достаточно просто указать количество, чтобы расчиталась стоимость. Вместе с этим есть несколько вспомогательных режимов, использование которых определяется здесь.

Если после выбора товара и, может быть, установки количества, кассир переведет курсор в поле "Стоимость", то возможны три варианта:

- Меняется количество. Кассир может изменить стоимость. При этом по той же цене пересчитается количество. Это можно использовать, например, при пробивке колбасы, на обертке которой, продавец написал "73 рубля". Количество (вес) расчитается автоматически.

- Меняется цена. При изменении стоимости количество останется прежним, но соответствующим образом изменится цена для данной покупки. Этот режим используют только в маленьких магазинах, в которых хозяин (он же кассир) может отпускать товар по договорным ценам.

- Изменение ЗАПРЕЩЕНО. В этом случае поле "Стоимость" закрыто от корректировки. Это обычный режим для больших магазинов.

  • На каких кассах может работать. Если в этом поле пусто, то пользователь может работать на любых рабочих местах, описанных в системе. Если требуется разрешить работу только на определенных местах, то здесь приводится их список.

Если для "администратора" или "кассира-администратора" в этом поле перечислены какие-нибудь рабочие места, то он может корректировать или удалять описания только этих рабочих мест.


Закладка Эквайринг

Эта закладка предназначена для настройки совместной работы программ SLS-Склад, SLS-Касса, SLS-Кассовый сервер с процессинговым центром банка для приема оплаты с помощью банковских карт.

Если обмен информацией с процессинговым центром делается автоматически с использованием программы SLS-Эквайринг, то надо также выполнить соответствующие настройки в программе SLS-Касса в разделе " Настройка рабочей станции ".

Если в программе SLS-Касса настройки не выполнены, то предполагается, что при платежах по банковской карте кассир вручную выполняет списание нужной суммы с помощью банковского терминала.

Для включения работы с банковсими картами надо включить флажок "Включить эквайринг" и заполнить появившееся поля:

  • Банк. В этом поле надо выбрать (или создать, а потом выбрать) контрагента в категории Поставщики, на карточке которого будут отображаться все операции с банковскими картами и вычисляться проценты комиссии банка по этим операциям.

  • Тип накладной для банка. В этом поле надо указать тип для приходных накладных, в которых будут отображаться операции с банковскими картами. Если нужно, то можно заранее в программе SLS-Склад создать новый тип для приходных накладных.

  • Категории банковских карт. В этой таблице находится список категорий, по которым предполагается вести учет. Для добавления, корректировки или удаления категорий служит кнопка справа от таблицы. Каждая категория имеет характеристики, задаваемые в специальном окне .

  • Префиксы. Для каждой категории существует набор префиксов (первых цифр номера карты). Эти префиксы позволяют по номеру карты отнести платеж к одной из категорий. Если у категории не описано ни одного префикса, то в списке категорий эта категория подсвечена красным и не используется в работе. Для добавления, корректировки и удаления префиксов служит кнопка справа от таблицы.

  • История действия %. Для каждой категории ведется история процентов комиссии банка по данной категории карт. При проведении оплаты или возврата по банковской карте, из этого списка выбирается тот процент, который действует на дату операции. Если у категории нет ни одной записи в этой таблице, то в списке категорий эта категория подсвечена красным и не используется в работе. Для добавления, корректировки и удаления префиксов служит кнопка справа от таблицы.

Добавлять, корректировать и удалять строчки в эту таблицу можно только с датами большими или равными сегодняшней. Изменения "задним числом" запрещены.

Для платежей с неопределенной категорией банковских карт

Эти настройки предназначены для учета операций по картам, категорию которых не удалось определить по номеру карты.

В частности, именно они будут использоваться при ручном списании с помощью банковского терминала.

Основное отличие в регистрации этих операций состоит в том, что каждая из них заносится в приходную накладную для банка как отдельная строка и в поле "примечание" этой строки заносится номер неопознанной карты. Это дает возможность скорректировать описания префиксов у одной из категорий, чтобы карты распознавались правильно.

  • Услуга для безналичных начислений. В этом поле надо выбрать услугу, на карточке которой будут отображаться оплаты банковскими картами с неопределенной категорией. Карточка услуги должна быть заранее создана в программе SLS-Склад.

  • Услуга для начисления %. В этом поле надо выбрать услугу, на карточке которой будут отображаться комиссионные проценты банка при оплате банковскими картами с неопределенной категорией. Карточка услуги должна быть заранее создана в программе SLS-Склад.

  • Процент банка. В этом поле надо указать процент комиссии банка для оплаты банковскими картами с неопределенной категорией.


Эквайринг. Описание категории.

Окно описания категории содержит следующие поля:

  • Название категории. Название может быть произвольным и используется только для отображения в таблице категорий. Можно использовать в качестве названия тип банковской карты - Visa, Maser Card и т.п.

  • Услуга для безналичных платежей. В этом поле надо выбрать услугу, на карточке которой будут отображаться оплаты банковскими картами с данной категорией. Карточка услуги должна быть заранее создана в программе SLS-Склад.

  • Услуга для начисления %. В этом поле надо выбрать услугу, на карточке которой будут отображаться комиссионные проценты банка при оплате банковскими картами с данной категорией. Карточка услуги должна быть заранее создана в программе SLS-Склад.

  • Действующий процент. В этом поле надо указать процент комиссии банка для оплаты банковскими картами с данной категорией.

Поле открыто для корректировки только при создании новой категории. При сохранении новой категории в таблицу "История действия %" автоматически добавляется запись с указанным процентом и сегодняшней датой. Дальнейшее изменение процента банка возможно только через таблицу "История действия %".


<Технические детали>

Этот раздел содержит некоторые технические детали реализации.

1. Информация, связанная с настройками рабочей станции хранится в registry на компьютере, где запущена программа Касса. Информация сохранена в ключе:

HKEY_Current_User \ Software \ SoftLand Systems \ Kassa \

2. В рабочей папке программы находятся файлы, имя которых состоит из восьми цифр. Это номер рабочего места из настроек, дополненный нулями слева. Назначаение файла определяется его расширением:

  • DAT - В этом файле содержится информация о номенклатуре и ценах для продаж товаров. В зависимости от режима работы программы, этот файл или создается самой программой (режим "Напрямую с базой данных" и "Автономный - база данных только для обмена") , или готовится для нее Кассовым сервером (режим "Автономный экспорт-импорт" и "Через Кассовый сервер"). Кассовый сервер создает файл с расширением NE-, который программа Касса переименовывает в DAT для обновления номенклатуры.

При отсутствии этого файла, программа Касса или создает его сама (при работе с базой данных), или выдает сообщение о том, что файл еще не создан Кассовым сервером.

В начале файла DAT содержится информация о дате и времени его создания и сроке действия (как правило, один день). Если при начале работы программа Касса определяет, что срок действия файла DAT истек, то она делает попытку создать его заново или выдает предупреждающее сообщение кассиру.

При нажатии Enter программа продолжит работу с той информацией, которая есть.

  • RES - В этом файле содержится информация о продажах, сделанных на этом рабочем месте. При отсутствии этого файла он автоматически создается.

Файл RES со временем увеличивается в размерах. Программа Касса проверяет размер этого файла и периодически создает его копию с расширением ~RES, а в самом файле оставляет информацию только за последние N дней. Количество дней задается в настройках рабочей станции.

Далее идут вспомогательные файлы.

  • LOG - Это текстовый файл, в который пишется информация о начале и конце работы программы, о сообщениях об ошибках, которые она выдавала кассиру, об аннулировании чеков и т.п.

  • ERR - Это текстовый файл, в который записывается информация об обмене с драйвером ККМ, в результате которого возникла ошибка. Нужен для диагностики.

Вспомогательные файлы со временем увеличиваются в размерах. Как только размер файла станет больше 2 Мбайт для файла ERR или 10 Мбайт для файла LOG, создается копия соответствующего файла с расширением ~ERR или ~LOG и соответствующий файл уменьшается в два раза. Таким образом, можно не беспокоится о том, что эти файлы со временем займут слишком много места на диске.


Часто возникающие вопросы

  • Какие имя и пароль использовать при первом подключении к программе?

  • Почему товар из базы данных не виден в программе Касса?

  • Что надо перенастроить при замене на рабочем месте фискального регистратора?

  • При сканировании штрих-кодов выбирается не тот товар?

  • При настройке внешних устройств или при начале работы появляется сообщение "СОМ-порт занят"?

  • Какие имя и пароль использовать при первом подключении к программе?

Для подключения к программе Касса используются имена и пароли, заданные в настройках программы Касса. Имена пользователей программы Склад для работы с программой Касса использовать нельзя.

Единственное исключение - имя Admin. Пользователь с этим именем существует всегда, даже если он не указан в явном виде в списке пользователей. Пароль пользователя Admin (в отличии от паролей других пользователей программы Касса) устанавливается в программе Склад. Если в программе Склад не включено расширенное санкционирование доступа, то это главный пароль базы данных.

При первом подключении к программе Касса надо в качестве имени ввести Admin, а пароль ввести тот же, который для имени Admin установлен в программе Склад. Если пароль для имени Admin не установлен, то поле пароля надо оставить пустым.

Рекомендуется создать в программе Касса кроме пользователей-кассиров, хотя бы одного пользователя с администраторскими правами, чтобы он мог выполнять все настройки.

Для того, чтобы пробивать чеки, пользователь не обязан иметь права кассира - единственное, что надо - это указать в правах пользователя карточку для списания товара. Поэтому можно разрешить администратору самому пробивать чеки - тогда настройка и тестирование программы будет проще для администратора - не придется переподключаться к программе для пробития чека.

  • Почему товар из базы данных не виден в программе Касса?

В список товаров программы Касса попадают только те товары, у которых:

-- Цена продажи не равна нулю

-- Сам товар есть в наличии на том складе, с которого идет списание программой Касса.

Если товар после обновления номенклатуры не попал в список товаров для продажи, то надо сделать следующее.

-- Посмотреть в настройках программы Касса (или Кассовый сервер) какие цены выбраны для торговли. Это может быть одна из цен в карточке товара, или цена из какого-нибудь прайс-листа. Далее в программе Склад найти этот товар и в режиме просмотра прайс-листа посмотреть какая цена продажи для него получается.

-- Если в базе данных включен учет по складам, то в программе Склад зайти на тот склад, который выбран в настройках программы Касса (или Кассовый сервер) для обслуживания (там он называется отделом). Проверить, что на этом складе данный товар есть в наличии. Если его нет, то надо или передать его с другого склада, или оприходовать на этот склад.

Если учет по складам не включен (или программа Склад имеет версию Стандарт), то товар должен быть в наличии в дереве товаров, т.е. его фактическое значение должно быть больше нуля. Если это не так, то надо оприходовать какое-нибудь количество (хотя бы одну штуку)

После этого можно обновить номенклатуру в программе Касса и товар там появится.

  • Что надо перенастроить при замене на рабочем месте фискального регистратора?

При выходе из строя фискального регистратора на рабочем месте, достаточно заменить его на резервный фискальный регистратор.

Если он того же типа, что и исходный, то ничего в программе настраивать не надо.

Если фискальный регистратор чем-то отличается от исходного, то достаточно в настройке рабочей станции на закладке "Фискальный регистратор" указать тип нового аппарата.

Если резервного фискального регистратора нет, то в настройке рабочей станции на закладке "Фискальный регистратор" можно выбрать режим работы "Без фискального регистратора". Однако, в этом случае, надо учитывать существующее законодательство.

  • При сканировании штрих-кодов выбирается не тот товар?

Скорее всего, сканер подключен в разрыв клавиатуры (или через USB с имитацией разрыва клавиатуры). В этом случае сканер передает цифры штрих-кода и символ Enter в конце. Проверить тип сканера проще всего так. Вызвать какой-нибудь стандартный текстовый радактор Windows - Блокнот, Wodpad, Word, Excel и попробовать просканировать какой-нибудь штрих-код. Если соответствующие цифры появятся на экране, то сканер подключен в разрыв клавиатуры.

Для того, чтобы программа Касса могла отличить ввод сканера от нажатий клавиш кассиром, надо в настройках рабочей станции на закладке Сканер выбрать правильный тип сканера. Там же есть возможность проверить правильность настройки.

Для сканеров подключенных через RS-232 (или через USB с виртуальным СОМ-портом) проверка в текстовом редакторе не пройдет - сканер прочтет код, но ничего на экране не появится. Для таких сканеров надо в настройках рабочей станции на закладке Сканер выбрать тип сканера через RS-232 и указать СОМ-порт, к которому он подключен.

  • При настройке внешних устройств или при начале работы появляется сообщение "СОМ-порт занят"?

Это сообщение может появиться в двух случаях:

1) Тот СОМ-порт, который выбран при настройке устройства (например, сканера штрих-кодов или электронного табло покупателя), уже используется каким-нибудь устройством, описанном в настройках Windows. Это может быть модем, мышка и т.п. При этом неважно подключено ли само устройство физически.

Проверьте в настройках Windows, что нужный Вам порт не занят другим устройством.

2) Если сообщение появляется при начале работы, то, скорее всего, его выдает драйвер фискального регистратора при попытке подключиться к ККМ. Это может быть связано с тем, что для работы драйвера назначен тот же СОМ-порт, что и для одного из внешених устройств, подключенных к программе Касса.

Посмотрите в настройках драйвера ККМ используемый им порт и проверьте, что в настройках внешних устройств этот порт не назначен ни одному из них. Если порт драйвера не пересекается с портами внешних устройств, то см. пункт 1.


Переход с ДОС-версии

Этот раздел предназначен для тех, кто ранее работал с ДОС-версией программы Касса.

Для кассиров почти ничего не изменилось - внешний вид, управляющие клавиши и порядок работы остались практически прежними.

Добавилась возможность проверки цены товара и активности дисконтной карты с помощью клавиши F7. Ранее для такой операции кассиры добавляли покупку в чек, а затем ее удаляли из чека.

Рекомендуется ознакомить кассиров с информацией раздела " Работа кассира ".

Для администратора системы.

1) Устанавливать Windows-версию программы Касса лучше не в ту папку, в которой раньше стояла ДОС-овская версия. В ДОС-версии использовалось много служебных файлов, которые теперь не нужны.

Если же, все-таки, установить Windows-версию программы в ту же папку, где ранее стояла ДОС-версия, то до первого программы Kassa_W.exe надо удостовериться, что в рабочей папке нет файла с именем <номер рабочего места>.RES. Если он есть, то его надо удалить.

2) В ДОС-версии настройки рабочей станции хранились в отдельных файлах в рабочей папке программы. В Windows-версии они хранятся в реестре рабочей станции. Поэтому настройки рабочей станции надо ввести в Windows-версии еще раз.

После первого запуска программы будет доступно только меню настройки рабочей станции (меню по клавише F10). В нем надо задать номер рабочего места, режим работы, путь к базе данных или к папке связи с Кассовым сервером. Далее надо настроить используемое оборудование.

Если требуется настроить несколько однотипных рабочих мест, то можно после настройки одного из них сохранить эти настройки и перенести их на другие компьютеры. Для этого надо запустить программу regedit, поставить в ней курсор на ветку HKEY_Current_User \ Software \ SoftLand Systems \ Kassa \ и экспортировать ее в файл. Далее перенести этот файл на другой компьютер и импортировать ее.

3) Настройки, записанные в базу данных для данного рабочего места сохраняются в том виде, как они были введены для ДОС-версии программы, т.е. их повторно вводить не надо.

4) После завершения первоначальных настроек надо перезапустить программу Касса. При последующих изменениях настроек перезапуска, как правило, не требуется.

5) Структура файла с результатами работы Кассы в Windows-версии ( <номер рабочего места>.RES ) отличается от структуры аналогичного файла ДОС-версии ( Kassa.RES ). Поэтому после установки Windows-версии становится невозможным выполнить такие операции, как возврат по предыдущим чекам, печать копии чека и печать товарных чеков, по тем продажам, которые были сделаны в ДОС-версии.

Если это существенно, то можно выполнить преобразование старого файла Kassa.Res в новый формат. К сожалению, в старом файле содержится меньше информации, чем в новом. Поэтому преобразование будет не вполне полным, но достаточным для выполнения перечисленных выше операций.

Преобразование лучше делать до начала продаж в Windows-версии. Для преобразования надо чтобы выполнялись два условия:

  • Размер нового файла продаж ( <номер рабочего места>.RES ) был меньше мегабайта.
  • В рабочей папке программы Kassa_W был старый файл продаж Kassa.RES

Для преобразования надо в меню F10 зайти в "Настройка > Рабочая станция". Если в рабочей папке есть файл Kassa.RES и размер нового файла продаж меньше мегабайта, то в правом верхнем углу первой вкладки появится кнопка для преобразования.

После ее нажатия информация за последние 90 дней из файла Kassa.RES преобразуется в новый формат, а все продажи, сделанные в новой версии, запишутся после записей Kassa.RES.

Если преобразование пройдет успешно, то файл Kassa.RES переименуется в Kassa.~RES и кнопка преобразования пропадет.

6) В отличии от ДОС-версии, номер рабочего места теперь не связан с заводским номером ККМ. Поэтому при замене ККМ на рабочем месте не требуется менять настройки. Единственное исключение, если ККМ меняется не на аналогичный аппарат - в этом случае надо в настройках рабочей станции выбрать правильный тип аппарата и, может быть, перенастроить драйвер ККМ.


Редактирование свойств закладок и кнопок

Окно редактирования свойств закладок и кнопок выглядит следующим образом:

  • Текст на кнопке (Название закладки). Здесь можно ввести текст, который должен быть написан на кнопке (закладке).

  • Код товара. Только для кнопок. Здесь можно ввести код, по которому будет выбираться товар при нажатии кнопки. Код можно ввести вручную, или выбором из списка товаров нужного. Для выбора надо нажать на кнопку, расположенную рядом с полем. Появится окно, в котором можно указать в каком списке нужно искать товар. Далее выбор делается так же, как при обычной работе.

Если после выбора кода поле "Текст на кнопке" оказывается пустым, то оно автоматически заполняется названием выбранного товара. После этого (если оно слишком длинное) его можно откорректировать.

Если после выбора товара поле "Текст на кнопке" уже заполнено, то задается вопрос - надо ли изменить текст в нем на название товара.

  • Флажок Закрывать панель выбора после нажатия кнопки. Виден только при редактировании кнопок и если панель быстрого выбора используется совместно с обычным выбором.

Если этот флажок включен, то после нажатия кнопки с товаром, панель быстрого выбора автоматически закрывается и товар попадает в нижнюю часть основного окна, где можно изменить его количество, указать продавца и т.д., как после обычного выбора.

Если флажок выключен, то после нажатия кнопки с товаром, панель быстрого выбора остается открытой и товар попадает прямо в чек с количеством равным 1.

Если в настройках указано, что используется "только панель быстрого выбора", то этот флажок не показывается и считается выключенным.

  • Шрифт. Нажатие кнопки справа от поля открывает окно выбора шрифта. Можно выбрать шрифт, его размер, начертание и цвет.

  • Цвет фона. Нажатие этой кнопки позволяет выбрать цвет фона кнопки или закладки. Рекомендуется выбирать не очень яркие цвета, чтобы меньше уставали глаза при работе.

Внизу справа отображается результат настроек - как будет выглядеть кнопка или закладка.

Примечания:

1) Если при описании кнопки не задать "Код товара", то в данном месте панели быстрого выбора будет не кнопка, а просто текст, написанный в поле "Текст на кнопке".

2) Если при работе окажется, что в базе данных нет товара с указанным кодом, то кнопка будет неактивной до тех пор, пока такой товар не появится.