<Назначение программы>

Программа Кассовый сервер (Kas_Serv.exe) предназначена для поддержки связи Кассового модуля (Kassa.exe) и базы данных SLS-Склад.

Хотя Кассовые модули могут самостоятельно работать с базой данных, использование Кассового сервера дает следующие преимущества:

  • Ускоряется работа Кассовых модулей. Кассовый модуль пробивает чек, но не производит списания из базы данных. Списание производится Кассовым сервером в фоновом режиме. Как правило, между пробитием чека и списанием товара из базы проходит 5-10 секунд.

  • Ускоряется работа пользователей SLS-Склад. Кассовый сервер регулирует скорость записи кассовой информации в базу данных с тем, чтобы не мешать работе менеджеров.

  • Обновление номенклатуры в кассах делается централизовано из Кассового сервера. При этом вся подготовка делается на Кассовом сервере, а Кассовый модуль закачивает к себе обновление в фоновом режиме не мешая обслуживать покупателей. Переключение на новый справочник номенклатуры делается в промежутке между пробитием чеков и занимает 4-5 секунд.

  • Настройка Кассовых модулей делается централизовано с помощью Кассового сервера.

  • В случае, если по какой-то причине пришлось восстановить базу данных с копии, Кассовый сервер автоматически догружает всю недостающую информацию о продажах.

  • При возникновении проблем с сетью, перезагрузки центрального компьютера и т.п. Кассовые модули автоматически переключаются в режим автономной работы. При возобновлении работы сети Кассовые модули автоматически возвращаются в нормальный режим и докачка информации о товарах, проданных при автономной работе, делается автоматически в фоновом режиме.

Настройка Кассового Сервера описана в разделе "Настройка программы"

Настройка Кассового модуля для совместной работы с Кассовым сервером описана в разделе " Настройка Кассового модуля ".

Основной режим работы см. в разделе " Основной экран кассового модуля ".

Технические детали реализации см. в разделе " Технические детали ".


<Настройка программы>

При первом запуске программы она просит указать базу данных, с которой должен работать Кассовый сервер и "директорию связи".

Под "директорией связи" понимается директория, которая служит для обмена информацией между Кассовым сервером и Кассовыми модулями. Эта директория может находится на любом компьютере. Единственное требование к ней - она должна быть доступна как от Кассового сервера, так и от всех Кассовых модулей.

Все пользователи должны иметь в этой директории полные права - чтение, запись, создание и удаление файлов.

Лучше всего создать директорию специально для этой цели. Файлы в ней будут содержать информацию о последних чеках, указатели в документы и т.п. Никакой общей информации из них получить нельзя.

В случае необходимости все эти файлы можно удалить - по мере необходимости они пересоздадутся.

После выбора базы данных и директории связи, появится основной экран Кассового сервера. Для продолжения настройки надо нажать F5 или выбрать из меню "Настройка" пункт " Настройка режимов работы ".

Настройка Кассового модуля для совместной работы с Кассовым сервером описана в разделе " Настройка Кассового модуля ".


<Ввод имени и пароля>

Программа Кассовый сервер стартует без запроса имени и пароля для подключения к базе данных. Основные пункты меню, в частности, обновление номенклатуры также не требуют ввода имени и пароля. Это дает возможность запускать программу и пользоваться ею любому пользователю.

Для выполнения действий, связанных с настройкой или с работой с чековыми электронными лентами, требуется наличие у пользователя прав. Для чего выполняется стандартная процедура подключения.

  • Имя. Имя пользователя, описанное в " Пользователях и их правах ".

  • Пароль. Пароль этого пользователя.

  • Имя пользователя по умолчанию. Если при подключении поставить здесь галочку, то имя, введенное при подключении, станет предлагаться при следующих подключениях автоматически. Это позволит вводить только пароль.

Справа от поля "Пароль" находится кнопка [image] . Если ее нажать, то символы, вводимые в поле "Пароль", станут видимыми. Это дает возможность проверить правильность ввода пароля. Напомним, что при вводе пароля учитывается регистр букв, поэтому случайное нажатие, скажем, Caps Lock не позволит правильно ввести пароль. Повторное нажатие на эту кнопку опять скроет символы пароля.

Примечания:

1.Имя пользователя Admin существует всегда, независимо от того, описано оно в "Пользователях и их правах" или нет. Пароль для этого имени определяется в программе Склад. Для тех версий программы, где в Глобальных параметрах не включено "Расширенное санкционирование доступа" (в версиях Стандарт и Мастер оно выключено всегда), этот пароль совпадает с "паролем базы данных".

2.Если пароль для данного имени пользователя не установлен, то поле "Пароль" при подключении должно оставаться пустым.

3.Существует одна неприятная ситуация, которая может возникнуть из-за специфики работы программы.

Администратор в " Настройке параметров работы " изменил базу данных, с которой должен работать кассовый сервер. После этого кассовый сервер автоматически перезапускается с новой базой данных и для продолжения настройки надо опять вызвать "Настройку параметров работы". Требуется ввод администраторского пароля, а администратор его не знает или забыл. Войти в "Настройку параметров работы", чтобы выбрать другую базу данных становится невозможно.

Для решения этой проблемы можно ввести в качестве имени Admin, а в качестве пароля OFF! . Программа отключится от текущей базы данных и даст возможность выбрать другую базу.


<Настройка режимов работы>

Перед тем как открыть окно настройки, программа спросит пароль администратора . Если в базе данных еще не описаны кассовые пользователи с администраторскими правами, то в качестве имени надо ввести Admin, а в качестве пароля - пароль пользователя Admin, введенный в программе SLS-Склад.

Для версий SLS-Склад Стандарт и Мастер, а также для остальных версий, в которых не включено расширенное санкционирование доступа, вводится имя Admin и пароль, который установлен на базу данных.

Если соответствующий пароль не устанавливался, то поле "пароль" оставляется пустым.

После ввода пароля, открывается окно настройки системы:

Оно состоит из пяти закладок:

  • Кассовый сервер. Здесь настраиваются параметры работы кассового сервера.

  • Общие для всех касс. Здесь настраиваются параметры, общие для всех Кассовых модулей. В описании каждого кассового модуля имеется возможность изменить некоторые или все эти параметры для данного рабочего места.

  • Рабочие места кассиров. Здесь производится описание всех кассовых модулей (рабочих мест кассира) - тип ККМ, заводской номер, обслуживаемые отделы и т.п.

  • Пользователи и их права. Здесь описываются все пользователи, которые должны иметь возможность работать с Кассовыми модулями и Кассовым сервером - кассиры, кассиры-администраторы и администраторы. Список этих пользователей ведется независимо от пользователей программы SLS-Склад. Единственным общим пользователем является главный администратор - Admin.

  • Эквайринг. Здесь описываются настройки для обработки информации об оплате покупок банковскими картами.


<Закладка "Кассовый сервер">

  • База данных. Здесь указывается база данных, к которой кассовый сервер автоматически подключается при запуске. Нужную базу данных можно выбрать с помощью кнопки "Обзор". Если изменить базу данных, то программа перезапустится и подключится к новой базе данных.

  • Папка связи кассового сервера и касс. Здесь с помощью кнопки "Обзор" указывается директория связи. Она должна быть видна от кассового сервера и от каждого кассового рабочего места. Все пользователи должны иметь полные права на доступ к этой директории.

  • Занимать базу данных не более... Эта настройка регулирует относительный процент времени, которое кассовый сервер занимает при записи информации от касс в базу данных. По умолчанию установлено 80%, что соответствует трем секундам записи и семисекундной паузе после этого. Обычно это нормальный режим работы. При изменении значения этого параметра меняется величина паузы от трех секунд (90%) до 30 секунд (10%). Следует отметить, что эта настройка сказывается только при записи в базу данных. Если новой информации от касс не приходит, то база данных не занята.

Административные скидки

  • Карта администратора. Здесь можно ввести штрих-код карты администратора. Если это поле заполнено, то при сканировании карты администратора с этим кодом, администратор может установить произвольную скидку или цену для каждой позиции чека или для всего чека целиком. Изменение цены в позиции возможно при чтении карты администратора в тот момент, когда покупка находится в нижней части экрана (до занесения ее в чек). Установка скидки на весь чек возможно при чтении карты администратора на экране итогов (там, где можно ввести полученные деньги и расчитать сдачу.

  • Округление. Тут можно указать как округлять цены при назначении скидки администратором. Если это поле не заполнено, то округление производится до копеек. Если в нем написать 0.1, то цена будет округлена до 10 копеек, при 1 - до рублей и т.д.

  • Максимальная скидка. Здесь можно указать предел для изменения цены администратором. При установлении большей скидки будет выдаваться предупреждение.

Наименование товара на чеке

  • Символ ограничитель в названии. Обычно на кассовых чеках место для названия товара ограничено. Для того, чтобы названия на чеках распечатывались по возможности без обрезания посреди слова, можно указать в этом поле символ, отличный от "?". Если поставить, например, пробел, то при печати чеков будет браться только первое слово названия (текст до первого пробела).

  • Использовать второе наименование. Если в Глобальных параметрах программы Склад включена возможность ввода второго наименования для товара, то галочка в этом поле приведет к тому, что на чеках будет печататься второе наименование товара. Если это наименование для данного товара не заполнено, то вместо него будет печататься как обычно основное название.

Загрузка товаров с нулевым остатком.

  • Срок возврата товара ХХ дней. При подготовке списка номенклатуры для кассового рабочего места, в этот список включаются только те товары, у которых есть цена продажи и положительный остаток в соответствующем отделе. Если в этом поле стоит число больше нуля и меньше 365, то в список также включаются товары, которые закончились не более, чем ХХ дней назад. Это дает возможность делать возврат через кассу для проданного полностью товара и продавать товар, который вчера кончился, а сегодня еще не успели его оприходовать.

Если значение этого поля 0, то в список включается только номенклатура, которая есть в наличии, если значение больше 365, то включается вся номенклатура, независимо от фактического остатка.

  • Загружать товары, у которых нет приходов. Это поле касается только пользователей SLS-Склад Стандарт или тех, у кого в Глобальных параметрах не включено использование нескольких мест хранения. Если здесь стоит галочка, то в список номенклатуры включаются все товары, у которых есть цена продажи, даже если в их карточках нет ни одной операции.

Запись информации о продажах по сотрудникам.

Этот блок доступен только в версии Касса Plus, при условии, что учет по сотрудникам включен в программе Склад.

  • Продавцы. Если выбран режим, отличающийся от "не использовать", то при пробивке каждой позиции чека можно будет указать продавца, который привел покупателя. Значение "Продавец в каждой покупке" позволяет указывать продавца для каждой из покупок чека индивидуально.

  • Администраторы. Если выбран режим, отличающийся от "не использовать", то при пробивке каждого чека можно будет указать администратора торгового зала, в чью смену пробит чек.

  • Флажок Для товаров без аналитического типа продавец обязателен. Если в Продавцы выбрано "Продавец в каждой покупке", то для товаров с аналитическим типом обязательность указания продавца для этого товара включается/выключается в свойствах аналитического типа. Для остальных товаров (без аналитических типов) обязательность указания продавца задается этим флажком.

-----------------------------------------------------

  • Кнопка Системная информация позволяет открыть окно для настройки системных параметров - размера кэш, сетевого протокола для работы с Сервером приложений и т.д. Как правило, настройки, принятые "по умолчанию", обеспечивают нормальную работу Кассового сервера.

  • Кнопка Обмен информацией с офисом. Эта кнопка доступна только в версии Касса Plus при использовании программы SLS-Обмен. При ее нажатии возникает окно настроек обмена информацией о продажах с офисом. Описание настроек см. в справке к программе SLS-Обмен.

  • Кнопка Работа со счетчиками покупателей. Эта кнопка доступна только в версии Касса Plus, при условии, что в программе Склад в расширенных свойствах склада включен учет посетителей. При ее нажатии можно указать базу данных, которая заполнена ПО счетчиков. Тогда Кассовый сервер сможет передавать информацию о количестве посетителей в базу данных программы Склад.


Системная информация

Это окно показывает текущие системные настройки.

  • Статистика за ... Время, в течение которого собиралась статистика, отображенная в этом окне. По умолчанию, это время, прошедшее с момента запуска программы.

  • Пользователь. Имя, под которым программа видна в Сервере приложений.

  • Файл базы данных. Путь и имя базы данных, с которой идет работа и ее текущий размер.

  • Буфера приемные. Количество буферов, выделенных для приема информации от Сервера приложений. Min и Tek - минимальное количество свободных буферов, за время сбора статистики и их текущее количество.

  • Буфера запросов. Количество буферов, выделенных для передачи информации к Серверу приложений. Min и Tek - минимальное количество свободных буферов, за время сбора статистики и их текущее количество.

  • Запросов/сек. Количество запросов в секунду от программы. Max - максимальное за время сбора статистики. Tek - текущее количество.

Качество работы сети.

  • Ошибок приема/передачи. При работе сетевой версии - это количество ошибок приема/передачи, обнаруженных аппаратно.

  • Ошибок контрольной суммы. При работе сетевой версии - это количество блоков, которые были нормально приняты аппаратно, но имели неверную контрольную сумму (т.е. были искажены при передаче).

В обоих случаях ошибки устраняются автоматической перепосылкой запроса, но вся работа из-за этого замедляется.

Общая статистика

  • Выполнено транзакций. Количество транзакций (сеансов записи) в базу данных.

  • Номер текущей транзакции. Общее количество транзакций, выполненых всеми программами, работающими с этой базой данных.

  • Количество блоков кэш. Количество оперативной памяти, выделенной для кэширования базы данных программой.

  • Занято блоков кэш. Сколько оперативной памяти для кэширования используется в данный момент.

  • Количество сбросов кэш. При сетевой работе кэш сбрасывается, если становится невозможно поддержать его состояние актуальным. Например, если другая станция выполнила большую транзакцию. После сброса кэш начинает заполняться заново по мере обращений к базе данных.

Работа с базой данных

  • Запись блока. Количество блоков, записанных в базу данных за время сбора статистики.

  • Чтение блока. Количество блоков прочтенных из базы данных и из кэш за время сбора статистики.

  • Чтение блока из базы. Количество блоков, которые не были найдены в кэш и реально читались из базы данных.

  • Взято из кэш %. Сколько процентов чтения из базы данных заменилось чтением из кэш.

Текущее состояние.

  • Чтение. Значение 1 означает, что рабочая станция в данный момент находится в состоянии чтения. 1/2 - завершает чтение.

  • Запись. Значение 1 означает, что рабочая станция выполняет транзакцию, т.е. находится в состоянии записи в базу данных.

Захваченные записи.

В выпадающем списке перечислены записи, которые программа защищает в данный момент от удаления и корректировки. Как правило, это заголовки накладных, с которыми работает кассовый сервер.

Кнопки

  • Закрыть окно. Завершает просмотр статистики.

  • Сброс статистики. Вся статистика начинает собираться с нуля.

  • Настройка. Открывает окно настройки системных параметров программы.

В верхней части окна расположен список сетевых протоколов, обнаруженных на данном компьютере.

Ниже расположено окно настройки размера кэш для программы. Увеличение размера кэш больше установленных по умолчанию трех мегабайт может ускорить работу программы. Зависимость между размером кэш и быстродействием не линейная. Так увеличение этого размера с 3-х до 30 мегабайт вызовет ускорение не более, чем в полтора раза.

ВНИМАНИЕ! Над окном расположена надпись синими буквами о количестве свободной оперативной памяти, доступной при старте программы. Размер кэш не должен быть больше, чем 1/3 - 1/2 от этого значения. Иначе Windows расположит кэш не в памяти, а на диске в файле подкачки. Как результат, вместо ускорения получится замедление работы.

Если программа сетевая и подключена к базе данных.

Слева от списка протоколов синим флажком отмечен тот протокол, по которому идет работа с Сервером приложений. Двойным кликом напротив любого протокола можно переместить флажок на этот протокол. Тогда при следующем открытии базы данных программа попытается использовать новый протокол. Если попытка не удастся, то будет проверяться возможность работы на всех других протоколах, до тех пор, пока не найдется протокол, на котором удастся установить связь с Сервером приложений.

В правой нижней части окна находится список протоколов, которые отмечены в настройке Сервера приложений. Там же находится кнопка Тестирование скорости связи. При ее нажатии программа в течение одной секунды по каждому из протоколов посылает тестовые пакеты, на которые Сервер приложений сразу отвечает. Количество пакетов, которыми удалось обменяться за секунду, отображается в списке протоколов в колонке Скорость. Чем больше число в этой колонке, тем быстрее идет обмен на данном протоколе. На не очень древних компьютерах Скорость должна выражаться 3-х или 4-х значным числом.


<Закладка "Общие для всех касс">

  • Какие цены использовать на кассах. В этом поле надо указать цены, которые будут использоваться на кассах при продаже товаров. В списке выбора есть три цены из карточки товара (учетная и две цены продажи) и цены из всех прайс-листов, созданных в программе SLS-Склад.

  • Тип кассовой накладной. Поскольку кассовые расходные накладные создаются автоматически, то в этом поле надо указать один из типов расходных накладных, определенных в программе SLS-Склад. Обычно здесь указывается "Наличный расчет", хотя можно в складской программе создать новый тип с названием, допустим, "Продажи через кассу" и использовать его.

  • Текущий номер кассовой накладной. Кассовым расходным накладным автоматически присваиваются возрастающие номера по порядку. Если это поле пустое (или 0), то в качестве номера следующей кассовой накладной будет взят максимальный номер обычной расходной накладной плюс один. Если в этом поле написать некоторое число, то для следующей кассовой накладной будет взят этот номер плюс один.

  • Флажок Каждая покупка - отдельная строка накладной.

Если этот флажок выключен, то в результирующей накладной производится "сворачивание" покупок. Если один и тот же товар продавался в течение дня несколько раз, то в накладной создается одна строка с общим количеством проданного товара. При этом Количество равно суммарному количеству продаж, Сумма равна общей сумме продаж, а Цена вычисляется как Сумма деленная на Количество, то есть это средняя цена продажи данного товара за день.

Если этот флажок включен, то все покупки пишутся в результирующую накладную отдельными строками. При включенном учете по продавцам и администраторам, флажок включается автоматически.

  • Режим печати чеков. Это поле влияет только на работу DOSовских версий программы Касса. В Windows-версиях соответствующие настройки делаются в самой программе Касса. Здесь возможны три значения:

Все покупки с наименованием - на чеке будет печататься каждая покупка и наименование соответствующего товара

Все покупки без наименования - на чеке будет печататься фискализирующая пробивка для каждой покупки, но название товара печататься не будет. При этом уменьшается расход чековой ленты.

Без покупок - только общая сумма чека - На чеке будет печататься только одна фискализирующая пробивка на полную сумму чека. Это имеет смысл, если одновременно печатается товарный чек, в котором все покупки полностью расписаны.

  • Печать скидок на чеке. Это поле влияет только на работу DOSовских версий программы Касса. В Windows-версиях соответствующие настройки делаются в самой программе Касса.Этот пункт касается только печати скидок , если скидки не используются, то его значение безразлично.

Не печатать СКИДКИ на чеке. Информация по скидкам видна на компьютере, все позиции чека пробиваются с учетом скидки, но на чеке про скидки ничего не печатается.

Печ. РУБ.+ % крупно - В заголовке чека печатается информация о проценте скидки и ее сумме. Все позиции чека пробиваются с учетом скидки (т.е. с меньшей ценой).

Печ. РУБ+ % мелко. - Аналогично предыдущему пункту, но на некоторых кассовых аппаратах информация уместится в одну строку вместо двух.

Только % - Печатается только процент скидки.

Только РУБ. - Печатается только сумма скидки.

  • Печатать количество. Это поле влияет только на работу DOSовских версий программы Касса. В Windows-версиях соответствующие настройки делаются в самой программе Касса. Если в этом поле стоит галочка, то на чеке для каждой покупки печатается дополнительная информация - цена за единицу товара и его количество.

  • Печатать сдачу. Это поле влияет только на работу DOSовских версий программы Касса. В Windows-версиях соответствующие настройки делаются в самой программе Касса. Если в этом поле стоит галочка, то после чека печатается дополнительно сумма, полученная от покупателя и выданная ему сдача.

  • Печатать фамилию кассира. Это поле влияет только на работу DOSовских версий программы Касса. В Windows-версиях соответствующие настройки делаются в самой программе Касса. Если в этом поле стоит галочка, то на чеке дополнительно печатается слово "Кассир" и его фамилия из " описания пользователей ".

  • Отдельный чек в каждый отдел. Это поле влияет только на работу DOSовских версий программы Касса. В Windows-версиях соответствующие настройки делаются в самой программе Касса. Если в этом поле стоит галочка и касса обслуживает несколько отделов (см. " Рабочие места кассиров "), то все покупки автоматически сортируются по отделам и печатается отдельный чек для каждого отдела. После всех чеков печатается общая сумма.

  • Печатать название отдела. Это поле влияет только на работу DOSовских версий программы Касса. В Windows-версиях соответствующие настройки делаются в самой программе Касса. Если в этом поле стоит галочка, то в заголовке чека печатается название соответствующего отдела.

  • Скидки. В этом поле настраивается до 10 скидок, которые кассир может давать в ручном или автоматическом режиме. Подробнее о скидках см. в разделе Скидки .

Ограничение прав пользователей с типом "Кассир".

Этот раздел позволяет запретить кассирам выполнять некоторые действия самостоятельно.

  • Запретить корректировать текущий чек. При необходимости изменить количество товара в уже введенной позиции, удалить какую-нибудь позицию, аннулировать чек и т.п., кассир получит сообщение, что для выполнения этого действия необходимо ввести пароль администратора (или кассира-администратора) и приглашение на ввод. Кассир должен подозвать администратора, чтобы тот выполнил требуемое действие.

  • Запретить работу с чековой лентой и отчеты. Пункты главного меню "Работа с чековой лентой" и "Получение Х и Z отчетов" будут недоступны для кассира.

  • Запретить работу с предыдущими чеками. В кассовой программе есть возможность просмотреть список уже пробитых чеков и сделать на их базе чеки на возврат или напечатать товарные чеки. Если это запрещено, то соответствующие пункты меню для кассира недоступны

  • Флажок Не фискализировать возвраты за предыдущие дни. В соответствии с разъяснениями налоговых служб, при возврате покупателем товара, купленного не сегодня, фискальный чек не должен пробиваться - деньги надо возвращать в бухгалтерии с составлением соответствующих актов и бухгалтерских документов. Вместе с этим, для того, чтобы оставить возможность произвести списание товара из базы данных обычным образом, возвраты за предыдущие дни можно делать в программе Касса.

Если этот флажок включен, то при возврате товара за предыдущие дни, программа Касса делает возврат как обычно (возвращает его в базу данных, если платеж был безналичным, то делается возврат через Эквайринг), но фискальный чек не пробивается.

Если флажок выключен, то фискальный чек на возврат пробивается независимо от даты покупки.

  • Настройка вида товарных чеков. Кассовая программа позволяет кроме обычных чеков печатать на принтере товарные чеки. Эта кнопка позволяет настроить внешний вид этих товарных чеков.

  • Настройка заголовка чека. Это поле влияет только на работу DOSовских версий программы Касса. Некоторые кассовые аппараты позволяют печатать в заголовке чека дополнительный текст. При желании, можно настроить здесь эту печать.


<Настройка вида товарных чеков>

При печати товарного чека на принтере, основная часть товарного чека формируется автоматически.

Она содержит дату и время печати, номер кассового аппарата, номер контрольной ленты и номер чека. После этого идет таблица, содержащая наименования товаров (до 120 символов), цену продажи, количество и сумму по каждому товару. В конце таблицы печатается итоговая строка.

В начале товарного чека (перед таблицей) можно вставить произвольный текст ("первый заголовок"). Например, название магазина, телефоны и т.п.

В конце товарного чека (после таблицы) можно вставить, например, текст с гарантийными обязательствами, подписи, место для печати и т.п.("последний подвал").

Если в товарном чеке много позиций и он не умещается на одном листе, то можно также добавить тексты, которые будут печататься в начале каждого листа ("промежуточный заголовок"), кроме первого - в начале первого листа всегда печатается "первый заголовок".

Можно также добавить тексты, которые будут печататься в конце каждого листа ("промежуточный подвал"), кроме последнего, где всегда печатается "последний подвал".

  • С помощью полей "Что показывать и редактировать" можно выбрать один из текстов. При этом в верхней части поля редактирования пишется соответствующий заголовок..

  • Пропустить в начале ХХ строк. Если требуется оставить в начале страницы свободное место, например, для типографского логотипа, то здесь можно указать число пропускаемых строк.

При наборе текста доступны следующие возможности.

  • Если какой-то текст заключен в фигурные скобки "{" и "}", то он будет печататься жирным шрифтом.
  • Если строчка начинается с первой колонки, то при печати она прижимается к левому краю.
  • Если в первой колонке строчки стоит не пробел, то строчка центрируется относительно ширины товарного чека.

  • Печатать ХХ экземпляров. Если указать здесь число большее 1, то будет напечатно ХХ экземпляров товарного чека.

Следующие настройки влияют на работу только программ Касса Windows-версии.

Печатать товарный чек

  • на ККМ. Если ширина чека ККМ больше 28 символов в строке, то можно включить этот флажок. В этом случае товарный чек будет печататься в нужном количестве экземпляров сразу после фискального чека.

  • на принтере Windows. Если флажок включен, то товарный чек печатается на принтере, который назначен в Windows принтером по умолчанию.

  • Узкий принтер. Этот флажок активен только если включена печать на принтере Windows. Если флажок включен, то товарный чек печатается не в виде таблицы, а посторочно как обычный чек. Это позволяет не делать шрифт печати слишком мелким.

Управление печатью названий в товарном чеке

  • Печатать в названии товара номенклатурный номер. Если этот флажок включен, то при печати товарного чека после названия добавляется номенклатурный номер товара. Например, "=4902030060503=". Для товаров, у которых нет номенклатурного номера, печатается номер карточки товара

  • Печатать в названии товара номер карточки. Если этот флажок включен, то при печати товарного чека после названия добавляется номер карточки товара. Например, "[Код: 12345]".

  • Не печатать имя кассира. Этот флажок виден только в версии PLUS. Если он включен, то в товарном чеке не печатается имя кассира, пробившего чек.

  • Не печатать имя продавца. Этот флажок виден только в версии PLUS. Если он включен, то в товарном чеке не печатается имя продавца, указанного во время продажи.


<Настройка заголовка чека>

Заголовок чека обычно устанавливается в кассовом аппарате при регистрации в налоговой инспекции. Некоторые кассовые аппараты позволяют печатать свой заголовок программным образом, другие - добавлять после "зашитого" в кассу заголовка одну или несколько строк произвольного текста. Этот текст можно добавить с помощью этого пункта настройки.

Внешний вид этого окна зависит от типа используемого кассового аппарата.

  • Текст. В этих полях можно писать произвольный текст.

  • Широкий шрифт. Если кассовый аппарат поддерживает печать крупным шрифтом, то галочка в этом поле включит для данной строки крупный шрифт.

  • Окно в правой части проказывает приблизительный внешний вид добавляемой части заголовка.


<Скидки>

Назад к закладке "Общие для всех касс".

В кассовой программе можно установить до 10 скидок, которые применяются ко всем покупкам чека.

Можно описать три вида скидок, которые по разному учитываются в складской программе.

  • Это скидки уменьшающие цену продажи, которые кассир выбирает вручную с помощью меню.

  • Скидки, которые отражаются в складской базе данных и могут выбираться через меню или через штрих-код.

  • Скидки, которые отражаются в складской базе данных и применяются автоматически в зависимости от суммы чека. Эти скидки можно также выбирать с помощью меню или штрих-кода.

Скидки всех типов можно использовать одновременно, но применяется к каждому из чеков только одна из них.

  • Скидки, связанные с уменьшением цены.

Для их включения надо в разделе "Скидки..." ввести описание каждой из скидок. При этом заполняются следующие поля:

"Название скидки" - название для меню кассира, позволяющее ему выбрать нужную скидку. Например, "До 10 утра".

"Скидка" - процент скидки (целое число)

"Округлять до" - здесь можно указать округление при расчете скидок. Например, 1.00 - округлять до рублей; 0.50 - до 50 копеек; 0.10 - до 10 копеек. Если не указано ничего, то округляется до 1 копейки.

В карточке каждого кассира ("Пользователи и их права") в поле "Может ли изменять цену продажи" надо поставить "ДА" - иначе выбор скидок из меню будет ему недоступен.

Если требуется печатать информацию о скидке на чеке, то надо в разделе "Настройка системы/Режим печати чека" установить в поле "Печатать ли скидку в чеке" значение "ДА".

При работе кассира в режиме подготовки чека у него появится возможность нажав клавишу F5 или F2 вызвать меню с установленными администратором скидками. Кроме того в нем будет строка "Убрать скидку". Выбранная скидка будет относиться ко всем покупкам чека, независимо от того, когда она была установлена - перед началом, в процессе или после набора покупок.

Скидка действует только в пределах чека. После его пробивки или аннулирования скидка автоматически сбрасывается.

Информация о скидках накапливается в "Работе с чековой лентой" и в отчете по чековой ленте можно узнать о сумме скидок за день.

В складской программе в накладных товары списываются по ценам со скидками, а информации о сумме скидок не ведется.

  • Скидки, учитываемые в складской программе.

До начала настройки кассовой программы надо в складской программе завести специальные карточки товаров - скидки. Для этого лучше всего создать отдельную группу товаров. В каждой карточке следует заполнить поля:

"Наименование товара" - название для меню кассира, позволяющее ему выбрать нужную скидку. Например, "До 10 утра".

"Ед.изм" - здесь указывается процент скидки в виде "-XX%". Например, -10% -скидка в 10%. Знак минус перед цифрой обязателен. Все символы вводятся без пробелов.

"Номенклатурный номер" - необязательное поле. Если в него ввести некоторый штрих-код, то кассир сможет выбирать скидку с помощью сканера штрих-кодов.

Для включения скидок в кассовую программу надо в разделе "Скидки..." ввести описание каждой из скидок. При этом заполняются следующие поля:

"Название скидки" - ссылка на складскую карточку со скидкой. В это поле вводится текст "sNNNNNN", где NNNNNN - номер карточки товара. Например, s31 означает, что соответствующая скидка описана в карточке номер 31.

"Скидка" - в данном случае содержимое этого поля игнорируется.

"Округлять до" - здесь можно указать округление при расчете скидок. Например, 1.00 - округлять до рублей; 0.50 - до 50 копеек; 0.10 - до 10 копеек. Если не указано ничего, то округляется до 1 копейки.

Если требуется печатать информацию о скидке на чеке, то надо в разделе "Настройка системы/Режим печати чека" установить в поле "Печатать ли скидку в чеке" значение "ДА".

В карточке каждого кассира ("Пользователи и их права") в поле "Может ли изменять цену продажи" можно поставить "ДА" или "Нет".

Если стоит "ДА", то при работе кассира в режиме подготовки чека у него появится возможность нажав клавишу F5 или F2 вызвать меню с установленными администратором скидками. Кроме того в нем будет строка "Убрать скидку". Выбранная скидка будет относиться ко всем покупкам чека, независимо от того, когда она была установлена - перед началом, в процессе или после набора покупок.

Если стоит "Нет", то кассир может выбирать скидки только с помощью сканера штрих-кодов. Для того, чтобы он мог отказаться от выбранной ранее скидки, следует в складской программе завести скидку с единицей измерения -0% и каким-либо штрих-кодом, который должен быть у каждого кассира.

Скидка действует только в пределах чека. После его пробивки или анулирования скидка автоматически сбрасывается.

Информация о скидках накапливается в "Работе с чековой лентой" и в отчете можно узнать о сумме скидок за день.

В складской программе все товары списываются по ценам продажи , а в конце расходной накладной добавляется по одной строке на каждый процент скидки, в которой видна суммарная скидка за день. Общая сумма накладной при этом соответствует сумме, пробитой на кассовом аппарате.

  • Автоматические скидки

Автоматические скидки устанавливаются и настраиваются так как описано в пункте 2. Единственное отличие состоит в том, что при заполнении карточки товара для скидки надо в полях "Цены продажи" указать пороговые значения для включения скидок. В первой цене продажи указывается сумма, начиная с которой действует данная скидка, а во второй - сумма, начиная с которой действие скидки прекращается. Если начальная сумма указана, а конечная нет, то считается что скидка действует от начальной цены и далее.

Пороговые суммы всегда указываются в рублях независимо от того как называется валюта соответствующего поля.

При подготовке чека кассиром после каждой введенной покупки автоматически проверяется сумма чека. Если она оказалась в диапазоне одной из заданных скидок, то эта скидка автоматически устанавливается.

Кассир имеет возможность в любой момент выключить или включить режим автоматических скидок.

Имеется дополнительная возможность включения/выключения автоматических скидок.

Для этого надо завести в складской программе карточку товара с некоторым номенклатурным номером. Остальные поля этой карточки товара безразличны.

В одной из строк описания скидок надо добавить строчку, где в поле "Название скидки" надо написать DNNNNNN, где NNNNNN - номер соответствующей карточки товара. Например, D155, если карточка имеет номер 155.

Если после этого кассир просканирует код, который совпадает с соответствующим номенклатурным номером, то для текущего чека включатся автоматические скидки. После печати или аннулирования чека, автоматические скидки выключатся.

Т.е. скидки, зависящие от суммы покупок можно будет предоставлять тоько покупателям с дисконтными картами.

Назад к закладке "Общие для всех касс".


<Закладка "Рабочие места кассиров">

На этой закладке содержатся описания всех кассовых рабочих мест, обслуживаемых Кассовым сервером.

Для каждого рабочего места отображаются его название, тип подключения к Кассовому серверу и номер кассового аппарата.

В список можно добавлять новые описания, корректировать или удалять старые. Это делается или через меню "Действия с описаниями" или с помощью правой кнопки мыши, или "горячими" клавишами (они перечислены в меню).

Как создается и корректируется описание рабочего места описано в следующем разделе.


<Рабочее место кассира>

Настройка рабочего места кассира содержит три закладки:

  • Рабочее место кассира. См. описание ниже.

  • Настройка драйвера ККМ.

  • Индивидуальные настройки

  • Название для меню и отчетов. Здесь можно написать произвольный текст, который будет отображаться на экране для данного рабочего места. Например, "Касса № 2", "Ночная касса", "Касса у окна" и т.п.

  • Номер рабочего места. Здесь должен быть указан тот же номер, который задан в программе Касса в настройке рабочего места.

  • Автоблокировка кассы через... минут. Если в этом поле стоит не 0, то через соответствующее количество минут неактивности, программа Касса покажет на экране окно подключения кассира и заблокируется до ввода правильного имени и пароля. Программа считается неактивной, если не открыто никаких окон и нет покупок в чеке.

  • Режим работы с Кассовым сервером.

Здесь возможно четыре варианта:

- Без Кассового сервера. Кассовый модуль не использует Кассовый сервер, а сам списывает покупки из базы данных и обновляет свою номенклатуру.

- Автономно ( экспорт / импорт ). Кассовый сервер готовит для кассового модуля файл с номенклатурой, ценами кодами и количеством (NE- файл). Затем этот файл передается в то место, где установлен кассовый аппарат, и кассовый модуль работает с этим файлом вместо базы данных. По истечении некоторого времени, кассовый модуль подготавливает файл с результатами продаж за некоторый период (KAS-файл). Этот файл передается в офис, где кассовый сервер импортирует эти данные в базу данных.

- С кассовым сервером. Кассовый модуль работает с Кассовым сервером.

- Резерв. Данное описание рабочего места игнорируется Кассовым сервером.

Подробнее о настройках в этих режимах.

  • Табло покупателя на экране. Если в этом поле стоит галочка, то в кассовой программе на экране будет отображаться крупными цифрами текущая сумма чека, а перед пробитием чека - сумма чека, полученные от покупателя деньги и сдача.

  • Запись покупки при заполнении количества. После выбора кассиром товара, курсор в кассовой программе устанавливается в поле "Количество". Если здесь стоит галочка, то при нажатии Enter в поле "Количество", покупка попадает в чек. Если галочки нет, то курсор переходит в поле "Стоимость", где кассир, в соответствии с настройкой его прав , может изменить стоимость для соответствующего изменения цены или количества.

  • Контроль остатка. Это поле позволяет управлять контролем за остатком товара при продажах через кассу. Тип контроля устанавливается для всех товаров, продающихся через данную кассу, независимо от того, что указано в складской базе данных в карточках этих товаров.

Возможно три варианта:

Контроль остатка выключен. Независимо от того, есть данный товар в наличии (по базе данных) или нет - покупка пробивается безо всяких вопросов. Обычно этот режим используется при продажах по системе универсамов, или когда к моменту пробивки чека товар уже отобран и заведомо есть в наличии. Понятно, что говорить покупателю о том, что в базе товара нет и поэтому мы не можем его продать, нельзя.

Контроль остатка с предупреждением. В этом случае при пробивке большего, чем есть по базе данных количества, кассиру выдается предупреждение о том, что столько пробить нельзя и сколько этого товара осталось. В зависимости от ситуации, кассир может или скорректировать пробиваемое количество, или все-таки пробить исходное количество. Этот режим обычно используется тогда, когда к моменту пробития чека товар еще не отложен. При появлении предупреждения, можно выяснить есть ли на самом деле товар и пробить то количество, которое есть реально.

Строгий контроль остатка. Все делается аналогично предыдущему пункту, но кассир не может пробить больше, чем есть по базе данных. Он может или отказаться от пробивки вообще, или пробить столько, сколько написано в базе данных.

Варианты поиска товаров.

Помимо поиска товаров с помощью сканера штрих-кодов, который включен всегда, у кассира есть возможность искать нужный товар в базе данных вручную:

- по названию товара (также включен всегда), Кассир отбирает товар из списка, отсортированного по названиям товаров.

- по номенклатурному номеру. Кассир выбирает товар из списка, отсортированного по номенклатурному номеру из карточки товара.

- по цене. Кассир выбирает товар из списка, отсортированного по возрастанию цен. Поскольку обычно товаров с одинаковой ценой немного, то это позволяет быстро найти нужный товар.

- по номеру карточки. Кассир выбирает товар по номеру карточки товара. Поскольку номера карточек уникальны и заполняются автоматически, то их можно использовать как коды для ручного выбора.

  • Основное поле поиска. Здесь можно указать какое из полей поиска является основным, т.е. полем "по умолчанию". Для поиска по другим включенным полям поиска кассиру надо будет перейти в них и только потом начинать поиск.

  • Печать товарного чека на принтер. Это поле позволяет настроить способ печати товарного чека на обычном принтере дополнительно к основному фискальному чеку кассового аппарата. Возможны четыре варианта:

- Не печатать. В этом случае товарный чек не печатается, а в меню кассовой программы нет соответствующих пунктов.

- Печатать всегда автоматически. Товарный чек всегда печатается одновременно с печатью фискального чека на кассовом аппарате.

- Задавать вопрос перед печатью. Перед началом печати каждого чека кассовый модуль спрашивает кассира "Печатать товарный чек?". В зависимости от ответа, товарный чек или печатается, или не печатается.

- Печатать только по запросу кассира. В этом случае кассир после печати обычного чека может через меню кассовой программы вызвать список пробитых чеков и для любого из них напечатать товарный чек. Для этого в настройках ограничений для кассиров (см. ограничение прав кассиров ) не должен быть включен запрет на просмотр предыдущих чеков.

- Печатать для продаж автоматически. В этом случае товарный чек автоматически печатается, но только для продаж. Для возвратов товарный чек не печатается.

  • Карточка для учета по ККМ.

Если это поле не пустое, то независимо от того, какая карточка для списания товара указана у кассира (см. Права пользователей ), весь товар по данному рабочему месту списывается на указанного контрагента. При этом расход учитывается не по кассирам, а по рабочим местам. Для очистки этого поля достаточно поставить в него курсор и нажать Ctrl+Y.

  • Обслуживаемые отделы.

Если программы Склад имеет версию больше, чем Стандарт и в ее Глобальных параметрах включен учет по нескольким местам хранения (складам), то здесь надо выбрать хотя бы один склад, который будет обслуживаться данным рабочим местом.

Например, учет в складской программе ведется по двум складам "Подсобка" и "Торговый зал". Товар передается в торговый зал актами передачи. Тогда для кассовой программы надо указать один отдел "Торговый зал", по которому она будет создавать расходные накладные для списания товара.

Если учет ведется раздельно по, скажем, складам "Галантерея" и "Продукты питания", то надо создать два отдела, куда кассир будет пробивать чеки.

Для каждого отдела имеется свой справочник номенклатуры для ручного поиска товара, но поиск по штрих-коду ведется во всех отделах и, после того, как товар найден, кассовая программа автоматически устанавливает нужный отдел.

Количество отделов не может быть больше, чем допускает используемый фискальный регистратор. В любом случае оно не может быть больше 14.

  • Пропускать товары, которые уже есть. Этот флажок присутствует только если в программе Склад включена работа с дополнительными свойствами товаров (поразмерный учет).

Если этот флажок включен, то при создании DAT-файла, товары, которые уже были записаны по предыдущим складам (тем, которые в списке обслуживаемых отделов находятся выше), не попадают в список номенклатуры второй раз.

Это можно использовать при переходе на учет по дополнительным свойствам. Если создать склад, на который будут передаваться товары, переведенные на новую схему учета, и поставить его в списке первым, то этот товар в списке номенклатуры для касс будет присутствовать только один раз - по первому отделу.

  • Путь от Кассового сервера к RES-файлу.

Если файл чековой ленты программы Касса виден с компьютера, где установлен Кассовый сервер, то указав его здесь можно получить возможность его просмотра и получения дополнительных отчетов для этого рабочего места.


Режимы работы с Кассовым сервером.

В этом разделе описаны практические настройки для работы в разных режимах.

  • Без Кассового сервера.

Описание Кассы, которая работает напрямую с базой данных, без обращений к Кассовому серверу.

В этом случае в программе Касса в "F10 > Настройка > Рабочая станция" на вкладке "Общие" должен быть выбран один из двух режимов работы - "Автономный - база данных только для обмена" или "Напрямую с базой данных".

В режиме "Автономный - база данных только для обмена" программа Касса подключается к базе данных только для обновления номенклатуры и для записи в базу результатов продаж. Все остальное время программа Касса отключена от базы данных.

Обновление номенклатуры и запись продаж выполняется кассиром вручную через меню "F10 > Записать продажи и обновить номенклатуру".

Этот режим имеет смысл использовать если программа Касса однопользовательская несетевая для того, чтобы она не занимала монопольно базу данных в процессе работы.

В режиме "Напрямую с базой данных" программа Касса во время работы постоянно подключена к базе данных. При этом записи о продажах автоматически заносятся в базу данных сразу после пробивки чека.

Обновление номенклатуры выполняется вручную кассиром через меню "F10 > Обновить номенклатуру".

Этот режим имеет смысл использовать для сетевых версий программы Касса, которые не занимают базу данных монопольно. Вторым ограничением является количество рабочих мест программы Касса. Если Касс больше двух-трех и они работают интенсивно, то лучше использовать режим работы "С кассовым сервером" (см. ниже).

В режиме работы "Без Кассового сервера" в настройках программы Касса "F10 > Настройка > Рабочая станция" на вкладке "Общие" должна быть указана база данных, с которой работает программа Касса. Кроме того, в программе Касса в "F10 > Настройка" появляется дополнительный пункт "Система (база данных)". С его помощью можно настроить описания в базе данных рабочих мест, пользователей и т.п. без Кассового сервера.

  • Автономно ( экспорт / импорт ).

Этот режим используется когда программа Касса находится в удаленной точке. При его выборе обмен информацией между Кассой и Кассовым сервером производится при помощи обмена файлами. Файл с обновлением номенклатуры <номер рабочего места>.NE- передается из центрального офиса в удаленный магазин, а файл с результатами продаж <номер рабочего места>.KAS передается из удаленного магазина в офис. Для передачи файлов можно использовать e-mai, флешку и т.п.

Допустим, в центральном офисе в Кассовом сервере есть описание рабочего места кассира, в котором "Номер рабочего места" равен 00000001 и "Режим работы с Кассовым сервером задан как "Автономно (экспорт / импорт)".

Тогда в удаленном магазине в настройках программы Касса "F10 > Настройка > Рабочая станция" на вкладке "Общие" в поле "Номер рабочего места" должно быть записано 00000001, а "Режим работы" должен быть "Автономно - экспорт / импорт". Кроме того, на локальном диске компьютера, где установлена программа Касса, должна быть создана папка для обмена информацией с офисом (например, C:\AAA). Эта папка должна быть указана в поле "Путь к папке для обмена файлами NE- и KAS.

Работа с такой удаленной кассой выглядит следующим образом:

1) В офисе в программе Кассовый сервер делается обновление номенклатуры для касс. После появления сообщения о том, что файл обновлений сделан, файл 0000001.NE- пересылается в магазин.

2) В магазине файл 00000001.NE- копируется в папку C:\AAA. В тот момент, когда программа Касса будет находиться в свободном состоянии (между пробитиями чеков), она автоматически заберет этот файл и выдаст сообщение о том, что номенклатура обновлена.

3) В магазине в любой момент времени можно выбрать в "F10 > Записать продажи (создать файл KAS)". Программа Касса создаст файл 00000001.KAS, в котором будет информация о продажах, сделанных после тех, информация о которых уже есть в центральной базе данных. Этот файл пересылается в центральный офис. Запись о том, какая покупка была последней в базе данных, содержится в файле 00000001.NE- и меняется при очередном обновлении номенклатуры.

4) В центральном офисе файл 00000001.KAS копируется в "Папку связи кассового сервера и касс", после чего Кассовый сервер автоматически закачивает эту информацию в базу данных. При этом пропускаются те продажи из файла KAS, которые ранее были загружены в базу данных.

Поэтому передача файлов с номенклатурой в магазин и файлов с результатами работы из магазина независимы друг от друга. Можно, скажем, передавать файлы с номенклатурой раз в неделю, а файлы с результатами работы три раза в день.

  • С Кассовым сервером.

В этом режиме работу с базой данных выполняет Кассовый сервер. В его настройках на вкладке "Кассовый сервер" должна быть указана "Папка связи Кассового сервера и Касс". Через файлы в этой папке осуществляется связь между Кассами и Кассовым сервером.

В "Рабочих местах кассиров" в Кассовом сервере должно быть создано описание рабочего места и ему должен быть присвоен произвольный "номер рабочего места". В "режиме работы" должно быть указано "С Кассовым сервером".

В программе Касса в "F10 > Настройка > Рабочая станция" должен быть указан тот же "номер рабочего места", что и в описании в Кассовом сервере. "Режим работы" должен быть указан "Через Кассовый сервер", а в поле "Путь к папке связи с Кассовым сервером" должна быть указана та же папка, что и в описании в Кассовом сервере.

  • Стоит в резерве.

Этот режим работы исключает данное рабочее место из обслуживания, однако описание этого рабочего места остается в базе данных. В произвольный момент времени его можно перевести в другой режим.


<Настройка драйвера ККМ>

В зависимости от использумого типа кассового аппарата или фискального регистратора (далее для краткости используется сокращение ККМ), кассовая программа использует различные настройки.

Сначала идут общие для всех настройки:

  • Модель кассового аппарата. Это список тех моделей, которые поддерживаются кассовым модулем. Нужно выбрать тот, который установлен на данном рабочем месте.

  • Заводской номер. Каждая ККМ имеет уникальный заводской номер. Как правило, он записан на табличке, прикрепленной к аппарату. В это поле вводится только цифровая часть номера.

  • Режим работы кассового аппарата.

- Работа только с ККМ. Кассовый модуль для работы требует наличия кассового аппарата или фискального регистратора.

- ККМ не используется. Кассовый модуль работает сам по себе. Наличия ККМ не требуется и фискальные чеки не пробиваются. В этом режиме кассовый модуль можно использовать для быстрого списания товаров если пробитие фискальных чеков не обязательно или делается вручную.

Далее настройки по типам ККМ.

АМС 100Ф

Мебиус 7-Ф

MStar -Ф

Общий драйвер Атол

e-Shop - настройки для экспорта в Интернет-магазин


<Драйвер АМС-100Ф>

  • Путь к программе драйвера. Кассовые аппараты АМС-100Ф работают с компютером через специальную программу-драйвер, которую надо вызывать для пробития чека. В этом поле надо указать путь к драйверу так, как он будет виден на кассовом рабочем месте. Обычно при установке этого драйвера, он предлагает установку в C:\KKM\.

  • Печатать дробные количества. Драйвер позволяет печатать дробные количества на чеке. Если поставить здесь галочку и включить в режиме печати чека " Печатать количества ", то на чеках будет возможность печати нецелых количеств.

  • Печатать три строки наименования. На аппаратах АМС можно печатать одну строчку наименования товара (17 символов) или три строчки наименования товара (51 символ). Если здесь стоит галочка, то будет печататься три строки наименования.

  • Включить безналичные платежи. Если этот флажок включен, то перед пробитием чека кассир имеет возможность выбора типа платежа - наличный или безналичный. В зависимости от типа платежа, он попадает в разные графы в Z-отчете.

  • Максимальное количество покупок в чеке. Если печать названий товара в чеке выключена, то в одном чеке может быть до 40 покупок, если включена печать одной строки названия - то 26 и, если включена печать трехстрочных названий, то только 8. Подробнее см. в документации к драйверу. В этом поле нужно поставить соответствующее количество. Тогда кассовый модуль при его превышении разобъет при печати большой чек на несколько чеков допустимого размера. После последнего чека будет напечатана общая сумма по всем чекам.

  • Количество покупок до Z-отчета. В аппаратах АМС ограничено количество покупок, которые можно поместить в одну контрольную ленту. Оно немного больше 1000 (точную цифру см. в документации к АМС). Если в этом поле поставить несколько меньшее значение, то кассовый модуль начнет предупреждать кассира о приближающемся конце контрольной ленты заблаговременно. Предупреждение выдается после пробития очередного чека и не препятствует дальнейшей работе. Кассир может выбрать удобный момент для снятия Z-отчета.

"Настройка драйвера ККМ"


<Драйвер MStar-Ф>

  • Включить безналичные платежи. Если этот флажок включен, то перед пробитием чека кассир имеет возможность выбора типа платежа - наличный или безналичный. В зависимости от типа платежа, он попадает в разные графы в Z-отчете.

  • Требовать Z-отчет при смене кассира. В фискальном регистраторе MStar требуется обязательное получение Z-отчета при регистрации нового кассира. Таким образом, если в течение дня на рабочем месте меняется несколько кассиров, то приходится снимать несколько Z-отчетов. Если этот флажок не установлен, то кассовый модуль при подключении нового пользователя не делает перерегистрации пользователя на фискальном регистраторе. Как результат - не надо снимать лишние Z-отчеты, но на всех чеках печатается номер кассира, который подключился первым. На учете в программе Склад это никак не отражается.

  • СОМ порт. Порт, к которому подключен фискальный регистратор.

  • Скорость. Скорость, на которой идет передача данных между компьютером и фискальным регистратором. Практически от нее мало зависит общая скорость работы, но чем больше скорость - тем чувствительнее соединение к помехам. Рекомендуется использовать 9600 или 19200. При изменении скорости, кассовый модуль автоматически устанавливает ее на фискальном регистраторе.

"Настройка драйвера ККМ"


<Драйвер Мебиус 7Ф>

  • Включить безналичные платежи. Если этот флажок включен, то перед пробитием чека кассир имеет возможность выбора типа платежа - наличный или безналичный. В зависимости от типа платежа, он попадает в разные графы в Z-отчете.

  • Режим печати чека. Здесь возможны три варианта:

- Чек целиком. Кассир набирает все покупки на компьютере и после оплаты весь чек печатается целиком. Достоинства - кассир полностью свободен в корректировке чека, в назначении скидок и т.п. Недостатки - покупатель ждет, пока напечатается чек.

- Чек в виде текста. То же, что и в предыдущем случае, но весь чек печатается как обычный текст, а в конце делается одна фискализирующая запись на общую сумму. Достоинства и недостатки такие же, как в предыдущем случае, но печать чека происходит чуть быстрее из-за уменьшения времени на фискализацию.

- По покупкам. После ввода каждой покупки она сразу печатается на фискальном регистраторе. После оплаты печатается только хвостовая часть чека с итогами. Если в процессе набора чека в него вносятся изменения, то на фискальном регистраторе печатаются сторнирующие записи. Достоинства - чек печатается одновременно со сканированием покупок и после оплаты остается напечатать только хвостовик. Недостатки - скидки надо назначать до сканирования первой покупки, при корректировке чека печатаются дополнительные сторнирующие записи.

  • СОМ порт. Порт, к которому подключен фискальный регистратор.

  • Скорость. Скорость, на которой идет передача данных между компьютером и фискальным регистратором. Здесь надо установить скорость, которая установлена на фискальном регистраторе, иначе связь будет невозможна.

"Настройка драйвера ККМ"


<Драйвер Атол>

Общий драйвер АТОЛ

  • Номер прерывания. Для данной группы кассовых аппаратов используется "Общий драйвер АТОЛ для фискальных регистраторов" (drvi.exe). Здесь надо указать шестнадцатиричный номер прерывания, через которое осуществляется связь с драйвером. Подробности см. в описании к драйверу.

"Настройка драйвера ККМ"


Настройки для экспорта в e-Shop

Если Кассовый сервер скомпилирован с опцией экспорта информации для Интернет магазина, то при выборе в качестве модели кассового аппарата "e-Shop" появятся следующие настройки.

Назначение полей следующее:

  • Экспорт с нулевым количеством. Если "разрешен", то экспортируются все товары, независимо от их наличия. Если "запрещен", то экспортируются только товары с положительным остатком по складу, выбранному на закладке "Рабочее место кассира" - поле "Обслуживаемые отделы".

  • Путь к папке, где будет создан файл. В этом поле надо написать (или выбрать с помощью кнопки, расположенной справа) путь к той папке, где будет создаваться результирующий файл.

  • Не экспортировать группы товаров. В этом поле можно перечислить через запятую номера групп товаров верхнего уровня, которые надо пропускать при экспорте.

  • Разделитель. В этом поле надо указать разделитель, который будет отделять в выходных записях одно поле от другого.

  • Выделять группы/подгруппы товаров. Если этот флажок включен, то в результирующем файле перед началом каждой новой группы/подгруппы будет выводиться строка с наименованием этой группы/подгруппы. В этой строке будут перечислены все вышестоящие группы и подгруппы.

  • Выгружать. В этой таблице перечислены поля, которые будут записываться в каждую из выходных строк по товарам.

- Номер товара в списке. Номер выгружаемого товара по порядку.

- Номер карточки товара. Поле "N п/п" из карточки товара (закладка Описание).

- Номенклатурный номер. Поле "Номенклатурный номер" из карточки товара (закладка Описание). Для того, чтобы это поле было видно в карточке товара, в Глобальных параметрах на закладке "Товары" в поле "Размер поля номенклатурный номер" должно стоять ненулевое значение.

- Первое наименования. Поле "Наименование" из карточки товара (закладка Описание).

- Второе наименование. Поле "Второе наименование" из карточки товара (закладка Описание). Для того, чтобы это поле было видно в карточке товара, в Глобальных параметрах на закладке "Товары" должен быть включен флажок "Два наименования товара".

- Единица измерения. Поле "ед.изм" из карточки товара (закладка Описание).

Если флажок около поля включен, то оно будет выгружаться в выходную строку.

  • Автоматическая выгрузка. Если этот флажок включен, то экспорт в выходной файл будет выполняться автоматически в соответствии с параметрами, перечисленными ниже. Если флажок выключен, то выгрузку можно сделать в любой момент через меню "Кассы".

  • Каждые. Интервал в формате ЧЧ:ММ через который будет выполняться автоматическая выгрузка.

  • Не начинать выгрузку до. Первая автоматическая выгрузка начнется не ранее указанного времени.

  • Не выполнять после. После указанного времени автоматические выгрузки не выполняются.

Примечание. Если время, указанное в "Не начинать выгрузку до" больше, чем время, указанное в "Не выполнять после", то считается, что заданный интервал переходит через сутки. Например, если указать "Не начинать выгрузку до" 21:30, а "Не выполнять после" 05:15, то автоматическа выгрузка сможет выполняться с 21:30 вечера до 5:15 утра.


<Индивидуальные настройки>

Здесь присутствуют настройки, описанные ранее в разделе " Общие для всех касс ".

Если в какой-нибудь группе установить флажок "Индивидуально", то для данного рабочего места можно поставить настройки, отличающиеся от общих.

При снятии этого флажка, соответствующие настройки вернутся к тому состоянию, которое установлено для всех рабочих мест.


<Закладка "Пользователи и их права">

На этой закладке отображается список пользователей кассовой подсистемы.

Для каждого пользователя отображаются его имя для подключения, уровень прав при работе и внутренний идентификатор имени.

В список можно добавлять новых пользователей, корректировать или удалять старых. Это делается или через меню "Действия с описаниями" или с помощью правой кнопки мыши, или "горячими" клавишами (они перечислены в меню).

Как создается и корректируется описание пользователя описано в следующем разделе.


<Описание пользователя>

  • Имя для подключения к системе. Здесь указывается имя, которое пользователь должен вводить при подключении к системе. Для кассиров имеет смысл вводить простые имена, состоящие только из цифр, поскольку их проще набирать. Если имя содержит буквы, то при подключении заглавные и строчные буквы считаются одинаковыми.

  • Пароль. Если пароль не установлен, то при подключении достаточно оставить поле "Пароль" пустым. Если пароль содержит буквы, то заглавные и строчные буквы считаются различными. Кроме букв и цифр в пароль можно включать функциональные клавиши (F1..F10), а также использовать с ними Ctrl и Shift.

Пользователь с правами администратора может менять пароли у остальных пользователей в случае, если они забудут пароль. Если забыть пароль администратора, то восстановить его будет невозможно.

  • Штрих-код. Если в этом поле записать штрих-код карточки сотрудника, то в программе Касса при подключении к программе и при запросе разрешения администратор, можно просто просканировать этот штрих-код.

  • Тип пользователя. Пользователь может иметь один из трех типов, в зависимости от необходимости ограничить его права.

- Администратор. Это пользователь, обладающий всеми правами в кассовой подсистеме.

- Кассир-администратор. Это пользователь, который имеет все права, кроме корректировки прав пользователей.

- Кассир. Это пользователь, который не имеет прав на настройку системы и может дополнительно ограничиваться в правах на работу с кассовым модулем. (см. раздел Закладка "Общие для всех касс"

Для нормальной работы хватает одного пользователя с типом администратор. Пользователи с другими типами создаются только если есть необходимость в разграничении прав.

  • Карточка сотрудника. Если в программе Склад включен учет продаж по сотрудникам, то появляется дополнительное поле. В нем надо с помощью кнопки, расположенной справа от поля выбрать карточку, с которой будет связан данный пользователь программы Касса.

  • Учет наличности на карточке. При списании кассовым модулем товара из складской базы данных создается расходная накладная. Здесь надо указать на какую карточку списывать товар, проданный данным пользователем. Для каждого кассира можно создать свою карточку, тогда в складской программе на этой карточке будут собираться все продажи данного кассира. В конце смены можно в разделе "платежи" отметить сданные им деньги.

Если в этом поле не указана карточка, то данный пользователь не сможет работать с кассовым модулем. Для того, чтобы очистить поле, достаточно поставить в него курсор и нажать Ctrl+Y.

Иногда предпочтительней вести учет не по кассирам, а по рабочим местам. В этом случае можно указать карточку для списания в соответствующем поле в описании рабочего места.

  • Имя для печати на чеке. Если в настройках рабочего места стоит галочка "Печатать фамилию кассира" , то в этом поле можно указать текст, который будет печататься на чеках. Если поле не заполнено, то вместо него будет печататься "имя для подключения к системе" (см.выше).

  • Может давать скидки вручную. Если здесь установлена галочка и скидки настроены, то в касовом модуле кассиру будет доступно меню назначения скидок. Если галочки нет, то возможно использование только автоматических скидок или скидок по штрих-кодам. (см. Скидки )

  • При изменении "Стоимости". При пробивке покупки есть три основных показателя - цена, количество и стоимость. Обычно, достаточно просто указать количество, чтобы расчиталась стоимость. Вместе с этим есть несколько вспомогательных режимов, использование которых определяется здесь.

Если после выбора товара и, может быть, установки количества, кассир переведет курсор в поле "Стоимость", то возможны три варианта:

- Меняется количество. Кассир может изменить стоимость. При этом по той же цене пересчитается количество. Это можно использовать, например, при пробивке колбасы, на обертке которой, продавец написал "73 рубля". Количество (вес) расчитается автоматически.

- Меняется цена. При изменении стоимости количество останется прежним, но соответствующим образом изменится цена для данной покупки. Этот режим используют только в маленьких магазинах, в которых хозяин (он же кассир) может отпускать товар по договорным ценам.

- Изменение ЗАПРЕЩЕНО. В этом случае поле "Стоимость" закрыто от корректировки. Это обычный режим для больших магазинов.

  • На каких кассах может работать. Если в этом поле пусто, то пользователь может работать на любых рабочих местах, описанных в системе. Если требуется разрешить работу только на определенных местах, то здесь приводится их список.

Если для "администратора" или "кассира-администратора" в этом поле перечислены какие-нибудь рабочие места, то он может корректировать или удалять описания только этих рабочих мест.


Закладка Эквайринг

Эта закладка предназначена для настройки совместной работы программ SLS-Склад, SLS-Касса, SLS-Кассовый сервер с процессинговым центром банка для приема оплаты с помощью банковских карт.

Для включения этой возможности надо включить флажок "Включить эквайринг" и заполнить появившееся поля:

  • Банк. В этом поле надо выбрать (или создать, а потом выбрать) контрагента в категории Поставщики, на карточке которого будут отображаться все операции с банковскими картами и вычисляться проценты комиссии банка по этим операциям.

  • Тип накладной для банка. В этом поле надо указать тип для приходных накладных, в которых будут отображаться операции с банковскими картами. Если нужно, то можно заранее в программе SLS-Склад создать новый тип для приходных накладных.

  • Категории банковских карт. В этой таблице находится список категорий, по которым предполагается вести учет. Для добавления, корректировки или удаления категорий служит кнопка справа от таблицы. Каждая категория имеет характеристики, задаваемые в специальном окне .

  • Префиксы. Для каждой категории существует набор префиксов (первых цифр номера карты). Эти префиксы позволяют по номеру карты отнести платеж к одной из категорий. Если у категории не описано ни одного префикса, то в списке категорий эта категория подсвечена красным и не используется в работе. Для добавления, корректировки и удаления префиксов служит кнопка справа от таблицы.

  • История действия %. Для каждой категории ведется история процентов комиссии банка по данной категории карт. При проведении оплаты или возврата по банковской карте, из этого списка выбирается тот процент, который действует на дату операции. Если у категории нет ни одной записи в этой таблице, то в списке категорий эта категория подсвечена красным и не используется в работе. Для добавления, корректировки и удаления префиксов служит кнопка справа от таблицы.

Добавлять, корректировать и удалять строчки в эту таблицу можно только с датами большими или равными сегодняшней. Изменения "задним числом" запрещены.

Для платежей с неопределенной категорией банковских карт

Эти настройки предназначены для учета операций по картам, категорию которых не удалось определить по номеру карты. Основное отличие в регистрации этих операций состоит в том, что каждая из них заносится в приходную накладную для банка как отдельная строка и в поле "примечание" этой строки заносится номер неопознанной карты. Это дает возможность скорректировать описания префиксов у одной из категорий, чтобы карты распознавались правильно.

  • Услуга для безналичных начислений. В этом поле надо выбрать услугу, на карточке которой будут отображаться оплаты банковскими картами с неопределенной категорией. Карточка услуги должна быть заранее создана в программе SLS-Склад.

  • Услуга для начисления %. В этом поле надо выбрать услугу, на карточке которой будут отображаться комиссионные проценты банка при оплате банковскими картами с неопределенной категорией. Карточка услуги должна быть заранее создана в программе SLS-Склад.

  • Процент банка. В этом поле надо указать процент комиссии банка для оплаты банковскими картами с неопределенной категорией.


Эквайринг. Описание категории.

Окно описания категории содержит следующие поля:

  • Название категории. Название может быть произвольным и используется только для отображения в таблице категорий. Можно использовать в качестве названия тип банковской карты - Visa, Maser Card и т.п.

  • Услуга для безналичных платежей. В этом поле надо выбрать услугу, на карточке которой будут отображаться оплаты банковскими картами с данной категорией. Карточка услуги должна быть заранее создана в программе SLS-Склад.

  • Услуга для начисления %. В этом поле надо выбрать услугу, на карточке которой будут отображаться комиссионные проценты банка при оплате банковскими картами с данной категорией. Карточка услуги должна быть заранее создана в программе SLS-Склад.

  • Действующий процент. В этом поле надо указать процент комиссии банка для оплаты банковскими картами с данной категорией.

Поле открыто для корректировки только при создании новой категории. При сохранении новой категории в таблицу "История действия %" автоматически добавляется запись с указанным процентом и сегодняшней датой. Дальнейшее изменение процента банка возможно только через таблицу "История действия %".


Настройка Кассового модуля

Для того, чтобы Кассовый модуль (DOS) мог работать с Кассовым сервером, необходимо его соответствующим образом настроить. Есть два варианта настройки:

Первый вариант:

1. Полностью выполнить настройку Кассового сервера и сделать в нем "обновление номенклатуры".

2. Запустить кассовый модуль с параметром /SERV

Kassa.exe /SERV

3. Кассовый модуль предложит выбрать директорию связи - надо указать ту же директорию, которая указана в Кассовом сервере.

4. Кассовый модуль предложит выбрать номер кассового аппарата и покажет список номеров, для которых Кассовый сервер подготовил номенклатуру.

5. После выбора надо перезапустить программу Kassa.exe опять-таки с параметром /SERV.

Второй вариант.

Если есть какие-то проблемы с первым вариантом, или требуется установить новые параметры, то можно просто отредактировать файл Kassa.DEF. Этот файл находится в рабочей директории Кассового модуля там же, где его файл Kassa.RES и DAT-файл. Если этого файла нет, то его можно создать. Для этого можно использовать встроенный редактор Norton или Far, а также Блокнот.

Файл должен иметь имя Kassa.DEF и содержать три строки:

Первая строка - восмизначный цифровой номер рабочего места. Если в номере меньше восьми знаков, то он должен быть дополнен слева нулям.

Вторая строка - путь к директории связи. Завершающий слэш "\" обязателен. Поскольку из-под DOS видны пути только в формате 8.3, в пути не должно быть названий длинее 8 символов, русских букв и пробелов. Нельзя также использовать пути вида //server_name/... При необходимости надо через "Сетевое окружение" Windows подключить сетевой диск, назначить ему какую-нибудь букву и использовать ее в пути.

Третья строчка (необязательная) - путь и имя соответствующей базы данных. Эту строчку можно не вводить вообще или оставить пустой.

Пример:

12345678

H:\niam\

P:\CLIENTS\NIAM\SKLADSLS.DBX

Примечание.

Кассовый модуль, который описан в системе как работающий через Кассовый сервер, должен всегда запускаться с параметром /SERV:

Kassa.exe /SERV


<Основной экран Кассового сервера>

Если все настройки выполнены, то после запуска программы она автоматически подключается к выбранной базе данных и переходит в нормальный режим работы.

Через несколько секунд после запуска происходит автоматическое обновление номенклатуры для всех касс. После чего Кассовый сервер продолжает автоматическую работу.

На экране при этом находится основное окно Кассового сервера. Оно позволяет наблюдать за работой касс и самого сервера. Если окно не нужно, то его можно свернуть. Для того, чтобы Кассовый сервер сразу запускался со свернутым окном, достаточно в свойствах запускающей иконки поставить запуск в минимизированном состоянии.

На экране содержится следующая информация:

  • Номер. В этой колонке находится номер кассового аппарата (рабочего места). Если в описании рабочего места указано, что режим рабрты "с кассовым сервером", то слева от номера находится лампочка - серая для неактивного в данный момент рабочего места, и зеленая - для активного. Рабочее место становится активным после того, как кассир в главном меню кассового модуля выберет пункт "Начать работу с ККМ".

  • Название. В этой колонке пишется название рабочего места.

  • Посл. запись в БД. Здесь стоит дата и время последней покупки, записанной в базу данных с данного рабочего места.

  • Номенклатура от. Для активных рабочих мест здесь указано с какой версией справочника номенклатуры они сейчас работают. Дата и время меняются после того, как кассовый модуль прочел номенклатуру и переключился на ее использование.

Для рабочих мест, работающих в режиме экспорта/импорта, в этой колонке стоит дата и время последнего созданного для них DAT-файла. Реальной информации о том, какой DAT-файл они используют на самом деле, в системе нет.

  • Группа. При обновлении номенклатуры самой медленной операцией является собственно составление списка номенклатуры, расчета цен для него и сортировки для быстрого поиска в кассовом модуле. Поэтому те рабочие места, которые используют одну и ту же номенклатуру, автоматически объединяются в одну группу. Список номенклатуры для всей группы делается один раз и копируется для всех членов с соответствующими модификациями для каждого из них. Это существенно ускоряет обновление номенклатуры.

В нижней части экрана находится панель с дополнительной информацией по той позиции, на которой стоит курсор.

Для управления работой Кассового сервера используется Главное меню .


<Главное меню>

Главное меню кассового сервера содержит следующие пункты:

Файл

  • Просмотр журнала сообщений . Поскольку кассовый сервер работает автоматически, то всевозможные сообщения, которые в обычных программах выдаются на экран и ожидают реакции пользователя, протоколируются в Журнале сообщений. Там же отмечаются начало и конец работы и некоторые действия администратора. Журнал ведется в файле Kas_Serv.log, который создается там же, где находится Kas_Serv.exe.

  • Шрифт Здесь можно выбрать шрифт для показа на экран, если шрифт, установленный по умолчанию Вас не устраивает.

  • Восстановить шрифт "по умолчанию"

  • Завершить работу программы. Работа кассового сервера завершается. Если в момент завершения работы идет обновление номенклатуры или импортирование информации о продажах, то выдается соответствующее предупреждение. Обновление и импорт можно при необходимости прекратить - это ни на чем не скажется.

Кассы

  • Обновить номенклатуру в кассах. Начинается обновление номенклатуры для всех обслуживаемых касс.

  • Обновить номенклатуру в группе кассы ХХХХХХХХ. Начинается обновление номенклатуры для кассы, на которой стоит курсор, и для всех касс, входящих в ту же группу.

  • Остановить работу с кассами. Временно прекращается работа с кассами - обновление номенклатуры и импорт результатов продаж. Экран при этом подсвечивается розовым цветом.

  • Работа с чековой лентой. Временно прекращается работа с кассами и вызывается модуль работы с чековыми лентами - результатами продаж по кассам.

Настройка

  • Настройка параметров работы . Поскольку при запуске программы никаких паролей нет, то при переходе в режимы, требующие наличия администраторских прав, нужно вводить имя и пароль. Поэтому при выборе этого пункта меню появляется окно подключения к системе.

  • Сворачивать задачу в трей. Этот пункт невидим при работе с Windows 95/98/Me, поскольку работа с треем в них не поддерживается. Если этот пункт отмечен, то при запуске программы и ее подключения к базе данных, программа сворачивается в значок [image] , расположенный в трее около часов. Для того, чтобы вызвать окно программы, надо или дважды кликнуть по этому значку, или выбрать соответствующий пункт в меню, вызываемом правой кнопкой мыши.

По окончании работы с окном программы, можно нажать кнопку "свернуть" [ _ ], после чего окно опять свернется в трей. Если нажать кнопку закрыть [ х ], то программа завершит работу.

В процессе работы значок отображает текущее состояние кассового сервера следующим образом:

- идет импорт из кассы

- идет обновление номенклатуры для касс.

- в кассовом сервере остановлена работа с кассами.


Модуль просмотра текстовых файло

Модуль просмотра текстовых файлов

Модуль предназначен для просмотра текстовых файлов в кодировке ASCII (DOS).

Показываются последние 5000 строк файла. Для полного просмотра файла можно использовать смотрельщик из FAR, Norton (клавиша F3), Total Commander, Windows Commander и т.п. Можно также использовать стандартное средство Windows - Блокнот. В Блокноте надо установить шрифт Terminal или Lucida Console.

В программе Кассовый сервер этот модуль вызывается из главного окна ("Просмотр журнала сообщений"). При этом показывается файл Kas_Serv.Log, который находится в той же директории, что и Kas_Serv.exe.

Этот же модуль вызывается из "Работы с чековой лентой". В этом случае, также, как при ручном открытии текстовых файлов, в заголовке написан путь и имя просматриваемого файла.


<Работа с чековой лентой>

При работе кассового модуля, он записывает информацию обо всех продажах в электронную чековую ленту. Эта лента может использоваться для контроля, получения некоторых отчетов, повторной записи информации в базу данных при возникновении сбоев и т.п.

Средства для работы с чековой лентой встроены в кассовый модуль. Кассовый сервер может также работать с чековой лентой, если соответствующий RES-файл виден от него.

Кроме того, кассы, работающие в режиме экспорт/импорт создают RES-файл с результатами продаж за какой-то период. Эти результаты можно импортировать в складскую базу данных с помощью Кассового сервера.

Поскольку право на работу с чековой лентой имеют не все пользователи, перед началом работы с ней выдается запрос на ввод имени и пароля пользователя . В случае, если тип пользователя "администратор" или "кассир-администратор", он может работать с чековой лентой.

Сразу после ввода имени и пароля, появляется окно

  • Рабочее место. Здесь надо указать к какому рабочему месту будет относиться чековая лента. От правильности указания будет зависеть на кого произойдет списание товара, если будет делаться загрузка в базу данных и т.п. По умолчанию сюда ставится то место, на котором стоял курсор при вызове.

  • Res-файл. Здесь надо указать какой файл содержит нужную информацию.

Связь между рабочим местом и Res-файлом сохраняется. Так что при следующих вызовах оба поля будут уже заполнены.

Для касс, работающих в режиме "с кассовым сервером", можно просто выбирать путь к файлу Kassa.Res, с которым работает Кассовый модуль. Тогда содержимое этого файла всегда будет актуальным. Подключение к этому файлу не мешает работе кассового модуля.

Если по каким-то причинам, реальный файл Kassa.Res недоступен от кассового сервера, то можно создать какую-то постоянную директорию для каждого из рабочих мест, куда по мере необходимости копировать текущий файл Kassa.Res.

Для касс, работающих в режиме экспорта/импорта, также имеет смысл создать постоянные директории для RES-файлов, чтобы упростить импорт.

После выбора, наконец, появится главное окно "Работа с чековой лентой"


<Работа с чековой лентой - Главное окно>

В окне находится список всех покупок, которые были произведены в кассовом модуле. Синим цветом выделены служебные строки - записи о подключении кассира, о снятии Z и X-отчетов и т.п.

Для каждой записи о покупке заполняются следующие графы:

Время, дата, номер чека - заполняются для первой покупки каждого чека.

Отд. - Номер отдела, в который пробит чек.

Сумма чека - Для первой покупки чека здесь стоит сумма всего чека.

Товар - Первые 17 символов названия товара.

Кол-во, Цена, Сумма - Количество, цена и сумма покупки.

БД - Знак + в этой графе означает, что эта запись уже внесена в базу данных. В базе данных для каждого рабочего места есть запись о последней записанной покупке. Покупка считается внесенной в базу данных, если ее дата и время меньше даты и времени последней записанной покупки.

В нижней части экрана находится несколько вспомогательных полей для текущей покупки.

Карточка/Номенкл. - номер карточки товара или номенклатурный номер для товара.

Касса - Номер кассы, на которой пробит чек.

Контр.лента - Номер контрольной ленты (Z-отчета), на которой находится этот чек.

Работа с контрольной лентой осуществляется с помощью меню, которое состоит из следующих пунтов.

  • Файл. Здесь выполняются общие действия.

  • Отчеты. Здесь можно получить отчет по продажам за любой период и протестировать состояние контрольной ленты.

  • Поиск. Здесь собраны команды для поиска записей в чековой ленте по разным критериям.

  • Отметить. Здесь находятся команды для выделения части информации на контрольной ленте. По отмеченным записям можно получать отчеты, экспортировать их в виде RES-файла и загружать в базу данных.

  • Действия. Здесь находятся команды, которые позволяют выгружать информацию в RES-файлы, загружать ее в базу данных, менять "последнюю загруженную" запись в базе данных. Прежде чем использовать эти команды, следует ознакомиться с соответствующим разделом справки и понять что они делают.


<Работа с чековой лентой - Файл>

Работа с чековой лентой - Файл.

Данный пункт меню содержит следующие подпункты.

  • Открыть другой RES-файл. С помощью этого пункта меню можно не выходя из "Работы с чековой лентой" перейти к другому рабочему месту и другому RES-файлу.

  • Шрифт Здесь можно выбрать шрифт для показа на экран, если шрифт, установленный по умолчанию Вас не устраивает.

  • Восстановить шрифт "по умолчанию"

  • Автообновление. Если с открытым для работы RES-файлом одновременно работает кассовый модуль, то, включив автообновление, можно видеть его текущее состояние. Каждый раз файл будет открываться заново и в нем будут появляться записи, которые за это время добавил в него кассовый модуль.

  • Завершить работу с чековой лентой. Просмотр чековой ленты завершается.


<Работа с чековой лентой - Отчеты>

В этом меню есть три пункта:

  • Отчет за ..... Если в момент выбора меню, курсор стоит на записи за какое-то число, то получается отчет за это число. Для того, чтобы получить отчет за другое число, надо предварительно поставить курсор на запись с нужной датой. Для этого можно использовать листание списка покупок или Поиск.

Если одна или несколько записей отмечены, то, независимо от положения курсора, отчет получается по отмеченным записям.

В отчете подводятся общие итоги, итоги по кассирам, по отделам и т.п. по записям заданного периода.

  • Тест информации за...

Информация, которая попадает в тест, выбирается также, как и для отчетов.

Тестирование применяется если надо найти причину несоответствия Z-отчета кассового аппарата (фискального регистратора) и отчета по электронной чековой ленте.

При пробитии покупок кассовый модуль получает информацию о номере контрольной ленты и номере текущего чека из кассового аппарата.

При тестировании просматриваются все записи и проверяется, что номера чеков увеличиваются от чека к чеку строго на 1. Если это выполняется, то в электронной чековой ленте присутствуют все записи, которые записывались в кассовый аппарат.

Примеры ошибок, возникающих в чеке.

Кассовые аппараты АМС-100Ф позволяют пробивать покупки вручную, без использования компьютера. Если одна или несколько покупок были пробиты вручную, то они не попадают в электронную чековую ленту и в ней возникает разрыв в номерах чеков.

Возможны случаи, когда фискальный регистратор сообщил о нормальном завершении фискализации, программа включила чек в электронную чековую ленту, а на фискальном регистраторе этот чек по каким-то причинам потерялся - в электронной чековой ленте возникнет два чека с одинаковыми номерами.

В любом случае, можно восстановить недостающую информацию по физической контрольной ленте - просто посмотреть что там пробито в недостающих чеках. После этого в складской программе можно сделать дополнительную расходную накладную на эти товары или скорректировать кассовую расходную накладную.

  • Протокол ошибок на кассе. При работе кассового модуля ведется протоколирование включений и выключений кассового модуля, аннулирований чеков, сообщений об ошибках и прочей информации, связанной с работой кассового модуля. Этот протокол ведется в файле с именем <номер кассы>.LOG, который находится в той же директории, где файл электронной чековой ленты Kassa.Res.

Если в директории, где находится просматриваемый RES-файл, для текущей позиции есть файл <номер кассы>.LOG, то данный пункт меню становится активным и его выбор открывает протокол приблизительно в том месте (по дате и времени), на котором стоит в данный момент курсор.


<Работа с чековой лентой - Поиск>

При нажатии одной из кнопок поиска, в нижней части экрана появляется дополнительная панель поиска. Если ни одна из кнопок не нажата, то панель поиска исчезает.

В левой части панели указывается критерий поиска, правее - окно для ввода поискового запроса и две кнопки - "Искать вверх" и "Искать вниз". Кнопки становятся активными как только поисковый запрос позволит начать поиск.

При нажатии "Поиск вверх" ищется позиция, отвечающая критериям поиска, которая находится выше текущей позиции. При нажатии "Поиск вниз" - ниже.

Критерии поиска

  • Поиск по дате. Надо ввести нужную дату и нажать кнопку поиска вверх или вниз. В отличие от всех остальных поисков, при поиске вверх находится не любая запись с искомой датой, а самая первая из них, т.е. курсор остановится на первой записи от этой даты. Аналогично, при поиске вниз находится последняя запись за эту дату.

  • Поиск по названию товара. Надо ввести любое слово или часть слова. Поиск ведется по 17 символам названия, которые есть в контрольной ленте. Если используются дополнительные свойства, то поиск ведется и по ним.

  • Поиск по номеру чека. Ищется чек с заданным номером.

  • Поиск по сумме. Ищется запись, в полях цена или сумма которой, находится указанное число. Поиск также включает в себя полную сумму чека, которая записана в колонке "Сумма чека".

  • Поиск по коду товара. Ищется запись у которой код товара или номер карточки начинается с заданных символов.


<Работа с чековой лентой - Отметить>

Работа с чековой лентой - Отметить.

Данный пункт меню предназначен для установки или снятия выделения для группы последовательных записей. По отмеченным записям можно получать отчет, проводить тестирование, экспортировать или загружать их в базу данных.

  • Отметить текущую запись как начало. Текущая запись отмечается как первая запись среди отмеченных. Если к этому моменту конечная запись уже отмечена и находится ниже текущей, то диапазон отмеченных записей выделяется на экране темно-зеленым цветом. Если конечная запись еще не отмечена, или находится выше текущей, то отметка запоминается, но на экране ничего не меняется.

  • Отметить текущую запись как конец. Текущая запись отмечается как последняя запись среди отмеченных. Если к этому моменту первая запись уже отмечена и находится выше текущей, то диапазон отмеченных записей выделяется на экране темно-зеленым цветом. Если первая запись еще не отмечена, или находится ниже текущей, то отметка запоминается, но на экране ничего не меняется.

  • Снять отметки. Ранее сделанное выделение отмеченных записей отменяется.


<Работа с чековой лентой - Действия>

Этот пункт меню предназначен для выполнения действий, которые могут внести изменения в базу данных, поэтому их надо выполнять осторожно, предварительно ознакомившись с этим разделом.

  • Загрузка в базу данных информации за... Этот пункт меню позволяет загрузить в базу данных информацию из чековой ленты. Обычно он используется для повторного ввода расходных кассовых накладных, если с существующими накладными есть какие-то проблемы (например, их случайно удалили).

Перед загрузкой следует убедиться, что в складской базе данных нет соответствующих накладных. Если при загрузке окажется, что такая накладная уже есть, то информация в ней будет задвоена.

Если в момент выбора меню, курсор стоит на записи за какое-то число, то в загрузке будут участвовать все записи за это число. Для того, чтобы загрузить записи за другое число, надо предварительно поставить курсор на запись с нужной датой. Для этого можно использовать листание списка покупок или Поиск .

Если одна или несколько записей отмечены, то, независимо от положения курсора, загружаться будут все отмеченные записи.

  • Изменить "последнюю запись в БД". При занесении покупок в базу данных или при импорте их из касс с режимом экспорт/импорт, кассовый сервер запоминает последнюю записанную в базу данных покупку. Это дает возможность загружать в базу только ту информацию, которой в ней еще нет.

Если по каким-то причинам требуется изменить эту запись, то достаточно установить курсор на нужную запись и выбрать этот пункт меню. Все записи, которые располагаются после текущей записи будут считаться еще не введенными в базу.

При загрузке в базу информации (см. пункт 1 этого раздела). Значение "последней записи" не принимается во внимание - загружается все, что выбрано для загрузки. После загрузки, если последняя загруженная запись находится после "последней записи", то она становится новой "последней записью". Если последняя загруженная запись находится до "последней записи", то "последняя запись" не меняется.

  • Выгрузка информации в файл за... Записи за указанное число или отмеченные выгружаются в один или несколько RES-файлов. Отдельный файл создается для каждого кассового аппарата. Имя файла состоит из номера кассового аппарата и расширения RES. Файл создается в директории связи.

  • Удаление из чековой ленты информации до... По мере работы, размер файла электронной чековой ленты увеличивается. Если его удалить, то он создастся заново и начнет накапливать информацию о покупках. Однако, одновременно потеряется информация о покупках за весь предшествующий период. Для того, чтобы уменьшить размер RES-файла, но сохранить в нем информацию за несколько последних дней или недель, можно использовать этот пункт меню.

Надо установить курсор на какую-нибудь запись в нужном дне и выполнить "удаление". При этом старый файл Kassa.Res переименуется в Kassa.Bak и создастся новый файл Kassa.Res, в котором будут записи, начинающиеся с заданной даты .

Примечание.

Такое удаление можно делать с помощью кассового модуля ("Главное меню > Работа с чековой лентой > F10). Там все необходимые условия выполняются сами по себе.

Если удаление делается из Кассового сервера, то надо убедиться в двух вещах:

1. Сейчас открыт именно тот RES-файл, с которым работает кассовый модуль, а не его копия. Иначе эта процедура никак не повлияет на работу.

2. Кассовый модуль, чей RES-файл укорачивается, должен быть выключен. При попытке выполнить эту операцию при работающем Кассовом модуле, возможно его аварийное завершение.


<Технические детали>

Этот раздел содержит некоторые технические детали реализации.

1. Почти вся информация, связанная с настройками хранится в базе данных, с которой работает кассовый сервер.

В registry на компьютере, где установлен Кассовый сервер хранится следующая информация:

В ключе:

HKEY_Local_Machine\Software\SoftLand Systems\Kas_Serv\

  • Путь и имя базы данных, к которой Кассовый сервер автоматически подключается (Database);

  • Директория связи (LinkDirectory);

  • Информация о настройке шрифтов, автообновления экрана для просмотра RES-файлов и размерах и положении главного окна программы.

2. В директории связи находятся файлы со следующими расширениями:

  • .ТIM - эти файлы создают кассовые модули. Имя файла соответствует номеру кассового аппарата. В файле содержится информация о дате и времени создания файла с номенклатурой (DAT-файла), с которым работает данный кассовый модуль. Эта информация отображается в графе "Номенклатура от" главного экрана Кассового сервера. Кассовый сервер уничиожает TIM-файл после прочтения, а кассовый модуль вновь создает его через 5 секунд. Если в течение 15 секунд этот файл не появляется, то кассовый сервер считает рабочее место неактивным и лампочка возле него делается серой.

  • .NE и .NE- - это файлы с обновлением номенклатуры для рабочего места, чей номер задает имя файла. Файл с расширением NE - это файл в процессе подготовки. После того, как подготовка закончена, расширение NE меняется на NE- . Фактически этот файл - это готовый DAT-файл и отличается от него только расширением.

Кассовый модуль копирует готовый NE- файл к себе в рабочую директорию, заменяет старый DAT-файл на скопированный и уничтожает файл NE- в директории связи.

  • .GET - это файл с запросом от кассового сервера на импорт информации из кассового модуля. Файл содержит запись с последней вошедшей в базу данных покупкой. Как только кассовый модуль обнаружит в своей чековой ленте (Kassa.RES) покупки, пробитые после этой записи, он подготовит файл с информацией для импорта в базу данных.

  • .KAS - это файл, содержащий информацию от кассового модуля для импорта в базу данных. В процессе подготовки он имеет расширение .KA- . Сам файл имеет тот же формат, что и RES-файл. После завершения импорта Кассовый сервер уничтожает этот файл и создает новый запрос (.GET).

  • .RES - это файл, созданный при экспорте из чековой ленты.

  • .DAT - файл с номенклатурой, созданный для касс, работающих в режиме экспорта/импорта.

  • .SET - файл, корректирующий количество товара в кассах одной группы при продаже какого-либо товара одной из них.

  • .TMP - промежуточные файлы, связанные с работой самого Кассового сервера.


Выбор покупателей для экспорта скидок

Отметьте нужных покупателей или группы покупателей и нажмите кнопку "Выбор".

Для отметки / снятия отметки можно использовать клавишу ПРОБЕЛ. Можно также отмечать с помощью мышки, кликая по серой вертикальной полосе слева от нужного покупателя. Отмеченный покупатель отмечается красной точкой слева от названия.

Если ни один из покупателей не отмечен, то при нажатии кнопки "Выбор" считается отмеченным один покупатель - тот на котором в этот момент установлен курсор в списке.