Установка программы

Комплект поставки программы SLS-Дисконт включает в себя:

  • Установочный диск
  • Электронный ключ
  • Лицензионное соглашение
  • Инструкция по установке программы

Для установки программы необходимо:

  • Вставить диск в дисковод. Через Стартовое меню вызвать программу "Проводник", открыть содержимое диска, найти и запустить файл setup.exe. Для запуска файла можно в Стартовом меню выбрать пункт "Выполнить" и указать файл A:\setup.exe.

  • Подтвердить установку программы.

  • Далее Пользователю будет предложено ознакомиться с Лицензионным соглашением

  • Выбрать папку для установки программы. Для выбора папки нужно нажать кнопку "Обзор". Если указать несуществующую папку, программа установки создаст ее автоматически.

  • Выбрать программную группу для создания группы пиктограмм в Стартовом меню. По умолчанию программ установки предложит выбрать группу SoftLand Systems. Для выбора другой группы нужно нажать кнопку "Обзор".

  • После подтверждения начнется инсталляция программы.

ВНИМАНИЕ!

Для успешного запуска программы необходимо вставить в LPT-порт (разъем для подключения принтера) электронный ключ, поставляемый с программой Дисконт. Для этого выключите компьютер и вставьте ключ. После этого компьютер можно включить. Без вставленного ключа программа работать не будет.

Если на Вашем компьютере установлен Windows 95/98, то после изменения параметров BIOS может потребоваться переустановка драйверов. Windows автоматически определяет необходимость в переустановке драйверов. Для успешной переустановки драйверов Вам потребуется установочный диск с Windows 95/98.

Чтобы избежать переустановки драйверов, требуется сначала успешно выполнить установку программы с диска и только после этого вставить электронный ключ.


Основные возможности программы Дисконт-Офис

Дисконт-Офис

Программа SLS-ДисконтОф предназначена для создания, ведения БД покупателей, а также истории правил предоставления скидок розничным покупателям, имеющим дисконтные карты магазинов сети. Дополнительно программа отвечает за подготовку файлов с новой информацией для магазинов и чтение новой информации, подготовленной магазинами сети.

Дополнительно см. Описание процесса сбора, хранения информации о покупателях, расчета скидок, обмена информацией между центральным офисом и магазинами сети


Основные возможности программы Дисконт-Магазин

Дисконт-Магазин

Программа SLS-ДисконтМаг предназначена для хранения необходимой информации о покупателях сети в БД каждого магазина, расчета скидки покупателя по запросу программы Касса, предоставления программе Касса информации о скидках по покупателям, накопления информации о покупках, совершенным каждым покупателем в магазине, а также для хранения и предоставления работникам магазина информации о том, с кем из покупателей и каким образом нужно связаться в связи с проведением маркетинговых акций. Дополнительно программа отвечает за подготовку файлов с новой информацией для центрального офиса и чтение информации, подготовленной центральным офисом.

Дополнительно см. Описание процесса сбора, хранения информации о покупателях, расчета скидок, обмена информацией между центральным офисом и магазинами сети


Требования к оборудованию и программному обеспечению

Для работы программы SLS-Дисконт для Windows требуется:

Программные средства:

  • Операционная система Windows 95/98 или Windows NT 4.0
  • Для сетевого варианта наличие локальной вычислительной сети, поддерживающей протокол IPX или NETBIOS (например, сети NOVELL или WINDOWS).

Аппаратные средства:

  • Оперативная память min - 16 Mb. Рекомендуется - 32Mb.
  • Процессор, тактовая частота min - 100 MHz. Рекомендуется - 200 MHz.
  • Рекомендуемое разрешение экрана - 800х600.
  • Наличие LPT-порта для подключения электронного ключа для однопользовательской версии.


Описание процесса

Описание процесса сбора, хранения информации о покупателях, расчета скидок, обмена информацией между центральным офисом и магазинами сети

  • В магазинах сети покупатели заполняют анкету и получают карточку с персональным штрих-кодом. Новые анкеты, заполненные покупателями, с присвоенными покупателям штрих-кодами ежедневно записываются администратором в базу данных (БД) магазина. В магазине, выдавшем карточку, покупка покупателя, получившего карточку, автоматически заносится в БД дисконтной системы магазина. При этом в БД формируется карточка нового клиента, в которой заполнен штрих-код и занесена сделанная покупка. В центральном офисе оператор может оформить новую карточку покупателя, выданную в офисе, при необходимости указав начальную сумму покупок.
  • В БД центрального офиса подготавливается и вводится в действие таблица скидок, предоставляемых покупателям сети в зависимости от суммы покупок (в рублях), совершенных покупателем в магазинах сети.
  • Ежедневно после сбора и обработки информации от всех магазинов центральный офис готовит файл обновлений для каждого магазина. В файл обновлений попадает информация о новых покупателях, изменения в информации уже имеющихся покупателей, таблица скидок. Таким образом, новая информация по покупателям (новая карточка, новая общая сумма покупок и пр.) подготавливается для магазинов сети в течение одного дня после свершения самого события (выдачи карточки с штрих-кодом, совершения новой покупки и пр.). И покупатель может воспользоваться полученной карточкой со штрих-кодом или новой скидкой не раньше, чем через 1 день после совершения покупки.
  • Считается, что для каждого магазина сети есть список покупателей, за которых магазин «отвечает». Это означает, что при проведении маркетинговых акций этим магазином, сотрудники магазина должны связаться с покупателями, находящимися в его зоне ответственности, и проинформировать покупателей о проводящихся маркетинговых акциях. По покупателям, за которых магазин «отвечает», в магазин передается не только штрих-код и сумма покупок, но еще контактная информация.
  • Первоначально магазины из центрального офиса (в порядке обновления информации) получают список покупателей, имеющих карточку покупателя, и таблицу скидок. На основании этой информации формируется первоначальная БД в каждом магазине. Список покупателей во всех магазинах и информация об общей сумме покупок каждого покупателя, а также таблица скидок во всех магазинах сети в идеальном случае должны быть одинаковыми. Различаться они могут только в случае неуспешного завершения процесса передачи информации из центрального офиса в какие-либо магазины сети, либо из-за существенного различия во времени окончания работы магазинов сети и офиса, обусловленного их географическим положением.
  • Дисконтная система в магазине готовит для касс файл, определяющий текущую скидку для каждого покупателя. Когда покупатель совершает покупку в магазине сети и предъявляет на кассе свою карточку покупателя, программа SLS-Касса отыскивает в файле по штрих-коду покупателя и соответствующую ему скидку. Если покупатель не найден, скидка не предоставляется, однако информация о покупке по карточке заносится в БД дисконтной системы магазина. В дальнейшем эта информация передается в центральный офис, где оператор должен принять решение, будет ли эта карточка признана недействительной, и по ней покупатели обслуживаться не будут, либо необходимо карточку с неправильно читающимся кодом заменить на новую, либо что-либо еще. Соответствующие отметки делаются в БД дисконтной системы.
  • При совершении покупки программа SLS-Касса формирует чек покупателю с учетом полученного значения скидки. Если чек успешно пробит (покупатель совершил покупку), то полная информация по чеку покупателя записывается в файл.
  • Периодически дисконтная система магазина считывает новую информацию о покупках из файлов, созданных кассами, и записывает эту информацию в БД дисконтной системы.
  • В конце рабочего дня (по времени магазина) дисконтная система магазина готовит файл со всеми покупателями, имеющими штрих-код, совершившими покупки с момента последней успешной отсылки информации в центральный офис. По каждому покупателю передается вся информация по чекам, пробитым для этого покупателя за рассматриваемый период, а также анкетная информация для новых покупателей. Подготовленный файл записывается по адресу файла экспорта, описанному в настройках системы. Если для записи такого файла необходимо активировать канал связи с удаленным ресурсом, то дисконтная система инициирует процесс подключения к этому ресурсу.
  • В конце рабочего дня (по времени центрального офиса) дисконтная система центрального офиса опрашивает все файлы импорта от магазинов (описанные в настройках системы) и считывает в БД дисконтной системы центрального офиса всю полученную новую информацию из магазинов о покупках, совершенных покупателями сети.
  • После успешного завершения импорта информации дисконтная система центрального офиса пересчитывает общие суммы покупок, совершенных покупателями, и рассчитывает новые значения скидок для покупателей.
  • Дисконтная система подготавливает файлы для всех магазинов сети с новой информацией (см. п.3). Каждый файл записывается по адресу, указанному для файла экспорта для каждого магазина в настройках системы. Если для записи файлов необходимо активировать канал связи с удаленным ресурсом, дисконтная система инициирует процесс подключения к этому ресурсу.
  • В начале рабочего дня (по местному времени) дисконтная система магазина считывает информацию из файла, подготовленного центральным офисом. Файл ищется по адресу, указанному в качестве файла импорта в настройках системы магазина.
  • и т.д.


С чего начать работу

Предлагается следующий порядок работы с программой:

  • Создать новую базу данных
  • Произвести настройку параметров
  • Установить пароль системы
  • Произвести настройку рабочей станции
  • Заполнить таблицу скидок (для офиса)
  • Заполнить классификатор магазинов сети (для офиса)
  • Заполнить классификатор кассовых мест (для магазина)


Настройка/Рабочая станция

Рабочая станция

Используется для настройки параметров работы системы автоматизации при запуске с данной рабочей станции. Эти настройки будут действовать, вне зависимости от конкретного пользователя, вошедшего в систему. Настройка рабочей станции включает в себя следующие параметры:

  • Шрифт для отображения на экране
  • Настройка печати выходных форм
  • При старте автоматически подключаться к базе данных
  • Открывать последнюю базу данных
  • Количество недавно открытых файлов
  • После подключения базы данных открывать пункт меню
  • Другие параметры
  • Настраиваемые формы брать из папки


С чего начать работу/Установить пароль для открытия базы данных

Установить пароль для открытия базы данных

Чтобы установить пароль для открытия определенной базы данных, нужно:

  • Открыть базу данных
  • Выбрать раздел Настройка/Изменить пароль

При вводе пароль отображается в виде звездочек (*). Чтобы увидеть введенное значение, нужно кликнуть мышкой на иконке "Очки" или нажать Ctrl+Tab.


Настройка/Параметры(маг)

Параметры

Используется для вызова окна настройки параметров базы данных. В данном разделе необходимо настроить следующие параметры:

На вкладке Общие:

  • Код
  • Название организации
  • Разница во времени
  • Время Ч
  • Размер штрих-кода
  • Штрих-коды в анкетах только из каталога
  • Новые карточки покупателей активны
  • Группы VIP карт
  • Определять активность для каждого штрих-кода
  • Пороги скидок для групп VIP
  • Аналитические типы в накопительной таблице скидок

Параметры обмена:

  • Тип обмена
  • FTP-сервер
  • Порт
  • Пользователь
  • Пароль

Файлы:

  • Для касс
  • Для экспорта
  • Для импорта

Обмен:

  • Последние данные из офиса
  • Подтвержденный экспорт
  • Дата файла импорта
  • Дата файла экспорта

Примечание:

  • Примечание

На вкладке Карточка покупателя:

  • ФИО указывать в отдельных полях
  • Отключить персонифицированный обмен
  • Фиксировать скидки при смене таблицы скидок
  • Дополнительные поля описания

На вкладке Замена карт:

  • Переход на новые дисконтные карты
  • В диапазоне от ... до ...
  • Заменять карты на кассах с


Настройка/Пользователи и их права

Пользователи и их права

Используется для вызова каталога пользователей базы данных. Расширенное санкционирование доступа позволяет назначить (описать) права пользователей, каждый из которых может иметь свои права и ограничения на просмотр, добавление, корректировку и удаление каждого логического раздела системы. Работа в разделе ведется при помощи меню Пользователи .


Настройка/Установить списки по умолчанию

Установить списки по умолчанию

Для установки списков по умолчанию нужно заполнить следующие параметры настройки списка:

  • Название списка, которое будет выдаваться в перечне настроенных списков
  • Перечень колонок, включенных в список.

При необходимости списки можно настроить вручную. Для этого, находясь в соответствующем списке, например в списке карточек покупателей, нужно нажать правую кнопку мышки и выбрать раздел "Списки". После этого появятся следующие пункты:

  • Исходный список - список, установленный по умолчанию. В случае нажатия (ОК) производится установка списков в исходном виде, заложенном в программе
  • Настройка списка - настройка необходимого списка.


Классификаторы/Кассовые места(маг)

Кассовые места

Раздел доступен пользователям с правом на работу с кассовыми местами и используется для описания всех кассовых мест, от которых дисконтная система получает информацию о покупках, пути к файлам, в которые кассы будут записывать свою информацию и время последней покупки, успешно переданной с кассового места.

Работа в разделе ведется при помощи меню:

  • Кассовые места - создание, корректировка и удаление описания кассового места, а для печати выходных форм используется меню Формы .

На экране отображается окно, представленное в виде списка с графами:

  • Идентификатор - идентификатор кассового места в магазине.
  • Файл импорта - полный путь к файлу, из которого считывается информация о покупках покупателей, сделанных через данную кассу. Файл формируется в рабочей директории программы Касса с именем kassa.dsc.
  • Последняя покупка - дата и время последней покупки, успешно считанной из файла импорта данной кассы. Поле заполняется автоматически после успешного импорта информации от кассы. Доступ к полю имеют только пользователи с правами администратора.

Список кассовых мест упорядочен по идентификатору кассового места. В списке действует подвод по первым символам идентификатора. В списке кассовых мест работает сортировка по любому столбцу классификатора.

Внимание!!! Для каждого кассового места, описанного в классификаторе, обязательно должен быть указан файл импорта, так как в противном случае операция обмена информацией между магазином и центральным офисом будет невозможна!!!


Кассовые места/Меню кассовые места/Добавить(маг)

Добавить

Для создания описания нового кассового места нужно заполнить следующие параметры:

  • Идентификатор
  • Файл импорта
  • Дата/Время последней покупки

Для пользователей программы SLS-Касса смотрите описание настройки кассовой программы для работы с SLS-Дисконт .


Кассовые места/Меню кассовые места/Изменить(маг)

Изменить

Используется для изменения описания следующих параметров описания пользователя и его прав:

  • Идентификатор
  • Файл импорта
  • Дата/Время последней покупки

Для пользователей программы SLS-Касса смотрите описание настройки кассовой программы для работы с SLS-Дисконт .


Кассовые места/Меню кассовые места/Удалить(маг)

Удалить

Используется для удаления описания кассового. Удаление произойдет после подтверждения.


Карточка покупателя(маг)

Карточка покупателя

Карточка покупателя - объект, в котором хранится необходимая анкетная информация по покупателю, подробная информация по покупкам покупателя, совершенным в данном магазине, а также сводная информация, переданная из центрального офиса, необходимая для расчета скидки, предоставляемой покупателю.

Работа в карточке покупателя ведется при помощи меню Покупатель и меню Заметки .

Для удобства работы вся информация в карточке покупателя разделена на вкладки:

  • Описание
  • Штрих-коды
  • Покупки
  • Заметки


Меню покупатели/Поиск(Справка)

Поиск

Функция доступна пользователям с правом на просмотр карточек покупателей и используется для поиска и отбора карточек покупателей.

Для проведения поиска нужно задать условия поиска и отбора покупателей и кликнуть на кнопке (Отобрать). Результаты поиска отображаются в ветви Найденные покупатели

В списке найденных карточек покупателей доступны следующие функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Изменить описание текущей карточки покупателя.
  • Поместить карточку покупателя в архив
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск
  • Отметить карточки путем проставления точек в поле слева от списка.
  • Снять все отметки
  • Удалить из списка
  • Включить активность
  • Отключить активность
  • Проставить ответственный магазин
  • Привязать к группе VIP
  • Отвязать от группы VIP
  • Отметить найденные


Меню Покупатели/Группы VIP(маг)

Группы VIP

Пункт меню отображается только в случае, если включен параметр настройки системы Группы VIP карт и доступен пользователям с правом доступа к каталогам покупателей. Верхний уровень каталога групп VIP представляет собой список организаций, с которыми заключаются договоры на VIP обслуживание. Внутри каждой организации расположены 2 ветви:

  • Покупатели
  • Акции

Если каталог групп VIP открыт на верхнем уровне, то список групп VIP в правой части окна каталога представлен в виде таблицы со следующими колонками:

  • Код - код группы VIP. Используется для однозначной идентификации групп VIP в «офисной» и «магазинных» базах данных.
  • Наименование - наименование группы VIP.
  • Полное наименование - полное наименование группы VIP.
  • Статус группы - статус группы VIP
  • Дата/время последней корректировки - используются при обмене данными между модулями Офис и Магазин и содержат дату и время внесения последних корректировок в описание группы VIP или одного из вложенных в нее объектов (дисконтных карт, таблиц скидок).

Список упорядочен в алфавитном порядке по коду группы VIP. В списке работает быстрый подвод по первым символам кода группы VIP. Работа в каталоге групп VIP ведется при помощи меню:

  • Группы VIP
  • Акции


Анкеты

Для автоматизации процесса передачи анкетных данных новых покупателей, получивших дисконтные карты, из магазина в центральный офис, используется следующая технология:

- в каталоге анкет заполняются анкетные данные, и хранится список всех анкет покупателей.

- при подготовке файла обмена для центрального офиса в файл помимо прочей информации помещаются новые анкеты.

- в центральном офисе по полученному файлу обмена заполняются анкеты покупателей в том случае, если до этого они не были заполнены.

- при подготовке файла обмена для магазина в файл помещается подтверждение успешного получения анкетных данных для каждой полученной анкеты.

Информация в разделе анкет покупателей имеет следующую структуру: в левом окне высвечивается дерево анкет покупателей , в правом окне - список анкет покупателей, соответствующий открытой группе в дереве анкет покупателей.

Работа ведется при помощи меню Анкеты , а для печати выходных форм используется меню Формы .

В списке анкеты отсортированы по алфавиту по ФИО покупателей. Чтобы произвести сортировку по другому полю, нужно кликнуть на заголовке данного поля. Если треугольник в заголовке поля расположен углом вниз, покупатели сортируются по данному полю по возрастанию. Если треугольник направлен вверх, происходит сортировка по убыванию.

В списке можно поменять колонки местами. Для этого нужно кликнуть мышкой на названии колонки, и не отпуская кнопки мыши, "перетащить" колонку в нужное место. Убрать колонку из списка можно уменьшив ее размеры до нуля. Чтобы изменить внешний вид списка карточек покупателей, нужно нажать правой кнопкой мыши и выбрать меню Списки/ Настройка списков .


Выгрузка базы данных

Выгрузка базы данных в текстовый файл производится в случае нарушения целостности базы данных в результате сбоев в ПЭВМ.

Чтобы выгрузить информацию, нужно открыть базу данных , из которой следует выгрузить информацию, и выбрать раздел меню Файл/Выгрузить базу данных .

Для выгрузки нужно заполнить параметры для выгрузки базы данных:

  • База данных
  • Текстовый файл

После завершения процедуры выгрузки для получения новой базы данных следует выполнить процедуру Создания базы данных по выгруженной информации .

Примечание.

Для выгрузки база данных должна быть отключена от Сервера приложений (для сетевой версии программы). В противном случае при попытке выгрузки будет выдано сообщение "База данных занята. Ждите ее освобождения."


Создание базы данных по выгруженной информации

Создание базы данных на основе существующей можно произвести только после ее выгрузки .

Чтобы создать базу данных, нужно выбрать раздел Файл/Создать базу данных .

Для создания базы данных нужно заполнить следующие параметры:

  • Текстовый файл
  • База данных


Резервное копирование

Скачки напряжения в электросети и сбои в работе компьютера могут привести к нарушению целостности базы данных. В целях сохранности информации, введенной в системе "SLS-Дисконт", Пользователю настоятельно рекомендуется как можно чаще проводить резервное копирование базы данных. Частота выполнения резервного копирования определяется в зависимости от объема информации, вводимой в систему в течение дня, и может составлять от одного раза в неделю до нескольких раз в день. В идеале рекомендуется хранить несколько резервных копий за последние несколько дней работы. Например, создать пять директорий, соответствующих дням недели, и в конце каждого рабочего дня проводить копирование базы данных в соответствующую директорию.


Открытие базы данных

Чтобы открыть базу данных, нужно в Главном меню выбрать пункт Файл/Открыть.. .


Создание базы данных

Создать базу данных

Чтобы создать новую базу данных, нужно в главном меню выбрать раздел Файл/Создать новую (пустую БД) .

Прежде чем начать работать с новой базой данных, нужно произвести настройку параметров и установить пароль для открытия базы данных .


Закрытие базы данных

Используется для закрытия базы данных. При открытии другой базы данных предыдущая открытая база закрывается автоматически.


Файл/Обмен/Экспорт обновлений в центр(маг)

Экспорт обновлений в центр

Для обмена информацией между БД следует провести экспорт информации, кликнув на кнопку (Начать). При этом проверяется доступность файла по пути файл для экспорта .

o Если файл недоступен, то сообщение об этом записывается в протокол ошибок экспорта, который имеет имя с наименованием базы данных_export.log. Экспорт из магазина не производится.

o Если файл доступен, то автоматически импортируется информации от касс и формируется файл, в который записывается следующая информация:

SLS-Discount System Export To Office File (номер текущей версии программы)

Строка 001 - системная информация.

001|A|B|C|D|E|F|G

A - код магазина, из которого формируется файл экспорта (Настройка/Параметры/Код организации).

B/С - дата/время наиболее свежей информации, успешно импортированной из центрального офиса (Настройка/Параметры/Последние данные из офиса). Дата записывается в формате гг-мм-дд.

D/E - дата/время последней корректировки по покупателям (если никаких корректировок не было, то текущие дата и время). Дата записывается в формате гг-мм-дд.

F/G - дата/время создания файла экспорта из магазина (Настройка/Параметры/Дата файла экспорта). Дата записывается в формате гг-мм-дд.

Строка 002 - штрих-коды карточек покупателей.

002 | Штрих-код

В строке отображаются все штрих-коды с вкладки Штрих-коды карточки покупателя.

Строк с кодом 002 столько, сколько имеется карточек покупателей, таких что Дата/Время последней корректировки больше или равно значению подтвержденный экспорт .

Строка 006 - покупка, совершенная по карточке со штрих-кодом, указанным выше в строке с кодом 002 (т.е. за каждой строкой со штрих-кодом следуют строки с информацией о покупках по этому штрих-коду если они есть).

006|A|B|C|D|E|F|G|H|I|J|K|L

A/B - дата/время совершения покупки. Дата записывается в формате гг-мм-дд.

C - номер чека, согласно которому совершена покупка.

D - штрих-код купленного товара.

E - названия дополнительных свойств товара.

F - значения дополнительных свойств товара.

G - количество купленного товара.

H - цена купленного товара.

I - cумма купленного товара.

J - размер скидки на товар.

K - cумма купленного товара со скидкой.

L - штрих-код дисконтной карты, на которую оформлена покупка.

Если параметр настройки системы группы VIP отключен, то строка имеет вид:

006|A|B|C|D|E|F|G|H|I|J|K

Строка 007 - информация об анкетах покупателей. Экспортируются только анкеты со статусом «готова к отправке» или «отправлена».

007|A|B|C|D|E|F|G|H|I|J|K|L|M|M |M |M |M |N|O|P|Q|R

А - штрих-код карточки покупателя, на которую оформляется анкета.

B - фамилия покупателя (Анкета покупателя/ФИО/значение поля, если параметр ФИО указывать в отдельных полях отключен, и значение первого из трех полей, если включен).

С - дата рождения покупателя в формате гггг-мм-дд.

D - пол покупателя (1 - женский, пробел - мужской).

E - образование покупателя (0 - высшее, 1 - среднее специальное, 2 - среднее, 3 - неоконченное высшее).

F - адрес покупателя.

G/H - дата/время заполнения анкеты. Дата записывается в формате гг-мм-дд.

I - имя покупателя (Анкета покупателя/ФИО/значение второго из трех полей, если оно заполнено, независимо от текущего значения параметра ФИО указывать в отдельных полях .

J - отчество покупателя (Анкета покупателя/ФИО/значение третьего из трех полей, если оно заполнено, независимо от текущего значения параметра ФИО указывать в отдельных полях ).

K - телефон покупателя.

L - e-mail покупателя.

М - значения используемых дополнительных полей описания (Настройка/Параметры/Дополнительные поля описания/Использование отлично от «не используется»), если пробел - параметр не используется или поле не заполнено в анкете покупателя.

N - код мобильного телефона покупателя.

O - номер мобильного телефона покупателя.

P - штрих-код из поля Замена карты старого образца из описания анкеты покупателя.

Q - получение информации по моб. телефону (1 - да, пусто - нет).

R - получение информации по e-mail (1 - да, пусто - нет).

Если включен параметр настройки системы отключить персонифицированный обмен , то строки с кодами 007 не формируются и не записываются в файл экспорта.

o Файл записывается по адресу файла экспорта параметров настройки магазина. Старый файл, если он есть, удаляется.

o Дата/время создания файла записываются в графу Дата файла экспорта параметров настройки магазина.

Кнопка (Начать) заменяется кнопкой (ОК), нажатие которой позволяет закрыть окно, а кнопка (Отказаться) заменяется кнопкой (Протокол), нажатие которой позволяет отобразить на экране протокол проведения процедуры экспорта информации.


Файл/Обмен/Импорт информации из центра(маг)

Импорт информации из центра

Для обмена информацией между БД следует провести импорт информации, кликнув на кнопку (Начать). При этом производятся следующие действия:

o Проверяется доступность файла по пути файл для импорта . Если файл недоступен, то сообщение об этом записывается в протокол ошибок импорта, который имеет имя с наименованием базы данных_import.log, импорт не производится.

o Если файл доступен, то проверяется версия файла импорта. При ее несовпадении с версией процедуры обмена, используемой данным экземпляром программы SLS-ДисконтОф, на экран выводится сообщение об ошибке: «Неверный формат файла», и загрузка данных из файла не выполняется. Кроме того, при возникновении такой ошибки в отдельном окне выводится сообщение об ошибке: «Неверный формат файла обмена из Офиса. Сообщите о возникшей ситуации администратору в Офис!».

o Проверяется идентичность кода магазина из строки 001 файла импорта и кода из параметров настройки системы. Если условие не выполняется, то сообщение об этом записывается в файл ошибок импорта, импорт из файла не производится. Если выполняется, то сравнивается дата/время создания файла экспорта для магазина из файла (второе значение дата/время из строки с кодом 001, т.е. значение поля Дата файла экспорта из описания магазина в программе SLS-ДисконтОф) со значением поля Дата файла импорта в параметрах настройки системы SLS-ДисконтМаг. Если эти даты равны, или первая раньше второй, то в окне параметров импорта выводится предупреждающее сообщение: «Новой информации по магазину нет», и импорт не производится.

o Если это не так, то последовательно считывается блок информации из файла импорта.

- При обработке строк с кодами 001 и 012 значения параметров настройки системы записываются в соответствующие поля настройки системы магазина (если в файле обмена значение параметра «пробел», то в параметрах настройки системы соответствующий параметр отключается, если значение «1», то включается). Если строка с кодом 001 содержит дополнительные поля описания, то значения последних 10 полей этой строки рассматриваются как 5 пар полей и используются для заполнения параметров настройки в блоке «Дополнительные поля описания». Значение первого из полей каждой пары используется в качестве значения параметра Наименование соответствующего по счету дополнительного поля описания покупателя, по значению второго поля заполняется параметр Использование следующим образом: «0» - «не используется», «1» - «необязательно», «2» - «обязательно».

- если в магазине параметр настройки Переход на новые дисконтные карты отключен, то если в файле в строке с кодом 001 значение параметра, соответствующего параметру настройки системы Переход на новые дисконтные карты, равно «1», то файл обрабатывается по следующим правилам:

§ Включается параметр настройки Переход на новые дисконтные карты.

§ Проводится процедура фиксирования скидки переходного периода по всем картам покупателей базы данных. Обрабатываются все карточки покупателей, в которых значение поля Общая сумма покупок > 0. Для каждого такого покупателя по значению поля Общая сумма покупок и действующей на момент запуска процедуры пересчета таблице скидок определяется % скидки, который должен предоставляться по такой накопленной сумме для товаров с аналитическим типом 00000001. Вычисленный % скидки записывается в поле Скидка перех. периода описания покупателя.

Замечание: дата/время последней корректировки карточки покупателя при этом не обновляется.

- При обработке строки с кодом 009 проверяется наличие в БД группы VIP с кодом группы из строки файла обмена. Если такая группа есть, то значения полей Наименование, Полное наименование и Статус в ее описании приводится в соответствие с данными из файла обмена. Если какому-либо коду группы VIP в БД не соответствует ни одна группа VIP покупателей, то она создается. В ее описании заполняется только код группы.

- При обработке строки с кодом 010 проверяется информация о действующей скидочной акции по группе VIP. Если в БД в соответствующей группе VIP описание акции отсутствует или отлично от данных из файла, то оно приводится в соответствие с данными из файла (полю Статус описания акции в базе данных всегда присваивается значение «действует»). Если строка с кодом 010 в файле пустая, то по группе VIP нет действующих скидочных акций, поэтому если в базе данных для группы есть запись об акции, то она удаляется.

- При обработке строки с кодом 011 заполняется список условий предоставления скидок по действующей акции в соответствие с данными из файла обмена.

- При обработке строки с кодом 002 проверяются списки штрих-кодов дисконтных карт, закрепленных за одним покупателем. Если в БД нет ни одного штрих-кода покупателя из списка, то создается карточка покупателя, в которую на вкладку Описание записывается основной штрих-код покупателя, считанный из файла, а также на вкладку Штрих-коды записываются остальные штрих-коды покупателя, если они есть. Кроме того, в строку описания штрих-кода записываются значения полей С, До и Сумма покупок. Полю Дата/время последней корректировки карточки покупателя присваивается значение текущей даты/времени создания карточки.

- Если штрих-код уже имеется в базе данных модуля Магазин, то значение поля Активность его описания обновляется в соответствии с данными из файла обмена (и значением параметра настройки определять активность для каждого штрих-кода ). Если же создается новая запись о штрих-коде, то поля Активность и Группа VIP его описания заполняются согласно данным из файла обмена.

- При обработке строки с кодом 003 вся анкетная и сводная информация по покупателю из файла переписывается в карточку покупателя БД.

- При обработке строки с кодом 004 информация о действующей таблице скидок приводится в соответствие с данными из файла обмена.

- При обработке строки с кодом 005 заполняется список предоставления скидок по действующей таблице в соответствие с данными из файла обмена.

- При обработке строки с кодом 008 по штрих-коду производится поиск анкеты. В найденной анкете статус изменяется на «Принята ЦО» и она перемещается в ветвь Принятые ЦО из ветви Новые анкеты.

o Если вся возможная информация из файла успешно записана в БД, то дата/время создания файла экспорта для магазина из файла (второе значение дата/время из строки с кодом 001, т.е. значение поля Дата файла экспорта из описания магазина в программе SLS-ДисконтОф) записывается в поля последние данные из офиса и дата файла импорта в параметрах настройки системы SLS-ДисконтМаг.

o Дата/время последнего успешного импорта из магазина из файла (первое значение дата/время из строки с кодом 001, т.е. значение поля Последние данные из магазина из описания магазина в программе SLS-ДисконтОф) записывается в поле подтвержденный экспорт в параметрах настройки системы SLS-ДисконтМаг.


Файл/Обмен/Создать файл для касс(маг)

Создать файл для касс

Для проведения процедуры экспорта информации в кассу нужно вызвать меню Файл -> Обмен информацией между БД -> Создать файл для касс. При нажатии кнопки (Начать) проверяется возможность записи файла для касс по адресу, указанному в глобальных параметрах. Если запись файла невозможна, то сообщение об ошибке записывается в файл ошибок импорта и файл для касс не формируется. Иначе, формируется файл, в который записывается следующая информация:

SLS-Discount System Export To Cash File|A|B|C|D|E

A - размер штрих-кода дисконтных карт (Настройка/Параметры/Размер штрих-кода).

B - число, задающее сумму покупок, начиная с которой покупателю предоставляется скидка.

C - определяет наличие групп VIP карт (пробел - групп VIP нет, работает только система накопительных скидок, 1 - в каталоге групп VIP есть хотя бы одна группа, в которой описана скидочная акция в период действия которой попадает текущая системная дата). Если включен параметр настройки аналитические типы в накопительной таблице скидок , то С = 1.

D - начало интервала номеров штрих-кодов карт нового образца (Настройка/Параметры/в диапазоне от…). Отображается, если заполнен параметр настройки заменять карты на кассах с .

E - окончание интервала номеров штрих-кодов карт нового образца (Настройка/Параметры/в диапазоне до…). Отображается, если заполнен параметр настройки заменять карты на кассах с .

Для каждой такой группы (группы VIP или безусловно):

Строка 001 - информация о группе VIP. Если включен параметр настройки аналитические типы в накопительной таблице скидок , то также информация о служебной группе VIP, содержащей действующие скидки по накопительным дисконтным картам.

001|Код|Наименование

Код - код группы VIP.

Наименование - наименование группыVIP.

Если включен параметр настройки аналитические типы в накопительной таблице скидок , то для служебной группы VIP:

001|Код|Наименование

Код - 00000000000.

Наименование - Накопительные дисконтные карты.

Строка 002 - условия предоставления скидок для карточек группы VIP.

002|Аналитический тип|Скидка|С суммы|Прочие

Аналитический тип - код аналитического типа товаров, на которые распространяется акция.

Скидка - размер скидки на товары, обладающие указанным аналитическим типом.

С суммы - значение соответствующего поля описания условия акции.

Прочие - пустое, если в описании условия акции параметр Прочие отключен, и равен «1» в противном случае.

Строк с кодом 002 столько, сколько имеется условий действующей скидочной акции.

Строка с кодом 003 - информация о штрих-кодах.

003|Штрих-код|Активность|Скидка|Код группы VIP|ФИО|Сумма|Скидка перех. периода

Штрих-код - штрих-код карточки покупателя.

Активность - активность карточки покупателя (1 - активна, 0 - неактивна), если параметр настройки системы определять активность для каждого штрих-кода отключен. И активность штрих-кода (1 - активен, 0 - неактивен), если параметр включен.

Скидка - текущая накопительная скидка из описания карточки покупателя, к которой привязан штрих-код, если штрих-код не привязан к группе VIP и «0» в противном случае.

Код группы VIP - « », если штрих-код не привязан к группе VIP и значение поля Код из описания группы VIP в противном случае. Если включен параметр настройки аналитические типы в накопительной таблице скидок , то для служебной группы VIP Код группы VIP - 00000000000.

ФИО заполняются только для штрих-кодов, привязанных к группам VIP.

Сумма - общая сумма покупок из описания карточки покупателя, если штрих-код не привязан к группе VIP или привязан к служебной группе VIP, или значение поля Сумма покупок строки с описанием штрих-кода в карточке покупателя, если штрих-код привязан к группе VIP. Сумма покупок записывается в строку с описанием штрих-кода только в том случае, если текущая системная дата попадает в период (С, До], где С и До - поля описания штрих-кода в карточке покупателя.

Скидка перех. периода - значение поля Скидка перех. периода из описания карточки покупателя. Отображается, если заполнен параметр настройки заменять карты на кассах с .

Файл записывается по адресу файла для касс из параметров настройки системы. Старый файл для касс удаляется.

Если при импорте данных из дисконтной системы кассовая программа получила информацию о размере штрих-кода дисконтных карт, то регистрация в кассе НОВЫХ дисконтных карт со штрих-кодами, размер которых отличен от заданного, недопустима.

После ввода номера дисконтной карты (штрих-кода покупателя) кассовая программа ищет информацию о ней в своем локальном файле скидок. Если штрих-код найден, то считывается соответствующие ему признак активности и скидка. Если штрих-код найден и карточка активна, то пробивается чек с соответствующей скидкой. Если штрих-код найден, но карточка неактивна, то кассир получает предупреждение о том, что карточка не обслуживается и скидка не предоставляется. Если штрих-код покупателя не найден, либо покупателю только что выдана карточка с новым штрих-кодом, скидка не предоставляется, но информация о покупке покупателя записывается в файл покупок, формируемый кассой!!!


Файл/Обмен/Импорт информации от касс(маг)

Импорт информации от касс

Для обмена информацией между БД следует провести импорт информации от касс, кликнув на кнопку (Начать). Далее необходимо отметить кассы, из которых нужно сделать импорт, в справочнике кассовых мест . Отметки проставляются слева от списка в специальном выделенном поле. Если кассы не отмечены, то выгрузка информации производится из всех касовых мест.

o Проверяется доступность файла по пути Файл импорта из описания кассового места. Если файл недоступен, то сообщение об этом записывается в протокол ошибок импорта и импорт не производится.

o Если файл доступен, то производятся следующие действия:

- Последовательно считывается блок информации из кассового файла импорта, имеющего следующую структуру:

SLS-Discount System Import From Cash File

A|B|C|D|E|F|G|H|I|J|K|L|M

A/B - дата/время совершения покупки. Дата записывается в формате гг-мм-дд.

C - штрих-код дисконтной карты, на которую оформлена покупка.

D - номер чека, согласно которому совершена покупка.

E - штрих-код купленного товара.

F - названия дополнительных свойств товара.

G - значения дополнительных свойств товара.

H - количество купленного товара.

I - цена купленного товара.

J - cумма купленного товара.

K - размер скидки на товар.

L - cумма товара с учетом скидки.

M - штрих-код дисконтной карты старого образца.

- Обработка строк начинается со строки, в которой дата/время совершения покупки позднее (и наиболее близка) к дате/времени последней покупки из описания соответствующего кассового места.

- Для каждой строки кассового файла проверяется наличие штрих-кода дисконтной карты в БД магазина. Если он отсутствует, то:

§ создается карточка покупателя, в которой:

§ на вкладку Описание и на вкладку Штрих-коды записывается штрих-код, считанный из файла.

§ полю Дата/время последней корректировки карточки покупателя присваивается значение текущей даты/времени создания карточки.

§ поле Группа VIP не заполняется.

§ значение поля Активность на вкладке Штрих-коды определяется значением параметра настройки системы определять активность для каждого штрих-кода , а значение поля Активность на вкладке Описание - значением параметра новые карточки покупателей активны .

§ информация по покупкам покупателя из файла переписывается в соответствующие поля в карточку покупателя на вкладку Покупки, а также в записи о покупке заполняется поле Дисконтная карта.

- Если обрабатываемый штрих-код уже имеется в БД, то информация по покупкам покупателя из файла переписывается в соответствующие поля в карточку покупателя на вкладку Покупки, а также в записи о покупке заполняется поле Дисконтная карта. При этом по каждой покупке проверяется, если все характеристики покупки из файла совпадают с соответствующими характеристиками какой-либо строки покупок в карточке покупателя, и штрих-код дисконтной карты из файла импорта равен штрих-коду в строке описания покупки в карточке покупателя, то повторно информация в БД не пишется.

- Если в обрабатываемой покупке заполнено поле с номером карты старого образца, то покупка импортируется в базу данных программы SLS-Дисконт Магазин по обычным правилам, а кроме того, производятся следующие действия:

§ Штрих-код новой карты из строки с покупкой создается со ссылкой на ту же карточку покупателя, что и штрих-код карты старого образца. Т.е. в карточке покупателя, соответствующей штрих-коду из нового поля, на вкладке Штрих-коды создается новая запись.

§ В записи о штрих-коде из поля Штрих-код строки файла обмена параметр Активность отключается.

§ В описании покупки на вкладке Покупки в поле Штрих-код записывается штрих-код карты нового образца.

§ В описании штрих-кода на вкладке Штрих-коды в поле Дата выдачи записывается значение поля Дата из описания покупки (из первой обрабатываемой строки с покупкой для данного штрих-кода).

- В поле Дата/время последней корректировки карточки покупателя записываются текущие дата/время.

Если вся возможная информация из файла успешно записана в БД, то дата/время последней успешно записанной покупки из файла записывается в поле Дата/время последней покупки для соответствующего кассового места.

- Если обрабатываемый штрих-код уже имеется в БД, то информация по покупкам покупателя из файла переписывается в соответствующие поля в карточку покупателя на вкладку Покупки, а также в записи о покупке заполняется поле Дисконтная карта. При этом по каждой покупке проверяется, если все характеристики покупки из файла совпадают с соответствующими характеристиками какой-либо строки покупок в карточке покупателя, и штрих-код дисконтной карты из файла импорта равен штрих-коду в строке описания покупки в карточке покупателя, то повторно информация в БД не пишется.

Если вся возможная информация из файла успешно записана в БД, то дата/время последней успешно записанной покупки из файла записывается в поле "Дата/время последней покупки" для соответствующего кассового места.

Внимание!!! Для каждого кассового места, описанного в классификаторе, обязательно должен быть указан файл импорта, так как в противном случае операция обмена информацией между магазином и центральным офисом будет невозможна!!!

Для пользователей программы SLS-Касса смотрите описание настройки кассовой программы для работы с SLS-Дисконт .


Общие команды редактирования

При вводе и корректировке любых полей информации в программе используются общие команды редактирования.

  • Для передвижения курсора от поля к полю служат клавиши:

Tab - переход на следующее поле;

Shift+Tab - переход на предыдущее поле;

Стрелки: налево, направо, вверх, вниз - переход на ближайшее поле в указанном направлении (если достигли границы поля);

Enter - если поле однострочное, то переход на следующее поле, если многострочное, то перенос информации справа от курсора на строку ниже

  • Для передвижения курсора внутри поля:

Стрелки: налево, направо, вверх, вниз;

Home - переход на левую границу текста в строке, на которой стоит курсор;

End - переход на правую границу текста в строке, на которой стоит курсор;

Backspace - для удаления символа слева от курсора;

Del - для удаления символа справа от курсора;

Ctrl+Y - для удаления всей информации внутри поля;

Esc - для отказа от корректировки или ввода информации;

PgDn - для сохранения введенной информации

* - устанавливает текущую дату в поле

  • Для создания, корректировки, удаления объектов:

Ins - добавить

F2 - изменить

Del - удалить

Ctrl+R - пересчет

Ctrl+P - печать


Кард ридер

Работа с устройством для считывания магнитных карт

Настройка кард-ридера в программных модулях "SLS-Дисконт" производится в меню "Настройка -> Рабочая станция". Следует нажать на кнопку "Настройка сканера", открыть вкладку "Кард-ридер" и заполнить следующие параметры:

  • Кард-ридер используется (поле-флажок). Если параметр включен, то кард-ридер будет использоваться на данной рабочей станции.
  • Порт, куда подключен кард-ридер. Значение по умолчанию СОМ1.
  • Поля для настройки режима порта (скорость передачи, четность, количество бит и количество стоп-бит).
  • Таблица настройки префиксов/суффиксов дорожек чтения и выбор дорожки, содержащей код карты.

Все настройки по умолчанию соответствуют настройкам для кард-ридера Cipher MSR 1023. В окне настройки также обеспечена возможность проверки чтения карточек и результатов этого чтения.

В каталоге карточек покупателей в ветвях "Покупатели по штрих-кодам" в программных модулях "SLS-Дисконт" при считывании кода кард-ридером осуществляется подвод к карточке покупателя с соответствующим номером дисконтной карты. Если карточка покупателя найдена, то она открывается на просмотр, если нет, то на экран выводится сообщение: "Карточка покупателя с номером N не найдена", где N - номер дисконтной карты, считанный устройством.

При создании и корректировке карточки покупателя в программе "SLS-ДисконтОф" можно воспользоваться кард-ридером для ввода номера считанной дисконтной карты в поле "Штрих-код". Номер вводится автоматически после провода карточки через кард-ридер, а фокус ввода в данный момент находится в любом из полей описания карточки.

В программе "SLS-Касса" в тех же самых местах программы, где допускается чтение дисконтной карты сканером, можно использовать чтение карточек кард-ридером.


Описание настройки кассовой программы

Настройка кассовой программы для работы с SLS-Дисконт

Настройка делается на кассовом рабочем месте с помощью программы Kassa.exe. Пользователю нужно подключиться к программе с правами администратора или кассира-администратора и выбрать в главном меню раздел "Настройка системы/Работа с SLS-Дисконт". На экране появится окно, в котором предлагается заполнить следующие параметры:

Путь и имя для общего файла со скидками позволяет указать файл (с расширением .exp), созданный программой SLS-ДисконтМаг (см. Настройка/Параметры/Файл для касс) и содержащий информацию о штрих-кодах дисконтных карт, их активности и предоставляемых по ним скидках. Если в этом поле нажать пробел или любую букву/цифру, то появится окно, в которое можно ввести нужную информацию, или (нажав пробел еще раз) указать нужный файл на диске.

Префикс кода покупателя может содержать от одного до четырех символов, с которых начинаются коды дисконтных карт магазинов сети. Префикс должен позволять отличить код дисконтной карты от кода товара. Если для дисконтных карт используется код EAN-13, то в качестве префикса можно выбрать, например, 22.

Если сумма покупки больше минимальной и карточки нет, то предназначен для определения действий программы при пробивке чека на сумму большую, чем минимальная сумма, с которой начинаются скидки.

Если дисконтная карта не прочтена, то при пробивке такого чека (после нажатия Enter в окне ввода сдачи) возможны три варианта:

можно пробивать и без карточки - чек пробивается в обычном режиме.

просто предупредить о необходимости выдачи карточки - кассир получает предупреждение о том, что нужно выдать дисконтную карту. Если он соглашается, то появляется окно, в котором можно просканировать и новую карточку, и уже имеющуюся на руках у покупателя. Если кассир отказывается от выдачи, то чек пробивается в обычном режиме без дисконтной карты.

пароль администратора для продажи с новой карточкой или без нее - на экране появляется сообщение о необходимости выдачи дисконтной карты, но для этого требуются администраторские права и приглашение для ввода имени и пароля администратора или кассира-администратора. Если подтверждение администратора получено, то дальше все происходит так, как описано в предыдущем пункте. Если кассир отказывается от ввода пароля администратора, то он возвращается на экран ввода сдачи - чек не пробивается.

Округлять до - предназначен для задания округления при использовании дисконтных скидок. При установке скидки по дисконтной карте сначала вычисляется цена товара с этой скидкой, затем производится округление и, наконец, рассчитывается сумма как новая цена умноженная на количество.

Примечание:

Если не заполнены первое или второе поле, то Дисконтная система в кассовой программе использоваться не будет.

Результаты работы Кассовой программы с дисконтными картами.

Все чеки, пробитые с использованием дисконтных карт, протоколируются в файле KASSA.DSС, который создается (или дописывается) в рабочей директории программы Касса.


Главное меню

Главное меню системы состоит из пунктов:

  • Файл
  • Покупатели
  • Скидки
  • Классификаторы
  • Настройка
  • Окна
  • Справка


Меню Файл

Файл

Используется для работы с базами данных: создания, открытия, закрытия файлов, обмена информацией между базами данных. Меню содержит следующие пункты:

  • Открыть
  • Закрыть БД
  • Подключиться с другим именем
  • Тестирование базы данных
  • Выгрузить базу данных
  • Создать базу данных по выгруженной информации
  • Создать новую (пустую) базу данных
  • Обмен информацией между базами данных
  • Системная информация
  • Параметры последней корректировки
  • Калькулятор
  • Календарь
  • Список последних открытых файлов
  • Завершение работы


Меню Покупатели(маг)

Покупатели

Встроенный модуль контроля карточек покупателей доступен пользователем с правом доступа к каталогам покупателей и содержит следующие разделы:

  • Карточки покупателей
  • Анкеты
  • Группы VIP


Меню Скидки

Скидки

Используется для хранения списка таблиц скидок, а также каталога групп VIP клиентов и содержит пункты:

  • Таблицы скидок
  • Акции групп VIP - отображается если включен параметр настройки группы VIP .


Меню Классификаторы(маг)

Классификаторы

Используется для хранения списка кассовых мест магазина и содержит пункт:

  • Кассовые места

Для пользователей программы SLS-Касса смотрите описание настройки кассовой программы для работы с SLS-Дисконт .


Меню Настройка

Настройка

Используется для настройки параметров работы системы. Настройка параметров необходима для адаптации программы к условиям и принципам работы конкретного предприятия.

Настройка параметров не требует знаний программирования и предназначена, в основном, для включения и выключения различных возможностей программы. Раздел содержит следующие пункты:

  • Рабочая станция
  • Изменить пароль
  • Параметры
  • Пользователи и их права
  • Установить списки по умолчанию


Меню Окна

Окна

Используется для работы с окнами и содержит следующие пункты:

  • Закрыть все окна
  • Список открытых окон


Меню Справка

Справка

Используется для открытия файла справочной системы и вызова пункта о программе


Файл/Открыть

Открыть

Используется для открытия рабочей базы данных. Если вызов функции подключения к базе данных производится, когда система уже подключена к какой-либо базе данных, то сначала система отключается от текущей базы данных, а затем управление передается функции подключения к другой базе данных.

В разделе Настройка/Рабочая станция можно указать базу данных, которая будет автоматически открываться при запуске программы. Для этого нужно заполнить параметр при старте автоматически подключаться к базе данных или открывать последнюю базу данных .

Если с базой данных работали в течение предыдущих сеансов, то ее можно открыть, выбрав из списка последних открытых файлов


Файл/Закрыть БД

Закрыть БД

Используется для закрытия базы данных. Система производит отключение от базы данных, после чего главное меню приводится к виду, отображаемому до подключения к базе данных.


Файл/Подключиться с другим именем

Подключиться с другим именем

Используется для подключения к базе данных с именем и паролем, описанным в каталоге пользователей системы для данной БД.


Файл/Тестирование БД

Тестирование БД

Используется для проверки целостности данных.

Формируется файл ИМЯ_test.log, (где ИМЯ - название текущей базы данных), который содержит список ошибок если таковые были обнаружены в результате тестирования. Для исправления ошибок в базе данных следует выполнить выгрузку базы данных и создание базы данных по выгруженной информации.


Файл/Выгрузить БД

Выгрузить БД

Выгрузка базы данных в текстовый файл производится в случае нарушения целостности базы данных в результате сбоев в работе компьютера.

Для выгрузки базы данных нужно заполнить следующие параметры:

  • База данных
  • Текстовый файл
  • После выгрузки создать БД по выгруженной информации

По окончании работы процедуры формируется файл с расширением .log, содержащий список выгруженных параметров. Просмотреть его можно нажатием кнопки (Протокол). После завершения процедуры выгрузки для получения новой базы данных следует выполнить процедуру создания базы данных по выгруженной информации .

Также возможна выгрузка и создание новой БД через командную строку

Примечание.

Для выгрузки база данных должна быть отключена от Сервера приложений (для сетевой версии программы). В противном случае при попытке выгрузки будет выдано сообщение "База данных занята. Ждите ее освобождения."


Файл/Выгрузить БД/База данных

База данных

Для выгрузки базы данных - имя БД, из которой выгружается информация. По умолчанию отображается имя открытой базы данных. Чтобы изменить имя выгружаемой БД, нужно вызвать стандартный каталог Windows для выбора другого файла БД с расширением .dbx.

Для создания базы данных - имя БД, которая будет создана по выгруженной информации. По умолчанию предлагается файл с именем БД из имени текстового файла, расположенный по тому же пути, что и выгружаемый файл. Чтобы изменить имя создаваемой БД, нужно вызвать стандартный каталог Windows для выбора другого файла БД с расширением .dbx.


Файл/Выгрузить БД/Текстовый файл

Текстовый файл

Для выгрузки базы данных - имя текстового файла с расширением .UNL, в который выгружается информация из БД. По умолчанию имя файла совпадает с именем базы данных, расположенный по тому же пути, что и выгружаемый файл. Чтобы изменить имя файла, нужно вызвать стандартный каталог Windows для выбора другого файла с расширением .unl.

Для создания базы данных - имя текстового файла с расширением .UNL, из которого загружается информация в БД. Чтобы изменить имя файла, нужно вызвать стандартный каталог Windows для выбора другого файла с расширением .unl.


Файл/Выгрузить БД/После выгрузки создать БД по выгруженной информации

После выгрузки создать базу данных по выгруженной информации

При включенном параметре после выгрузки БД в текстовый файл произойдет автоматический вызов функции создания БД по выгруженной информации


Файл/Создать БД по выгруженной информации

Создать БД по выгруженной информации

Используется в случае нарушения целостности базы данных в результате сбоев в работе компьютера. Для создания базы данных нужно заполнить следующие параметры:

  • База данных
  • Текстовый файл

По окончании работы процедуры формируется файл с расширением .log, содержащий список загруженных параметров. Просмотреть его можно нажатием кнопки (Протокол).

Перед созданием БД обязательно нужно выполнить выгрузку старой БД в текстовый файл, выбрав раздел выгрузить базу данных .

После создания базы данных следует установить пароль системы!


Файл/Выгрузить/Загрузить БД через командную строку

Выгрузка и создание БД по выгруженной информации через командную строку

Если команда в командной строке имеет формат «Полный_путь_к_DiscountOffice.exe Полный_путь_к_базе_CENTER.dbx /U», то её выполнение приводит к следующим действиям:

§ Запускается .exe-файл, расположенный по указанному адресу;

§ Запущенная программа открывает базу данных с указанным названием;

§ Открытая база данных выгружается, в директории с текущей базой данных создается по выгруженной информации файл *.unl;

§ По этому файлу в той же директории создается по выгруженной информации новая база данных с тем же названием, что и исходная (перед этим исходная БД удаляется);

§ Программа DiscountOffice.exe закрывается.

Таким образом, выполнение этой команды приводит к тем же результатам, что и последовательное выполнение функций Выгрузить БД и Создать БД по выгруженной информации , вызванных из программы DiscountOffice.exe для базы CENTER.dbx.


Файл/Создать новую (пустую БД)

Создать новую (пустую БД)

Используется для создания новой базы данных для работы с программой. В созданной базе данных выполняется создание всех необходимых структур (таблицы, индексы и т.п.), а также заносится следующая информация:

§ В таблицу логических пользователей базы данных заносится привилегированный пользователь-администратор по умолчанию с именем «admin», данный пользователь не отображается в каталоге пользователей и является универсальным пользователем-администратором базы данных. При создании базы данных пароль для данного пользователя не задается, однако он может быть задан позднее.

После завершения действий по созданию базы данных производится автоматическое подключение к базе данных от имени пользователя admin.


Файл/Обмен информацией между БД(маг)

Обмен информацией между БД

Обмен данными между центральным офисом и каждым магазином проводится через два файла обмена: в один файл система записывает экспортируемую информацию, из другого считывает информацию, записанную второй системой. Данные об именах и месте расположения файлов на дисках компьютеров вносятся в параметры настройки систем, функционирующих в магазинах, и в справочник магазинов (по каждому магазину своя пара файлов) в центральном офисе. В каждой системе реализуются функции обмена информацией между системами, которые вызываются операторами через меню каждой системы.

Каждая система отвечает за подготовку и запись, а также за чтение информации только на своей стороне. Для того, чтобы подготовленная одной системой информация попала в БД другой системы, в той системе также необходимо выполнить функцию "Импорт информации".

Раздел "Обмен информацией между базами данных" используется для:

  • Выполнения процедуры экспорта данных с целью дальнейшего импорта данных в другую базу данных;
  • Выполнения процедуры импорта данных из файла экспорта в базу данных;
  • Выполнения процедуры импорта данных из всех касс с последующим экспортом обновлений кассовым местам.

Все значения дат и времени в магазинах записываются в местном времени магазинов. Все значения дат и времени в центральном офисе записываются в местном времени центрального офиса. При передаче информации из центрального офиса в магазин и обратно все даты/время, импортируемые из удаленных баз данных, приводятся к местному времени.

Внимание!!! При работе с дисконтной системой каждая база данных, принимающая участие в обмене информацией, должна иметь собственные настройки и уникальные файлы обмена. В центральном офисе и в каждом из магазинов сети необходимо осуществлять работу с одной базой данных, т.к. в противном случае (при работе с копиями) информация может быть безвозратно утеряна.

Раздел содержит следующие пункты:

  • Импорт информации из центра
  • Создать файл для касс
  • Импорт информации от касс
  • Экспорт обновлений в центр

Внимание!!! Для каждого кассового места, описанного в классификаторе, обязательно должен быть указан файл импорта, так как в противном случае операция обмена информацией между магазином и центральным офисом будет невозможна!!!

Доступ к разделу "Обмен информацией между базами данных" имеют только пользователи с правами администратора.

Подробнее см.

Процедура экспорта-импорта информации для нового магазина

Процедура экспорта-импорта информации для одного из магазинов сети

Описание процесса обмена информацией между центральным офисом и магазинами сети


Файл/Калькулятор

Калькулятор

Встроенный калькулятор вызывается в разделе Файл либо клавишами Ctrl+Alt+C на любом уровне программы.

Для вычисления нужного значения, в рабочее поле "Формула" заносится математическое выражение с использованием круглых скобок, операций сложения (+), вычитания (-), умножения (*), деления (/) и дополнительных функций, определенных в списке "Показывать список функций и переменных".


Файл/Календарь

Календарь

Открывается календарь на текущий месяц. Пользователь может установить курсор на названии текущего месяца и нажатием левой кнопкой мыши получить список всех месяцев года и самостоятельно выбрать нужный. Кроме того, нажатие левой кнопки мыши на значении года позволяет ввести необходимый для просмотра год.


Файл/Список последних открытых файлов

Список последних открытых файлов

В окне содержится список последних открытых файлов базы данных (не более десяти). Количество файлов задается в настройках рабочей станции. Используется для быстрого открытия файла базы данных.

При выборе файла из списка:

  • Автоматически закрываются все открытые окна
  • Закрывается ранее открытая база данных
  • Открывается выбранная база из списка


Файл/Завершить работу

Завершить работу

Используется для завершения работы программы. Все ранее открытые окна автоматически закрываются, происходит отключение от базы данных и работа приложения завершается.


Скидки/Таблицы скидок(маг)

Таблицы скидок

В разделе хранится действующая на данный момент таблица скидок. После получения из центрального офиса новой информации по команде оператора по для всех касс создается файл с рассчитанными скидками для всех покупателей.

Возможность назначения разных скидок для товаров разных аналитических типов для накопительной скидочной программы определяется параметром настройки системы аналитические типы в накопительной таблице скидок . На накопительной карте покупателя копится общая сумма покупок независимо от аналитических типов купленных товаров.

Список таблиц представлен в виде списка с графами:

  • Действует с - дата, с которой вводится в дейтсвие таблица скидок
  • Примечание - любой комментарий к таблице
  • Статус - статус таблицы может принимать любое из трех значений: Архив или Действует или Проект

В нижней части экрана отображается окно со списком строк, соответствующих текущей таблице из списка таблиц, представленный в виде таблицы с графами:

  • Аналитический тип - код аналитического типа из программы SLS-Эксперт. Скидка предоставляется только на товары с данным аналитическим типом. Если поле пустое, то скидка предоставляется на товары, в которых аналитический тип не задан.
  • Прочие товары - скидка распространяется на все товары, не попадающие под другие условия по значению аналитического типа.
  • С суммы - число (сумма в рублях), задающее сумму покупок, начиная с которой покупателю предоставляется скидка.
  • Скидка - размер скидки в %, предоставляемый покупателю.
  • Примечание - можно внести примечание по данной строке.

Столбцы Аналитический тип и Прочие товары отображаются, если включен параметр настройки аналитические типы в накопительной таблице скидок .

Список скидок упорядочен в алфавитном порядке по аналитическим типам, а затем по возрастанию значений С суммы.

В таблице скидок не может быть двух строк с одинаковыми значениями полей Аналитический тип, Прочие товары, С суммы.

В списке можно поменять колонки местами. Для этого нужно кликнуть мышкой на названии колонки и не отпуская кнопки мыши "перетащить" колонку в нужное место. Убрать колонку из списка можно уменьшив ее размеры до нуля. Чтобы изменить внешний вид списка, нужно нажать правой кнопкой мыши и вызвать меню Списки/ Настройка списка .

Для печати выходных форм используется меню Формы .


Классификаторы/Кассовые места/Меню Кассовые места(маг)

Кассовые места

Используется для создания, корректировки и удаления кассовых мест и состоит из пунктов:

  • Добавить
  • Изменить
  • Удалить
  • Закрыть


Кассовые места/Меню кассовые места/Закрыть(маг)

Закрыть

Используется для закрытия окна или каталога.


Кассовые места/Добавить/Параметры описания кассового места

Параметры описания кассового места

К параметрам описания кассового места относятся следующие пункты:

  • Идентификатор
  • Файл импорта
  • Дата/Время последней покупки

Для пользователей программы SLS-Касса смотрите описание настройки кассовой программы для работы с SLS-Дисконт .

Внимание!!! Для каждого кассового места, описанного в классификаторе, обязательно должен быть указан файл импорта, так как в противном случае операция обмена информацией между магазином и центральным офисом будет невозможна!!!


Параметры описания кассового места/Идентификатор

Идентификатор

Идентификатор кассового места в магазине. Идентификатор должен быть уникальным среди всех идентификаторов кассовых мест.


Параметры описания кассового места/Файл импорта

Файл импорта

Полный путь к файлу, из которого считывается информация о покупках покупателей, сделанных через данную кассу. Файл формируется в рабочей директории программы Касса с именем kassa.dsc.


Параметры описания кассового места/Дата/Время последней покупки

Дата/Время последней покупки

Дата и время последней покупки, успешно считанной из файла импорта данной кассы. Поле заполняется автоматически после успешного импорта информации от кассы. Закрыто для корректировок всем пользователям, кроме пользователя admin.


Настройка/Параметры/Код(маг)

Код

Код магазина. Используется для контроля информации, пришедшей из центрального офиса при подготовке файлов для экспорта в центральный офис. В базах данных офиса и магазина код магазина должен совпадать!


Настройка/Параметры/Файл для касс(маг)

Файл для касс

Полный путь (или путь относительно папки, где установлена программа) к файлу, в который будет записываться информация о скидках по покупателям для касс магазина.


Настройка/Параметры/Файл экспорта(маг)

Файл экспорта

В случае FTP обмена указывается полный путь к файлу, в который помещается информация, экспортируемая в центральный офис, в случае файлового обмена - полный путь или путь относительно папки, где установлена программа.


Настройка/Параметры/Файл импорта(маг)

Файл импорта

В случае FTP обмена указывается полный путь к файлу, в который помещается информация, экспортируемая в центральный офис, в случае файлового обмена - полный путь или путь относительно папки, где установлена программа.


Настройка/Параметры/Разница во времени(маг)

Разница во времени

Разница во времени (в часах) между магазином и центральным офисом. Разница считается положительной, если магазин находится восточнее центрального офиса и отрицательная, если магазин находится западнее центрального офиса.


Настройка/Параметры/Время Ч(маг)

Время Ч

Местное время, не позже которого следует подготовить новую информацию для экспорта в центральный офис.


Настройка/Параметры/Последние данные из офиса(маг)

Последние данные из офиса

Дата/время наиболее свежей информации, успешно импортируемой из центрального офиса. Проставляется функцией импорта информации из центрального офиса, закрыта от ручной корректировки пользователем.


Настройка/Параметры/Подтвержденный экспорт(маг)

Подтвержденный экспорт

Дата/время наиболее свежей информации, успешно экспортированной в центральный офис (подтверждение успешного импорта от центрального офиса). Проставляется функцией импорта информации из центрального офиса, закрыта от ручной корректировки пользователем.


Настройка/Параметры/Примечание(маг)

Примечание

Любая дополнительная информация по магазину.


Настройка/Параметры/Дата файла импорта(маг)

Дата файла импорта

Дата создания успешно загруженного в базу данных магазина файла импорта из центрального офиса. Проставляется функцией импорта информации из центрального офиса, закрыта от ручной корректировки пользователем.


Настройка/Параметры/Дата файла экспорта(маг)

Дата файла экспорта

Дата создания файла экспорта для центрального офиса. Проставляется функцией экспорта информации в центральный офис, закрыта от ручной корректировки пользователем.


Настройка/Изменить пароль

Настройка пароля

Используется для замены пароля пользователя, от имени которого произведено подключение к базе данных

Установка пароля

Чтобы установить пароль, нужно выбрать данный пункт меню и вписать пароль в поле «Введите новый пароль» и в поле «Введите новый пароль еще раз для контроля». После этого следует кликнуть на кнопке (Сохранить). Введенный пароль отображается в виде звездочек. Чтобы увидеть настоящий пароль, нужно кликнуть на пиктограмме с очками.

Снятие пароля

Чтобы снять пароль, нужно в поле «Введите старый пароль» заполнить старый пароль, остальные поля оставить пустыми и кликнуть на кнопке (Сохранить).

Изменение пароля

Чтобы изменить пароль, нужно заполнить старый пароль в поле «Введите старый пароль», в поля «Введите новый пароль» и «Введите новый пароль еще раз» заполнить новый пароль и кликнуть на кнопке (Сохранить).


Установка списка по умолчанию/Настройка списка

Настройка списка

На различных уровнях работы в программе пользователь имеет право самостоятельно настроить список информации, представленной на экране, включив в него дополнительные колонки и исключив ненужные.

Для настройки списка нужно правой кнопкой мышки вызвать вертикальное меню, выбрать в нем пункт Списки/Настройка списков.

Чтобы создать новый вид списка, нужно кликнуть на кнопке (Добавить) и заполнить следующие параметры настройки списка:

  • Название списка, которое будет выдаваться в перечне настроенных списков
  • Перечень колонок, включенных в список.

Допускается создание нескольких различных видов списков. Для корректировки и удаления списков предназначены кнопки (Изменить) и (Удалить) соответственно.

Чтобы получить на экране настроенный список, нужно правой кнопкой мыши вызвать вертикальное меню, выбрать в нем пункт Списки и выбрать один из описанных списков. Для перехода к обычному списку нужно выбрать в вертикальном меню пункт Списки/Исходный список.


Окна/Список открытых окон

Список открытых окон

Если открыты какие-либо окна, соответствующие разделам системы, то их заголовки отображаются в разделе Окна.

Пункт используется для быстрого перехода в другое окно.


Окна/Закрыть все окна

Закрыть все окна

Используется для закрытия всех открытых разделов системы, кроме главного окна.


Справка/О программе

О программе

Содержит краткую информацию о названии и версии программного продукта, а также контактную информацию о фирме-изготовителе SoftLand Systems (почтовый и электронный адрес, телефон).


Настройка/Параметры/Переход на новые дисконтные карты(маг)

Переход на новые дисконтные карты

Признак, указывающий на введение программы перехода на новые дисконтные карты. Заполняется функцией импорта информации из центрального офиса. Закрыт от корректировки.

Если ранее пустой параметр включается, то проводится процедура фиксирования скидки переходного периода по всем картам покупателей базы данных. Обрабатываются все карточки покупателей, в которых значение поля общая сумма покупок > 0. Для каждого такого покупателя по значению поля общая сумма покупок и действующей на момент запуска процедуры пересчета таблице скидок определяется % скидки, который должен предоставляться по такой накопленной сумме для товаров с аналитическим типом 00000001. Вычисленный % скидки записывается в поле скидка перех. периода описания покупателя. Дата/время последней корректировки карточки покупателя при этом не обновляется.


Настройка/Параметры/Название организации

Название организации

Полное название фирмы, которое будет распечатываться в заголовке различных форм и документов.


Настройка/Параметры/В диапазоне от ... до ... (маг)

В диапазоне от ... до ...

Диапазон номеров штрих-кодов новых дисконтных карт. Заполняется функцией импорта информации из центрального офиса. Закрыто от корректировки.


Настройка/Параметры/FTP-сервер

FTP-сервер

Используется для ввода имени или IP адреса сервера, посредством которого будет производиться обмен данными. Параметр доступен для заполнения/корректировки, если параметр Тип обмена имеет значение FTP.


Настройка/Параметры/Заменять карты на кассах с(маг)

Заменять карты на кассах с

Дата, начиная с которой при сканировании дисконтной карты на кассе будет определяться принадлежность карты к картам «старого» или «нового» образца и для карт «старого» образца будет проводиться процедура замены. Заполняется функцией импорта информации из центрального офиса. Закрыто от корректировки.


Настройка/Параметры/Порт

Порт

Используется для ввода порта, через который осуществляется доступ на FTP-сервер. Значение по умолчанию 21. Параметр доступен для заполнения/корректировки, если параметр Тип обмена имеет значение FTP.


Настройка/Параметры/Пользователь

Пользователь

Используется для задания имени пользователя, которое будет запрашиваться для входа на FTP-сервер. Доступ к разделу Настройки/Параметры имеют только пользователи с правами администратора. Параметр доступен для заполнения/корректировки, если параметр Тип обмена имеет значение FTP.


Настройка/Параметры/Пароль

Пароль

Используется для ввода пароля пользователя. Вводимые символы маскируются символом «*». Параметр доступен для заполнения/корректировки, если параметр Тип обмена имеет значение FTP. Доступ к разделу Настройки/Параметры имеют только пользователи с правами администратора.


Настройка/Пользователи и их права/Пользователи(маг)

Пользователи

Пункт меню доступен пользователям с правом на доступ к системным функциям. Используется для добавления, корректировки и удаления описаний пользователей в программе и содержит следующие пункты:

  • Добавить
  • Скопировать
  • Изменить
  • Удалить
  • Закрыть


Пользователи/Добавить(маг)(Справка)

Добавить

Для создания описания нового пользователя и его прав нужно заполнить следующие параметры:

  • Имя пользователя
  • Пароль
  • Доступ к системным функциям
  • Доступ к кассовым местам
  • Доступ к каталогам покупателей
  • Доступ к операции замены карты


Пользователи/Имя пользователя

Имя пользователя

Произвольное имя пользователя, которое будет запрашиваться при входе в программу. Каждый пользователь должен иметь уникальное имя.


Пользователи/Пароль

Пароль

Пароль пользователя, который будет запрашиваться при входе в программу.

Установка пароля

Чтобы установить пароль, нужно выбрать данный пункт меню и вписать пароль в поле "Введите новый пароль" и в поле "Введите новый пароль еще раз для контроля". После этого следует кликнуть на кнопке (Сохранить). Введенный пароль отображается в виде звездочек. Чтобы увидеть настоящий пароль, нужно кликнуть на пиктограмме с очками.

Снятие пароля

Чтобы снять пароль, нужно в поле "Введите старый пароль" заполнить старый пароль, остальные поля оставить пустыми и кликнуть на кнопке (Сохранить).

Изменение пароля

Чтобы изменить пароль, нужно заполнить старый пароль в поле "Введите старый пароль", в поля "Введите новый пароль" и "Введите новый пароль еще раз" заполнить новый пароль и кликнуть на кнопке (Сохранить).


Новый пользователь/Доступ к системным функциям

Доступ к системным функциям

Может принимать значения запретить или разрешить. Если для пользователя указано значение разрешить, то при подключении к системе данный пользователь сможет получить доступ к ряду функций и разделов системы, недоступных другим пользователям, а именно:

  • Тестирование БД
  • Выгрузить БД
  • Создать БД по выгруженной информации
  • Создать новую (пустую БД)
  • Обмен информацией между БД

В системе SLS-ДисконтМаг доступ к параметрам настройки системы, списку пользователей системы и параметрам последней корректировки имеет только пользователь Admin.


Пользователи/Доступ к кассовым местам(маг)

Доступ к кассовым местам

Может принимать значения запретить или разрешить. Если для пользователя указано значение разрешить, то при подключении к системе данный пользователь сможет выполнять операции в классификаторе кассовых мест в полном объеме.


Пользователи/Доступ к каталогам покупателей(маг)

Доступ к каталогам покупателей

Может принимать значения запретить или разрешить. Если для пользователя указано значение разрешить, то при подключении к системе данный пользователь имеет доступ к каталогам покупателей и групп VIP и может осуществлять работу с ними.

Если пользователю запрещен доступ к каталогам покупателей, то он имеет доступ к каталогу анкет, в котором ему доступна только ветвь Новые анкеты со всей функциональностью. При создании и корректировке анкеты для заполнения поля Штрих-код пользователь имеет доступ к списку штрих-кодов карточек, зарегистрированных в системе. Каталог покупателей такому пользователю недоступен. В каталоге групп VIP ему недоступен раздел Покупатели в каждой группе VIP.

Если же пользователю разрешен доступ к каталогам покупателей, то он имеет возможность работать с каталогом анкет в полном объеме и видеть каталоги покупателей и групп VIP в полном объеме.


Пользователи/Скопировать(Справка)

Скопировать

Используется для создания нового пользователя на основании описания пользователя, на котором в списке стоит курсор в момент вызова операции.


Основные разделы/Акции групп VIP(офис)

Акции групп VIP

Просмотр - пользователь может просматривать классификатор акций групп VIP (полностью или без архивных акций), а также список условий предоставления скидок по ним. При этом пользователь может привязывать группы VIP в акциям и отвязывать их при наличии права на изменение групп VIP.

Добавление - пользователь может добавить новую акцию для группы VIP в классификатор.

Корректировка - пользователь может корректировать описание акции для группы VIP, а также добавлять/корректировать/удалять условия предоставления скидок по ним.

Удаление - пользователь может удалить описание акции для группы VIP из классификатора.


Пользователи/Изменить

Изменить

Используется для изменения имени текущего пользователя, изменения разрешенных для него действий, а также для задания нового пароля для него.


Новый пользователь/Доступ к операции замены карты(маг)

Доступ к операции замены карты

Может принимать значения запретить или разрешить. Если для пользователя указано значение разрешить, то при подключении к системе данному пользователю доступна операция замены дисконтной карты в карточке покупателя.


Пользователи/Удалить

Удалить

Используется для удаления описания текущего пользователя из списка.


Карточки покупателей/Дерево покупателей(маг)

Дерево покупателей

Дерево покупателей доступно пользователям с правом на доступ к каталогу покупателей и имеет следующую структуру:

  • Покупатели по именам
  • Покупатели по штрих-кодам
  • Найденные покупатели


Покупатели(офис)

Покупатели

Используется для создания, корректировки и отбора карточек покупателей по набору критериев и содержит следующие пункты:

  • Добавить
  • Изменить
  • Просмотр
  • Пересчет
  • Поиск
  • Закрыть


Покупатели/Ветвь Покупатели по именам(маг)

Покупатели по именам

Раздел представляет собой список всех карточек покупателей, для которых данный магазин является ответственным, отсортированный в алфавитном порядке по полю ФИО, если параметр настройки системы ФИО указывать в отдельных полях отключен, и по полю Фамилия, если параметр включен. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Группа VIP - отображается, если включен параметр настройки системы группы VIP карт и содержит наименование группы VIP, к которой привязан основной штрих-код карточки покупателя с вкладки Описание
  • Дата рождения
  • Адрес
  • Телефон
  • Мобильный телефон
  • E-mail
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

Также с помощью настройки списков могут быть отображены следующие столбцы:

  • Ответственный магазин
  • Исходящий магазин

В списке карточек покупателей доступны функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск .
  • Быстрый поиск карточки покупателя по первым символам фамилии покупателя.


Покупатели/Ветвь Покупатели по штрих-кодам(маг)

Покупатели по штрих-кодам

Раздел представляет собой список всех карточек покупателей, отсортированный по штрих-коду в порядке возрастания. Список представлен в виде таблицы со следующими колонками:

  • Штрих-код
  • Активность - отображается, если включен параметр настройки системы определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Группа VIP - отображается, если включен параметр настройки системы группы VIP карт и содержит наименование группы VIP, к которой привязан текущий штрих-код карточки покупателя.
  • Ф.И.О.
  • Дата рождения
  • Адрес
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

В списке карточек покупателей доступны функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск .
  • Быстрый поиск по первым символам штрих-кода.


Покупатели/Ветвь Найденные покупатели(маг)

Найденные покупатели

Раздел представляет собой список карточек покупателей, отобранных в результате поиска . Список хранится до проведения следующего поиска карточек покупателей и представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Группа VIP - отображается, если включен параметр настройки системы группы VIP карт и содержит наименование группы VIP, к которой привязан основной штрих-код карточки покупателя с вкладки Описание
  • Дата рождения
  • Адрес
  • Телефон
  • Мобильный телефон
  • E-mail
  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

В списке найденных карточек покупателей доступны следующие функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск
  • Отметить карточки путем проставления точек в поле слева от списка.


Меню покупатели/Просмотр(для маг)

Просмотр

Используется для просмотра карточки покупателя , на которой установлен курсор.


Вкладка Описание/ФИО(маг)

ФИО

Фамилия, имя и отчество покупателя. Импортируется из центрального офиса функцией импорта информации и закрыто от корректировки.

Если в базе данных центрального офиса:

  • параметр настройки Отключить персонифицированный обмен включен, то импорт ФИО покупателей не производится.
  • параметр настройки Отключить персонифицированный обмен отключен, но включен параметр настройки Передавать ФИО в магазины, то импорт ФИО осуществляется для всех покупателей во все магазины.
  • параметры настройки Отключить персонифицированный обмен и Передавать ФИО в магазины отключены, то импорт ФИО производится только для тех покупателей, за связь с которыми отвечает данный магазин.

Если включен параметр настройки ФИО указывать в отдельных полях , то ФИО покупателя отображается в трех отдельных полях: Фамилия, Имя, Отчество. Если параметр отключен, то в карточке покупателя отображается одно поле ФИО.


Вкладка Описание/Дата рождения(маг)

Дата рождения

Дата рождения покупателя. Импортируется из центрального офиса функцией импорта информации и закрыта от корректировки.

Если в базе данных центрального офиса:

  • параметр настройки Отключить персонифицированный обмен включен, то импорт дней рождений покупателей не производится.
  • параметр настройки Отключить персонифицированный обмен отключен, но включен параметр настройки Передавать ФИО в магазины, то импорт дней рождений осуществляется для всех покупателей во все магазины.
  • параметры настройки Отключить персонифицированный обмен и Передавать ФИО в магазины отключены, то импорт дней рождений производится только для тех покупателей, за связь с которыми отвечает данный магазин.


Вкладка Описание/Пол(маг)

Пол

Пол покупателя. Импортируется из центрального офиса функцией импорта информации и закрыт от корректировки.

Если в базе данных центрального офиса:

  • параметр настройки Отключить персонифицированный обмен включен, то импорт пола покупателей не производится.
  • параметр настройки Отключить персонифицированный обмен отключен, но включен параметр настройки Передавать ФИО в магазины, то импорт пола осуществляется для всех покупателей во все магазины.
  • параметры настройки Отключить персонифицированный обмен и Передавать ФИО в магазины отключены, то импорт пола производится только для тех покупателей, за связь с которыми отвечает данный магазин.


Карточка покупателя/Анкета/Образование

Образование

Образование покупателя: высшее, неоконченное высшее, среднее, среднее специальное.


Вкладка Описание/Адрес(маг)

Адрес

Адрес покупателя. Импортируется из центрального офиса функцией импорта информации и закрыт от корректировки.

Если в базе данных центрального офиса:

  • параметр настройки Отключить персонифицированный обмен включен, то импорт адресов покупателей не производится.
  • параметр настройки Отключить персонифицированный обмен отключен, но включен параметр настройки Передавать ФИО в магазины, то импорт адресов осуществляется для всех покупателей во все магазины.
  • параметры настройки Отключить персонифицированный обмен и Передавать ФИО в магазины отключены, то импорт адресов производится только для тех покупателей, за связь с которыми отвечает данный магазин.


Вкладка Описание/Штрих-код(маг)

Штрих-код

Уникальный код дисконтной карточки, выданной покупателю. Импортируется из центрального офиса функцией импорта информации, либо импортируется из файла импорта от касс, либо присваивается специальной функцией замены дисконтной карты.


Техническая информация/Активность

Активность

Если параметр включен, то карточка покупателя считается активной, если нет, то неактивной, и покупатель с данной карточкой не сможет получить скидку в магазинах.

Если в параметрах настройки системы включен параметр Определять активность для каждого штрих-кода , то при корректировке данного поля производятся следующие действия: если до корректировки параметр был отключен, а после корректировки его включили, то на вкладке Штрих-коды заполняется столбец Активность значением "+" для штрих-кода с вкладки Описание. Если до корректировки параметр был включен, а после корректировки отключен, то на вкладке Штрих-коды столбец Активность очищается для соответствующего штрих-кода.


Техническая информация/Исходящий магазин

Магазин (исх.)

Наименование магазина, где была выдана карточка покупателя. Исходящий магазин заполняется функцией импорта информации из магазина (если он еще не задан) или вручную путем выбора из справочника магазинов.

Наименование исходящего магазина помещается в поле Исходящий магазин в запись о штрих-коде и в карточку покупателя на вкладку Штрих-коды.

Если значение поля изменяется, то при сохранении изменений новое значение записывается в поле Исходящий магазин в описании основного штрих-кода.


Техническая информация/Дата/Время заполнения

Дата/Время заполнения

Дата и время заполнения карточки покупателя.


Техническая информация/Ответственный магазин

Ответственный магазин

Наименование магазина, в который необходимо пересылать контактную информацию по покупателю. Ответственный магазин заполняется функцией импорта информации из магазина (если он еще не задан) или вручную путем выбора из справочника магазинов.


Техническая информация/Примечание

Примечание

Любая дополнительная информация по покупателю.


Карточка покупателя/Вкладка Описание(маг)

Описание

Вкладка содержит поля описания карточек покупателя, техническую и сводную информацию. Описание покупателя включает в себя следующие параметры:

Анкетные данные:

  • Ф.И.О.
  • Дата рождения
  • Пол
  • Адрес
  • E-mail
  • Телефон
  • Мобильный телефон

Техническая информация:

  • Штрих-код
  • Активность

Сводная информация (используется при просмотре карточки покупателя):

  • Общая сумма покупок
  • Текущая скидка - отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен.
  • Дата/Время последней корректировки


Карточка покупателя/Вкладка Штрих-коды(маг)

Штрих-коды

Вкладка содержит информацию обо всех штрих-кодах присвоенных покупателю. Записи упорядочены по штрих-кодам в порядке возрастания. В списке штрих-кодов работает сортировка по любому столбцу вкладки.

Список представлен в виде таблицы со следующими колонками:

  • Штрих-код - номер дисконтной карточки покупателя.
  • Активность - отображается, если включен параметр определять активность для каждого штрих-кода . В столбце отображается «+», если дисконтная карта со штрих-кодом активна.
  • Группа VIP - отображается наименование соответствующей группы VIP клиентов, если включен параметр группы VIP карт .
  • С - дата начала периода действия текущей акции по группе VIP. Отображается, если включен параметр настройки пороги скидок для групп VIP . Поле заполняется системой автоматически и недоступно для ручной корректировки пользователям.
  • До - дата окончания периода действия текущей акции по группе VIP. Отображается, если включен параметр настройки пороги скидок для групп VIP . Поле заполняется системой автоматически и недоступно для ручной корректировки пользователям.
  • Сумма покупок - общая сумма покупок, совершенных по данной дисконтной карте в период, ограниченный датами С и До. Отображается, если включен параметр настройки пороги скидок для групп VIP . Поле заполняется системой автоматически и недоступно для ручной корректировки пользователям.
  • Дата выдачи - дата выдачи дисконтной карточки покупателю. Отображается, если включен параметр настройки переход на новые дисконтные карты .


Карточка покупателя/Вкладка Доп. описание(офис)

Доп. описание

На вкладке отображаются наименования и значения дополнительных настраиваемых полей, если они описаны в настройках параметров системы и заданы их значения в карточке покупателя.


Карточка покупателя/Вкладка Покупки(маг)

Покупки

Вкладка представляет собой список покупок покупателя, совершенных в данном магазине за период непрерывного ведения истории покупок в текущей БД и составлен в виде таблицы со следующими колонками:

  • Дата - дата совершения покупки.
  • Время - время совершения покупки.
  • Дисконтная карта - штрих-код карты, ссылка на которую установлена в покупке.
  • Кассовое место - идентификатор кассового места, ссылка на которое установлена в покупке.
  • Номер чека - номер чека, ссылка на который установлена в покупке.
  • Штрих-код товара - номенклатурный номер товара.
  • Названия доп. свойств - названия дополнительных свойств товара, характеризующих покупку.
  • Значения доп. свойств - значения дополнительных свойств товара, характеризующих покупку.
  • Количество - количество товара.
  • Цена - цена товара.
  • Сумма - сумма товара.
  • Скидка - скидка, полученная на товар.
  • Сумма с учетом скидки - сумма товара с учетом скидки.

Покупки упорядочены по дате совершения, а в рамках одной даты по времени. В списке покупок работает сортировка по любому столбцу вкладки.

Вкладка заполняется функцией импорта информации из кассы (программа SLS-Касса) и доступна оператору только для просмотра.


Карточка покупателя/Вкладка Заметки

Заметки

Здесь можно записать по датам любую дополнительную информацию по взаимоотношениям с покупателем. Заметки упорядочены по дате. В списке заметок работает сортировка по любому столбцу вкладки. Вкладка представляет собой список с полями:

  • Дата - дата заметки.
  • Содержание - содержание заметки.

Работа на вкладке осуществляется с помощью меню Заметки .


Сводная информация/Общая сумма покупок

Общая сумма покупок

Общая сумма покупок (в рублях) - рассчитывается программой как сумма начальной и общей суммы покупок, и на основании информации из магазинов. Закрыто от корректировки.

Если включен параметр настройки группы VIP и для некоторого штрих-кода выполняется операция привязки к группе VIP , то из Общей суммы покупок вычитаются все суммы покупок, оформленных на привязываемый штрих-код. При этом выполняется следующее соглашение: если в списке покупок есть покупки без штрих-кода дисконтной карты, то в такие покупки проставляется привязываемый штрих-код, и их суммы также вычитаются из значения поля Общая сумма покупок описании покупателя.

Если включен параметр настройки группы VIP и для некоторого штрих-кода выполняется операция отвязки от группы VIP , то к Общей сумме покупок прибавляются все суммы покупок, оформленные на отвязываемый штрих-код.


Сводная информация/Текущая скидка

Текущая скидка

Отображается, если параметр настройки аналитические типы в накопительной таблице скидок отключен. Размер текущей скидки покупателя (в %) - рассчитывается автоматически после обновления информации по покупкам покупателя на основании значения общей суммы покупок покупателя по правилам предоставления скидок, описанным в БД. Закрыто от корректировки.


Сводная информация/Дата/Время последней корректировки(офис)

Дата/Время последней корректировки

Дата, время последней корректировки или первого заполнения хотя бы одного из полей карточки покупателя. Рассчитывается автоматически (закрыта от корректировки пользователем).


Меню Заметки/Добавить

Добавить

Функция доступна пользователям с правом на просмотр карточек покупателей. Для создания новой дополнительной информации о покупателе нужно заполнить следующие параметры:

  • Дата - дата внесения информации.
  • Содержание - конкретная информация по покупателю.


Поля описания заметки

Описание дополнительной информации о покупателе содержит следующие параметры:

  • Дата - дата внесения информации.
  • Содержание - конкретная информация по покупателю.


Меню Заметки/Изменить

Изменить

Функция доступна пользователям с правом на просмотр карточек покупателей. Используется для изменения описания следующих параметров:

  • Дата - дата внесения информации.
  • Содержание - конкретная информация по покупателю.


Меню Заметки/Удалить

Удалить

Функция доступна пользователям с правом на просмотр карточек покупателей и используется для удаления дополнительной информации по покупателю.


Сводная информация/Скидка переходного периода/Зафиксированная скидка

Скидка перех. периода

Скидка покупателя при смене дисконтной политики компании. Отображается, если включен параметр настройки переход на новые дисконтные карты .

Закрыта от корректировки и рассчитывается автоматически при включении параметра настройки переход на новые дисконтные карты . При этом обрабатываются все карточки покупателей ветви Покупатели по именам, в которых значение поля Общая сумма покупок > 0. Для каждого такого покупателя по значению поля Общая сумма покупок и действующей на момент запуска процедуры пересчета таблице скидок определяется % скидки, который должен предоставляться по такой накопленной сумме для товаров с аналитическим типом 00000001. Вычисленный % скидки записывается в поле Скидка перех. периода описания покупателя.

Зафиксированная скидка

Скидка покупателя при фиксировании скидок по некоторой таблице скидок. Отображается, если включен параметр настройки фиксировать скидки при смене таблицы скидок .

Закрыта от корректировки и рассчитывается автоматически при вызове операции зафиксировать скидки по таблице скидок.


Поиск

Условия поиска и отбора покупателей

К условиям поиска карточек покупателей относятся:

  • Область поиска
  • ФИО
  • Дата рождения
  • Пол
  • Адрес
  • Штрих-код
  • Е-mail
  • Телефон
  • Моб. телефон

Если поиск карточек покупателей осуществляется в центральном офисе (в программе SLS-ДисконтОф), то дополнительно можно задать следующие параметры отбора на вкладке Описание :

  • Активность
  • Выдача карты
  • Ответственный магазин
  • Регионы ответственных магазинов
  • Исходящий магазин
  • Регионы исходящих магазинов
  • Общая сумма покупок
  • Текущая скидка
  • Дополнительные поля описания
  • Подписка на новости
  • Последняя корректировка
  • Дата заполнения
  • Образование
  • Информацию получать по
  • Скидка перех. периода/Зафиксированная скидка - отображается, если включен хотя бы один из параметров настройки переход на новые дисконтные карты или фиксировать скидки при смене таблицы скидок .

а также использовать параметрвы поиска на вкладках Доп. описание , Подписка на новости и Покупки .


Поиск/Область поиска

Область поиска

Параметр определяет область отбора карточек покупателей и может принимать следующие значения:

  • все покупатели - отбор карточек покупателей ведется среди всех карточек, включая находящиеся в архиве.
  • все кроме архива - карточки покупателей, помещенные в архив, не участвуют в проведении процедуры поиска.
  • только архив - отбор карточек покупателей ведется только среди карточек, находящихся в архиве.

Если поиск осуществляется в магазине, то он ведется только по всем карточкам покупателей.


Поиск/ФИО

Ф.И.О.

Если включен параметр настройки ФИО указывать в отдельных полях , то вместо параметра поиска "ФИО" отображаются 3 поля:

  • Фамилия. Отбор по фамилии или части фамилии покупателя.
  • Имя. Отбор по имени или части имени покупателя.
  • Отчество. Отбор по отчеству или части отчества покупателя.

Каждое поле допускает задание маски в виде шаблона .


Поиск/Дата рождения

Дата рождения

Диапазон искомых дат рождения покупателей. Результатом поиска будут покупатели, даты рождения которых попадают в заданный интервал.


Поиск/Пол

Пол

Половая принадлежность покупателя. Может принимать значения: любой, мужской, женский. Если выбрано значение «любой», то отбор будет производиться среди всех покупателей независимо от пола. Если выбрано значение, отличное от «любой», то результатом поиска будут покупатели с заданным полом.


Поиск/Адрес

Адрес

Адрес покупателя. Задается полностью или в виде шаблона .


Поиск/Штрих-код

Штрих-код

Штрих-код карточки покупателя. Задается полностью или в виде шаблона .


Поиск/Шаблон

Шаблон

Шаблон можно задать в следующем виде:

  • ТЕКСТ - ТЕКСТ встречается как полное слово;
  • ТЕКСТ* - начало совпадает с шаблоном, а конец произвольный.
  • *ТЕКСТ* - указанный текст встречается в любом месте названия.
  • *ТЕКСТ - начало слова произвольное, а конец полностью совпадает с шаблоном.
  • * - поле должно быть пустым
  • ** - поле должно быть непустым


Меню покупатель/Записи

Записи

Используется для перемещения по списку покупателей.

Меню содержит следующие пункты:

  • Первая - переход в первую карточку покупателей в списке карточек группы/подгруппы;
  • Предыдущая - переход из текущей карточки в предыдущую карточку покупателя в списке карточек группы/подгруппы;
  • Следующая - переход из текущей карточки в следующую карточку покупателя в списке карточек группы/подгруппы;
  • Последняя - переход в последнюю карточку покупателя в списке карточек группы/подгруппы.


Таблицы скидок/Скидки/С суммы(офис)

С суммы

Сумма, начиная с которой действует соответствующая скидка.


Таблицы скидок/Скидки/АТ(офис)

Аналитический тип

Параметр отображается, если включен параметр настройки аналитические типы в накопительной таблице скидок . Код аналитического типа из программы SLS-Эксперт. Позволяет указать, что скидка предоставляется только на товары с данным аналитическим типом. Если поле пустое, то это означает, что скидка предоставляется на товары, в которых аналитический тип не задан. Закрыто от корректировки, если включен параметр прочие товары .


Таблицы скидок/Скидки/Прочие товары(офис)

Прочие товары

Параметр отображается, если включен параметр настройки аналитические типы в накопительной таблице скидок . Позволяет указать, что скидка распространяется на все товары, не попадающие под другие условия по значению аналитического типа. Если параметр включен, то поле аналитический тип очищается и закрывается от корректировки.


Магазины сети/Меню магазины сети/Закрыть(офис)

Закрыть

Используется для закрытия окна классификатора или каталога.


Поля описания региона/(cправка)(офис)

Поля описания региона

Для описания региона необходимо заполнить следующие поля:

  • Код
  • Название


Карточка покупателя/Меню покупатель(маг)

Покупатель

Используется для просмотра и корректировки карточек покупателей и содержит следующие пункты:

  • Просмотр
  • Поиск
  • Закрыть


Вкладка Описание/Общая сумма покупок(маг)

Общая сумма покупок

Импортируется из центра функцией импорта информации.


Вкладка Описание/Дата,время посл корр(маг)

Дата/Время последней корректировки

Дата, время записи в карточку последнего (нового) значения штрих-кода покупателю.


Карточка покупателя/Меню покупатель(маг)

Покупатель

Используется для создания и корректировки карточек покупателей и содержит следующие пункты:

  • Замена дисконтной карточки
  • Записи
  • Закрыть


Замена карточки покупателю(маг)

Замена карточки покупателю

Функция доступна пользователям с правом на работу с каталогами покупателей и используется для добавления штрих-кода в карточку покупателя (рекомендуется делать это сканированием карточки покупателя).

Поле для ввода нового штрих-кода имеет длину, заданную параметром настройки системы размер штрих-кода . Ввод штрих-кода иной длины недопустим.

Введенное значение записывается в список штрих-кодов на вкладке Штрих-коды карточки покупателя. Если включен параметр определять активность для каждого штрих-кода , то новый штрих-код считается активным.

Если новый штрих-код успешно добавляется в список, то:

  • в описании карточки покупателя полям Дата/Время последней корректировки присваиваются текущие системные дата и время.
  • текущая системная дата помещается в поле Дата выдачи в запись о соответствующем штрих-коде и на вкладку Штрих-коды.


Покупатели/Карточки покупателей(маг)

Карточки покупателей

Информация в разделе имеет древовидную структуру . Работа ведется при помощи меню Покупатели , а для печати выходных форм используется меню Формы .

В списке карточки покупателей отсортированы по штрих-коду. Чтобы произвести сортировку покупателей по другому полю, нужно кликнуть на заголовке данного поля. Если треугольник в заголовке поля расположен углом вниз, покупатели сортируются по данному полю по возрастанию. Если треугольник направлен вверх, происходит сортировка по убыванию.

В списке можно поменять колонки местами. Для этого нужно кликнуть мышкой на названии колонки и не отпуская кнопки мыши "перетащить" колонку в нужное место. Убрать колонку из списка можно уменьшив ее размеры до нуля. Чтобы изменить внешний вид списка, нужно нажать правой кнопкой мыши и выбрать меню Списки/ Настройка списков .


Карточка покупателя/Меню Заметки

Заметки

Используется для добавления, корректировки и удаления дополнительной информации по покупателю и содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить
  • Закрыть


Файл/Системная информация

Системная информация

Содержит информацию об использовании ресурсов и работе с базой данных для опытных пользователей. Окно отображает информацию по текущей сессии работы пользователя.


Файл/Параметры последней корректировки

Параметры последней корректировки

Пункт активен, если в текущем активном окне системы отображается список каких-либо объектов, и позволяет для текущей в списке позиции просмотреть сведения о дате/времени создания и последней корректировке данного объекта, а также пользователях, выполнивших создание и последнюю корректировку. Пункту также соответствует клавиатурное сокращение клавиш (Ctrl+Shift+I).

Доступ к разделу имеют только пользователи с правами администратора.


Поля описания анкеты покупателя/Дата время заполнения

Дата/Время заполнения

Дата и время заполнения анкеты покупателя. Если включен параметр настройки переход на новые дисконтные карты , то поле обязательно для заполнения. Значение по умолчанию - текущие системные дата и время.


Меню Анкеты

Анкеты

В магазинах сети операторы заполняют анкеты покупателей, получивших дисконтные карты. Процесс передачи анкетных сведений из магазинов сети в офис происходит автоматически.

Меню анкетных данных покупателей содержит следующие разделы:

  • Добавить
  • Изменить
  • Удалить
  • Просмотр
  • Закрыть


Поля описания анкеты покупателя/ФИО

ФИО

Фамилия, имя и отчество покупателя. Если включен параметр настройки ФИО указывать в отдельных полях , то при заполнении анкетных данных покупателя ввод фамилии, имени и отчества осуществляется в трех отдельных полях: Фамилия, Имя, Отчество. Если параметр отключен, то в анкете покупателя отображается одно поле ФИО.

Если включен параметр настройки переход на новые дисконтные карты , то поле обязательно для заполнения и по умолчанию имеет значение из карточки покупателя, которой принадлежит штрих-код из поля замена карты старого образца . Если дополнительно включен параметр настройки ФИО указывать в отдельных полях , то все три поля обязательны для заполнения.


Поля описания анкеты покупателя/Дата рождения

Дата рождения

Дата рождения покупателя. Дата может быть введена вручную или выбрана из календаря, вызываемого нажатием клавиши "Пробел".

Если включен параметр настройки переход на новые дисконтные карты , то поле обязательно для заполнения и по умолчанию имеет значение из карточки покупателя, которой принадлежит штрих-код из поля замена карты старого образца .


Анкеты/Добавить

Добавить

Для создания новой анкеты покупателя нужно заполнить следующие параметры:

  • Штрих-код
  • Дата/Время заполнения
  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • E-mail
  • Телефон
  • Мобильный телефон
  • Статус
  • Замена карты старого образца
  • Информацию получать по

Дополнительное описание:

Если в настройках параметров системы заполнены параметры описания дополнительных настраиваемых полей, то эти поля отображаются в карточке анкеты покупателя в блоке «Доп. описание». Обязательность заполнения также определяется параметрами настройки.


Поля описания анкеты покупателя/Пол

Пол

Пол покупателя. Если включен параметр настройки переход на новые дисконтные карты , то поле по умолчанию имеет значение из карточки покупателя, которой принадлежит штрих-код из поля замена карты старого образца .


Анкеты/Изменить

Изменить

Для корректировки описания текущей анкеты покупателя доступны следующие параметры:

  • Штрих-код
  • Дата/Время заполнения
  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • E-mail
  • Телефон
  • Мобильный телефон
  • Статус
  • Замена карты старого образца
  • Информацию получать по

Дополнительное описание:

Если в настройках параметров системы заполнены параметры описания дополнительных настраиваемых полей, то эти поля отображаются в карточке анкеты покупателя в блоке «Доп. описание». Обязательность заполнения также определяется параметрами настройки.

Все поля анкеты доступны для корректировки для анкет со статусом, отличным от «Принята ЦО».


Поля описания анкеты покупателя/Образование

Образование

Образование покупателя. Если включен параметр настройки переход на новые дисконтные карты , то поле по умолчанию имеет значение из карточки покупателя, которой принадлежит штрих-код из поля замена карты старого образца .


Анкеты/Удалить

Удалить

Используется для удаления описания анкеты покупателя. Удаление доступно только для анкет, имеющих статус «готова к отправке» и «не готова к отправке».


Поля описания анкеты покупателя/Адрес

Адрес

Адрес покупателя. Если включен параметр настройки переход на новые дисконтные карты , то поле по умолчанию имеет значение из карточки покупателя, которой принадлежит штрих-код из поля замена карты старого образца .


Анкеты/Просмотр

Просмотр

Используется для просмотра текущей в списке анкеты покупателя.


Поля описания анкеты покупателя/E-mail

E-mail

Адрес электронной почты покупателя. Если включен параметр настройки переход на новые дисконтные карты , то поле обязательно для заполнения, если поле мобильный телефон пустое.


Поля описания анкеты покупателя/Телефон

Телефон

Телефонный номер покупателя. Если включен параметр настройки переход на новые дисконтные карты , то поле по умолчанию имеет значение из карточки покупателя, которой принадлежит штрих-код из поля замена карты старого образца .


Поля описания анкеты покупателя/Мобильный телефон

Мобильный телефон

Номер мобильного телефона покупателя. Если включен параметр настройки переход на новые дисконтные карты , то поле обязательно для заполнения, если поле е-mail пустое.


Поля описания анкеты покупателя

Описание полей анкеты покупателя

Описание анкеты покупателя включает в себя следующие реквизиты:

  • Штрих-код
  • Дата/Время заполнения
  • Ф.И.О.
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • E-mail
  • Телефон
  • Мобильный телефон
  • Статус
  • Замена карты старого образца
  • Информацию получать по


Поля описания анкеты покупателя/Штрих-код

Штрих-код

Уникальный код карточки, выданной покупателю. Штрих-код должен имеет длину, заданную параметром настройки размер штрих-кода .

Если включен параметр группы VIP карт , то выбор штрих-кодов, привязанных к группам VIP недоступен.

Если включен параметр штрих-коды в анкетах только из каталога , то при добавлении и корректировке анкеты покупателя штрих-код может быть выбран только из списка штрих-кодов системы.

Если параметр выключен, то дополнительно допустимо задание штрих-кода вручную с помощью кнопки «…», при нажатии которой на экран отображается ветвь Покупатели по штрих-кодам каталога карточек покупателей для выбора штрих-кода. В окне работает подвод по первым символам штрих-кода карточки покупателя.

Если включен параметр настройки переход на новые дисконтные карты , то штрих-код не должен быть привязан к группе VIP и должен принадлежать диапазону новых карт из параметра в диапазоне от ... до ... . Если поле заполняется, то открывается для корректировки поле замена карты старого образца . Если поле очищается, то поле замена карты старого образца также очищается.


Поля описания анкеты покупателя/Выдача карты

Выдача карты

Причина выдачи карты: новая карта или обмен карты старого образца.


Поля описания анкеты покупателя/Замена карты старого образца

Замена карты старого образца

Отображается, если включен параметр настройки переход на новые дисконтные карты . Доступно для корректировки, если в поле штрих-код задан штрих-код дисконтной карты, ссылающийся на карточку покупателя такую, что в списке вкладки Штрих-коды есть хотя бы один штрих-код, не привязанный к группе VIP и его номер не попадает в промежуток из параметра настройки в диапазоне от ... до ... . Если поле доступно, то его заполнение обязательно. Если указанным критериям в карточке покупателя удовлетворяет только 1 штрих-код, то он предлагается в качестве значения по умолчанию и поле закрывается от корректировки.


Вкладка Описание/E-mail(маг)

E-mail

Адрес электронной почты покупателя. Импортируется из центрального офиса функцией импорта информации и закрыт от корректировки.

Если в базе данных центрального офиса:

  • параметр настройки Отключить персонифицированный обмен включен, то импорт e-mail адресов покупателей не производится.
  • параметр настройки Отключить персонифицированный обмен отключен, но включен параметр настройки Передавать ФИО в магазины, то импорт e-mail адресов осуществляется для всех покупателей во все магазины.
  • параметры настройки Отключить персонифицированный обмен и Передавать ФИО в магазины отключены, то импорт e-mail адресов производится только для тех покупателей, за связь с которыми отвечает данный магазин.


Поля описания анкеты покупателя/Информацию получать по

Информацию получать по

Способ получения информации об акциях компании: по телефону или по e-mail.


Поиск/Регионы ответственных магазинов(офис)

Регионы ответственных магазинов

Регион расположения ответственного магазина. Если задано несколько регионов, то результом поиска будут покупатели, у которых ответственный магазин расположен в одном из заданных регионов.


Поиск/Регионы исходящих магазинов(офис)

Регионы исходящих магазинов

Регион расположения исходящего магазина. Если задано несколько регионов, то результом поиска будут покупатели, у которых исходящий магазин расположен в одном из заданных регионов.


Анкеты покупателей/Дерево анкет

Дерево анкет

Дерево анкет покупателей пользователям с правом на доступ к каталогу покупателей иимеет следующую структуру:

  • Новые анкеты
  • Принятые ЦО
  • Все анкеты
  • По штрих-кодам


Дерево анкет покупателей/Новые анкеты

Новые анкеты

В разделе хранится список еще неотправленных в центральный офис (ЦО) анкет и анкет, которые уже отправлялись в ЦО, но еще не получивших подтверждение об их успешном приеме в ЦО. В списке отображаются анкеты со статусами "не готова к отправке", "готова к отправке", "отправлена". Список покупателей представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Статус
  • Мобильный телефон

В списке анкет покупателей доступны следующие функции:

  • Открыть текущую анкету покупателя - анкета отрывается на вкладке Описание .
  • Быстрый поиск анкеты покупателя по первым символам ФИО покупателя.

Работа в ветви ведется при помощи меню Анкеты


Дерево анкет покупателей/Принятые ЦО

Принятые ЦО

В разделе хранится список уже отправленных в ЦО анкет с подтверждением о том, что информация была удачно принята в ЦО. В списке отображаются анкеты со статусами «принята ЦО». Список покупателей представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Мобильный телефон

В списке анкет покупателей доступны следующие функции:

  • Открыть текущую анкету покупателя - анкета отрывается на вкладке Описание .
  • Быстрый поиск анкеты покупателя по первым символам ФИО покупателя.


Дерево анкет покупателей/Все анкеты

Все анкеты

В разделе хранится следующий список анкет:

  • еще неотправленные в ЦО
  • уже отправленные в ЦО, но еще неполучившие подтверждение об их успешном приеме в ЦО
  • отправленные в ЦО с подтверждением о том, что информация была удачно принята в ЦО.

Список покупателей представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Статус
  • Мобильный телефон

В списке анкет покупателей доступны следующие функции:

  • Открыть текущую анкету покупателя - анкета отрывается на вкладке Описание .
  • Быстрый поиск анкеты покупателя по первым символам ФИО покупателя.


Дерево анкет покупателей/По штрих-кодам

По штрих-кодам

В разделе хранится список всех анкет, отсортированнный по штрих-кодам. Список покупателей представлен в виде таблицы со следующими колонками:

  • Штрих-код
  • ФИО
  • Дата рождения
  • Пол
  • Образование
  • Адрес
  • Статус

В списке анкет покупателей доступны следующие функции:

  • Открыть текущую анкету покупателя - анкета отрывается на вкладке Описание .
  • Быстрый поиск анкеты покупателя по первым символам штрих-кода карточки покупателя.


Пример экспорта-импорта для нового магазина

Процедура экспорта-импорта информации для нового магазина

В магазине и в офисе параметры, относящиеся ко времени импорта и времени экспорта пока не заполнены.

1) Первичный экспорт из центрального офиса в новый магазин произошел, например 14.04.05 в 13.02. Формируется файл экспорта ne.exp, который имеет вид: Код магазина I Дата/время импорта (Последнее дата время новой информации, успешно полученной из магазина) I Время экспорта, т.е. в нашем случае он выглядит так: Код I Пусто I :50414 I 1302

2) В магазине производится следующая проверка: дата, время экспорта из файла центрального офиса меньше либо равна дате, времени импорта, обозначенных в глобальных параметрах магазина? Т.е. 14.04.05 13.02 меньше чем пусто? Если нет, то пусто записывается в графу «подтвержденный экспорт», а 14.04.05 13.02 в графу «последние данные из офиса» в глобальных параметрах магазина.

3) В магазине 14.04.05 в 13.11 был получен файл от касс или произошла какая-то другая корректировка какой-либо карточки покупателя.

4) Первичный экспорт из магазина в центральный офис произошел, например 14.04.05 в 13.12. Формируется файл экспорта ni.exp, который имеет вид: Код магазина I Дата/время импорта (Последнее дата время новой информации, успешно полученной из центрального офиса) I Дата/время последней корректировки по покупателям (если "свежей" информации нет, то записываются текущие дата/время) I Дата/время формирования файла экспорта (текущие системные дата и время), т.е. в нашем случае он выглядит так: Код I :50414 I 1302 I :050414 I 1311 I :050414 I 1312

5) В офисе происходит следующая проверка: дата, время последней информации магазина из файла меньше ли даты, времени импорта, обозначенных в классификаторе «Магазины сети» для данного магазина? Т.е. 14.04.05 13.11 меньше чем пусто? Если нет, то 14.04.05 13.02 записывается в графу «подтвержденный экспорт», а 14.04.05 13.11 в графу «последние данные из магазина» в офисе в классификаторе «Магазины сети» для данного магазина.

Теперь в магазине в глобальных параметрах установятся следующие значения:

  • в графе «последние данные из офиса» 14.04.05 13.02,
  • в графе «подтвержденный экспорт» пустое значение до тех пор, пока из офиса не придет подтверждение об успешно принятой информации,
  • в графе «дата файла импорта» 14.04.05 13.02,
  • в графе «дата файла экспорта» 14.04.05 13.12.

В центральном офисе в классификаторе «Магазины сети» для данного магазина установятся следующие значения:

  • в графе «подтвержденный экспорт» 14.04.05 13.02,
  • в графе «последние данные из магазина» 14.04.05 13.11,
  • в графе «дата файла экспорта» 14.04.05 13.02,
  • в графе «дата файла импорта» 14.04.05 13.12.


Пример экспорта-импорта для магазина

Пример экспорта-импорта информации для магазина

Перед началом очередного обмена данными в магазине и в офисе параметры, относящиеся ко времени импорта и времени экспорта таковы:

Магазин - раздел Настройка/Параметры

последние данные из офиса 13.03.05 11.00

подтвержденный экспорт 12.03.05 10.00

дата файла импорта 13.03.05 11.00

дата файла экспорта 14.03.05 13.00

Центральный офис - раздел Классификаторы/Магазины сети

подтвержденный экспорт 13.03.05 11.00

последние данные из магазина 14.03.05 12.00

дата файла экспорта 13.03.05 11.00

дата файла импорта 14.03.05 13.00

1) Экспорт из центрального офиса в магазин произошел, например 15.03.05 в 13.00. Формируется файл экспорта Имя1.exp, (где Имя1 - имя файла для экспорта, указанное в параметрах описания магазина). Файл имеет следующий вид: Код магазина I Дата/время импорта (Последнее дата время новой информации, успешно полученной из магазина) I Время экспорта, т.е. в нашем случае он выглядит так: Код I :50314 I 1200 I :50315 I 1300

2) В магазине производится следующая проверка: дата, время экспорта из файла центрального офиса меньше либо равна дате, времени импорта, обозначенных в глобальных параметрах магазина? Т.е. 15.03.05 13.00 меньше чем 13.03.05 11.00? Если нет, то 14.03.05 12.00 записывается в графу «подтвержденный экспорт», а 15.03.05 13.00 в графу «последние данные из офиса» в глобальных параметрах магазина.

3) В магазине 15.03.05 в 14.00 был получен файл от касс или произошла какая-то другая корректировка какой-либо карточки покупателя.

4) Экспорт из магазина в центральный офис произошел, например 15.03.05 в 15.00. Формируется файл экспорта Имя2.exp, (где Имя2 - имя файла для экспорта, указанное в разделе Настройка/Параметры). Файл имеет следующий вид: Код магазина I Дата/время импорта (Последнее дата время новой информации, успешно полученной из центрального офиса) I Дата/время последней корректировки по покупателям (если "свежей" информации нет, то записываются текущие дата/время), т.е. в нашем случае он выглядит так: Код I :50315 I 1300 I :050315 I 1400 I :050315 I 1500

5) В офисе происходит следующая проверка: дата, время последней информации магазина из файла меньше ли даты, времени импорта, обозначенных в классификаторе «Магазины сети» для данного магазина? Т.е. 15.03.05 14.00 меньше чем 15.03.05 13.00? Если нет, то 15.03.05 13.00 записывается в графу «подтвержденный экспорт», а 15.03.05 14.00 в графу «последние данные из магазина» в офисе в классификаторе «Магазины сети» для данного магазина.

В центральный офис из магазина пришло подтверждение получения информации, отправленной из офиса 15.03.05 в 13.00, поэтому экспорт считается успешно проведенным и в классификаторе «Магазины сети» для данного магазина в графе «подтвержденный экспорт» установится значение 15.03.05 13.00, а в графе «последние данные из магазина» 15.03.05 14.00.

Теперь в магазине в глобальных параметрах установятся следующие значения:

  • в графе «последние данные из офиса» 15.03.05 13.00,
  • в графе «подтвержденный экспорт» 14.03.05 12.00 до тех пор, пока из офиса не придет подтверждение об успешно принятой информации,
  • в графе «дата файла импорта» 15.03.05 13.00,
  • в графе «дата файла экспорта» 15.03.05 15.00.

В центральном офисе в классификаторе «Магазины сети» для данного магазина установятся следующие значения:

  • в графе «подтвержденный экспорт» 15.03.05 13.00,
  • в графе «последние данные из магазина» 15.03.05 14.00,
  • в графе «дата файла экспорта» 15.03.05 13.00,
  • в графе «дата файла импорта» 15.03.05 15.00.


Настройка/Параметры/Тип обмена

Тип обмена

Если выбран вариант "FTP", то схема обмена реализуется в предположении, что между компьютерами в центральном офисе и в магазине не существует прямой связи. Предлагается использовать протокол обмена файлами FTP и компьютер-посредник - FTP-сервер, к которому должны иметь доступ компьютеры в центральном офисе и в каждом магазине. При обмене данными каждая система будет считывать для нее другой стороной файл обмена для чтения с FTP-сервера и записывать на него файл обмена для записи. В параметрах настройки всех систем сети задаются имя FTP-сервера, номер порта для связи с ним, имя пользователя и его пароль доступа к FTP-серверу. При работе функции обмена данными в дисконтной системе программа выполняет команду записи или чтения информации с FTP-сервера.

Если выбран вариант "файловый", то вся схема обмена производится без помощи удаленной связи. В этом случае файлы обмена, сформированные программой SLS-ДисконтОф должны быть переданы пользователем в программу SLS-ДисконтМаг самостоятельно, например посредством электронной почты (таким же образом передаются файлы из программы SLS-ДисконтМаг в систему SLS-ДисконтОф).


Классификаторы/Магазины сети/Новые карточки покупателей активны(офис)

Новые карточки покупателей активны

Значение параметра с помощью процедуры экспорта передается в соответствующий магазин. При включенном параметре новые карточки, регистрируемые в кассах магазина, становятся активными в магазине после импортирования информации от касс. В центральном офисе при импорте из магазина новых карточек покупателей в описании покупателя автоматически будет включен параметр активность .


Настройка/Параметры/Новые карточки покупателей активны(маг)

Новые карточки покупателей активны

Закрыто от корректировки вручную, заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, то при импорте информации от касс все полученные новые карточки покупателей автоматически становятся активными.


Настройка/Параметры/Размер штрих-кода(маг)

Размер штрих-кода

Заполняется автоматически при импорте данных из центрального офиса и закрыт от корректировки. Если параметр включен, то новые карточки, регистрируемые в кассах магазинов или выданных взамен утраченных, должны иметь указанный размер штрих-кода.


Настройка/Параметры/Штрих-коды в анкетах только из каталога(маг)

Штрих-коды в анкетах только из каталога

Параметр закрыт от ручной корректировки и заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, то при добавлении и корректировке анкеты покупателя штрих-код может быть выбран только из списка штрих-кодов, имеющихся в системе.

Внимание! Если параметр включен, то перед созданием анкет новых покупателей необходимо произвести процедуру импорта информации от касс, т.к. в противном случае для новых карточек покупателей, зарегистрированных в кассе, не удастся создать анкеты.


Настройка/Параметры/ФИО указывать в отдельных полях (маг)

ФИО указывать в отдельных полях

Параметр закрыт от ручной корректировки и заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, то при просмотре карточки покупателя и при заполнении анкеты покупателя ввод фамилии, имени и отчества осуществляется в трех отдельных полях Фамилия, Имя и Отчество.


Настройка/Параметры/Фиксировать скидки при смене таблицы скидок(маг)

Фиксировать скидки при смене таблицы скидок

При изменении действующей таблицы скидок покупатель должен получать скидку не меньше, чем он имел по предыдущей действующей таблице скидок до тех пор, пока он не накопит сумму покупок, достаточную для перехода на порог с более высоким % скидки согласно новой действующей таблице скидок.

Параметр закрыт от ручной корректировки и заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, это означает, что скидки зафиксированы по некоторой таблице скидок, дата ввода в действие которой отображается в параметре настройки Скидки зафиксированы по таблице от.

Если параметр включен, то в карточке покупателя отображается поле Зафиксированная скидка для хранения размера скидки покупателя по заданной таблице скидок.


Настройка/Параметры/Дополнительные поля описания(маг)

Дополнительные поля описания

Закрыто от корректировки вручную, заполняется автоматически при импорте данных из центрального офиса. Используется для добавления в карточку покупателя дополнительных полей описания (например, марка транспортного средства), которые будут отображаться в карточке покупателя на вкладке Доп. описания.

В блоке задаются параметры пяти настраиваемых полей. Описание каждого поля задается следующим набором параметров:

  • Использование - поле с выпадающим списком значений - не используется, необязательно, обязательно.

Если выбрано "не используется", то настраиваемое поле в анкете покупателя не отображается.

Если выбрано "необязательно", то при создании и корректировке анкеты покупателя поле отображается в ней, но необязательно для заполнения.

Если выбрано "обязательно", то при создании и корректировке анкеты покупателя поле обязательно к заполнению.

  • Наименование. Отображается в качестве названия дополнительного поля описания в анкете покупателя.


Настройка/Параметры/Отключить персонифицированный обмен(офис)

Отключить персонифицированный обмен

Используется для отключения возможности обмена анкетными данными покупателей. Если параметр включен, то при подготовке файла экспорта из центрального офиса для магазинов в файл не помещается информация из блока «Анкета» карточки покупателя.

Если параметр включается, то параметр Передавать ФИО в магазины отключается и закрывается от корректировки.


Настройка/Параметры/Использовать в магазинах(офис)

Использовать в магазинах

Используется для работы с дополнительными полями описания в магазинах сети. Если параметр включен, то после проведения процедуры экспорта данных в магазины, в магазине при добавлении и корректировке анкеты покупателя заполнение каждого дополнительного поля определяется значением параметра Использование.


Вкладка Описание/Телефон(маг)

Телефон

Телефонный номер покупателя. Импортируется из центрального офиса функцией импорта информации и закрыт от корректировки.

Если в базе данных центрального офиса:

  • параметр настройки Отключить персонифицированный обмен включен, то импорт номеров телефонов покупателей не производится.
  • параметр настройки Отключить персонифицированный обмен отключен, но включен параметр настройки Передавать ФИО в магазины, то импорт номеров телефонов осуществляется для всех покупателей во все магазины.
  • параметры настройки Отключить персонифицированный обмен и Передавать ФИО в магазины отключены, то импорт номеров телефонов производится только для тех покупателей, за связь с которыми отвечает данный магазин.


Вкладка Описание/Мобильный телефон(маг)

Мобильный телефон

Номер мобильного телефона покупателя. Импортируется из центрального офиса функцией импорта информации и закрыт от корректировки.

Если в базе данных центрального офиса:

  • параметр настройки Отключить персонифицированный обмен включен, то импорт номеров мобильных телефонов покупателей не производится.
  • параметр настройки Отключить персонифицированный обмен отключен, но включен параметр настройки Передавать ФИО в магазины, то импорт номеров телефонов осуществляется для всех покупателей во все магазины.
  • параметры настройки Отключить персонифицированный обмен и Передавать ФИО в магазины отключены, то импорт номеров телефонов производится только для тех покупателей, за связь с которыми отвечает данный магазин.


Вкладка Описание/E-mail

E-mail

Адрес электронной почты покупателя.


Поиск/E-mail

E-mail

Электронный адрес покупателя. Задается полностью или в виде шаблона


Поиск/Телефон

Телефон

Номер телефона покупателя. Задается полностью или в виде шаблона


Поиск/Моб. телефон

Моб. телефон

Номер мобильного телефона покупателя. Задается полностью или в виде шаблона


Операции/Проставить ФИО(офис)

Проставить ФИО

Функция доступна пользователям с правом на изменение карточек покупателей и используется для заполнения ФИО в выделенном наборе карточек покупателей.

При вызове операции на экране отображается окно, содержащее следующие параметры:

  • Ф.И.О. Если параметр настройки системы ФИО указывать в отдельных полях отключен, то отображается одно поле. Если включен, то отображаются три поля, заполнение первого из которых обязательно.
  • Перезаписывать заполненные ФИО. Если параметр включен, то действия функции распространяются на все отмеченные карточки, если отключен, то только на те, в которых поля Ф.И.О. не заполнены.

По окончании работы операции в каждой карточке покупателя из списка отмеченных (либо для тех из отмеченных, у которых не заполнено поле Ф.И.О.) выполняются следующие действия:

  • в описании карточки полю/полям Ф.И.О. присваивается значение, заданное в запросе
  • в поле Дата/время последней корректировки записываются текущие дата/время


Операции/Отметить найденные

Отметить найденные

Функция доступна пользователям с правом на просмотр карточек покупателей и приводит к проставлению отметок для всех отобранных карточек покупателей.


Настройка/Параметры/Определять активность для каждого штрих-кода(маг)

Определять активность для каждого штрих-кода

Заполняется автоматически при импорте данных из центрального офиса и закрыт от корреткировки. Если параметр включен, то в карточке покупателя для каждого штрих-кода активность устанавливается индивидуально. Если параметр отключен, то активность определяется на уровне карточки покупателя в целом.


Настройка/Параметры/Группы VIP(маг)

Группы VIP

Параметр закрыт от ручной корректировки и заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, то в системе отображается каталог организаций, с которыми заключены договора на корпоративное обслуживание (группы VIP карт). Для каждой организации указывается список дисконтных карт, закрепленных за ней, а также задаются правила предоставления скидок. Если дисконтная карточка не привязана ни к одной организации, то скидки по ней предоставляются по накопительной программе согласно общей действующей таблице скидок. Если же дисконтная карточка привязана к некоторой организации (группе VIP), то скидки по ней предоставляются согласно таблице скидок, действующей для этой группы/подгруппы (накопительная система скидок для карточки не действует). При описании скидок, действующих для некоторой организации (группы VIP), допускаются следующие виды скидок:

  • Фиксированный процент скидки на все товары;
  • Фиксированный процент скидки на товары определенного аналитического типа.

При описании условий предоставления скидки, аналитические типы задаются кодами, которые назначены указанным объектам в системе SLS-Эксперт. При этом названия классов, типов и признаков в модулях системы SLS-Дисконт нигде не отображаются.


Группы VIP/Ветвь Покупатели(маг)

Покупатели

Дерево покупателей любой из групп VIP содержит следующие ветви:

  • Все - полный список покупателей, относящихся к группе VIP.
  • Отмеченные - в списке отображаются только позиции, отмеченные в списках других ветвей.
  • Последний поиск - в списке отображаются позиции, отобранные в результате последней операции поиска


Группы VIP/Ветвь Акции(маг)

Акции

Просмотр ветвей Акции любой из групп VIP доступен пользователям с правом доступа к каталогам покупателей. В верхней части окна отображается список акций, согласно которым предоставляются скидки по дисконтным картам группы VIP, в нижней части окна - список условий предоставления скидок по акции, на позиции с которой стоит курсор в верхнем списке.

Список скидочных акций представлен в виде таблицы со следующими колонками:

  • Начало - дата, с которой акция вводится в действие.
  • Завершение - дата, до которой действует акция (включительно).
  • Примечание - произвольное описание акции.
  • Статус - только «Действует».

Работа со списком скидочных акций осуществляется при помощи меню Акции

В нижней части экрана список условий предоставления скидок по акции представлен в виде таблицы с графами:

  • Аналитический тип - код аналитического типа товаров.
  • С суммы - общая сумма покупок за период действия акции, после достижения которой предоставляется скидка по условию. Столбец отображается, если включен параметр настройки системы пороги скидок для групп VIP .
  • Скидка - размер скидки на товары, обладающие указанным аналитическим типом.

В списке скидочные акции отсортированы по дате начала действия акции, а условия предоставления скидок по столбцу Скидка.

Список упорядочен по значению столбца Аналитический тип, а в рамках одного аналитического типа по возрастанию значений столбца С суммы. В списке условий предоставления скидок работает сортировка по любому столбцу.


Группы VIP/Меню Группы VIP(маг)

Группы VIP

Используется для просмотра каталога групп VIP в режиме отображаемых и неотображаемых архивных групп и содержит пункт:

  • Показывать архивные группы/Не показывать архивные группы


Группы VIP/Меню Акции(маг)

Акции

Используется для просмотра скидочных акций в каталоге групп VIP в режиме отображаемых и неотображаемых архивных скидочных акций и содержит пункт:

  • Показывать архивные акции/Не показывать архивные акции


Группы VIP/Меню Группы VIP/Архив(маг)

Показывать архивные группы/Не показывать архивные группы

Используется для отображения или скрытия в списке каталога архивных групп VIP.


Группы VIP/Меню Группы VIP/Полное наименование(офис)

Полное наименование

Полное наименование группы VIP.


Группы VIP/Ветвь Покупатели/Все(маг)

Все

В разделе хранится список карточек покупателей, содержащих хотя бы один штрих-код, привязанный к группе VIP, отсортированный по именам. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Активность - отображается, если включен параметр определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Дата рождения
  • Телефон
  • E-mail

В списке карточек покупателей доступны функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск .
  • Быстрый поиск карточки покупателя по первым символам фамилии покупателя.
  • Отметить карточки путем проставления точек в поле слева от списка.
  • Снять все отметки


Группы VIP/Ветвь Покупатели/Отмеченные(маг)

Отмеченные

Раздел представляет собой список отмеченных карточек покупателей некоторой группы VIP и хранится до закрытия базы данных. При следующем открытии базы данных он очищается. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Активность - отображается, если включен параметр определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Дата рождения
  • Телефон
  • E-mail

В списке отмеченных карточек покупателей группы VIP доступны следующие функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск
  • Снять все отметки
  • Удалить из списка


Группы VIP/Ветвь Покупатели/Последний поиск(маг)

Последний поиск

Раздел представляет собой список карточек покупателей некоторой группы VIP, отобранных в результате поиска и хранится до закрытия базы данных. При следующем открытии базы данных он очищается. Список представлен в виде таблицы со следующими колонками:

  • Ф.И.О.
  • Штрих-код
  • Активность - отображается, если включен параметр определять активность для каждого штрих-кода . В столбце отображается «+», штрих-код дисконтной карты активен.
  • Дата рождения
  • Телефон
  • E-mail

В списке отобранных карточек покупателей группы VIP доступны следующие функции:

  • Открыть текущую карточку покупателя - карточка открывается на вкладке Описание
  • Отобрать покупателей по совокупности заданных параметров, используя Поиск
  • Снять все отметки
  • Удалить из списка
  • Отметить найденные


Группы VIP/Меню Акции/Архив(маг)

Показывать архивные акции/Не показывать архивные акции

Функция доступна пользователям с правом на просмотр групп VIP и используется для отображения или скрытия в списке каталога архивных скидочных акций для групп VIP клиентов.


Поля описания скидочной акции(справка)(офис)

Поля описания акции

Для описания скидочной акции для группы VIP клиентов необходимо заполнить следующие поля:

  • Начало
  • Завершение
  • Примечание
  • Статус


Поля описания условия скидочной акции(справка)(офис)

Поля описания условия скидочной акции

Для описания условия скидочной акции для группы VIP клиентов необходимо заполнить следующие поля:

  • Аналитический тип
  • Прочие
  • Скидка
  • С суммы


Настройка/Параметры/АТ в накопительной таблице скидок(маг)

Аналитические типы в накопительной таблице скидок

Параметр закрыт от ручной корректировки и заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, то в программе имется возможность задания скидок в зависимости от аналитического типа товара в накопительной таблице скидок.


Настройка/Параметры/Пороги скидок для групп VIP(маг)

Пороги скидок для групп VIP

Параметр закрыт от ручной корректировки и заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, то для VIP групп могут быть назначены скидки в зависимости от накопленной суммы покупок за период действия скидочной акции


Настройка/Параметры/Отключить персонифицированный обмен(маг)

Отключить персонифицированный обмен

Параметр закрыт от ручной корректировки и заполняется автоматически при импорте данных из центрального офиса. Если параметр включен, то при подготовке файла экспорта из центрального офиса для магазинов в файл не помещается информация из блока «Анкета» карточки покупателя.


С чего начать работу/Создать новую базу данных

Создать новую базу данных

Чтобы создать новую базу данных, нужно в главном меню выбрать пункт Файл/Создать новую (пустую БД) .

Прежде чем начать работать с новой базой данных, нужно:

  • Произвести настройку параметров
  • Установить пароль для открытия базы данных


С чего начать работу/Заполнить классификатор кассовых мест

Заполнить классификатор кассовых мест

В данном разделе магазины можно добавлять, корректировать и удалять при помощи меню Кассовые места , а для печати выходных форм использовать меню Формы .

На экране отображается окно, представленное в виде списка с графами:

  • Идентификатор - идентификатор кассового места в магазине.
  • Файл импорта - полный путь к файлу, из которого считывается информация о покупках покупателей, сделанных через данную кассу.
  • Последняя покупка - дата и время последней покупки, успешно считанной из файла импорта данной кассы. Поле заполняется автоматически после успешного импорта информации от кассы. Доступ к полю имеют только пользователи с правами администратора.


Открыть базу данных

Чтобы открыть базу данных, нужно в Главном меню выбрать пункт Файл/Открыть.. .


С чего начать работу/Заполнить классификатор магазинов сети

Заполнить классификатор магазинов сети

В данном разделе магазины можно добавлять, корректировать и удалять при помощи меню Магазины сети , а для печати выходных форм использовать меню Формы .

На экране отображается окно, представленное в виде списка с графами:

  • Код - вводится код магазина
  • Название - вводится название магазина
  • Файл для импорта - полный путь к файлу, из которого берется информация, полученная из магазина. Заполняется оператором, поле обязательно для заполнения.
  • Последний экспорт - заполняется автоматически в результате обмена данными между центральным офисом и текущим магазином
  • Последний импорт - заполняется автоматически в результате обмена данными между центральным офисом и текущим магазином


Как установить пароль

Чтобы установить пароль для открытия определенной базы данных, нужно:

  • Открыть базу данных
  • Выбрать раздел Настройка/Пароль системы .

При вводе пароль отображается в виде звездочек (*). Чтобы увидеть введенное значение, нужно кликнуть мышкой на иконке "Очки" или нажать Ctrl+Tab.


Рабочая станция/Шрифт для отображения на экране

Шрифт для отображения на экране

В параметре задается шрифт, в котором отображается вся информация на экране. Справа расположена кнопка (Изменить), позволяющая вызвать диалог выбора шрифта.


Рабочая станция/Настройка печати

Настройка печати

В данном пункте задаются настройки для печати отчетов на принтере и для экспорта файлов.

Настройка печати производится на следующих вкладках:

  • Общие
  • Страница
  • Автосохранение
  • RTF
  • HTML
  • EXCEL
  • Текстовый файл


Рабочая станция/При старте автоматически подключаться к базе данных

При старте автоматически подключаться к базе данных

Используется для задания базы данных, которая будет автоматически вызываться при запуске системы. В поле отображается полный путь к базе данных. Справа расположена кнопка (Изменить), позволяющая открыть стандартный каталог Windows для выбора файла базы данных с расширением .dbx.


Рабочая станция/Открывать последнюю базу данных

Открывать последнюю базу данных

Используется для автоматического открытия последней базы данных, с которой осуществлялась работа в течение предыдущего сеанса.


Рабочая станция/После подключения базы данных открывать пункт меню

После подключения базы данных открывать пункт меню

Используется для задания раздела системы, который будет открываться на экране после подключения к базе данных. Раздел выбирается из следующего списка:

  • не указано
  • каталог покупателей
  • каталог групп VIP
  • классификатор таблиц скидок
  • классификатор магазинов сети
  • классификатор регионов


Рабочая станция/Другие параметры

Другие параметры

  • Показывать разделительные полосы - при включенном параметре в списке карточек покупателей строки разделяются горизонтальными линиями.
  • Использовать картинки в меню и списках - при включенном параметре при вызове пунктов главного меню в системе отображаются изображения, соответствующие некоторым пунктам.
  • При вызове окон показывать максимизированными: окна с основными списками/окна с основными карточками - при включенных параметрах окна со списками и карточками, соответственно, открываются с максимально возможным размером. Параметр отключен и закрыт от корректировки, если включен параметр Сохранять положение и размеры окон.
  • Сохранять положение и размеры окон - при включенном параметре положение и размеры окон будут сохранены при следующем подключении к системе с данной рабочей станции. Параметр отключен и закрыт от корректировки, если включен параметр При вызове окон показывать максимизированными.
  • Включить панели инструментов - при включеннном параметре в системе отображаются иконки, соответствующие основным разделам системы.
  • При старте выводить окно Wizard'a - при включенном параметре каждый раз при вызове программы отображается окно Wizard'a, в котором выбирается база данных для открытия.
  • Показывать результаты поиска сразу - при включенном параметре после завершения процедуры поиска пользователь немедленно перенаправляется в список с отобранными записями. Если же параметр отключен, то перед переходом в данный список пользователь должен закрыть окно с кратким отчетом о ходе процедуры поиска (время, количество отобранных и просмотренных записей и т.п.), нажав в нем кнопку (Закрыть).
  • Спрятать заголовок главной формы - при включенном параметре в системе отображается заголовочная строка с названием фирмы, имя базы данных и версия программы.
  • Картинки на вкладках - при включенном параметре на вкладках карточки покупателя указываются соответствующие пиктограммы (если они имеются).
  • Показывать горячие клавиши на вкладках - при включенном параметре на вкладках карточки покупателя указываются соответствующие клавиши.
  • Отключить режим drag&drop - при включенном параметре в дереве групп товаров нельзя переносить группы и подгруппы с помощью мышки.
  • Запрашивать имя файла при экспорте списков в Excel - при включенном параметре при экспорте списков в Excel отображается окно, содержащее стандартный каталог Windows для задания имени файла экспорта. По умолчанию предлагается название из заголовочной строки экспортируемого списка.


Рабочая станция/Настраиваемые формы брать из папки

Настраиваемые формы брать из папки

Пользователь с правами администратора имеет возможность создать собственную папку для отчетов (*.frm файлы), указав полный путь к ней в данном поле, например C:\SLS-Discount\Reports\User1. При подключении пользователя-администратора к базе данных все дополнительные формы будут по умолчанию браться из указанной папки.

Для пользователей системы, не имеющих права администратора, настраиваемые формы всегда берутся и папки forms, которая размещена в директории, где установлена программа.


Рабочая станция/Количество недавно открытых файлов

Количество недавно открытых файлов

Используется для установки количества файлов, соответствующих базам данных, с которыми осуществлялась работа в течение предыдущих сеансов. Список последних открытых файлов отображается в меню Файл после пункта Калькулятор.


Общие/Заголовок выходной формы на экране

Заголовок выходной формы на экране

Используется для выделения заголовка отчета при его выводе на экран. Параметр может принимать одно из нескольких значений:

  • Нормальный - без выделения.
  • Жирный
  • Курсив
  • Жирный курсив


Общие/Выделение цветом

Выделение цветом

Позволяет установить цвет заголовка при печати выходной формы на экране.


Общие/Заголовок выходной формы при печати

Заголовок выходной формы при печати

Используется для выделения заголовка отчета при его печати на принтере. Параметр может принимать одно из нескольких значений:

  • Нормальный
  • Жирный
  • Курсив
  • Жирный курсив


Страница/Положение и вид номера страницы

Положение и вид номера страницы

В параметре выбирается место размещения на листе номера страницы и один из предлагаемых видов номера страницы.

Чтобы отменить печать номера страницы, нужно включить параметр "Не печатать номера страниц".


Страница/Разбивать листы в ширину по границам колонок

Разбивать листы в ширину по границам колонок

При печати отчета на принтер, если выходная форма не умещается по ширине на лист бумаги, она будет распечатана на нескольких листах.

Если параметр включен, то колонка, которая полностью не умещается на листе, будет напечатана на следующем листе.

Если параметр отключен, часть колонки будет напечатана на одном листе, а часть - на другом.


Страница/Автоматически сжимать форму по ширине

Автоматически сжимать форму по ширине

  • Автоматически сжимать форму по ширине до одного листа - если параметр включен, то для отчета, который по ширине не умещается на листе бумаги, автоматически может быть изменен шрифт, размеры колонок и др.
  • Автоматически сжимать форму по ширине в пределах 1/2 листа - если параметр включен, то для отчетов, которые занимают меньше страницы, автоматически могут быть изменены шрифт, размеры колонок и пр.

Если параметр отключен, то широкие отчеты не сжимаются.


Общие/Открывать все формы в одном окне

Открывать все формы в одном окне

Параметр устанавливается либо в настройках рабочей станции (см. параметры печати выходных форм), либо непосредственно в созданной печатной форме документа, отчета, справки и т.д. (в параметрах по умолчанию Ctrl+F2), и позволяет, находясь в печатной форме, открывать любые сохраненные на диске формы для печати в одном окне.


Меню Формы(офис)

Формы

Специально для системы SLS-Дисконт разработан язык программирования SLS-Report , предназначенный для создания дополнительных выходных форм - различных отчетов, актов, справок и т.д. на основании информации из БД системы SLS-Дисконт.

Для создания файлов дополнительных выходных форм с помощью языка SLS-Report, используется редактор программ Far, Norton Commander и т.д., а также более мощный текстовый редактор Office Editor, бесплатно предоставляемый компанией SoftLand Systems.

Файлы, созданные с использованием языка, должны иметь расширение *.frm.

Одна из особенностей языка SLS-Report - контекстная зависимость переменных. Все внутренние переменные, доступные пользователю, разбиты на условные группы - контексты, которые соответствуют определенным разделам системы SLS-Дисконт. К примеру, контекст «карточка покупателя» объединяет все данные по отдельно взятому покупателю и т.д.

В соответствии с контекстом, дополнительные формы могут быть распечатаны из следующих разделов системы SLS-Дисконт для Windows:

  • Карточки покупателей
  • Таблицы скидок
  • Магазины сети

Для того, чтобы прикрепить описание дополнительной формы к одному из выше описанных разделов необходимо перейти в этот раздел и выбрать раздел Формы/Настройка форм .

Внимание: контекст дополнительной формы должен соответствовать выбранному разделу (описание контекстов см. в файле документации SLS-Report.doc).

Теперь, если в соответствующем разделе системы SLS-Дисконт войти в меню Формы, либо нажать Ctrl+P (Печать), то среди прочих форм появится название дополнительной формы.


Меню Формы(маг)

Формы

Специально для системы SLS-Дисконт разработан язык программирования SLS-Report , предназначенный для создания дополнительных выходных форм - различных отчетов, актов, справок и т.д. на основании информации из БД системы SLS-Дисконт.

Для создания файлов дополнительных выходных форм с помощью языка SLS-Report, используется редактор программ Far, Norton Commander и т.д., а также более мощный текстовый редактор Office Editor, бесплатно предоставляемый компанией SoftLand Systems.

Файлы, созданные с использованием языка, должны иметь расширение *.frm.

Одна из особенностей языка SLS-Report - контекстная зависимость переменных. Все внутренние переменные, доступные пользователю, разбиты на условные группы - контексты, которые соответствуют определенным разделам системы SLS-Дисконт. К примеру, контекст «карточка покупателя» объединяет все данные по отдельно взятому покупателю и т.д.

В соответствии с контекстом, дополнительные формы могут быть распечатаны из следующих разделов системы SLS-Дисконт для Windows:

  • Карточки покупателей
  • Таблицы скидок
  • Кассовые места

Для того, чтобы прикрепить описание дополнительной формы к одному из выше описанных разделов необходимо перейти в этот раздел и выбрать раздел Формы/Настройка форм .

Внимание: контекст дополнительной формы должен соответствовать выбранному разделу (описание контекстов см. в файле документации SLS-Report.doc).

Теперь, если в соответствующем разделе системы SLS-Дисконт войти в меню Формы, либо нажать Ctrl+P (Печать), то среди прочих форм появится название дополнительной формы.


Карточки покупателей/Формы

Карточки покупателей

Раздел содержит список дополнительных форм, созданных в контексте "Карточка покупателя". Для того чтобы добавить, изменить или удалить описание формы, воспользуйтесь пунктом меню Формы .

Любую форму из данного списка можно получить (распечатать) внутри карточки покупателя, воспользовавшись разделами "Формы" или "Печать" (Ctrl+P).


Таблицы скидок/Формы

Таблицы скидок

Раздел содержит список дополнительных форм, созданных в контексте "Таблицы скидок". Для того чтобы добавить, изменить или удалить описание формы используется пункт меню Формы .

Любую форму из данного списка можно получить (распечатать) внутри карточки товара, воспользовавшись разделами "Формы" или "Печать" (Ctrl+P).


Магазины сети/Формы

Магазины сети

Раздел содержит список дополнительных форм, созданных в контексте "Магазины сети". Для того чтобы добавить, изменить или удалить описание формы, воспользуйтесь пунктом меню Формы .

Любую форму из данного списка можно получить (распечатать) внутри карточки товара, воспользовавшись разделами "Формы" или "Печать" (Ctrl+P).


Кассовые места/Формы

Кассовые места

Раздел содержит список дополнительных форм, созданных в контексте "Кассовые места". Для того чтобы добавить, изменить или удалить описание формы, воспользуйтесь пунктом меню Формы .

Любую форму из данного списка можно получить (распечатать) внутри карточки товара, воспользовавшись разделами "Формы" или "Печать" (Ctrl+P).


Меню Формы/Настройка форм(Справка)

Формы

Используется для присоединения, изменения и удаления описания дополнительной формы в определенном разделе системы.

1. Выберите раздел программы SLS-Дисконт, к которому вы хотите прикрепить настраиваемую форму (файл *.frm).

2. Воспользуйтесь разделом Формы/Настройка форм в выбранном разделе программы.

Меню содержит следующие пункты:

  • Добавить
  • Изменить
  • Удалить


Меню Формы/Настройка форм/Формы/Добавить(Справка)

Добавить

Используется для присоединения дополнительной формы к определенному разделу системы. Описание дополнительной формы содержит следующие поля:

  • Название формы - под этим названием отчет будет предлагаться пользователю в меню "Формы".
  • Файл - имя текстового файла с описанием формы. Файл должен иметь расширение *.frm и лежать в настраиваемой папке для отчетов - см. настройки рабочей станции в программе SLS-Дисконт.

После добавления описания настраиваемой формы в соответствующий раздел программы, название данной формы появится в меню "Формы" данного раздела.


Меню Формы/Настройка форм/Формы/Изменить(Справка)

Изменить

Чтобы изменить название дополнительной формы или прикрепить другой файл описания *.frm, необходимо откорректировать следующие поля:

  • Название формы
  • Файл


Меню Формы/Настройка форм/Формы/Удалить

Удалить

Используется для удаления описания дополнительной формы из списка.


Настройка форм/Формы/Добавить/Название формы

Название формы

Название - название дополнительной формы, удобное пользователю, которое будет выводиться в меню "Формы".


Настройка форм/Формы/Добавить/Файл

Файл

Файл - имя текстового файла с описанием формы. Файл должен иметь расширение *.frm и лежать в настраиваемой папке для отчетов - см. настройки рабочей станции в программе SLS-Дисконт.


Настройка отчетов с помощью языка SLS-Report

Разработанный компанией SoftLand Systems язык программирования SLS-Report, предназначен для создания внешних (дополнительных) выходных форм на основе имеющейся информации из баз данных системы SLS-Дисконт (Магазин, Офис).

Поддержка и развитие языка SLS-Report обусловлены необходимостью иметь возможность дополнительной настройки различных справок и отчетов в SLS-программах с учетом специфики деятельности отдельно взятого предприятия. Наличие такого инструмента как SLS-Report намного эффективнее, чем программирование форм на заказ, поскольку оно дает пользователю возможность самостоятельно настраивать нужные формы, независимо от производителя программного продукта.

Для создания файлов дополнительных выходных форм с помощью языка SLS-Report, используйте любой текстовый редактор, поддерживающий кодировку ASCII. Файл с описанием формы должен иметь расширение *.frm и размещаться в папке forms, которая, в свою очередь, находится в директории, где установлена программа SLS-Дисконт. Вы также можете использовать текстовый редактор Office Editor, разработанный специалистами компании SoftLand Systems. Текстовый редактор Office Editor вы можете бесплатно скачать на сайте компании SoftLand Systems www.sls.ru .

Полное описание языка SLS-Report к программе SLS-Дисконт находится в файлах SLSReportDiscount.doc и SLSReportPartI.doc, которые размещены в папке, где установлена программа.

Для добавления формы в список настраиваемых форм:

  • Выберите раздел программы SLS-Дисконт, к которому вы хотите прикрепить настраиваемую форму (файл *.frm).
  • Воспользуйтесь пунктом Формы/Настройка форм в выбранном разделе программы. Меню содержит следующие пункты:

Добавить

Изменить

Удалить

  • Добавьте описание дополнительной формы. Описание дополнительной формы содержит следующие поля:

Название формы - под этим названием отчет будет предлагаться пользователю в меню «Формы».

Файл - имя текстового файла с описанием формы. Файл должен иметь расширение *.frm и лежать в настраиваемой папке для отчетов - см. настройки рабочей станции в программе SLS-Дисконт.

  • После добавления описания настраиваемой формы в соответствующий раздел программы, название данной формы появится в меню "Формы" данного раздела.


Рабочая станция/Настройка печати/общие

Общие

Вкладка содержит общие параметры печати выходных форм. К ним относятся:

  • Заголовок выходной формы на экране
  • Выделение цветом
  • Заголовок выходной формы при печати
  • Полный заголовок на всех листах
  • Межстрочный интервал
  • Печать в несколько колонок
  • При сохранении файлов печати на диск предлагать длинные имена
  • Открывать все формы в одном окне


Рабочая станция/Настройка печати/Автосохранение

Автосохранение

Вкладка содержит параметры автосохранения:

  • Автоматически сохранять новые формы после их создания
  • Директория, в которой сохраняются формы


Рабочая станция/Настройка печати/RTF

RTF

Вкладка содержит параметры экспорта в формате Excel:

  • Директория, куда экспортировать файлы
  • Выбирать директорию перед экспортом
  • Показывать результат после экспорта
  • Шрифт фиксированного размера


Рабочая станция/Настройка печати/HTML

HTML

Вкладка содержит параметры экспорта в формате Excel:

  • Директория, куда экспортировать файлы
  • Выбирать директорию перед экспортом
  • Показывать результат после экспорта
  • Разбивать таблицы по
  • Стилевой файл
  • Файл, вставляемый ...


Рабочая станция/Настройка печати/EXCEL

EXCEL

Вкладка содержит параметры экспорта в формате Excel:

  • Директория, куда экспортировать файлы
  • Выбирать директорию перед экспортом
  • Показывать результат после экспорта
  • Шрифт фиксированного размера
  • При старте автоматически подключаться к базе данных
  • Открывать последнюю базу данных
  • Количество недавно открытых файлов


Рабочая станция/Настройка печати/Текстовый файл

Текстовый файл

Вкладка содержит параметры печати текстового файла:

  • Директория, куда экспортировать файлы
  • Выбирать директорию перед экспортом
  • Кодировка
  • Символ-разделитель
  • Ограничитель строк


Общие/Полный заголовок на всех листах

Полный заголовок на всех листах

Если параметр включен, то на каждом листе будет печататься полный заголовок выходной формы.


Общие/Межстрочный интервал

Межстрочный интервал

Используется для определения следующей величины: сколько в процентном отношении составляет высота горизонтальных линий от высоты строки. Параметр может принимать значения в интервале от 10 до 100%. 10% - минимальный межстрочный интервал. 100% - максимальный межстрочный интервал.


Общие/При сохранении файлов печати на диск предлагать длинные имена

При сохранении файлов печати на диск предлагать длинные имена

Если параметр включен, то при сохранении файла предлагается имя, включающее номер, дату документа и наименование контрагента. Если параметр отключен, то при сохранении предлагается имя вида "sprxxxx", где хххх - порядковый номер.


Рабочая станция/Настройка печати/Страница

Страница

Вкладка содержит параметры страницы для печати:

  • Размер левого, правого, верхнего, нижнего поля листа в сантиметрах
  • Печать вертикально/горизонтально
  • Шрифт
  • Разбивать листы в ширину по границам колонок
  • Автоматически сжимать форму по ширине
  • Если возможно, печатать два экземпляра на лист
  • Положение номера страницы
  • Вид номера страницы


Страница/Лист вертикально/горизонтально

Лист вертикально/горизонтально

Используется для задания положения листа.


Страница/Размер полей листа

Размер полей листа

Используется для задания размер полей в сантиметрах.


Страница/Шрифт

Шрифт

Используется для выбора шрифта печати текста. При нажатии на кнопку "..." появляется окно, в котором выбираются шрифт, начертание и размер.


Общие/Печатать в несколько колонок

Печатать в несколько колонок

  • Количество колонок - задается "по описанию" или от 1 до 9
  • Интервал между колонками - задается от 0 до 9


Страница/Если возможно, печатать два экземпляра на лист

Если возможно, печатать два экземпляра на лист

Если параметр включен, то будут печататься два экземпляра на одном листе.


Автосохранение/Автоматически сохранять новые формы после их создания

Автоматически сохранять новые формы после их создания

Если параметр включен, то новые формы автоматически сохраняются на диске.


Автосохранение/Директория, в которой сохраняются формы

Директория, в которой сохраняются формы

Используется для задания директории, в которую будут сохраняться выходные формы. Для выбора нужно кликнуть на кнопке (Обзор), войти в директорию и указать любой файл из нее.


RTF/Директория, куда экспортировать файлы

Директория, куда экспортировать файлы

Используется для задания директории, в которую будут экспортироваться файлы. Нужно кликнуть на кнопку (Обзор) и выбрать директорию и любой файл из нее.


RTF/Выбирать директорию перед экспортом

Выбирать директорию перед экспортом

Если параметр включен, то перед экспортом файла будет предлагаться выбрать директорию.


RTF/Показывать результат после экспорта

Показывать результат после экспорта

Если параметр включен, то на экран выводится содержимое файла экспорта.


RTF/Шрифт фиксированного размера

Шрифт фиксированного размера

Выбирается шрифт, начертание и размер для печати в файле экспорта.


HTML/Разбивать таблицы по

Разбивать таблицы по...строк на страницу

Если указано 0, то вся таблица печатается на одной странице.


HTML/Стилевой файл

Стилевой файл

Полный путь и имя стилевого файла.


HTML/Файл, вставляемый ...

Файл, вставляемый ...

Имена соответствующих файлов. Для выбора нужно кликнуть на кнопку (Обзор).


EXCEL/Результат экспорта - книга Excel

Результат экспорта - книга Excel

Если параметр включен, то результатом экспорта будет файл Excel. Если параметр отключен, то результатом экспорта будет текстовый файл с разделителями.


EXCEL/Передавать в Excel картинки

Передавать в Excel картинки, начертание шрифтов, объединять ячейки

Параметр включается для передачи картинок, шрифтов, объединения ячеек.


EXCEL/Перенос по словам длинных строк в ячейках

Перенос по словам длинных строк в ячейках

Если параметр отключен, то содержимое ячейки будет печататься в одну строку.


Текстовый файл/Кодировка

Кодировка

Выбирается один из трех вариантов кодировки:

  • Windows
  • DOS
  • Unicode


Текстовый файл/Ограничитель строк

Ограничитель строк

Выбирается ограничитель строк. Напротив выбранного значения нужно установить галочку.


Текстовый файл/Символ-разделитель

Символ-разделитель

Выбирается один из предлагаемых симоволов-разделителей. Напротив выбранного значения нужно установить галочку.